• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Lost all paid apps in market

Search This thread

wintermute000

Senior Member
Jul 13, 2010
1,607
171
I've been trying to fix a market issue with my SG tab 7.7 so I did a full wipe and reflashed the ROM in CWM.

Now when I go into the market, all my paid apps don't show up as paid, it wants me to pay again (e.g. titanium root, mobile odin etc.) Ditto on the web store as well.

I've filled in the form on the website but I"m not holding my breath for google (lack of) customer service, anybody run into this before?

Checking on my other droids, the same issue appears to be afflicting them as well, even if the app comes up in 'my apps' when I click on it instead of letting me reinstall it wants me to pay again!!!!

EDIT: Please DO NOT BOTHER SUGGESTING any of the normal 'fixes' such as clearing cache/data, clearing google service framework, full wipe, remove and re-add account, check google account is selected etc. This thread is for those of us whom none of the client side fixes work. And yes our web store is also similarly broken. Confirmed its a google side issue via raising a ticket with them. As per google: ""We are currently aware of this problem with Android apps on Google Play and are trying to resolve it. This complex issue involves several areas of the Google Play Store app and is not an easy fix, so I don’t have a good estimate on how long it will take us to resolve it. As soon as I have any updates, I’ll be the first to let you know.""
 
Last edited:

foxis1981

Member
May 2, 2011
40
8
Just one silly question. Are you using the same gmail account for your paid market apps ? Is the device id remain the same as it is ?

Touch wood, so far I never experience your issue here. I have did several times of full data wipe with flashed more than 10 different roms from GB to ICS and so far my paid apps still displaying as "purchased". It will appear as "not installed" in "My Apps" section if I haven't re-download/restore them.

Try contact google and probably you need to show them your receipts from the apps you purchased in the past.
 

wintermute000

Senior Member
Jul 13, 2010
1,607
171
Same account, I didn't change any ID or whatever (full wipe and reinstall of same rom). Besides its happening on all 3 droids I own (1 phone 2 tablets).

tried clearing market data, cache, force stop etc. no change.
On web store it says I don't own any apps :(

As for receipts I have it all in my gmail of course but I have to wait for goog to get back to me, the lack of customer service (e.g. I can't even call someone) is appalling IMO. I have over 30 paid apps so this is super annoying, and now I"m afraid to buy any more in meantime until its resolved lest it screw my account even more
 

Vulk_ZA

Member
Oct 10, 2010
8
1
Hey, this is my first post ever on XDA.

I just wanted to say that exactly the same thing has happened to me. I've bought around 50 apps on the market, and as of yesterday all of them started saying that I would need to pay in order to install them.

On the web store it says I don't own any apps, so I'm sure this has nothing to do with my individual device. It seems like a problem on the back-end. Maybe some glitches appeared in the system during the transition to Google Play?

Anyway, I'm stuck in the exact same boat that you are. I've reported the problem to Google via their support form, but aside from the automated response that you get when you first report a problem, I haven't heard anything back from them.

I also started wondering whether the problem might fix itself if I buy another app. But I'm also paranoid about making it worse somehow. Sigh...

---------- Post added at 01:36 AM ---------- Previous post was at 01:25 AM ----------

Oh, by the way, I'm running an unrooted Galaxy Nexus with 100% stock firmware. So I really think this is issue has nothing to do with custom ROMs - I reckon the problem is entirely on Google's side.
 

wintermute000

Senior Member
Jul 13, 2010
1,607
171
Yep has to be if the web store is borked as well. Also under my apps, all, it sometimes throws 'error connecting to server [RPC]' or something like that

Two of my droids are custom (Atrix w/ ICS Cm9 beta, Samsung galaxy tab 7.7 w/ tweaked stock) but a third is stock unrooted (sony tablet S).

poor form from goog they really need to up their customer service, even if 'sorry we know there's an issue with XYZ and we're working on it'. I've also got 50+ apps lol
 

Kurisu87

Senior Member
Jun 5, 2011
226
21
Scotland
yup im having the same, I first thought it was due to my custom FW but seems unrooted stock folk are also having this problem. I made a thread about it a couple of days ago and again all having the same issue

http://forum.xda-developers.com/showthread.php?p=24026026#post24026026

what i found, is if i go to the web store and see my purchase history and click a product, it shows as purchased (like it should) but will not download when clicked, when using the search bar looking for the same app (my case both was titanium pro) it wanted me to purchase.

also, when you try to "re purchase" an app you already have, it will attempt to buy but you get an error, followed by 2 emails, a receipt immediately followed by a refunded email.

on an additional note, "play" has now been added to the black bar google home page above the search results in between maps ans youtube, so it seems they are messing with something
 
Last edited:

foxis1981

Member
May 2, 2011
40
8
Anyone tried to connect to a 3g/wifi and manually sync your gmail account ? So far I observed is whenever I just wiped my phone. It will take awhile to fully synced back my email, contact, calendar and the last one which should be google market place.

Try don't take any attempts to make it work and let it be under internet connection and see if they will come back by their own. Just don't do any full wipe again, and performs a normal personal data restoration (like titanium backups). Let it be like 1 day normal usage with internet connectivity and see if those missing apps will appear back or not.

My personally experience is that I didn't actually take any action when I see them blank after full wipe. I proceed and busy with my gmail account login, sync back my contact and calendar, then performs titanium restoration and sms restoration. Eventually they just appeared after couple of hours or maybe 1 day or I dunno, I didn't actually care about it as I just know that they will come back to me and so far the app did appear back by its own in "My Apps" section.
 
  • Like
Reactions: mrmcbill

Kurisu87

Senior Member
Jun 5, 2011
226
21
Scotland
none rooted stock phones are also having this problem, so im not sure its anything to do with wiping the cache and thanks, but thanks for the input.
 
Last edited:

summer_love

Senior Member
Jun 14, 2010
186
18
UK
I've been hit with this too. My apps on the website are completely gone. The orders are still there, thank god. So if google ever actually try and help I can prove I bought them.

All I did was clear cache and data in the play store on ICS because I couldn't download updates. Did they change clear data so it wipes EVERYTHING server side? o_O

My playstore on my ICS xoom has a completely blank "my apps" page. If I try and update my apps it asks me to pay.

My nexus one on GB still uses a really old version of market (I froze the updater some time ago) and that's working fine at the moment. I can do updates ok too.

On my xoom I unistalled updates to pre "play store" re-brand (so plain old android market) and it shows all my apps and lets me update them without asking me to pay again. Next time I open it, I'm back on the play store with no apps listed in "my apps". So I uninstall updates again next time I need to use it. There doesn't seem to be an updater to freeze any more.

I daren't try buying any new apps in case that messes it up even more.

As a short term workaround try using an older version of the market. The one that works for me is 3.3.12.

I've tried going back to a nandroid from a couple of weeks ago, didn't work. I've wiped, flashed, market doctored, everything I could think of. No help. This is definitely server side.

I've sent emails to google but they haven't replied. I sent a few because there wasn't an option for "you deleted everything on my account for no reason."
 

summer_love

Senior Member
Jun 14, 2010
186
18
UK
"My playstore on my ICS xoom has a completely blank "my apps" page."

My playstore on my ICS Galaxy S2 had the same bug. I installed a free app, cleared my playstore and did a Restart. I don´t know why, but my apps are here again. :)

I tried that already :(

I'll try again though.... Nope, now it's not blank, but it just lists the free app I installed!

Thank you for the tip though, appreciate you trying to help!
 

summer_love

Senior Member
Jun 14, 2010
186
18
UK
wow.. thats totally wierd.
did u login using the same google account??

lol, yes I did. I removed all others just to make sure :)

What does Playstore on your Computer say, about your installed and bought apps?
Try to install them from internet explorer (www_play_google_com/apps) _=> .

Nope, play store on my computer is also blank. The orders are in google wallet, but the apps aren't there in "my android apps".

I know it sounds completely ridiculous, but my account has been wiped on the server. I've attached some screenshots. The first 2 are what happens when I go to play.google.com "my android apps" (I always get one or the other), the third is my xoom's store, the 4th is google wallet showing a handful of the apps that should be there.
 

Attachments

  • playstorefail1.jpg
    playstorefail1.jpg
    47.8 KB · Views: 250
  • playstorefail2.jpg
    playstorefail2.jpg
    125.6 KB · Views: 257
  • playstorefail3.jpg
    playstorefail3.jpg
    26.8 KB · Views: 257
  • someplaystoreorders.jpg
    someplaystoreorders.jpg
    62.6 KB · Views: 287
Last edited:

romansib

Member
Sep 10, 2011
7
0
Moscow
lol, yes I did. I removed all others just to make sure :)



Nope, play store on my computer is also blank. The orders are in google wallet, but the apps aren't there in "my android apps".

I know it sounds completely ridiculous, but my account has been wiped on the server. I've attached some screenshots. The first 2 are what happens when I go to play.google.com "my android apps" (I always get one or the other), the third is my xoom's store, the 4th is google wallet showing a handful of the apps that should be there.

Absolutely the same situation...
Purchased apps looks like not purchased
 

Attachments

  • play.jpg
    play.jpg
    23.2 KB · Views: 222
Last edited:

Vulk_ZA

Member
Oct 10, 2010
8
1
Hopefully Google will fix this soon. Or at least reply to one of us... maybe :confused:

I got a reply from Google Play Support, but it seemed like a canned response: it was mostly suggestions to try things I've already tried, such as logging in with the correct account, making sure I've upgraded to the latest version of the Play Store app, or doing a hardware reset of the device.

I replied with a more detailed explanation, and included several screenshots to illustrate the problem.

I also included a link to this thread. Hopefully someone at Google will realise that there's a problem on their side that needs to be fixed.
 

wintermute000

Senior Member
Jul 13, 2010
1,607
171
I haven't even gotten a single response short of the initial auto reply, and its nearly 72 hours. Pathetic really. If I was an apple customer and lost all my itunes purchases.......... GAH google get it sorted
 

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    Okay, i was having the same issue on my 2.3.3 phone after a factory reset. Samsung Galaxy S2 if thats relevant.

    Anyways, to fix it, i went to SETTINGS > APPLICATIONS > MANAGE APPS

    From there, hit the ALL tab, and scroll until you find GOOGLE PLAY STORE. Hit the CLEAR DATA.


    Go back to the Google Play Store, and it should ask you to agree to w/e it is it wants, then it should resync up the account. I was able to get my damned Tapatalk again.


    Hope this works for you guys too!
    1
    Anyone tried to connect to a 3g/wifi and manually sync your gmail account ? So far I observed is whenever I just wiped my phone. It will take awhile to fully synced back my email, contact, calendar and the last one which should be google market place.

    Try don't take any attempts to make it work and let it be under internet connection and see if they will come back by their own. Just don't do any full wipe again, and performs a normal personal data restoration (like titanium backups). Let it be like 1 day normal usage with internet connectivity and see if those missing apps will appear back or not.

    My personally experience is that I didn't actually take any action when I see them blank after full wipe. I proceed and busy with my gmail account login, sync back my contact and calendar, then performs titanium restoration and sms restoration. Eventually they just appeared after couple of hours or maybe 1 day or I dunno, I didn't actually care about it as I just know that they will come back to me and so far the app did appear back by its own in "My Apps" section.
    1
    Okay, i was having the same issue on my 2.3.3 phone after a factory reset. Samsung Galaxy S2 if thats relevant.

    Anyways, to fix it, i went to SETTINGS > APPLICATIONS > MANAGE APPS

    From there, hit the ALL tab, and scroll until you find GOOGLE PLAY STORE. Hit the CLEAR DATA.


    Go back to the Google Play Store, and it should ask you to agree to w/e it is it wants, then it should resync up the account. I was able to get my damned Tapatalk again.


    Hope this works for you guys too!

    Thanks, but we've tried that. A lot.

    edit: XD Kurisu87 beat me to it!
    1
    Fixed here too. It seems like the nightmare is finally over, at least for me!

    FWIW, if anyone from Google is reading this thread: thanks for fixing this. I really do appreciate it. That said, next time something goes wrong with your services, some communication from your side would be nice too. I understand that systems break down sometimes, and I'm sympathetic. It's just that feeling of throwing emails into an abyss, with no hint as to whether anyone is even listening, that gets so frustrating.