Lost my WiMAX RSA key

Search This thread


Senior Member
May 15, 2010
TL;DR - There IS a WiMAX RSA key somewhere on our device and it CAN be lost. It would be great if we could track it down and figure out how to back it up.

Here's the story. I had to send my E4GT in to Samsung for a new logic board, and about a week after I got it back, WiMAX stopped working. I discovered that my WiMAX MAC address had reset to 00:00:00:00:00:00, and all the other settings (MRU, REALM, etc) had been cleared, as well. I was able to reprogram the MAC address to the one on the sticker, and the other settings to match my NS4G. I still couldn't connect, so I did a ##786# reset, and re-activated; still no go. I was getting desperate, so I called Sprint. The support agent didn't know jack about WiMAX, but she updated my profile, still no-go. I called Samsung, too, but they claimed there was not way the repair process could have affected my WiMAX. I have used the WimaxLineTest application to verify that Authentication fails, so I have to believe that there is an authentication RSA key somewhere in flash, which was lost when my WiMAX settings got reset.

I'm not looking for a solution to my problem, as my local Sprint store is getting me a replacement. I do think that it would benefit the community, though, if we could figure out where the RSA key is stored so we can find a way to back it up. Thoughts?