[lt03wifi][P600][ROM][CM13.0][6.0.1]Temasek's UNOFFICIAL Builds [Discontinued]

Search This thread


Senior Member
Oct 12, 2013
Windsor, Ontario. Canada
So, JOSHNDOID IS working to find a wothy replacemt for Temasek's build? And would we seek it here, or will there be an announcement when he does so? I will be interested to see what he finds. ;-Deano


Senior Member
Dec 30, 2013
Fort Worth, TX
So, JOSHNDOID IS working to find a wothy replacemt for Temasek's build? And would we seek it here, or will there be an announcement when he does so? I will be interested to see what he finds. ;-Deano

This ROM has served it's purpose.

Try this instead.


---------- Post added at 12:09 PM ---------- Previous post was at 12:08 PM ----------

hello everyone, I just installed this rom, and I have small black spots when I rotate the screen for example. am I the only one, sorry im with google traduction

It's a know issue, has to do with the LP bootloader.

Try this ROM instead

  • Like
Reactions: calaiou


Senior Member
Nov 29, 2014
This ROM has served it's purpose.

Try this instead.


---------- Post added at 12:09 PM ---------- Previous post was at 12:08 PM ----------

It's a know issue, has to do with the LP bootloader.

Try this ROM instead


i tried this rom, but i have bug with the s.pen, not posible to move the cursor control with the s.pen.. sorry for my english


Senior Member
Jun 15, 2010


Senior Member
Jun 15, 2010
The ZakooZ CM 14.0? The ROM's own page says the camera isn't working, though the camera preview is. I'm not sure if Skype would in effect be using the preview.

No, ShevT's CM13. Linked 5 comments back.

Thanks, I'll have a look.

That link, BTW, leads to the middle of the Temasek CM 13.0 thread, and I spent a few minutes trying to figure out what ROM you were referring to before posting to ask.


New member
Dec 21, 2016
Hey there,

i know this ROM is discontinued, but i still got one problem with this Rom and perhaps someone else got a same problem and knows a solution for it, so i thought to just give it a try.

With this rom i always get a reboot when using an external mouse. Connecting works fine, but as soon as i move the mouse the tablet reboots. Every time.
Happens with a Bluetooth mouse but also when connected via USB OTG. Keyboard (USB) is working fine, but as soon as i move the mouse, tablet reboots. :confused:

On stock Touchwiz Rom it did work, but i didn't like Touchwiz and all the bloatware that comes with it. Really loving this Rom though, apart from this one bug i encounter.

I would like to stay on 5.1.1. (CM 12.1) because on 6 or 7 i can't get ScummVM to work. And as i mainly use my tablet as a DOS emulator for playing old Games using ScummVM is quite handy for some of those. :)

Perhaps another kernel would solve my problem but i couldn't find one for 5.1.1. AOSP (CM 12.1).

Did anyone else encouter similar problems and did they find a solution?

I would have attached a logfile but couldn't figure out how to get a logfile when the tablet reboots. My logcat always starts new after reboot.


Edit: I forgot to mention, i get the same Bug on the latest CM12.1 Nightly.
Last edited:


Senior Member
Jan 6, 2009
My cpu seems to be stuck at 1900 mhz on all four cores with no load showing in monitoring apps. As a result my tablet gets really hot and the battery drains fast, does anybody know the fix. I am to remember it was something in kernel adiutor but can't find it

Sent from my SM-P600 using Tapatalk
Last edited:


Oct 15, 2011

You are the greatest! I followed your instructions and that 100% solved the sound crackeling/stuttering issue on my device.:highfive:

I restored my nandroid backup and updated to v. 4.6.2 so it could also be because of the last update by joshndroid, but after that i started music play and everything works perfect. I am still on the old bootloader now.

I know that was not the intention of your post to solve this issue but it was the solution. Big thanks.:D

I followed those steps, but the sound keeps crackeling/stuttering everytime I touch the screen or open/close an app...don't know what I'm doing wrong.....hmmm I really want to keep the rom because is super fast comparing it with the stock, but It's annoying that issue.

---------- Post added at 01:26 AM ---------- Previous post was at 12:48 AM ----------

Can I ask a stupid question? I have searched the forum and I couldn't find the answer. How do I see my background apps? I have tried everything and I just can't find the answer.

Pressing the old "menu botton" :D
Jan 11, 2018
I keep trying to flash the ROM and I'm getting the error "failed to verify whole-file signature" can any one explain to me what I might be doing wrong? I'm rooted and I installed the lollipop bootloader. I also can't get a different recovery mode to show up other than the stock one even though I installed twrp 2.7
through odin


Senior Member
Dec 30, 2013
Fort Worth, TX

Top Liked Posts

  • There are no posts matching your filters.
  • 87
    Temasek's UNOFFICIAL CM13.0 BUILDS


    I will attempt to get builds out as soon as Temasek releases a new version, however due to commitments i may miss a release. I will not upload a ROM until i have flashed it myself. Please report any bugs or issues that you see; when applicable, Thank you.


     * Your warranty is now void.
     * I am not responsible for bricked devices, dead SD cards,
     * thermonuclear war, or you getting fired because the alarm app failed. Please
     * do some research if you have any concerns about features included in this ROM
     * before flashing it! YOU are choosing to make these modifications, and if
     * you point the finger at me for messing up your device, I will laugh at you. Hard. A lot.

    This thread is currently under maintenance. Should there be any inaccurate information, please PM me. Images and formatting will be handled at a future date.


    ...not ready yet


    I use my TWRP version linked in Second post

    Clean Install
    1. Download the appropriate ROM using links provide in the second post.
    2. Download the appropriate GApps following the links in the second post.
    3. Back up any and all important data.
    6. WIPE SYSTEM. <<-- You don't have to do this unless you want too
    7. Flash the ROM in recovery.
    7.1. DO NOT FIX PERMISSIONS AFTER FLASHING, doing so will cause a bootloop.
    8. Flash the GApps.
    9. Reboot Device.

    Dirty Flash
    1. Download the appropriate ROM using links provide in the second post.
    2. WIPE CACHE/DALVIK. (I find wiping /SYSTEM can stop some issues with play store F/C’s)
    3. Install the zip from recovery.
    4. Install GApps (ensure that they are from the same build, otherwise you must do a clean installation when using a newer GApps package)
    3.1. DO NOT FIX PERMISSIONS AFTER FLASHING, doing so will cause a bootloop.
    5. Reboot Device.




    Screenshot 2

    screenshot 3


    probably others i havn't found as yet

    FAQ: "Q: Have problems connecting to your Wi-Fi router? -> A: Make sure you have selected the correct region/country code in the advanced wi-fi settings!"


    @RaymanFX - without him there would be no original trees for our device, simple.
    @ShevT - without him there would be no cm-13.0 for our device, simple.
    @benand - for highlighting a dam error that i had missed for over a month, thanks
    CM Team]

    Joshndroid Source
    Note 10.1 Device Tree
    Note 10.1 Kernel
    Note 10.1 Vendor Files
    Rom Source

    Temasek Github Changelog

    Shared Google Drive Device Folder (have Rom shared directly to your Google Drive Folder)
    see here for further - http://forum.xda-developers.com/showpost.php?p=65559375&postcount=2252

    Basketbuild Download - Backup Download Location (OR for those not in Google Shares)
    https://basketbuild.com/devs/Joshndroid/Temasek Roms/lt03wifi

    GApps - 6.0 GApps Package
    http://opengapps.org/ (select ARM & 6.0)
    I have be extremely pleased with Open Gapps and you can even download daily packages, I have tried the micro, mini and nano packages with good success so far - All credit to their team and original thread source can be found here for important information and updates - http://forum.xda-developers.com/android/software/pa-gapps-continuation-t3098071

    SuperSU for flashing via recovery - Credit to @Chainfire
    Unfortunately I have admitted defeat in bringing up the lt03wifi from my original branches. I just did not have the skill to complete the task.... This shows I have plenty more to learn. I couldn't seem to work out what the primary issue was whether it was vendor, or whether it was kernel related. While i pushed a few things to CM gerrit to assist in the device hardware repos (slsi-cm) being brought up and working in building, the device itself I just couldn't seem to work out, despite literally 100's of builds with minor to massive changes between them. The major issue was to do with black screen on boot, it would light up, black screen... other times it would just lock up and reboot back to TWRP. I pulled in new graphics, updated graphics, all sorts of new boardconfig things, i tried changing aspects in flashing partitions and all that sort of thing, still nothing. Shawn developed a new vendor based on latest source drop, despite some issues, which still did not fix the problem. Last thing to try was kernel, i tried a few things, removing F2FS (as it was troublesome with cm-13.0) completely, pulling in outside (working) kernels as well as prebuilding kernel for lt033g and pushing it across.... I just couldnt fix it.

    I then jsut gave up TBH for the past month or so, and focused all my work on my working devices, funnily enough, all nexus devices (far easier). The Note 10.1 just sat in the drawer collecting dust and out of change.

    The silver lining however is that I have however managed to get a working version based off @ShevT device trees for lt033g. For both CM and Temasek

    At the moment I have only renamed a few things back to lt03wifi... While I have pushed a couple of small commits already back to ShevT device tree this does not, in my mind, allow me to just use his trees to further my own cause. i don't think that is appropriate to use this until I have done a bit more work than just rename some trees.

    I have a bit more work yet and hopefully get the ok to rebase our device from @ShevT trees:fingers-crossed::fingers-crossed::fingers-crossed::fingers-crossed:
    Alright so, after wanting to get F2FS support for our device lt03wifi, I stumbled upon the necessity to have a recovery that supports it. At current, our latest version of TWRP did not support it. So I had to make one.

    Within the third post of the thread I have linked a new recovery, supporting F2FS.

    F2FS is called the 'flash friendly file system.' Realistically it has been developed to assist mobile type devices with EMMC get better read speeds, among other things, to achieve a better user experience.
    Still want to know a bit more check this out – https://en.wikipedia.org/wiki/F2FS. Further have a look here for benchmarks completed on another device - http://forum.xda-developers.com/showthread.php?t=2697069

    So, how do I get F2FS?
    Firstly, your going to need to have partitions that are in F2FS format and with that you need a recovery which is capable of doing that. In the third post you will see a link for an F2FS supported recovery.
    Secondly, your going to need a ROM that supports it. That means, the ROM itself to support mounting partitions correctly, etc. as well as the KERNEL so it can utilise the partitions and actually boot the device.

    Yeah okay, so its entirely intertwined, now what?
    Well, we now have the recovery, ROM and kernel all working with F2FS we need to put it in to practice

    Follow these steps (you will need a micro sdcard inserted into your device)
    Complete these steps in their entirety and accurately (if I find out you didn't complete a step or skipped one because you 'know better', leading to a bricked device, I wont be happy). They might seem condescending, but hey 2 extra minutes/step may make the difference.

    1. Go to https://dl.twrp.me/lt03wifiue/ and download the appropriate stock TWRP (I recommend now) .IMG file AND .zip of your recovery and place onto your EXTERNAL SD CARD (these are in case something doesn't work)

    2. While at https://dl.twrp.me/lt03wifiue/ download the same IMG.TAR and place those files into your usual ODIN directory (in case we REALLY need to flash back a recovery) - If you need Odin, download that as well.

    3. Download my latest ROM zip anything from V17.6 will be supporting f2fs unless stated otherwise. Place this file into your EXTERNAL SDCARD also.

    4. Download your latest version of gapps and have a supersu zip handy (latest). Place these files into your EXTERNAL SDCARD

    5. Okay download my f2fs supported recovery signified by F2FS in the name (ZIP or IMG will work in TWRP Link in third post or https://s.basketbuild.com/devs/Joshndroid/TWRP/lt03wifi

    6. Place the F2FS supported recovery into your EXTERNAL SDCARD

    7. BACKUP all important files from your device's INTERNAL SDCARD as it will be WIPED when formatting to a new partition type (and I mean it will be GONE)

    8. reboot into your recovery

    9. select the F2FS IMG file or ZIP and flash as necessary.

    10. If successful reboot back to recovery. (if not see below, it may be to do with your current twrp version)

    11. BACKUP EVERYTHING to EXTERNAL SDCARD (this will save partition info, boot/userdata/system). If super keen, transfer a copy to computer

    12. Okay now the partitioning
    - Go to wipe
    - Go to advanced wipe
    - click on cache
    - click on repair or change file system
    - click on change file system
    - click on F2FS
    - swipe to confirm
    - click back till you get to the partition selection again
    - Repeat step 12 changing 'cache' for 'data' and then for 'system'

    13. Go back to the main menu

    14. Flash ROM zip, Gapps and Super Su

    15. Reboot

    16. Download a free app called 'disk info' from play store
    17. check your partitions are now listed as F2FS. if they list as EXT4, you've done something wrong and need to try it again.


    Is this safe?
    Yes, provided you do it correctly you wont have any issues.

    Do it need to do it each time I flash my ROM?
    No, you only need to convert once. Then each ROM flash will see your partitions as F2FS and format accordingly.

    But I know the device formats system or other partitions during ROM flash, why do I have to do it manually?
    Because the ROM zip detects the partition file system type. It will then format it with the correct tool. If you don't essentially set the file system to F2FS how does it know to format with F2FS.

    Does my favourite kernel support F2FS?
    probably not, check with the developer and ask them to support F2FS. If they are stuck, point them in my direction I will help.

    I followed the steps correctly and get a black screen after booting?
    You have probably messed something up, this seems to be kernel related. If you tried to flash a custom kernel, don't. Use only the bundled kernel until you know your favourite custom kernel supports f2fs.

    Can I have some partitions as EXT4 and some as F2FS?
    Probably, but I don't recommend it. Don't half complete this mod, either go full F2FS or remain at EXT4.

    What about other partitions I see/know about? Can these be F2FS too?
    No, they are not supported
    Only System, Data (userdata) and Cache are supported, these are the typical partitions supported by other ROM devs for other devices.

    So I don't have a recovery, or when I reboot to recovery it goes straight to the ROM, or I just get a blank screen?
    Your recovery isn't working or didn't flash correctly. Your going to have to flash TWRP with ODIN and try the steps again (I've tested with the F2FS supported IMG and the ZIP file and both work)

    I don't like/want F2FS can I go back?
    Yes, follow the steps once again and where it says F2FS in step 12, change it to EXT4.

    Can I revert to an old backup, but it was before I changed to F2FS?
    Yes you can, but FIRST you MUST re-partition back to EXT4 before restoring your old backup. If that means using an older TWRP (not mine) it will still format your device back to EXT4, just do it BEFORE you restore.

    Can I just restore a backup of F2FS?
    Yes, but see the above ^^^ you will need to format to F2FS before restoring.

    Will EXT4 still be supported?

    Is F2FS better?
    Not really sure, I haven't had enough time to play with it. It doesn't feel much 'faster' maybe im just being cynical lol.

    I really broke/bricked my device, HELP?
    if you have a stock firmware your best solution is to flash that with Odin.

    Where's your TWRP source?
    here - https://github.com/Joshndroid/android_device_samsung_lt03wifiue

    Can I build my own TWRP?
    Yes, but you need omnirom source so its not really worth doing it.
    This is great news because I have exactly the same problem. Could you tell me which firmware you used please (maybe a link where I can find it). Did you just do all the above through recovery?


    Follow at your own risk:

    1. Download and extract the following

    2. Set up Odin (I use 3.10.7 but other versions should work) and make sure you can connect properly

    3. Turn off your device and boot into bootloader/download mode and connect to Odin

    4. In Odin, attach the BL_... file to BL, the AP_... file to AP, and CSC_... to CSC and tick the boxes.

    5. Click the "Pit" tab and ignoring the warning, attach the .pit file which is also in the folder.

    6. Under the "Options" tab, Auto Reboot, Re-Partition and Reset Time should now be ticked automatically. In addition to those, tick "Nand Erase All"

    7. Switch back to the "Log" tab, and hit Start. Do not disconnect the cable and wait for it to finish. The tablet will reboot, the old school "Android is updating" thing will appear for a bit, then will reboot again. Waiting some more, the old Samsung boot animation should come up signalling success! You can now disconnect the cable.

    This should have completely nuked and rebuilt your internal storage. Verify in the device settings that available storage is what it should be, and /system isn't taking up more than it should. If all is well, you're free to flash your custom recovery and reinstall from there, although I'd personally recommend flashing back to your flavour of stock 5.1.1. before doing so.

    ETA: If your device is affected by the audio crackle/distortion issue, doing the above without going back to 5.1.1 may fix your issue.