Magisk General Support / Discussion

Search This thread

elhennig

Senior Member
Feb 21, 2011
957
231
2021.5.12 Magisk v23.0
This release is focused on fixing regressions and bugs.

Note: Magisk v22 is the last major version to support Jellybean and Kitkat. Magisk v23 only supports Android 5.0 and higher.
When I try to install v23 apk i get only one method to chose the file to be patch and I have no idea how to proceed there. Having renamed apk to zip and ran the installation from the TWRP recovery the app claims the Magisk is not installed. What can I do?
 

pndwal

Senior Member
Jun 23, 2016
2,400
1,691
Sydney
Xiaomi Redmi Note 7
Installation Instruction update:
John Wu, 41m

I just spent some time rewording parts of the installation instructions. Hopefully this makes it less confusing to newcomers!
https://topjohnwu.github.io/Magisk/install.html

I really want to make things simpler, but as anything that involves Android, it is of course an absolute mess due to fragmentation, so unfortunately the instructions are super verbose 😶
www.twitter.com/topjohnwu/status/1392409550024679426

(Commit, for comparison:
https://github.com/topjohnwu/Magisk/commit/4f73534837bda59fd58ca010fe25d3d66556883e )

Have a look. New look / quite a few clarifications. 👍 PW
 
Last edited:

pndwal

Senior Member
Jun 23, 2016
2,400
1,691
Sydney
Xiaomi Redmi Note 7
When I try to install v23 apk i get only one method to chose the file to be patch and I have no idea how to proceed there. Having renamed apk to zip and ran the installation from the TWRP recovery the app claims the Magisk is not installed. What can I do?
Please say device (model), what Magisk version, if any, you had working before installing v.23.0, etc. PW
 
  • Like
Reactions: J.Michael

pndwal

Senior Member
Jun 23, 2016
2,400
1,691
Sydney
Xiaomi Redmi Note 7
Had some issues w the last update:

Oneplus 6T, Elemental Kernel, XXX_NO_LIMITS ROM

After I updated I passed safety net for the 1st time in ages, but my sim cards were not registering.

Uninstalled all my modules, rebooted, phone worked.

No longer passed safety net.

Added my modules back 1 by 1 and rebooted, phone still works.

After I added XXX back I got a weird reboot about a minute in. Couple of odd restarts from OS14 Launcher, but everything is working.

Still don't pass safety net though. Magisk hide is turned on. Magisk Hide props config is installed. Tried all the different configs for the 6t via Termux terminal, none got me to pass safety net.

Really odd that when my phone wasn't working I passed but now I don't....again.

Not a HUGE deal as I have no google account on my phone, but would be nice to have it working.

Thoughts?
For SafetyNet pass, you generally need Universal SafetyNet Fix even with basic attestation reported, due to Google changes.

Nothing else needed for most stock ROMs, but if Chinese uncertified stock, or custom ROMs w/o certified fingerprint spoofing, you'll need MagiskHide Props Config, and a certified fingerprint set up. If using certified stock ROM, best to remove MHPC.

Re. SIM issues:

Try disabling all modules except USNF (and MHPC if needed) and rebooting.

Nb. Mods like OOS Native Call Recording module have been reported to cause symptoms like yours in OnePlus devices, and may no longer be compatable with Android 11 for example.

Nb.2. Some OnePlus users have had issues with USNF module also, especially after Android 11 upgrade. However, surprising success is reported with a test module from the same Dev, eg:
https://github.com/kdrag0n/safetynet-fix/pull/13#issuecomment-792931429

The test SafetyNet Fix module the user above reported fixed his OnePlus Nord w/ A11 ("works flawlessly"), is linked in the same pull request thread. It tests "Shim the keystore service instead of replacing it", and is designed to test the following scenarios and issues:
- 32-bit ARM devices
- Heavy OEM skins
- Samsung One UI
- MIUI
- Broken biometric authentication in apps
- Unstable system (i.e. rebooting and/or crashing)

Download link:
https://github.com/kdrag0n/safetynet-fix/pull/13#issuecomment-767863635

This may well help you especially if running Android 11. PW
 
Last edited:

wtosta

Member
Apr 26, 2015
30
8
Pszów
My device is Samsung S9 with the latest Magisk 23.0 installed. I also applied the safetynet-fix-v1.1.1.zip and turned on the MagiskHide option in Magisk settings. SafetyNet passes with the basic integrity check and also I am able to register the payment cards in Google Pay. But when I try to turn on the NFC module to start using contactless payments the Google Pay app says that it can't set up the NFC. I had the same problem with the previous versions of Magisk Canary just before the official version 23.0 was released. Have any of you encountered such a problem before?

Best regards
Witek
 

pndwal

Senior Member
Jun 23, 2016
2,400
1,691
Sydney
Xiaomi Redmi Note 7
My device is Samsung S9 with the latest Magisk 23.0 installed. I also applied the safetynet-fix-v1.1.1.zip and turned on the MagiskHide option in Magisk settings. SafetyNet passes with the basic integrity check
Do you mean basicIntegrity is checked (ticked), or that SafetyNet Check uses Basic attestation evalType? (Two very different things). Also, can we assume ctsProfile pass as well?
and also I am able to register the payment cards in Google Pay. But when I try to turn on the NFC module to start using contactless payments the Google Pay app says that it can't set up the NFC.
Do you get an error message here? Eg un-secure / modified environment, or root / jailbreak detected?
I had the same problem with the previous versions of Magisk Canary just before the official version 23.0 was released. Have any of you encountered such a problem before?
Likely solution:
Post in thread 'Magisk General Support / Discussion' https://forum.xda-developers.com/t/magisk-general-support-discussion.3432382/post-84790337 PW
 
Last edited:

Alexkidd85

Senior Member
Jun 29, 2010
106
5
Catania
Google Pixel 4 XL
Hi guys

problem: pixel4xl updated to the latest patch and flashed last boot patched.

apps that require root work (probably only the old ones with permissions already granted), magisk passes the safatynet BUT...


on "installed" gives me n / a
obviously I can't hide anything

and, I did not know that now android, seeing the root, also canceled the unlock with my face (or at least I think that is why, it would make sense)

anyone have any ideas?

if I have to format everything, i'm not ready for android 12 yet !! :D :D
 

wtosta

Member
Apr 26, 2015
30
8
Pszów
Do you mean basicIntegrity is checked (ticked), or that SafetyNet Check uses Basic attestation evalType? (Two very different things). Also, can we assume ctsProfile pass as well?
After applying safetynet fix (before applying the fix evalType was Hardware and the SafetyNet check didn't pass).
Currently:
SafetyNet check: Succeeded
basicIntegrity: ticked
ctsProfile: ticked
evalType BASIC

Forgive me being imprecise.

Do you get an error message here? Eg un-secure / modified environment, or root / jailbreak detected?
No, it doesn't occur.

Likely solution:
Post in thread 'Magisk General Support / Discussion' https://forum.xda-developers.com/t/magisk-general-support-discussion.3432382/post-84790337 PW
I am trying to test what is written in the solution, but with no avail :-(
 
Last edited:

zgfg

Senior Member
  • Oct 10, 2016
    5,307
    2,607
    Hi guys

    problem: pixel4xl updated to the latest patch and flashed last boot patched.

    apps that require root work (probably only the old ones with permissions already granted), magisk passes the safatynet BUT...


    on "installed" gives me n / a
    obviously I can't hide anything

    and, I did not know that now android, seeing the root, also canceled the unlock with my face (or at least I think that is why, it would make sense)

    anyone have any ideas?

    if I have to format everything, i'm not ready for android 12 yet !! :D :D
    Hint (every second day somebody asks the same and it usually helps) - search through the Settings, Apps and uninstall your previous/old Magisk Manager, or old mngr/apk if you did hide it.
    If needed, uninstall also the new Magisk app (not the Magisk itself) and install the apk again.
    You can basically find the same in Magisk Wiki, available on Github, link from Magisk main window - IMO, users should take time and read to be familiar where to find the answers when something goes wrong)
     

    Didgeridoohan

    Senior Moderator / Dev Committee / Dev Relations
    Staff member
    May 31, 2012
    11,648
    12,432
    Gothenburg
    Google Nexus 4
    Nexus 6
    @pndwal

    Is "snet extension" the "SafetyNet Fix" module?

    I thought the release note was saying that Magisk now did what was needed to pass SafetyNet. I assumed that meant that the separate module was no longer needed.

    No. That has nothing to do with the SafetyNet fix to circumvent hardware backed key attestation. That's just the update to the Magisk app SafetyNet check so that it uses a new API key (since the old one got revoked).
     

    zgfg

    Senior Member
  • Oct 10, 2016
    5,307
    2,607
    @pndwal

    Is "snet extension" the "SafetyNet Fix" module?

    I thought the release note was saying that Magisk now did what was needed to pass SafetyNet. I assumed that meant that the separate module was no longer needed.
    That is the same fix (new/valid SN API key) that has previously been applied to Magisk Canary apk - hence to avoid the API error.
    Because of that API error the real SN test was not executed and Basic Integrity / CTS profile 'failures' had no meanings

    Hence, there is no more need to switch to Canary or to use third party SN checkers - but it doesn't help to pass SN if there are real problems with Basic Integrity or CTS profile
     
    • Like
    Reactions: J.Michael

    absinth4

    Member
    Nov 25, 2014
    44
    4
    Edinburgh
    Sorry if I am postin on the wrong thread about this, wasnt sure where to do it :( . I have noticed that one of my banking apps (Bank of Scotland) is recognizing that my phone is rooted and wont let me log in. I have tried all the ways to bypass that, like magisk hide , hide props config, hiddin the magisk app itself, rebooting, reinstalling the banking app, but seriously nothing at all seems to work. with other banking apps that ppl had similar issues like Revolut, something from the above seemed to work but not for this. Am i missing any other workarounds for my issue guys? i would be really greatful !
     

    whitewallman

    Senior Member
  • May 1, 2010
    119
    27
    This is probably a stupid question, but what does that last number in parentheses in the version number indicate? In my case, (21)
    Screenshot_20210512-120440.png
     
    Last edited:
    • Like
    Reactions: J.Michael

    wafna

    Member
    Jan 13, 2012
    20
    6
    updated to the latest Android (11) on a Note 10+, using Odin, patched AP file etc. Usual standard method. Got Magisk to start only once. Can boot into recovery while plugging in a USB-C earphone cable.

    Magisk itself (framework) only loaded once, all other times Magisk Manager says Magisk is not installed. No clue. Used to be that Magisk needed a Volume Down press together with Power On and then release.

    Now if I try that, nothing happens (except the double warning that my phone has been modified). Can boot into recovery by using a Volume Up + Power Key + something plugged in.

    Does anyone have any advice? will reflash and probably downgrade back to Android 10 but maybe someone has an idea. Thanks.
     

    Didgeridoohan

    Senior Moderator / Dev Committee / Dev Relations
    Staff member
    May 31, 2012
    11,648
    12,432
    Gothenburg
    Google Nexus 4
    Nexus 6
    This is probably a stupid question, but what does that last number in parentheses in the version number indicate? In my case, (21)
    That's the app stub version. The stub is installed when you repackage the app with a random package name.
     

    pndwal

    Senior Member
    Jun 23, 2016
    2,400
    1,691
    Sydney
    Xiaomi Redmi Note 7
    Thanks for the response, and pardon my ignorance... But I don't believe I repackaged the app. I installed the APK that I downloaded from the magisk GitHub link. Is it something I inadvertently did?
    Then you didn't Install stub... But that's the included version that will be used if you click 'Hide the Magisk app' in App settings. PW
     

    Top Liked Posts

    • 4
      Magisk:
      Installed: 21.1 (21100), A/B: Yes, Ramdisk: No, SAR: Yes
      App:
      Newest: 23.0(23000)
      Installed: 23.0 (23000)

      I am using an PH-1 with an Android 11 Rom (Build: RQ1A.201205.010)

      The main 'problem' I had is solved. I have Magisk back and so far everything is working.
      If I get some sparetime I will have a look on patching the boot.img. Until then I will go with the actual setup. So once again thank you for the great support!
      A bit further; - I did a little digging into this because I was surprised to see a report of an A/B device w/ Ramdisk = No.

      I hadn't seen (factory boot) ramdisk status change before, and I'm pretty sure it isn't meant to.

      Clearly, your PH-1 is SAR by Google's definition (legacy SAR by John Wu's.) See this:
      https://topjohnwu.github.io/Magisk/boot.html
      and is a Type II device with a recovery ramdisk in boot partition.

      Devices with any type of ramdisk in boot partition should show Ramdisk = Yes, ie. all types I, II & IV.

      Type III are the ONLY type that have no ramdisk in stock (factory) boot partition! ... And these often (but not always) lack bootloader support even for manually added ramdisk in boot partition. See table here:
      https://topjohnwu.github.io/Magisk/boot.html#piecing-things-together

      So it seems to me there's something peculiar (messed up?) with your device, perhaps related to TWRP which resides in boot partition on Type II devices if you have this and Magisk has patched the already TWRP patched boot image. Or perhaps related to a pre-built modded boot image, Android 11 ROM (seems to be a custom port?), device tree used, etc, etc.

      Anyway, I'm betting that those on stock images (including the recovery part of boot.img) w/ Magisk patched boot.img only, have Ramdisk = Yes in Magisk App...

      Root guide here:
      https://forum.xda-developers.com/t/guide-rooting-your-essential-ph-1.3701976/

      Incidentally, I noticed here that @ipdev has PH-1 also. Perhaps he can help with configuration, Ramdisk status, etc. 😜 PW
      1
      Magisk:
      Installed: 21.1 (21100), A/B: Yes, Ramdisk: No, SAR: Yes
      App:
      Newest: 23.0(23000)
      Installed: 23.0 (23000)

      I am using an PH-1 with an Android 11 Rom (Build: RQ1A.201205.010)

      The main 'problem' I had is solved. I have Magisk back and so far everything is working.
      If I get some sparetime I will have a look on patching the boot.img. Until then I will go with the actual setup. So once again thank you for the great support!
      What ROM are you using?
      Are you porting/bringing up a rom?

      Let me know and I will give it a try. :)

      A bit further; - I did a little digging into this because I was surprised to see a report of an A/B device w/ Ramdisk = No.

      I hadn't seen (factory boot) ramdisk status change before, and I'm pretty sure it isn't meant to.

      Clearly, your PH-1 is SAR by Google's definition (legacy SAR by John Wu's.) See this:
      https://topjohnwu.github.io/Magisk/boot.html
      and is a Type II device with a recovery ramdisk in boot partition.

      Devices with any type of ramdisk in boot partition should show Ramdisk = Yes, ie. all types I, II & IV.

      Type III are the ONLY type that have no ramdisk in stock (factory) boot partition! ... And these often (but not always) lack bootloader support even for manually added ramdisk in boot partition. See table here:
      https://topjohnwu.github.io/Magisk/boot.html#piecing-things-together

      So it seems to me there's something peculiar (messed up?) with your device, perhaps related to TWRP which resides in boot partition on Type II devices if you have this and Magisk has patched the already TWRP patched boot image. Or perhaps related to a pre-built modded boot image, Android 11 ROM (seems to be a custom port?), device tree used, etc, etc.

      Anyway, I'm betting that those on stock images (including the recovery part of boot.img) w/ Magisk patched boot.img only, have Ramdisk = Yes in Magisk App...

      Root guide here:
      https://forum.xda-developers.com/t/guide-rooting-your-essential-ph-1.3701976/

      Incidentally, I noticed here that @ipdev has PH-1 also. Perhaps he can help with configuration, Ramdisk status, etc. 😜 PW

      Essential PH-1 (mata) is basically a sister to Pixel 2/XL.
      Save for PH1's bootloader not having a boot option.
      - You could flash taimen's system image on mata and everything normally worked.


      I haven't fired mine up in a while, normally just use it for testing. ;)

      ---

      Installed the current lineage 18.1 nightly...
      Using lineage's recovery.

      - Patched the boot image with Magisk canary.
      - Flashed the patched image and booted.
      - Direct install worked fine.

      Cheers. :cowboy:

      PS.
      When PH-1 was supported, before Essential closed their doors, all the official builds had a ramdisk in boot.
      It is what I used to pull the monthly fingerprint and security patch date from.

      PPS.
      The l18.1 boot image boots AOSP Android 10 GSI on mata. ;)
      “We don't make mistakes, just happy little accidents.” - Bob Ross.
      1
      What ROM are you using?
      Are you porting/bringing up a rom?

      Let me know and I will give it a try. :)

      Essential PH-1 (mata) is basically a sister to Pixel 2/XL.
      Save for PH1's bootloader not having a boot option.
      This made me think, but guess meant Fastboot option!?
      - You could flash taimen's system image on mata and everything normally worked.

      I haven't fired mine up in a while, normally just use it for testing. ;)
      ---
      Installed the current lineage 18.1 nightly...
      Using lineage's recovery.

      - Patched the boot image with Magisk canary.
      - Flashed the patched image and booted.
      - Direct install worked fine.

      Cheers. :cowboy:

      PS.
      When PH-1 was supported, before Essential closed their doors, all the official builds had a ramdisk in boot.
      It is what I used to pull the monthly fingerprint and security patch date from.

      PPS.
      The l18.1 boot image boots AOSP Android 10 GSI on mata. ;)
      Many thanks for info, especially confirmation A11 (LOS 18.1) works as expected on PH-1. 👌
      “We don't make mistakes, just happy little accidents.” - Bob Ross.
      🤩 PW
    • 8
      From what John has said on Reddit and behind the scenes, recanting on some made statements, he can not touch magisk at all not speak on it anymore.
      Most here are aware of that quote, and as has been pointed out, it was private, he didn't 'say it on Reddit', it was only part of a much longer communication and the 'leak' was not appreciated, but my guess is that many colaborators will be in the loop.
      Since he does own the repositories for magisk so we could see them just disappear. He can't push an update which only he can do, so it's either fork it and go that route, which he knows all the ins and outs of magisk and now works for Google(2+2 says he will spilling the beans on the background to block it), I believe they have him on a gag because conflict of interest with magisk sidestepping their security system.
      I don't think G needs him to spill the beans on 'blocking' Magisk; they're quite aware of how it works. It's source is open, after all...

      But if you meant blocking attestation spoofing / bypassing (MagiskHide, some modules, and other), they already know how to make this foolproof. It does require compliant hardware to implement however, and it seems that when some target percentage of devices have launched with tee, a switch will be flipped, and spoofing attestation, and hence MagiskHide at least outside of userspace (ie bootloader Unlocked / verified boot, will become impossible for practical purposes for most users.

      MagiskHide will still be able to hide root from apps within userspace, but these can still check secure boot status through tee attestation, and will likely report 'root/jailbreak' but actually mean 'insecure boot environment'.

      Expect the pool of those still able to hide bootloader status to be reduced, for practical purposes, to those running custom OSs with inbuilt spoofing or Magisk on devices with launch version < or = to Android 7 (last version without requisite keymaster 3) overnight. (Nb. Hardware-backed Keystore began to be hardened from Android 6)
      https://source.android.com/security/keystore

      Hardware TEE of course, stands for Trusted Execution Environment, and it is not just implemented by Google.

      It actually facilities security in RISC, IBM, AMD, Intel, Apple, as well as Qualcomm, MediaTek, Samsung and Huawei SOCs running various systems. Here's an article focussing on ARM implementation:
      https://embeddedbits.org/introduction-to-trusted-execution-environment-tee-arm-trustzone/

      Interestingly, it states:
      TEE is not the solution to all of our security problems. It is just another layer to make it harder to exploit a vulnerability in the operating system. But nothing is 100% secure.
      You can't work for somewhere and have an ap they completely bypasses their OS without a amjor conflict of interest.
      Well, it doesn't bypass it; it gives superuser access as well as ways to overlay mods on an OS, and both things are certainly allowed by design if bootloader is unlocked.

      There are ways to prevent such unlocking, but Google doesn't do that. That's not to say they don't know how however. That would be laughable; It is their system (both open source Android framework and proprietary apps). They simply leave that to OEMs to implement, and, of course, a number take such measures.
      https://support.google.com/accounts/answer/9211246?hl=en
      Google doesn't even want you using a "modified system" to access your Google account. Google has major issue with root.
      They NEVER said that.

      They have protected their proprietary apps by forbidding bundling GApps with custom ROMs, originally ordering Steve Kondik to 'cease and desist' bundling with CyanogenMod, but offered an olive branch in quick succession when he assumed project was dead, allowing individual users to sideload the same, and sites like OpenGApps to host them.

      They have also expressly stated they DON'T oppose either root or custom ROMs, even recently. Eg from Tech Lead for Android hardware-backed security subsystems:
      Shawn Willden, May 19

      The Platform Security team has never been opposed to modding/rooting (and most of us are firm believers in users' right to own their devices), but remains firmly focused on maximizing security for the 99.99% of users who don't. Root weakens the security model.
      www.twitter.com/shawnwillden/status/1394665579076743175

      In line with the above, they state clearly that if you choose to mod your device, "you lose some of the security protection provided by Google", and they do have recommendations, including "Use a different device for important accounts & sensitive data"
      https://support.google.com/accounts...s-with-modified-rooted-android-versions?hl=en

      Also, rather than prevent their own proprietary apps from running in custom modded systems, they allow these to appear on PlayStore and be used freely. Very few are restricted at all, unless for good (security, corporate partners requirements etc) reason. GPay comes to mind here.

      They could, of course, prevent this (especially when HKA is fully functional), simply by requiring PlayProtect Certified Device, but so far they have PURPOSELY allowed custom modders even with uncertified (Chinese etc) devices to add their devices to their online White List that allows them to run the very GApps (without spoofing) that they were prevented from using w/ stock ROMs.

      This sets an example to others (wish likes of Maccas would wake up), but SafetyNet API and PlayProtect certification are available for apps / code deemed a security risk... Of course, SafetyNet Implementation can be abused, but Google's stance is that the code's author has the right to be informed about the execution environments status and make such decisions.

      Interestingly, it seems not only that Google is unopposed to custom ROMs, but they are not averse to the idea of certifying these / issuing appropriate signing keys so bootloader can be locked to allow full SafetyNet pass (with no spoofing), and GApps can be included legitimately. Of course, this solution evidently precludes root.

      The spiritual successor of CyanogenMod, LineageOS, is in a good position to get such an agreement as they already take pains not to 'subvert Google's security model', never bundling GApps, pre-root, signature spoofing (MicroG would come unstuck here 😉) or any other spoofing mods or techniques. Note this conversation between Shawn and Luca Stefani ('Director for LineageAndroid & Developer'):
      www.twitter.com/shawnwillden/status/1238161446200127488

      That ones been a while (time of initial Google Hardware Key Attestation testing), but I hope we see more on the front. 😛

      In short, Google is against subverting their security model, which includes SafetyNet implementation which ALLOWS code to run in insecure environments (even with superuser privileges) WITHOUT subverting it, by making TEE attestation results available to interested parties. Hardware TEE just ensures that the attestation is accurate... And Google didn't invent it either!

      Here's a bit I posted re. mainstream influence on Google's decision to implement Hardware backed attestation for for verified boot and Trusted Execution Environment:
      https://forum.xda-developers.com/t/magisk-general-support-discussion.3432382/post-83280363

      I don't want to take sides in this; only to give perspective. There's certainly room for many viewpoints. Take what John said on the subject just 4 months ago:
      https://forum.xda-developers.com/t/magisk-general-support-discussion.3432382/post-84398495

      ... I wonder what he's thinking now! 😜 PW
      8
      there is no access via terminal

      i installed my fave module, debloat, but of course cant access it...they were serious about the lite part :)

      As for the install of lite...i installed the apk and patched a boot img, had no errors

      v4a/vanced youtube doesnt work either, now i really want to die :)

      going to bed finally, in disgust
      Installation of modules works in Magisk Lite but with some additional tricks:

      1) When you install a module from Magisk Lite app, it creates its folder in:
      /data/adb/modules_update

      When you reboot, Lite will not read that folder and the module(s) will not really be installed/updated (instead, they would be next time when you boot to Stable/Beta/Canary/Alpha, because they do read from /data/adb/modules_update)

      Hence:
      - Install one or more modules you need
      - Use MiXplorer (or another root explorer), or terminal and mv command, or rename it by TWRP:
      /data/adb/modules_update
      to:
      /data/adb/lite_modules_update
      -Reboot, Magisk Lite will properly finish installation of your modules and you will find them in:
      /data/adb/lite_modules

      2) MHPC: I successfully installed but in terminal it doesn't recognize the props command.
      Something is wrong with the path

      You can still use MHPC by invoking instead:
      /system/xbin/props

      3) Similarly for BusyBox NDK. It was installed to /system/xbin

      Indeed, you can list all its commands by:
      ls /system/xbin

      4) I have successfully installed Vanced YouTube root (latest v16.16.38) as a module:

      No ads, background playing, all ok

      5) Smali patcher - Safe Screenhot Mode (allowing to screenshot from apps otherwise not allowing the screenshots)

      E.g., I can make screenshots from Chrome Incognito window

      6) If your debloater uses terminal and installs to /system/xbin, you should be able to exploit as explained above for MHPC and BB

      However, I use my own Systemless Debloater that does not use command line interface (terminal):

      and I have successfully debloated all the same 32 system apps as I do with Magisk Stable/Canary/Alpha

      7) I have manually copied hosts folder from:
      /data/adb/modules/
      to:
      /data/adb/lite_modules/

      and got the adblocking work.
      However, Adaway does not know for that folder and if you update/change anything in AdAway, it will write to its regular modules/hosts folder (but you can always copy again the same folder or just its etc/hosts file)

      9) I didn't try with Viper4Android (I'm already back to Magisk Beta with 'regular' modules) but I believe the installation should work the same way I always install it to Stable/Canary:

      And Lite should similarly work for other modules


      I have some issues with MixPlorer though in Magisk Lite (although I completely uninstalled and reinstalled MiXplorer):

      9) MiXploree was granted root and it works but AFTERWARDS Magisk Lite app shows that Magisk is not installed and I simply have to reboot to get Lite properly working again

      10) MiXplorer can only see the stock content in /system/xbin, i e. without props and BusyBox commands (btw, ls from terminal works fine)

      Same for all other folders being overlaid by Magisk systemless mounting - MiXplorer always shows their stock content while terminal su commands work with the Magisk overlaid content


      But altogether, it would be possible to live with Magisk Lite - even the modules work


      Edit:
      I have Magisk apps Canary, Alpha and Lite downloaded and renamed like:
      Magisk-Lite-7717f0a6(23001).apk

      I have also my boot.ing patched by Magisk Canary, Alpha and Lite and renamed like:
      boot-Magisk_Alpha_23001-xiaomi.eu_multi_HMK20MI9T_21.5.20_v12-11.img

      When I want to switch, I simply install the right Magisk apk, flash the corresponding img from TWRP (or Fastboot) and reboot

      When going from Stable/Canary to Aplha/Lite (or vice versa), that previous Magisk app must be uninstalled because of different signatures

      When installing the Alpha or Lite apk I was asked by Play Protect to send the report - I ignored and upon rebooting with Magisk and MagiskHide properly back on, Play Protect was always ok
      8
      That is the most wrong statement. If Google didn't has no issues with having root, there would not magsikhide. Just that statement alone conflicts with itself. MagiskHide hides root... Google has a problem with hiding root and not root, then why hide it? Why is there basic attention and cts profile check? Now a hardware check? Root, on Android is what they don't want, or else there would be no need for a modified kernel, we would all have root like on Linux desktop... Any terminal on desktop has root instantly, Android doesn't.. They did pretty damn good job of taking something away they wanted to have all along right? Wow.
      This whole discussion took a bit of a turn, and I'm not gonna get further into that. But, you might want to reread what I said again: "Google has no interest in preventing root". That statement doesn't say anything on how Google think about root in security terms (and I'm talking about the Google security team here, which John now is a part of).

      We're talking about different things, I believe...

      You're talking about the security aspect, which Google cracks down on (since generally, rooting a device compromises the systems security), and I'm talking about just being able to root your device regardless of if SafetyNet triggers or not.

      If they wanted to, Google could make it so much harder (impossible?) to root your Android device... From statements I've seen from Google security team members, that's not on their agenda. But of course, beefing up the security on Android in general might have the unfortunate side effect of accomplishing the same thing.
      7
      Is this a bug or a feature?
      Feature, and has been like that since very early in Magisk's history. Magic mounting files and folders to the root of /system, that doesn't previously exist there, can cause all kinds of weird issues.
      7
      FWIW, as there is no news of updated Magisk from John Wu, I'm now running Alpha Magisk and Magisk App from dev @vvb2060 (Nangong Xueshan).

      Seems his App maintains connection to standard Stable / Beta / Canary channels from topjohnwu, but adds his Alpha (Bleeding edge) channel:
      https://github.com/vvb2060/magisk_files/tree/alpha

      Click View code, Download / install app-release.apk 👍

      Screenshot_2021-05-29-17-24-43-651_com.topjohnwu.magisk.jpg


      No problems running this Alpha so far. 👍

      - Nb. Unhide Magisk App if changing to this. Conflict with hidden Apps are still occurring.

      Alpha adds new / experimental commits. Some of these already have pull requests in John's Magisk GitHub.

      Nb. John Wu recently changed his description of debug Canary builds from 'Bleeding Edge' to 'Cutting Edge'...

      WARNING

      If you move to Nangong Xueshan's Alpha, my advice is to consider yourself on the Bleeding Edge again... and to understand what this means!

      Changelog for Alpha, next post. PW
    • 1050
      This is the place for general support and discussion regarding "Public Releases", which includes both stable and beta releases.
      All information, including troubleshoot guides and notes, are in the Announcement Thread
      156
      Hello, I haven't given much support on XDA lately. It can be resulted from
      • University started and I have limited free time. In fact, I mostly develop during midnight
      • I live in Taiwan, which has large time zone differences between my European/American contributors/testers, which usually forces me to stay up late at night to discuss/test stuffs.
      • The new version is about to come, I don't want to spend effort on supporting old releases
      The planned update is delayed again and again, to some point I think I'll shed some light about what has been happening lately, also along with some announcements.

      New Forum!
      As you might have already discovered, Magisk got its own subforum on XDA! Many thanks to all the support you gave me, and much more information/features/support is about to come!
      **For developers supporting all the devices that are not using standard Android boot format, feel free to create threads in this section (actually, PLEASE do so) for your favorite devices after v7 is out. As I currently know, Asus devices require signing the boot image before flashing, and is model dependant; Sony devices seems to use ELF kernel that is unpatchable, or some has two ramdisks (inner + outer), both requires different workarounds; LG bootloader locked devices has to manually "BUMP" the boot image after flashing Magisk..... and there may be lots of other crazy boot image formats that haven't come up to my attention yet.
      It is impossible for me to support all these non-standard boot images, and I hope the community can collaborate to make Magisk running across all the devices. Overall, community collaboration is what XDA about :D

      The Pixel Phone
      Some of you might already know this news, that the next Pixel Phone right around the corner seems like it does not have ramdisk in boot image, which pretty much wrecked Magisk in all ways. However, it pretty much doomed root itself too. Kernel modifications is inevitable IMO, so I'll try to migrate my scripts to C programs that could possibly be included into the kernel itself. Note that I'm not familiar with linux kernel, I'm not even sure if my idea and concept is correct or not. But once the device is available, I think developers will find a way to bypass all the difficulties, and I'll do my best to learn things ;)

      Current Progress
      In the past month, I've spent quite some time learning SELinux, so that I can avoid using SuperSU's sepolicy patches. Thanks to the helps and tips from @phhusson and @Chainfire, I finally have a much clearer understanding of how SELinux works. The Magisk core parts (the scripts, boot image patches, new features, more supports) are actually done some time ago. What is causing all the delays is the Magisk Manager.
      To be completely honest, although I can code in Java without much issues, Magisk Manager is actually my first Android application, I had to reach out for assistance, and fortunately awesome developers like @DVDandroid and @digitalhigh contributed a lot, which makes the current Manager awesome.
      After the repo system and module management is mostly done, I was about to do some adjustments and release, but what we really done is decided to add another feature: auto-unroot with per-app settings. I decided to wait for it to be finished, and then do my adjustments. Due to reasons that'll be mentioned later, this feature will likely not be available for the next release (should come in future updates)

      Safety Net Disaster
      Those who are using Magisk for Safety Net bypass purposes must have known that Google recently updated the detection method of my Systemless Xposed. I still have no idea what Safety Net is detecting, so currently I cannot fix it on my side (also because I'm busy working on the next update). However, suhide developed by @Chainfire is able to hide Xposed and worked fine.
      However, only my Systemless Xposed v86.2, which is based on SuperSU's su.d, is supported using that method. v86.2 and v86.5 (latest, Magisk based) have nearly identical binaries, and the only difference is the path where the binaries are stored.
      I'm still not sure what's the real issue for it not being supported, I just hope it is not done intentionally.

      Conclusion
      Due to the fact that my Safety Net bypass is not 100% perfect now, I do not want to spend any more time waiting for auto-unroot to be polished. What I'm doing now is finishing up all the things I'd like to change in Magisk Manager (it has been a while since I last contributed to Manager, my fellow developers are doing all the heavy job), which might take a little more time, after that, packed with tons of information to be announced in Magisk Section, I'll release the long awaited update.

      Hope this lengthy post gives you the idea of the whole situation, and again thanks for all your support!!
      121
      Ah, some Chainfire bashing, I hope it is not too late for me to exercise additional villainy.

      First, let me make clear I have nothing against @topjohnwu, nor against Magisk. Magisk is an interesting project and it certainly displays @topjohnwu ingenuity and persistence. I don't doubt we will see more interesting things from his hands.

      -------------------------

      What has happened here is not all that dark and complicated, from either end. I returned from holidays, and someone pointed me at Magisk. My first thought: interesting!

      Among other things, the thread lists some issues with SuperSU, which in combination with the phrase The developer also requests users to not bug Chainfire with compatibility requests for SuperSU with Magisk from the portal article, raised my left eyebrow by nigh half an inch. The popular systemless xposed mod is apparently now based on it, and apparently it now no longer works with SuperSU, and apparently I'm not supposed to fix that, nor any of the other found issues. I found that a bit weird. So yes, I have told @topjohnwu that I was a bit surprised he was posting about issues with SuperSU without notifying me about them (I can't fix or help fix issues I'm not aware of, after all).

      He's also spreading a modified version of the SuperSU package, which is not all that uncommon, nor necessarily a problem. I have not looked into what he modified, I only ran a few quick tests on one of my devices, and found some commonly used commands run as root to be broken. I have informed him of this as well.

      It appears the tool of choice for Magisk is phh's Superuser, because of some of the mentioned issues with SuperSU. That's fine by itself, but fixing issues in that superuser by incorporating SuperSU's binaries into it is a somewhat questionable practise. After all, SuperSU is a commercial closed-source package that helps pay for my dinner, and superuser is a direct competitor. I have informed him that I was surprised he did this without asking for permission. I have expressed similar surprise on him spreading a modified version of LiveBoot (which helps pay for a snack now and then).
      @topjohnwu has also stated that Magisk's scripts are largely influenced by mine (I have not checked). Scripts based on mine are used all over the place on XDA, some people have crafted amazing things based on them, I have never made an issue of this (otherwise I would have just made them binaries). But yes, I have also stated to him that I don't think it's very nice to base something on one program, and then using that to (almost exclusively) push something directly competing with that program.

      tl;dr Towards @topjohnwu, I have:
      - expressed surprise he has issues getting Magisk to work with SuperSU, and has chosen not to inform me about those
      - expressed surprise he is using SuperSU binaries in a competing superuser without permission
      - expressed surprise he is posting a modified LiveBoot without permission
      - informed him of issues with the modified SuperSU he has posted
      - let him know I thought it wasn't very nice to be applying my scripts to benefit seemingly exclusively that same competing superuser

      To be crystal clear:
      - I have not asked for an apology
      - I have not asked for Magisk to be abandoned, neither the root hiding nor systemless module parts, and certainly not systemless xposed
      - I have not made an issue of any of this anywhere, until this post
      - I have not even specifically asked for anything to be taken down (though obviously in my opinion the other superuser package mixed with SuperSU's binaries, as well as the LiveBoot package, should go)
      - I have not reported this thread to XDA moderators for copyright violations or otherwise

      While my conversation with @topjohnwu may not win any awards for being friendly (though it may win some for brevity), I think all things considered my response has been rather mild. To be perfectly honest, until the apology post, I thought this was over with already. I think the apology post was triggered because I haven't replied to his last PM for a while - I was in the zone, it happens.

      To emphasize again, I have nothing against @topjohnwu, Magisk, or systemless xposed, and it is certainly not my goal to see any of them go. If it can be made to work together with SuperSU, great.

      I get it though: you think of something, you want to see if you can make it work, you finally get it to work, you publish it, it takes off - enthusiasm gets the better of you. Maybe in the rush some mistakes are made. That doesn't mean you have to just drop it and run. None of my stuff would make it past 0.1 if I stopped at the first big mistake :)

      Aside from said being in the zone coding, I usually regret actually responding to these sort of things the day after, which has made me hesitant to reply. Surprise me.
      76
      Thread temporarily closed so everyone sees this.

      The flood of "SafetyNet isn't working for me either!" posts are not helpful, at all. Please refrain from posting further, it will be looked into. Please do not forget that not passing SafetyNet is 100% NORMAL AND INTENDED when you have an unlocked booloader or running custom firmware. These are workarounds and they will be worked around in turn.

      The Flash
      Forum Moderator

      EDIT: Thread is reopened... I will be cleaning any SafetyNet posts for a while to keep the thread clean for real issues.
      75
      Hello everyone!

      I am aware that Google has updated Safety Net that makes Magisk itself a no go for Android Pay. In fact, I witnessed the change live while I am developing the new magiskhide, which should hide all Magisk modules and Magisk installed root.

      Google is serious about Safety Net now, clearly hunting down all possibility to run Xposed with Safety Net passed. I spend quite some time examining the new security measures last midnight, and fortunately it seems that it is possible to run Magisk and root along with Safety Net if no Xposed is running. I'm glad I removed the old root toggle at the right time lol, that is no longer feasible with the latest detection.

      So stay tuned for the next update, it will come with bug fixes, along with the new magiskhide to bypass that Safety Net.

      Google, how will a few systemless mods do any harm :p:p