Magisk General Support / Discussion

Search This thread

ttar ttar

Apr 6, 2020
Temporary fix to avoiding hardware attestation on affected devices. This changed "ro.product.odm.model" to unknown value to reset checking from HARDWARE to BASIC.

Should work while google selectively activates verification on certain device models.

Magisk module:

It worked perfectly. Just flash the USFN v1.2.0-MOD. Thanks!! @Displax
Last edited:


Senior Member
Oct 10, 2016
Heads-up: Do not use a wrong SN checker (like the one on the first screenshot with volume limitations on the back side - failing when too many users try to test with)


  • IMG_20210902_225517.jpg
    235.6 KB · Views: 183
  • Screenshot_2021-09-02-23-02-27-846_com.topjohnwu.magisk.jpg
    186.3 KB · Views: 184
  • Screenshot_2021-09-02-23-02-45-061_com.scottyab.safetynet.sample.jpg
    610.2 KB · Views: 152
  • Screenshot_2021-09-02-23-03-28-177_de.guenthers.safetynet.jpg
    434.7 KB · Views: 180
Last edited:


Senior Member
Oct 23, 2010
Not working on Xiaomi MI9T Pro with latest EvolutionX. With latest ArrowOS on the same device works perfectly without magisk modules.
Last edited:


Senior Member
Jun 5, 2013
Google Nexus 10
Google Nexus 4
Temporary fix to avoiding hardware attestation on affected devices. This changed "ro.product.odm.model" to unknown value to reset checking from HARDWARE to BASIC.

Should work while google selectively activates verification on certain device models.

Magisk module:
I've been getting CTS errors on a OnePlus 8T since this morning.
Using @Displax's hardware off module fixes the issue. On my device, just using
resetprop ro.product.model BASIC
does the trick. Until next time of course.


Senior Member
Mar 14, 2011
It sets these props, so it's simulating Pixel:

Could be the reason why it doesn't work on PE
Anyway without the module I have my phone's original device.
Im not good at this, any idea de how to fix for pe users?

Top Liked Posts

  • 1
    Hello, I am new to Magisk but have rooted my Moto Edge and successfully have bank and game apps working using modules USNF, Shamiko, and MagiskHide props conifg...however I realized I have accidently installed the Canary Debug vesion of magisk 25.2 ((25200) (34) ...How do I change to a stable or beta version of 25.2? Or should I just stay on the Canary version? Any help would be appreciated.
    I'd say keep what you've got.
  • 8
    New Shamiko-v0.6(126)

    With this new Shamiko, Momo does no more detect Zygisk and Zygote (official latest Magisk Canary 25205, Zygisk enabled, DenyList configured and not enforced, Shamiko v0.6 in default black-list mode)
    Just Curious
    Which command did you use to flash the patched_magisk...img with?
    1. fastboot flash init_boot magisk_patched...img
    2. fastboot boot init_boot magisk_patched...img
    I think they both will work. :)
    Personally, unless booting an image is not an option..

    I always test boot the Magisk patched image using fastboot boot NameOfFile.img instead of flashing it.
    If it boots, Magisk will be active and I then use the Direct install option to make it permanent.
    If it does not boot, then no harm since the stock boot image is still installed. 🙃

    Cheers. :cowboy:

    Root detection, as on the screenshot

    I can pass with Delta but cannot with TJW Canary

    latest, Zygisk, MagiskHide, no Shamiko, App Data Isolation, HMA

    latest, Zygisk, DenyList, Shamiko, App Data Isolation, HMA, even with Magisk app uninstalled

    I have tested thoroughly on my two Xiaomi phones, one with A11 and the other with A12.
    Tested on both phones with Canary and with Delta - and I have the same results on both phones

    Not to mention that I fully pass Oprek, Ruru, TB-Checker, SafetyNet/Play Integrity
    Yup, Native bridge loading based on Maru Magisk fork implementation of Riru's loading method seems to have much merit...

    Nb. Original author says it's an experiment however, still not perfectly implemented and may be issues w/ some modules... Also Shamiko hiding with probably not work properly with this... Long read here for those interested:

    For others, I put more here too:

    🙂 PW
    Worth pointing out that @zgfg asked me to test that on Magisk Canary (official) earlier but ive broken something it seems with my uber Samsung debloat and cant get S-check to even open anymore :)

    Anyone else care to chime in with Magisk Canary (official)
    I had that issue a while back, I do not remember what I did to fix it. :unsure:
    I just setup my Pixel 5a (it did not like updating from July to November 🙄) so clean flash. 😛

    No issues with Security Check. 🙂

    Pixel 6 - Stock Google 12L (July 2022).
    Pixel 5a - Stock Google 13 (November 2022).

    Magisk debug (snapshot)
    - Personal build from the official branch, so it includes the commits since the last canary/debug release.
    Magisk - [GitHub] - Building and Development

    USNF - Not the one that includes Displax's changes.
    - Personal test build that includes some other (mostly prop) changes.
    Fork - [GitHub] - commits
    One of these days I will have to pull Displax's Zygisk changes. 🙃

    - Set fingerprint back to stock Pixel 12.
    Pixel 6 is using the Pixel 6 12 print, 5a is using the 5a 12 print.

    Shamiko and LSPosed modules.

    HMA (Beta v3.0.5 r373)
    Two templates.
    - Settings (renamed Magisk app).
    - Hide My Applist.

    - YouTube
    - YouTube Music​

    AdAway running in VPN (non-root) mode. ;)

    Cheers. :cowboy:
    Personally, unless booting an image is not an option..

    I always test boot the Magisk patched image using fastboot boot NameOfFile.img instead of flashing it.
    If it boots, Magisk will be active and I then use the Direct install option to make it permanent.
    If it does not boot, then no harm since the stock boot image is still installed. 🙃

    Cheers. :cowboy:
    Some have said it's a waste of time to test by booting first, then direct installing because you can just flash the stock image back if it doesn't work.
    This maybe true, but directly flashing the patched image does NOT give Magisk the chance to back up the stock boot image, whereas booting then installing does.
    This makes it easier to take an OTA update on devices that require everything to be pure stock before proceeding by using Magisk's restore images function.
    Hello everyone!

    Thank you for the very active thread i finally managed to figure out what i did wrong (yet again).

    I rarely tinker with the device, and when i am forced to, then i forget about A/B partitions, and wipe boot.img.

    I was hoping there is now another way for keeping TWRP and Magisk. Aside from embedding twrp image in stock boot, and than patching from magisk manager?

    Thank you.

    Also if someone more knowledgeable could help (even though it is slightly Offtopic), do i patch boot img with firmware boot img, or boot img from the custom rom i was using?

    Because that rom was then for testing (even though i kept it), and i can't figure out the version.
    I suspect when i run adb shell getprop "ro.product.version" it will probably fail, because i did a number on that device trying to fix it without understanding A/B partitions.
    Only if you don't have Recovery partition, then you patch TWRP to Boot (and afterwards the Magisk)

    (It's not necessarily specific to A/B devices - there are A/B devices that do have separated Boot and Recovery partitions, and in that case TWRP goes to Recovery partition, Magisk to Boot)

    But when you update Magisk, you can just take Direct Install (update)


    And of course, you must patch the boot.img corresponding to your current ROM. Usually, you can find it in the ROM zip file

    If you use some stock boot.img instead, then you risk the bootloop (of course, if boot img from your custom ROM coincides with the stock boot img then it doesn't matter, but usually it won't be the case - or you will not know

    That does not depend on Magisk - if the boot.img is wrong and you flash it (with or without Magisk) it will cause the bootloop (in the 'better' case, it may boot but you might have troubles later because of eg the wrong Kernel).
    Hence make sure to always use (for patching) the correct boot img
  • 1089
    This is the place for general support and discussion regarding "Public Releases", which includes both stable and beta releases.
    All information, including troubleshoot guides and notes, are in the Announcement Thread
    Hello, I haven't given much support on XDA lately. It can be resulted from
    • University started and I have limited free time. In fact, I mostly develop during midnight
    • I live in Taiwan, which has large time zone differences between my European/American contributors/testers, which usually forces me to stay up late at night to discuss/test stuffs.
    • The new version is about to come, I don't want to spend effort on supporting old releases
    The planned update is delayed again and again, to some point I think I'll shed some light about what has been happening lately, also along with some announcements.

    New Forum!
    As you might have already discovered, Magisk got its own subforum on XDA! Many thanks to all the support you gave me, and much more information/features/support is about to come!
    **For developers supporting all the devices that are not using standard Android boot format, feel free to create threads in this section (actually, PLEASE do so) for your favorite devices after v7 is out. As I currently know, Asus devices require signing the boot image before flashing, and is model dependant; Sony devices seems to use ELF kernel that is unpatchable, or some has two ramdisks (inner + outer), both requires different workarounds; LG bootloader locked devices has to manually "BUMP" the boot image after flashing Magisk..... and there may be lots of other crazy boot image formats that haven't come up to my attention yet.
    It is impossible for me to support all these non-standard boot images, and I hope the community can collaborate to make Magisk running across all the devices. Overall, community collaboration is what XDA about :D

    The Pixel Phone
    Some of you might already know this news, that the next Pixel Phone right around the corner seems like it does not have ramdisk in boot image, which pretty much wrecked Magisk in all ways. However, it pretty much doomed root itself too. Kernel modifications is inevitable IMO, so I'll try to migrate my scripts to C programs that could possibly be included into the kernel itself. Note that I'm not familiar with linux kernel, I'm not even sure if my idea and concept is correct or not. But once the device is available, I think developers will find a way to bypass all the difficulties, and I'll do my best to learn things ;)

    Current Progress
    In the past month, I've spent quite some time learning SELinux, so that I can avoid using SuperSU's sepolicy patches. Thanks to the helps and tips from @phhusson and @Chainfire, I finally have a much clearer understanding of how SELinux works. The Magisk core parts (the scripts, boot image patches, new features, more supports) are actually done some time ago. What is causing all the delays is the Magisk Manager.
    To be completely honest, although I can code in Java without much issues, Magisk Manager is actually my first Android application, I had to reach out for assistance, and fortunately awesome developers like @DVDandroid and @digitalhigh contributed a lot, which makes the current Manager awesome.
    After the repo system and module management is mostly done, I was about to do some adjustments and release, but what we really done is decided to add another feature: auto-unroot with per-app settings. I decided to wait for it to be finished, and then do my adjustments. Due to reasons that'll be mentioned later, this feature will likely not be available for the next release (should come in future updates)

    Safety Net Disaster
    Those who are using Magisk for Safety Net bypass purposes must have known that Google recently updated the detection method of my Systemless Xposed. I still have no idea what Safety Net is detecting, so currently I cannot fix it on my side (also because I'm busy working on the next update). However, suhide developed by @Chainfire is able to hide Xposed and worked fine.
    However, only my Systemless Xposed v86.2, which is based on SuperSU's su.d, is supported using that method. v86.2 and v86.5 (latest, Magisk based) have nearly identical binaries, and the only difference is the path where the binaries are stored.
    I'm still not sure what's the real issue for it not being supported, I just hope it is not done intentionally.

    Due to the fact that my Safety Net bypass is not 100% perfect now, I do not want to spend any more time waiting for auto-unroot to be polished. What I'm doing now is finishing up all the things I'd like to change in Magisk Manager (it has been a while since I last contributed to Manager, my fellow developers are doing all the heavy job), which might take a little more time, after that, packed with tons of information to be announced in Magisk Section, I'll release the long awaited update.

    Hope this lengthy post gives you the idea of the whole situation, and again thanks for all your support!!
    Ah, some Chainfire bashing, I hope it is not too late for me to exercise additional villainy.

    First, let me make clear I have nothing against @topjohnwu, nor against Magisk. Magisk is an interesting project and it certainly displays @topjohnwu ingenuity and persistence. I don't doubt we will see more interesting things from his hands.


    What has happened here is not all that dark and complicated, from either end. I returned from holidays, and someone pointed me at Magisk. My first thought: interesting!

    Among other things, the thread lists some issues with SuperSU, which in combination with the phrase The developer also requests users to not bug Chainfire with compatibility requests for SuperSU with Magisk from the portal article, raised my left eyebrow by nigh half an inch. The popular systemless xposed mod is apparently now based on it, and apparently it now no longer works with SuperSU, and apparently I'm not supposed to fix that, nor any of the other found issues. I found that a bit weird. So yes, I have told @topjohnwu that I was a bit surprised he was posting about issues with SuperSU without notifying me about them (I can't fix or help fix issues I'm not aware of, after all).

    He's also spreading a modified version of the SuperSU package, which is not all that uncommon, nor necessarily a problem. I have not looked into what he modified, I only ran a few quick tests on one of my devices, and found some commonly used commands run as root to be broken. I have informed him of this as well.

    It appears the tool of choice for Magisk is phh's Superuser, because of some of the mentioned issues with SuperSU. That's fine by itself, but fixing issues in that superuser by incorporating SuperSU's binaries into it is a somewhat questionable practise. After all, SuperSU is a commercial closed-source package that helps pay for my dinner, and superuser is a direct competitor. I have informed him that I was surprised he did this without asking for permission. I have expressed similar surprise on him spreading a modified version of LiveBoot (which helps pay for a snack now and then).
    @topjohnwu has also stated that Magisk's scripts are largely influenced by mine (I have not checked). Scripts based on mine are used all over the place on XDA, some people have crafted amazing things based on them, I have never made an issue of this (otherwise I would have just made them binaries). But yes, I have also stated to him that I don't think it's very nice to base something on one program, and then using that to (almost exclusively) push something directly competing with that program.

    tl;dr Towards @topjohnwu, I have:
    - expressed surprise he has issues getting Magisk to work with SuperSU, and has chosen not to inform me about those
    - expressed surprise he is using SuperSU binaries in a competing superuser without permission
    - expressed surprise he is posting a modified LiveBoot without permission
    - informed him of issues with the modified SuperSU he has posted
    - let him know I thought it wasn't very nice to be applying my scripts to benefit seemingly exclusively that same competing superuser

    To be crystal clear:
    - I have not asked for an apology
    - I have not asked for Magisk to be abandoned, neither the root hiding nor systemless module parts, and certainly not systemless xposed
    - I have not made an issue of any of this anywhere, until this post
    - I have not even specifically asked for anything to be taken down (though obviously in my opinion the other superuser package mixed with SuperSU's binaries, as well as the LiveBoot package, should go)
    - I have not reported this thread to XDA moderators for copyright violations or otherwise

    While my conversation with @topjohnwu may not win any awards for being friendly (though it may win some for brevity), I think all things considered my response has been rather mild. To be perfectly honest, until the apology post, I thought this was over with already. I think the apology post was triggered because I haven't replied to his last PM for a while - I was in the zone, it happens.

    To emphasize again, I have nothing against @topjohnwu, Magisk, or systemless xposed, and it is certainly not my goal to see any of them go. If it can be made to work together with SuperSU, great.

    I get it though: you think of something, you want to see if you can make it work, you finally get it to work, you publish it, it takes off - enthusiasm gets the better of you. Maybe in the rush some mistakes are made. That doesn't mean you have to just drop it and run. None of my stuff would make it past 0.1 if I stopped at the first big mistake :)

    Aside from said being in the zone coding, I usually regret actually responding to these sort of things the day after, which has made me hesitant to reply. Surprise me.
    Thread temporarily closed so everyone sees this.

    The flood of "SafetyNet isn't working for me either!" posts are not helpful, at all. Please refrain from posting further, it will be looked into. Please do not forget that not passing SafetyNet is 100% NORMAL AND INTENDED when you have an unlocked booloader or running custom firmware. These are workarounds and they will be worked around in turn.

    The Flash
    Forum Moderator

    EDIT: Thread is reopened... I will be cleaning any SafetyNet posts for a while to keep the thread clean for real issues.
    Hello everyone!

    I am aware that Google has updated Safety Net that makes Magisk itself a no go for Android Pay. In fact, I witnessed the change live while I am developing the new magiskhide, which should hide all Magisk modules and Magisk installed root.

    Google is serious about Safety Net now, clearly hunting down all possibility to run Xposed with Safety Net passed. I spend quite some time examining the new security measures last midnight, and fortunately it seems that it is possible to run Magisk and root along with Safety Net if no Xposed is running. I'm glad I removed the old root toggle at the right time lol, that is no longer feasible with the latest detection.

    So stay tuned for the next update, it will come with bug fixes, along with the new magiskhide to bypass that Safety Net.

    Google, how will a few systemless mods do any harm :p:p