Magisk General Support / Discussion

Search This thread

pndwal

Senior Member
I've flashed recently CSC file and lost the root.
I'm guessing flash CSC = factory reset? Did you do this in Odin w/ other needed binaries incl. AP?...
I updated MAgisk app up to 25.1 version (not a zip file just apk) but still no root. I have flashed Magisk 25.1.zip file in TWRP recovery. Now the phone is rooted, but I unable to start Magisk app. It just stuck on the start (The Mask).
Strange issue... Do you have issues starting other apps? Tried clearing its app data?...

Also, try deleting everything in /data/adb and rebooting to rebuild Magisk config files... Use TWRP if you can't use a root explorer...
I tried to uninstall Magisk app via Application manager, and reinstall it following by reboot. Still Magisk unable to start. I don't remember whether MAgisk was unhidden before the update and zip installation. What should I do next?
Hidden app would be gone if did factory reset...

If installed since, check in device settings, Apps for 'Settings' (default name) or whatever you named it. Uninstall if found...
Should I rename the Magisk.apk to uninstall.zip and run this file in TWRP. Then install Magisk apk and install zip file from within Magisk App? If so, what the best way to install MAgisk App; via TWRP or File Manager?
Install app like any other .apk from 'unknown aources'...
Samsung Galaxy S5
Marshmallow 6.0.1
👍 PW
 

zgfg

Senior Member
Oct 10, 2016
7,793
5,194
Also, Zygisk itself is just out of beta... Guess we shouldn't expect hide for Zygisk era Magisk to mature overnight...
After having no luck with Shamiko or DenyList Unmount, I now run without of them and with Enforce DenyList enabled

I still have the same Momo detections (su, Zygisk, Magisk) but bystem boots evidently faster and runs (hard to be sure since the phone is fast anyway) maybe even more fluid then with Shamiko
 
  • Like
Reactions: ipdev

dohanin

Senior Member
Mar 26, 2011
231
128
Sony Xperia X Compact
Xiaomi Mi Pad 4
Hi all, just some sharing on my experience in the past week.

I updated Magisk from stable 24.3 to 25.1, everything seemed fine.
Then noticed there were updates of USNF and Shamiko, which are the only modules I use, then I updated both.
Then the latest Momo reported nothing found (only bootloader unlocked), so all looked good.

However, in my Work profile, Zimperium zIPS detected ROOT! This is the last thing I want because it will automatically reports to my company that I'm using a rooted device to access company mails, etc. :_(

I reverted USNF and Shamiko to the previous versions, still no luck.
Then a full uninstall of Magisk, followed by installing 24.3. Then latest versions of USNF and Shamiko.

Well, Momo this time reported Zygisk found. Then zIPS only reported App Tampering instead of ROOT.
Ok, reverted Shamiko from 0.5.1 to 0.5.0, then App Tampering is gone too. So, everything back to normal for me (except Momo reporting Zygisk, which I don't care!)

So Magisk 24.3, USNF latest, Shamiko previous (0.5.0) works for my device to defeat zIPS.
Edit: Momo only detects Unlocked Bootloader for me in this setup.

Just some sharing :)
 
Last edited:

pndwal

Senior Member
I had never done the Hide the Magisk app, but the issue does seem to involve remnants of something. The first time i tried to uninstall it (using Settings / Apps / Magisk), I then attempted to install via adb, and received a warning the app already existed. I then uninstalled via adb, and attempted to install after that (no warnings, but something still not working).

Later, with 25.1 supposedly installed again, I noticed in F-Droid (I have never used F-Droid to install Magistk, but of couse it reports the existence of any app with the same name as one in its repository) that it still reported 24.3 installed. So, I used F-Droid to uninstall Magisk (why not?), but then, after reloading F-Droid, it still reported version "1.0" as installed. So, I uninstalled that as well, and F-Droid no longer reported any Magisk on the system. I searched through System / Apps (even with Show system enabled), and saw nothing that I did not recognize. I installed the 25.1 apk downloaded from github again, flashed the patched boot image again, and... same result (Magisk just shows as N/A).

I do notice that if I attempt to install Magisk 25.1, I get the full app (Settings / Apps shows Magisk as 23.42 MB), but if I install 24.3 (working perfectly until a few hours ago), it initially shows as 22.80 MB, but the first time I attempt to start it, it crashes immediately, and then the icon changes to the generic Android icon, and the size in Settings / Apps changes to 224 KB.
Assuming 25.1 binary is installed, this seems to be intended behaviour for 25.1+ daemon:
  • [General] Enforce the Magisk app to always match or be newer than magiskd
(Commit:
Force app version not lower than daemon)

The device (a Teclast T10 tablet with the exact model number of E3C5) has the latest stock firmware (1.05_20180306) built from Android 7.0.
This issue seems strange however, and may warrant a GitHub issue ticket... Do what you can to ensure no stub is installed first however...

Type Magisk -c in terminal emulator to see Magisk binary version installed, or Magisk -v to see daemon version running...

Note that since 16.6 we had
  • [Daemon] Check whether a valid Magisk Manager is installed on boot, if not, install stub APK embedded in magiskinit
This has been working in older Magisk, but seems to be removed / broken in 25.x on my device... I'm guessing you've been getting stub installation on boot after removing full app w/ 24.3 binary installed...

Anyway, check you are installing full app matching installed binary and stub is not present...

Nb. There have be many recent tweaks for app loading, signature checks, stub functions etc, so you are ikely experiencing some regression... More changes are coming too, eg this is already merged in TJW master but not yet built in a release:
Build dynamic stub resource APK at runtime ...
Close #6013
Co-authored-by: vvb2060
topjohnwu and vvb2060 committed 8 days ago

🤠 PW
 
Last edited:
  • Like
Reactions: ipdev and rodken

pndwal

Senior Member
Or boosted, actually :D
Yup... But boost = catalyst for Oxidation... he's excited about Rust... 😛

2 commits in his CXX (interop) repo, 1 in ONDK (w/ rust tool-chain), and 6 in Rust (Programming language) Custom and fix-lid branches in last 10 hrs...

Of course this is all still relevant!:
John Wu, Jun 19

Magisk v25.1 published to public stable 🎉🎉
www.twitter.com/topjohnwu/status/1534117522424811520/photo/1

This marks the official start of v26's development cycle, which also starts the Oxidation Project (adding Rust to Magisk). So excited!
www.twitter.com/topjohnwu/status/1538462758332575744

... and he's been studying Rust for more than a year... good to see such commitment being distilled now for Android modders benefit!

Seems open source & equally committed contributors / collaborators have also allowed him to do this...
https://forum.xda-developers.com/t/magisk-general-support-discussion.3432382/post-84827781

Linus says Rust is coming to the Linux kernel "real soon now... Rust is a way to try something new. And hopefully, it works out, and people have been working on it a lot, so I really hope it works out because otherwise they'll be bummed."
https://www.theregister.com/2022/06/23/linus_torvalds_rust_linux_kernel/

Seems Rust is coming to Magisk injection for kernels 'real soon now' too... If Rust is a way to try something new, hopefully it works out for Magisk too... John's clearly been working on it a lot, so I really hope it works out... because we don't want to be given the bum's rush...

😷 PW
 
Last edited:

HippoMan

Senior Member
May 5, 2009
1,926
745
Hippoland
Seems Rust is coming to Magisk injection for kernels 'real soon now' too... If Rust is a way to try something new, hopefully it works out for Magisk too... John's clearly been working on it a lot, so I really hope it works out... because we don't want to be given the bum's rush...

😷 PW
... nor the bum's Rust.

(Sorry, couldn't resist!)
 

pndwal

Senior Member
Yup... But boost = catalyst for Oxidation... he's excited about Rust... 😛
...
😷 PW
Covidtime = downtime?... Nah! It's Dreamtime... For the TJW-CPU, uptime! -
John Wu, Jul 1

Spent the past few days while resting and recovering from COVID setting up Magisk for Rust development semi-consciously LMAO 😵💫
www.twitter.com/topjohnwu/status/1542633717495083008

😴💭💡😝 PW
Maybe it's a game to him... "The RUST sleep command will allow admins and moderators, upon issuing the command, to instantly put themselves into sleeper mode. Once they're in sleeper mode, they are required to press any button on their keyboard or mouse to wake up."
https://www.corrosionhour.com/rust-sleep-command/
 
  • Like
Reactions: dr4go and 73sydney

73sydney

Senior Member
Covidtime = downtime?... Nah! It's Dreamtime... For the TJW-CPU, uptime! -

www.twitter.com/topjohnwu/status/1542633717495083008

😴💭💡😝 PW
Maybe it's a game to him... "The RUST sleep command will allow admins and moderators, upon issuing the command, to instantly put themselves into sleeper mode. Once they're in sleeper mode, they are required to press any button on their keyboard or mouse to wake up."
https://www.corrosionhour.com/rust-sleep-command/

Theres no stopping him

Theres a rumour he can actually see Ponkles in real time
 
  • Haha
Reactions: pndwal and dr4go
I have a question about OTA incremental updates. I have a OnePlus 9 on OxygenOS 12 C.48. C.61 is now being pushed out. Oxygen Updater no longer offers the full updates and is telling me to use incremental. Everytime I updare with incremental I get a boot loop and have to factory reset to be able to boot again, of course losing all data. Is there some new way we are supposed to update with incremental? The following is how I usually try to do it.


1. Magisk > Uninstall > Restore Images
2. System Settings update (DO NOT REBOOT)
3. Magisk > Install > Install Into Inactive Slot (After OTA)


Am I missing something? I do not have any modules installed, except Systemless Hosts. I have read that I should disable modules. Should I just restore images and complete uninstall Magisk?
 

ipdev

Recognized Contributor
Feb 14, 2016
1,916
1
3,507
Google Nexus 10
Nexus 7 (2013)
I'm stuck in a bootloop due to a module I installed (foxyboot?). I can boot normally with the stock boot.img and another boot image that gives me ADB root access.

(SNIP)

Is it possible for me to just remove all the ADB files on the device eMMC and reinstall magisk manager? Where else is magisk storing files other than /data/ADB ?
Yes.

The /data/adb directory will be created the next time you boot a magisk patched boot image.
There might be a few extra magisk files in /data (magisk backup files).
If you installed magisk by flashing in recovery and you ROM supports addon.d scripts, there will be a Magisk script in the /system/addon.d directory.​

Use the App Info section to uninstall the Magisk app.
Normally long-press the icon and you will get an option for info or, go though system setting, Apps.
Use app info to Force stop, clear cache and data then uninstall the magisk app.​

---

Then reboot with your stock boot image.

Install Magisk (app) and patch your stock boot image.
Reboot with the new Magisk patched image.


Cheers. :cowboy:
 

Finnzz

Senior Member
Sep 26, 2017
222
131
Yes.

The /data/adb directory will be created the next time you boot a magisk patched boot image.
There might be a few extra magisk files in /data (magisk backup files).
If you installed magisk by flashing in recovery and you ROM supports addon.d scripts, there will be a Magisk script in the /system/addon.d directory.​

Use the App Info section to uninstall the Magisk app.
Normally long-press the icon and you will get an option for info or, go though system setting, Apps.
Use app info to Force stop, clear cache and data then uninstall the magisk app.​

---

Then reboot with your stock boot image.

Install Magisk (app) and patch your stock boot image.
Reboot with the new Magisk patched image.


Cheers. :cowboy:
Thank you, I got it sorted. I forgot to I was using an incompatible magisk boot image. Once I switched that out everything was working again. Two hours wasted on that lol
 
  • Like
Reactions: ipdev

meric57

Senior Member
Oct 2, 2017
223
39
Oeutrange
Samsung Galaxy Tab E
Hello, how does it work well there is this package ddgv.cdb that normally there was John Wu.com.
 

Attachments

  • Screenshot_20220702-193737.jpg
    Screenshot_20220702-193737.jpg
    296.2 KB · Views: 42

zgfg

Senior Member
Oct 10, 2016
7,793
5,194
Hello, how does it work well there is this package ddgv.cdb that normally there was John Wu.com.
OMG
'Hiding' Magisk app does repackaging (changing package name to random).
Unhide if you don't like and don't hide in the future (or get to know and understand that renaming package to random helps to hide it from banking and similar apps)
 
  • Like
Reactions: meric57

zgfg

Senior Member
Oct 10, 2016
7,793
5,194
Good evening zgfg, thank you so as I hid magisk as proposed setting so it comes from this package of its name.
I don't know where is the problem. How hiding works and what it does and everything about has been mentioned and discussed literally hundredth of times in this thread

And one of the XDA forum rules (and not only on XDA) asks that people read and learn before asking. Hence it really makes no sense to ask about something absolutely basic and to be surprised about, and for others to waste time teaching that hiding the Magic app will rename it's package name and what for
 
  • Like
Reactions: meric57

Top Liked Posts

  • 2
    I have problem to update Magisk in samsung note 9 sm-n960f/ds. Please help
    View attachment 5719965
    You need to do just as the message above states; download ROM corresponding exactly with current version (especially if you took OTAs since first Magisk installation), patch the AP binary and Odin flash all 4 binaries per 'Samsung (System-as-root)' section in Installation Instruction page under 'Upgrading the OS' (even though you're not 😉 ): Flash magisk_patched.tar as AP, together with BL, CP, and HOME_CSC...

    (- Please say if you use a custom ROM... May have additional issues...)

    This is needed because refactoring of magiskinit injection in 25+ has broken Direct Install (when updating previously patched boot images) in a number of 2SI boot type devices as images w/ patched fstab (no longer done) are now incompatible with magiskboot patching... Instructions for patching / flashing Magisk from unpatched images still works fine...

    Further, since updating your legacy ramdisk boot type device to Android 10 it has been automatically updated to 2SI boot type... As such 'Samsung (System-as-root)' section (methods, precautions, warnings) has information pertinent to your device despite the message "If your Samsung device is NOT launched with Android 9.0 or higher, you are reading the wrong section". (- This was true at the time of writing however since no Sammy devices yet had A10)...

    👀 PW
    1
    yes gsi was smooth.

    google A13 and i just discovered LeOS beta based on android 13 works fine too but there are no google apps. it is very smooth. and yes i did flash all the other binaries along with the patched ap file. i also have twrp installed and vb meta disabler.tar flashed along with it. thats how i install gsi's through twrp
    oh its not about magisk the A13 image didnt even boot at all no matter what i did. this build was actually based on sooti's android 13 aosp which didnt boot on alot of devices including mine soo it makes sense. maybe some better gsi will pop up eventually. but thanks
    ... Just a couple of thoughts:

    ROM Devs properly don't distribute GApps with ROM if they care about Google's rules / licensing for proprietary code, however these are easy to 'sideload', and distributions for this purpose, ie. for personal installation by end user on certified (licenced) or Google Registered (whitelisted for custom ROM use by submitting Google Services Framework Android ID) devices, are permitted / sanctioned by Google... You should be able to install OpenGapps, BitGapps, NIKGapps or other distributions after installing a ROM lacking these...

    If you can get a fastboot type distribution of your desired ROM you may have more success, and even with a recovery ROM you should be may be able to extract vbmeta partition and flash it with the following switches:
    fastboot flash vbmeta --disable-verity --disable-verification vbmeta.img
    per official Magisk (optional) instructions:
    https://topjohnwu.github.io/Magisk/install.html#patching-images
    instead of using 3rd party vbmeta disabling methods... I really don't know if this will help, but may be worth a shot...

    🙂 PW
  • 7
    Can someone either provide actual proof that zygisk/shamiko etc does anything to GPS (i havent had a single issue and i use it daily) or i dunno, maybe stop spreading FUD because of personal gripes you have against people on other platforms that dont take part here, and therefore wont get any of the swipes youre taking at them here that only further add to the aforementioned FUD.

    We've all had our moments with those folk and its fine to mention the odd bit of spice you may come across when trying to submit an issue on github (ive done this myself), but to then to continually poison magisk proper/shamiko because of that person/persons taking part is not helping anyone. Thats a personal gripe, and shouldnt colour the entire magisk (proper) project/shamiko. What we dont need is spice here....

    Please, you know who you are...

    I think we've all had enough, now
    5
    Hello good people,

    I'm trying my luck here hoping that someone more knowledgeable with magisk can give me a hint about my issue.
    I succeed to build a Samsung S22 Ultra (S908B) rom with f2fs rw partitions (stock rom has locked ro dynamic partitions) but it boots only on permissive kernel patched with magisk 24.3, more precisely 24301. I mention that it boots ok but zygisk cannot be activated. (activation ok in magisk app settings but it says Zygisk = No on magisk app home page)
    As soon I update and patch the kernel with a higher version of magisk, the phone bootloops. Tried all v24 and v25 magisk versions and it bootloops on any version higher than 24301.

    Here are the differences between magisk 24301 (boots ok) and 24302 (bootloop).

    Diffs 24301 --> 24302

    - Support multiple CPIO concatenated
    - Use /data as tmpfs mount point in 2SI setup
    - Cleanup inheritance
    - Introduce new sepolicy injection mechanism
    - Add hijack sepolicy support for rootfs devices
    - Remove unused code
    - Reorganize magiskinit code
    - Fix #5589 (WARNING: linker: su unsupported flags DT_FLAGS_1=0x8000001 after typing su on terminal emulator)
    - Log if failed to dlopen a zygisk module
    - Use standalone magiskpolicy
    - Make magiskinit not magiskpolicy
    - SAR can also have monolithic sepolicy
    - Also hijack plat_file_contexts if necessary

    PS. On stock rooted rom magisk update to v24 and v25 is ok but all partitions are ro. Although it still need permissive kernel to boot.

    Thank you in advance for any hint/advice.
    FWIW, I found older info I posted in addition to link above re. problems getting r/w /system at least w/ stock Android 10 or later any more due to shared blocks implementation:
    https://forum.xda-developers.com/t/magisk-general-support-discussion.3432382/post-85049195

    ... and re. Magic Mount, the new way to 'write' to /system w/ Magisk systemlessly.

    Of course you can rebuild whole filesystem to overcome OEMs locking /system to read only (by using an automated bash script by XDA member @lebigmac to "Universally Mount System read write"... BUT (big but), you MUST be adventurous / maverick / a 'Power User' / know your stuff) as mentioned, but you should be able to make just about any needed changes to /system systemlessly using Magisk without the myriad issues/pitfalls inherent in R/W mounted /system... Of course for simple property manipulation @Didgeridoohan's MagiskHide Props Config module is probably all you need, but you can overlay /system (hence Magisk description 'The Magic Mask for Android') with just about any files / code using Magisk Tools provided.

    Interestingly, the link following refers to how John Wu has even overlayed a stock system with an entire custom ROM as Proof of Concept for a projected Universal MultiROM (Magisk powered custom ROM)... Unfortunately he didn't take that much further...

    I posted (earlier) info on these two methods here:
    https://forum.xda-developers.com/t/magisk-general-support-discussion.3432382/post-84859571

    🤠 PW
    5
    I'm sorry I didn't realize that.

    I've been so used to generic steps (boot recovery -> flash recovery -> reboot recovery -> wipe all -> flash firmware -> flash ROM -> flash GApps -> flash dm-verity disabler -> boot system -> boot recovery -> flash Magisk -> flash *Posed) that I didn't bother checking if steps have changed.

    Therefore, neither.

    Honestly I think it's too bad that we can't just flash ZIPs anymore, that was so easy.

    Anyway, thank you for your response.
    For everyone, a bit of

    Insight into Custom Recovery installation method Depreciation:

    Yup... Method was fine for old legacy ramdisk booting devices, but does rely on custom recovery compatibility, and John ended up fielding the TWRP issues; plenty from official TWRP builds not to mention broken unofficial ones... Then Dees Troy needed to attend to real life and Team Win simply couldn't adapt to Google's ever changing system architecture, boot methods etc fast enough and lagged way behind Magisk. (See John's Android Booting Shenanigans)...

    This precipitated the move to an installation solution that doesn't rely on other custom development, but wasn't the only practical consideration; 'Manager' and now 'App' patching w/ fastboot (etc) flashing meant owners of
    devices with no custom recovery can start rooting and do further modification
    https://forum.xda-developers.com/t/magisk-the-magic-mask-for-android.3473445/post-72587983
    and users can also preserve stock recovery to apply OTAs etc... Thus 'Magisk Manual Injection' was born...

    Next, support was added for patching Samsung AP firmware which recovery/zip installation couldn't achieve. Then with Project Treble came efforts to
    update Magisk to be modular and adaptive to follow Google's Pixel concept... modding a device has changed completely. I am a strong advocate of these new changes, praising the effort Google has put into designing such weird but fascinating setup despite many view this as "moves against developers".

    With the announcement of Project Treble, all devices will go through the same "Pixel-ize" treatment, so this future is inevitable. Project Treble is all about "modular", and Magisk has been rewritten to embrace this concept. I have spent extra effort to backport the changes made requires to run on these new modern devices to downward support all devices, so we do not need 2 drastically different installation methods...
    https://forum.xda-developers.com/t/magisk-the-magic-mask-for-android.3473445/post-74961572
    ... and then 'recovery mode' support for many A-only legacy SAR devices (A9 / 2018) w/ ramdisk only in recovery partition (again not supported by recovery/zip installation)... And it is now noted:
    This installation method is deprecated and is maintained with minimum effort. YOU HAVE BEEN WARNED!

    Installing using custom recoveries is only possible if your device has boot ramdisk.

    Installing Magisk through custom recoveries on modern devices is no longer recommended. If you face any issues, please use the proper Patch Image method.
    ...

    Note that even (old) legacy ramdisk boot-type devices are to be considered 'modern' once running Android 10+ as they are automatically converted to current 2SI "SAR" boot-type!...

    👀 PW
    5
    How does PixelFlasher invoke boot_patch.sh?
    Does it invoke it as an "executable", creating a new process? Or does it "source" it, so changes to the environment will survive?

    Does PixelFlasher create an environment variable named "SHA1"?

    My copy of boot_patch.sh has a compound statement that tests whether SHA1 has a non-zero length value before setting it to the sha1 of the boot image. If the environment variable is already set, it will not be overwritten. I don't know why.
    I wouldn't source. The script is supposed to be called as an executable

    Eg, my following code is rather primitive but it dumps the active Boot partition (it supports A/B and non-A/B devices), then it patches by invoking the boot_patch.sh script, finally it dumps back to the Boot partition and automatically reboots

    Ie, it updates me the Magisk and it also leaves me the patched-boot img in the Download folder

    Code:
    #!/system/bin/sh
    
    # Boot partition
    AB=$(getprop ro.boot.slot_suffix)
    BOOT_PART=/dev/block/bootdevice/by-name/boot"$AB"
    
    # Boot and patched boot images
    DOWNLOAD=/sdcard/Download/
    BOOT_IMG="$DOWNLOAD"boot.img
    PATCHED_BOOT_IMG="$DOWNLOAD"patched-boot.img
    
    # Magisk path
    MAGISK_PATH=/data/adb/magisk/
    
    # Disk-dump boot image to Download folder
    dd if="$BOOT_PART" of="$BOOT_IMG"
    
    # Patch the boot image and move to Download folder
    "$MAGISK_PATH"boot_patch.sh "$BOOT_IMG"
    mv "$MAGISK_PATH"new-boot.img "$PATCHED_BOOT_IMG"
    
    # Flash the patched boot image
    dd if="$PATCHED_BOOT_IMG" of="$BOOT_PART"
    
    # Reboot
    reboot
  • 1085
    This is the place for general support and discussion regarding "Public Releases", which includes both stable and beta releases.
    All information, including troubleshoot guides and notes, are in the Announcement Thread
    156
    Hello, I haven't given much support on XDA lately. It can be resulted from
    • University started and I have limited free time. In fact, I mostly develop during midnight
    • I live in Taiwan, which has large time zone differences between my European/American contributors/testers, which usually forces me to stay up late at night to discuss/test stuffs.
    • The new version is about to come, I don't want to spend effort on supporting old releases
    The planned update is delayed again and again, to some point I think I'll shed some light about what has been happening lately, also along with some announcements.

    New Forum!
    As you might have already discovered, Magisk got its own subforum on XDA! Many thanks to all the support you gave me, and much more information/features/support is about to come!
    **For developers supporting all the devices that are not using standard Android boot format, feel free to create threads in this section (actually, PLEASE do so) for your favorite devices after v7 is out. As I currently know, Asus devices require signing the boot image before flashing, and is model dependant; Sony devices seems to use ELF kernel that is unpatchable, or some has two ramdisks (inner + outer), both requires different workarounds; LG bootloader locked devices has to manually "BUMP" the boot image after flashing Magisk..... and there may be lots of other crazy boot image formats that haven't come up to my attention yet.
    It is impossible for me to support all these non-standard boot images, and I hope the community can collaborate to make Magisk running across all the devices. Overall, community collaboration is what XDA about :D

    The Pixel Phone
    Some of you might already know this news, that the next Pixel Phone right around the corner seems like it does not have ramdisk in boot image, which pretty much wrecked Magisk in all ways. However, it pretty much doomed root itself too. Kernel modifications is inevitable IMO, so I'll try to migrate my scripts to C programs that could possibly be included into the kernel itself. Note that I'm not familiar with linux kernel, I'm not even sure if my idea and concept is correct or not. But once the device is available, I think developers will find a way to bypass all the difficulties, and I'll do my best to learn things ;)

    Current Progress
    In the past month, I've spent quite some time learning SELinux, so that I can avoid using SuperSU's sepolicy patches. Thanks to the helps and tips from @phhusson and @Chainfire, I finally have a much clearer understanding of how SELinux works. The Magisk core parts (the scripts, boot image patches, new features, more supports) are actually done some time ago. What is causing all the delays is the Magisk Manager.
    To be completely honest, although I can code in Java without much issues, Magisk Manager is actually my first Android application, I had to reach out for assistance, and fortunately awesome developers like @DVDandroid and @digitalhigh contributed a lot, which makes the current Manager awesome.
    After the repo system and module management is mostly done, I was about to do some adjustments and release, but what we really done is decided to add another feature: auto-unroot with per-app settings. I decided to wait for it to be finished, and then do my adjustments. Due to reasons that'll be mentioned later, this feature will likely not be available for the next release (should come in future updates)

    Safety Net Disaster
    Those who are using Magisk for Safety Net bypass purposes must have known that Google recently updated the detection method of my Systemless Xposed. I still have no idea what Safety Net is detecting, so currently I cannot fix it on my side (also because I'm busy working on the next update). However, suhide developed by @Chainfire is able to hide Xposed and worked fine.
    However, only my Systemless Xposed v86.2, which is based on SuperSU's su.d, is supported using that method. v86.2 and v86.5 (latest, Magisk based) have nearly identical binaries, and the only difference is the path where the binaries are stored.
    I'm still not sure what's the real issue for it not being supported, I just hope it is not done intentionally.

    Conclusion
    Due to the fact that my Safety Net bypass is not 100% perfect now, I do not want to spend any more time waiting for auto-unroot to be polished. What I'm doing now is finishing up all the things I'd like to change in Magisk Manager (it has been a while since I last contributed to Manager, my fellow developers are doing all the heavy job), which might take a little more time, after that, packed with tons of information to be announced in Magisk Section, I'll release the long awaited update.

    Hope this lengthy post gives you the idea of the whole situation, and again thanks for all your support!!
    121
    Ah, some Chainfire bashing, I hope it is not too late for me to exercise additional villainy.

    First, let me make clear I have nothing against @topjohnwu, nor against Magisk. Magisk is an interesting project and it certainly displays @topjohnwu ingenuity and persistence. I don't doubt we will see more interesting things from his hands.

    -------------------------

    What has happened here is not all that dark and complicated, from either end. I returned from holidays, and someone pointed me at Magisk. My first thought: interesting!

    Among other things, the thread lists some issues with SuperSU, which in combination with the phrase The developer also requests users to not bug Chainfire with compatibility requests for SuperSU with Magisk from the portal article, raised my left eyebrow by nigh half an inch. The popular systemless xposed mod is apparently now based on it, and apparently it now no longer works with SuperSU, and apparently I'm not supposed to fix that, nor any of the other found issues. I found that a bit weird. So yes, I have told @topjohnwu that I was a bit surprised he was posting about issues with SuperSU without notifying me about them (I can't fix or help fix issues I'm not aware of, after all).

    He's also spreading a modified version of the SuperSU package, which is not all that uncommon, nor necessarily a problem. I have not looked into what he modified, I only ran a few quick tests on one of my devices, and found some commonly used commands run as root to be broken. I have informed him of this as well.

    It appears the tool of choice for Magisk is phh's Superuser, because of some of the mentioned issues with SuperSU. That's fine by itself, but fixing issues in that superuser by incorporating SuperSU's binaries into it is a somewhat questionable practise. After all, SuperSU is a commercial closed-source package that helps pay for my dinner, and superuser is a direct competitor. I have informed him that I was surprised he did this without asking for permission. I have expressed similar surprise on him spreading a modified version of LiveBoot (which helps pay for a snack now and then).
    @topjohnwu has also stated that Magisk's scripts are largely influenced by mine (I have not checked). Scripts based on mine are used all over the place on XDA, some people have crafted amazing things based on them, I have never made an issue of this (otherwise I would have just made them binaries). But yes, I have also stated to him that I don't think it's very nice to base something on one program, and then using that to (almost exclusively) push something directly competing with that program.

    tl;dr Towards @topjohnwu, I have:
    - expressed surprise he has issues getting Magisk to work with SuperSU, and has chosen not to inform me about those
    - expressed surprise he is using SuperSU binaries in a competing superuser without permission
    - expressed surprise he is posting a modified LiveBoot without permission
    - informed him of issues with the modified SuperSU he has posted
    - let him know I thought it wasn't very nice to be applying my scripts to benefit seemingly exclusively that same competing superuser

    To be crystal clear:
    - I have not asked for an apology
    - I have not asked for Magisk to be abandoned, neither the root hiding nor systemless module parts, and certainly not systemless xposed
    - I have not made an issue of any of this anywhere, until this post
    - I have not even specifically asked for anything to be taken down (though obviously in my opinion the other superuser package mixed with SuperSU's binaries, as well as the LiveBoot package, should go)
    - I have not reported this thread to XDA moderators for copyright violations or otherwise

    While my conversation with @topjohnwu may not win any awards for being friendly (though it may win some for brevity), I think all things considered my response has been rather mild. To be perfectly honest, until the apology post, I thought this was over with already. I think the apology post was triggered because I haven't replied to his last PM for a while - I was in the zone, it happens.

    To emphasize again, I have nothing against @topjohnwu, Magisk, or systemless xposed, and it is certainly not my goal to see any of them go. If it can be made to work together with SuperSU, great.

    I get it though: you think of something, you want to see if you can make it work, you finally get it to work, you publish it, it takes off - enthusiasm gets the better of you. Maybe in the rush some mistakes are made. That doesn't mean you have to just drop it and run. None of my stuff would make it past 0.1 if I stopped at the first big mistake :)

    Aside from said being in the zone coding, I usually regret actually responding to these sort of things the day after, which has made me hesitant to reply. Surprise me.
    76
    Thread temporarily closed so everyone sees this.

    The flood of "SafetyNet isn't working for me either!" posts are not helpful, at all. Please refrain from posting further, it will be looked into. Please do not forget that not passing SafetyNet is 100% NORMAL AND INTENDED when you have an unlocked booloader or running custom firmware. These are workarounds and they will be worked around in turn.

    The Flash
    Forum Moderator

    EDIT: Thread is reopened... I will be cleaning any SafetyNet posts for a while to keep the thread clean for real issues.
    75
    Hello everyone!

    I am aware that Google has updated Safety Net that makes Magisk itself a no go for Android Pay. In fact, I witnessed the change live while I am developing the new magiskhide, which should hide all Magisk modules and Magisk installed root.

    Google is serious about Safety Net now, clearly hunting down all possibility to run Xposed with Safety Net passed. I spend quite some time examining the new security measures last midnight, and fortunately it seems that it is possible to run Magisk and root along with Safety Net if no Xposed is running. I'm glad I removed the old root toggle at the right time lol, that is no longer feasible with the latest detection.

    So stay tuned for the next update, it will come with bug fixes, along with the new magiskhide to bypass that Safety Net.

    Google, how will a few systemless mods do any harm :p:p