Magisk General Support / Discussion

Search This thread


Senior Member
OT for this thread but..
The update to TWRP 3.6.2 broke adb sideload and partitions formatted with fastboot were not recognized by TWRP, when using newer/current versions of Platform Tools.
The fix (9-1) for adb sideload (using newer builds of Platform Tools) was a revert of a previous commit.
Can you please test if MTP works ?

Remember some issues .. and the reason for changing the USB product / vendor ID in recovery at this time.
The revert fixed adb sideload but broke MTP. 😥
So currently, we have to use older adb/fastboot builds to be compatible with TWRP 3.6.2.
Platform-Tools r27.0.1 (December 2017) seemed to be the safest to use at the moment.
You can download an older release of platform-tools by adjusting the official download link to the release you want.

Cheers. :cowboy:

Pertinent for Sammy users...

... but even if MTP can work partially with errors after bad TWRP install (guess that's what you're saying), it seems that MTP corruption is still likely even w/o TWRP w/ large files... But I guess it's still possible all affected users had TWRP... Just never saw this connection... PW


Recognized Contributor
Feb 14, 2016
Google Nexus 10
Nexus 7 (2013)

Pertinent for Sammy users...

... but even if MTP can work partially with errors after bad TWRP install (guess that's what you're saying), it seems that MTP corruption is still likely even w/o TWRP w/ large files... But I guess it's still possible all affected users had TWRP... Just never saw this connection... PW
No connection to anyone/anything.

I only noted it as another example of MTP failing and only with (recovery) TWRP.
The device in question is not a Samsung device.
Rather the one Google is trying hard to forget. 🙃

Once the device is running in system..
I never checked if the unofficial lineage 19.1 build has working MTP.
I got pulled into testing TWRP for the device. 😛

Cheers. :cowboy:
  • Like
Reactions: pndwal


Senior Member
May 9, 2020
Hi, there. I don't know here is the right thread or not.

Is there anyone knowing how to write "sepolicy.rule" with respect to a property in a magisk module?

There is a bug only on A12 that "modules.usbaudio.audio_hal" via "AudioALSAHardware" cannot find a property "" (a tunable for the USB buffer size). I'm thinking a workaroud for this bug by writing a sepolicy.rule now. Although only for MTK Dimensity devices on A12 there is another way to reset the USB buffer size, i.e., by using a property "", for other devices there isn't such a property.

Logcat output:
D/AudioALSAHardware(880): -setParameters(): card=1;connect=67108864;device=0
I/AudioFlinger(6037): openOutput() this 0x7d15455000, module 26 Device type:0x4000000,@:card=1;device=0;, SamplingRate 0, Format 00000000, Channels 0, flags 0
D/modules.usbaudio.audio_hal(880): [USB_AUD] adev_open_output_stream
W/libc    (880): Access denied finding property ""
I/AudioFlinger(6037): HAL output buffer size 480 frames, normal sink buffer size 1920 frames
I/AudioFlinger(6037): AudioFlinger's thread 0x7d1160bd80 tid=8677 ready to run
D/modules.usbaudio.audio_hal(880): [USB_AUD] out_standby
Although people here don't have any interest any more, I succeeded in making the ALSA hardware driver on A12 to read "" property by replacing this property string in a USB related library with "". The ALSA driver on A12 cannot read "*" properties, but can "*" ones because of SELinux enforcing and its rules.

If you like, try my magisk module audio misc. settings with a USB DAC and popular music streaming apps.
  • Like
Reactions: J.Michael


Senior Member
Dec 17, 2007
I ran recently magisk app on my tablet and it showed me there is a new version.
So I downloaded it :)
I updated magisk app to 25.2 and when I launched it, it crashed with only a small message : [xxxxx] failed to get root access
And app is uninstalled...
Could someone please help me ?


Senior Member
I ran recently magisk app on my tablet and it showed me there is a new version.
So I downloaded it :)
I updated magisk app to 25.2 and when I launched it, it crashed with only a small message : [xxxxx] failed to get root access
And app is uninstalled...
Could someone please help me ?
Was previous Magisk App hidden?... Please check in Device settings, Apps for app whatever you named it (default is 'settings') and uninstall it if found... PW
  • Like
Reactions: J.Michael


Senior Member
What do you mean by "hidden" ?
I have to check in the settings, in the application list, if I find Magisk, and uninstall it if I find it ?
In Magisk App settings is Hide the Magisk app option. This uninstalls the full app and installs small stub app and it's data is populated with Magisk app binaries to obfuscate it. By default it is renamed simply to 'settings', but user can choose any name...

Experience shows that if App is hidden (user didn't take Restore the Magisk app before updating), update fails to recognise hidden app in 50% of attempts, leaving user with two apps competing for root and access to Magisk core functions...

Did you ever take the Hide the Magisk app option?... PW
  • Like
Reactions: J.Michael


Aug 6, 2022
Search in USNF thread for USNF mod from @Displax and install it... Is spoofs a very old fingerprint that should kill two birds; 1) need for fingerprint / security patch date matching in custom and other uncertified ROMs (always in official LOS due to their policy not to alter expected signals), and 2) new Play Integrity MEETS_DEVICE_INTEGRITY failure.

Traditional solution for CTS Profile match in official LOS etc was to configure a passing fingerprint/patch date combination using MHPC module, but this shouldn't be needed w/ @Displax modded USNF... PW
I tried but cannot find the post.

Also I have the current GA USNF installed and it does not work


Senior Member
Jan 11, 2010
I'm a bumbling advisor
Never sell yourself short when sharing good/decent advice in a detailed aspect.
-- At least some folks on XDA will express or share further details in context from sometimes reliable sources.
-- Unlike certain users of Social Media channels that are profoundly disconnected when it comes to sharing details.
Last edited:


Senior Member
Well there's a thought!
John Wu, Aug 5

Seeing all the Chinese missile news last night might triggered some PTSD in me. This morning I woke up during a nightmare of me being forced to perform military training for an additional 20 months...

Jane Manchun Wong

But can you root the missiles?

John Wu

If it runs Android then yes 🙃

... They couldn't be i-missiles could they?

🚀🚀🚀 🙃 PW
  • Like
Reactions: dr4go and 73sydney


Senior Member
Oct 10, 2016


  • IMG_20220808_183529.jpg
    441.1 KB · Views: 28
  • Haha
Reactions: dr4go


Recognized Contributor
Jan 20, 2018
Samsung Galaxy Tab A series
Update :
Now I can open Magisk app without crash.
But when I try to update to 25.2 (from 24.3), it fails : boot image kernel_dtb was patched by old (unsupported) magisk
I don't have an unpatched boot image as asked in the message...

What should I do ?
@pndwal already explained, sometimes there's a boundary version, direct install cannot cross that boundary.

If this ROM comes with Magisk already installed, you need to contact the distributor, or wait for him to release a version with a later Magisk.

Otherwise, you must have an unpatched version of the ROM -- whatever you started with.

Flash stock system. You will lose Magisk. Make sure system works. Then install the newest Magisk, using instructions for initial installation.

If initial installation involves wiping data, wait until you hear from someone who knows what he's talking about -- there may be a way that avoids losing data.
  • Like
Reactions: ipdev

Top Liked Posts

  • 3
    Yeah, even better and more friendly

    I think safe mode using key combination is not very reliable, or at best requires a tricky timing.
    @gecowa6967 can comment, but it wouldn't work for him, not sure if it booted to safe mode and Magisk failed to disable the modules (in which case it would be a Magisk bug) or Safe mode never got activated.

    I personally didn't know that we could boot to safe mode from the UI, which was a great tip that we can try if this happens again, I know that gecowa6967 was not the only one that experienced this issue.

    Yes, I was not able to boot into safe mode using key combination when I was using the patched boot image.

    I only have the log of the bootloop I posted before, I do not know which module caused the issue. Once I was able to boot with my modified patched boot image, I ran "magisk --remove-modules" to remove all modules.

    When I ran "magisk --remove-modules" with the "normally" patched boot image during boot, the phone would restart, but the modules would not be removed. I think magisk did not have write permission for the folder or something like this.

    The idea of a "dumb" patched image that does not load any modules would have been good, that's why I posted the APK for anyone else having this issue.

    I am very grateful for all the kind feedback you gave me for my hacky solution. And also thank you to my roommate who helped me with all of this. :)
    .....the only catch with MBP is that users need to have had that module prior to the problem.... this being integrated into Magisk makes it simpler and easier.
    We can't write to /data/adb/modules without root (and we're bootlooping with root), hence why it has to be to somewhere like /data/local/tmp
    We definitely can create such file in adb which would have helped @gecowa6967
    Yup, but doesn't this still require USB debugging enabled?... And @gecowa6967 had issue where adb command magisk --remove-modules had no effect...
    but can we create such file using fastboot?

    I looked at fastboot commands, and I see this, but I have no idea how to use it and if it can help us create an empty file
    Android Things:
     stage IN_FILE              Sends given file to stage for the next command.
     get_staged OUT_FILE        Writes data staged by the last command to a file.

    If we can, then @gecowa6967 code, instead of disabling loading modules would simply look for the presence of such file and if found skip loading the modules.
    Yup... No idea either. 😶
    I don't see that Fastboot is needed
    It's just a working possibly (actually allowed the fix used); seems ADB (requires USB debugging enabled anyway) and Safemode (user could only enter it w/ unpatched boot image) had no effect and are also often inaccessible to other users...
    ...Even more user friendly: let it be a file on Internal memory (like in Download folder) - hence one does not even need to pinpoint with adb

    For this, root is not needed and without Magisk, there should be no bootloop due to the modules

    3) Then flash back the patched boot.img and reboot.
    Magisk should read the file from step 2 and disable the module(s)
    This seems a good approach...

    My further thoughts: Seems it would be even simpler to restore old core-only mode toggle in-app instead of using a file-based flag however...

    Of course we could then simply flash unpatched image and set this mode in such an 'emergency' before re-flashing patched image to boot Magisk w/ modules disabled! 🤪

    This would also circumvent these difficulties:
    - Magisk uses /data/adb (not /data/local/tmp or Internal memory) since an app needs a root to access there.
    Otherwise, all banking and similar apps would be able to read...

    Magisk might even delete that file once it consumes the command...
    I think safe mode using key combination is not very reliable, or at best requires a tricky timing.
    @gecowa6967 can comment, but it wouldn't work for him, not sure if it booted to safe mode and Magisk failed to disable the modules (in which case it would be a Magisk bug) or Safe mode never got activated.
    He was only able to boot to Android Safe mode w/o root (ie after flashing unpatched boot image) which doesn't trip Magisk Safe mode (requires running Magisk daemon to detect Safe mode triggers and to set flags for disabling modules)... Not a Magisk bug since it wasn't running! 😉
    I personally didn't know that we could boot to safe mode from the UI, which was a great tip that we can try if this happens again, I know that gecowa6967 was not the only one that experienced this issue.
    And need for running Magisk daemon is the key to this too; We boot to Android Safe mode w/o root but rely on reboot after a fastboot flash (we access fastboot from Safe mode to flash Magisk-patched image) being reboot back to Safe Mode... Modules will only be disabled at this point...
    Although I still don't understand what is wrong with Safe Mode. Are there devices that cannot boot to Android Safe Mode, or just ppl don't know about, or don't know (google about) how to use the fingers to boot to the Safe mode
    User simply couldn't get access w/ key combo w/ patched boot image, but this is also problematic due to Magisk's need to detect user entering key combo (booting from off state only) and timing is also critical... Eg on MIUI we can generally get Android Safe Mode w/o triggering Magisk Safe Mode unless we alter the usually key release timing... I know others have also had different problems with this approach...
    In fact, nost of the stuff above (a control file on /data/local/tmp and so) makes actually a re-inventiion of the wheel...
    Praps we could just use an old wheel (Core Only mode) again for emergency use!... 😋 PW
    ... one more good feature in the latest Delta - Clean Hidelist...
  • 7
    Can someone either provide actual proof that zygisk/shamiko etc does anything to GPS (i havent had a single issue and i use it daily) or i dunno, maybe stop spreading FUD because of personal gripes you have against people on other platforms that dont take part here, and therefore wont get any of the swipes youre taking at them here that only further add to the aforementioned FUD.

    We've all had our moments with those folk and its fine to mention the odd bit of spice you may come across when trying to submit an issue on github (ive done this myself), but to then to continually poison magisk proper/shamiko because of that person/persons taking part is not helping anyone. Thats a personal gripe, and shouldnt colour the entire magisk (proper) project/shamiko. What we dont need is spice here....

    Please, you know who you are...

    I think we've all had enough, now
    I'm using the systemless debloater module to degoogle and debloat a device (and several other magisk modules to assist in that endeavor). I'd really like to be able to do a factory reset to clear the device of any data/artifacts from the debloated apps, but of course a factory reset wipes out magisk modules, so I'm in a catch 22.
    You can do some cleaning like this:

    - Wipe (from TWRP or by root explorer like MiXPlorer)

    -In MiXPlorer, go to three dots, Tools and clean by App Remnants

    -Install SD Maid:
    And clean by CorpsFinder option
    Installing on Samsung S7 (SM-G930F) with /e/OS?
    Okay folks, thought I'd post up the procedure:
    1. Follow these instructions until you get to 7th bullet point here;
    2. Stop. Some points to mention on the way:
      1. Note my progress above from 'Preliminaries' until point 5, adb pull /sdcard/Download/magisk_patched_[random_strings].img works just fine;
      2. Ignore my rambling queries up to point 5;
    3. Install heimdall;
    4. Boot device into 'Download' mode without USB cable connected, then once in 'Download' mode insert USB cable (this seemed important as I ran into quite a lot of ERROR: Protocol initialisation failed! type errors which seemed possibly cable/ hardware related);
    5. Bash:
      $ heimdall detect
      Device detected
      $ heimdall print-pit --no-reboot > print-pit.txt
    6. From print-pit.txt discover:
      --- Entry #10 ---
      Binary Type: 0 (AP)
      Device Type: 8 (Unknown)
      Identifier: 5
      Attributes: 5 (Read/Write)
      Update Attributes: 1 (FOTA)
      Partition Block Size/Offset: 10240
      Partition Block Count: 10240
      File Offset (Obsolete): 0
      File Size (Obsolete): 0
      Partition Name: BOOT
      Flash Filename: boot.img
      FOTA Filename:
    7. Reboot into 'Download' mode (this rebooting also seemed to help prevent the above errors);
    8. Bash:
      $ heimdall detect
      Device detected
    9. Then, instead of fastboot flash boot /path/to/magisk_patched.img at the 7th bullet point here

      $ heimdall flash --BOOT magisk_patched-25200_UjUVt.img
      Heimdall v1.4.2
      Copyright (c) 2010-2017 Benjamin Dobell, Glass Echidna
      This software is provided free of charge. Copying and redistribution is
      If you appreciate this software and you would like to support future
      development please consider donating:
      Initialising connection...
      Detecting device...
      Claiming interface...
      Setting up interface...
      Initialising protocol...
      Protocol initialisation successful.
      Beginning session...
      Some devices may take up to 2 minutes to respond.
      Please be patient!
      Session begun.
      Downloading device's PIT file...
      PIT file download successful.
      Uploading BOOT
      BOOT upload successful
      Ending session...
      Rebooting device...
      Releasing device interface...
    10. At which, the device reboots and:
    11. Happiness :)
    How does PixelFlasher invoke
    Does it invoke it as an "executable", creating a new process? Or does it "source" it, so changes to the environment will survive?

    Does PixelFlasher create an environment variable named "SHA1"?

    My copy of has a compound statement that tests whether SHA1 has a non-zero length value before setting it to the sha1 of the boot image. If the environment variable is already set, it will not be overwritten. I don't know why.
    I wouldn't source. The script is supposed to be called as an executable

    Eg, my following code is rather primitive but it dumps the active Boot partition (it supports A/B and non-A/B devices), then it patches by invoking the script, finally it dumps back to the Boot partition and automatically reboots

    Ie, it updates me the Magisk and it also leaves me the patched-boot img in the Download folder

    # Boot partition
    AB=$(getprop ro.boot.slot_suffix)
    # Boot and patched boot images
    # Magisk path
    # Disk-dump boot image to Download folder
    dd if="$BOOT_PART" of="$BOOT_IMG"
    # Patch the boot image and move to Download folder
    mv "$MAGISK_PATH"new-boot.img "$PATCHED_BOOT_IMG"
    # Flash the patched boot image
    dd if="$PATCHED_BOOT_IMG" of="$BOOT_PART"
    # Reboot
  • 1085
    This is the place for general support and discussion regarding "Public Releases", which includes both stable and beta releases.
    All information, including troubleshoot guides and notes, are in the Announcement Thread
    Hello, I haven't given much support on XDA lately. It can be resulted from
    • University started and I have limited free time. In fact, I mostly develop during midnight
    • I live in Taiwan, which has large time zone differences between my European/American contributors/testers, which usually forces me to stay up late at night to discuss/test stuffs.
    • The new version is about to come, I don't want to spend effort on supporting old releases
    The planned update is delayed again and again, to some point I think I'll shed some light about what has been happening lately, also along with some announcements.

    New Forum!
    As you might have already discovered, Magisk got its own subforum on XDA! Many thanks to all the support you gave me, and much more information/features/support is about to come!
    **For developers supporting all the devices that are not using standard Android boot format, feel free to create threads in this section (actually, PLEASE do so) for your favorite devices after v7 is out. As I currently know, Asus devices require signing the boot image before flashing, and is model dependant; Sony devices seems to use ELF kernel that is unpatchable, or some has two ramdisks (inner + outer), both requires different workarounds; LG bootloader locked devices has to manually "BUMP" the boot image after flashing Magisk..... and there may be lots of other crazy boot image formats that haven't come up to my attention yet.
    It is impossible for me to support all these non-standard boot images, and I hope the community can collaborate to make Magisk running across all the devices. Overall, community collaboration is what XDA about :D

    The Pixel Phone
    Some of you might already know this news, that the next Pixel Phone right around the corner seems like it does not have ramdisk in boot image, which pretty much wrecked Magisk in all ways. However, it pretty much doomed root itself too. Kernel modifications is inevitable IMO, so I'll try to migrate my scripts to C programs that could possibly be included into the kernel itself. Note that I'm not familiar with linux kernel, I'm not even sure if my idea and concept is correct or not. But once the device is available, I think developers will find a way to bypass all the difficulties, and I'll do my best to learn things ;)

    Current Progress
    In the past month, I've spent quite some time learning SELinux, so that I can avoid using SuperSU's sepolicy patches. Thanks to the helps and tips from @phhusson and @Chainfire, I finally have a much clearer understanding of how SELinux works. The Magisk core parts (the scripts, boot image patches, new features, more supports) are actually done some time ago. What is causing all the delays is the Magisk Manager.
    To be completely honest, although I can code in Java without much issues, Magisk Manager is actually my first Android application, I had to reach out for assistance, and fortunately awesome developers like @DVDandroid and @digitalhigh contributed a lot, which makes the current Manager awesome.
    After the repo system and module management is mostly done, I was about to do some adjustments and release, but what we really done is decided to add another feature: auto-unroot with per-app settings. I decided to wait for it to be finished, and then do my adjustments. Due to reasons that'll be mentioned later, this feature will likely not be available for the next release (should come in future updates)

    Safety Net Disaster
    Those who are using Magisk for Safety Net bypass purposes must have known that Google recently updated the detection method of my Systemless Xposed. I still have no idea what Safety Net is detecting, so currently I cannot fix it on my side (also because I'm busy working on the next update). However, suhide developed by @Chainfire is able to hide Xposed and worked fine.
    However, only my Systemless Xposed v86.2, which is based on SuperSU's su.d, is supported using that method. v86.2 and v86.5 (latest, Magisk based) have nearly identical binaries, and the only difference is the path where the binaries are stored.
    I'm still not sure what's the real issue for it not being supported, I just hope it is not done intentionally.

    Due to the fact that my Safety Net bypass is not 100% perfect now, I do not want to spend any more time waiting for auto-unroot to be polished. What I'm doing now is finishing up all the things I'd like to change in Magisk Manager (it has been a while since I last contributed to Manager, my fellow developers are doing all the heavy job), which might take a little more time, after that, packed with tons of information to be announced in Magisk Section, I'll release the long awaited update.

    Hope this lengthy post gives you the idea of the whole situation, and again thanks for all your support!!
    Ah, some Chainfire bashing, I hope it is not too late for me to exercise additional villainy.

    First, let me make clear I have nothing against @topjohnwu, nor against Magisk. Magisk is an interesting project and it certainly displays @topjohnwu ingenuity and persistence. I don't doubt we will see more interesting things from his hands.


    What has happened here is not all that dark and complicated, from either end. I returned from holidays, and someone pointed me at Magisk. My first thought: interesting!

    Among other things, the thread lists some issues with SuperSU, which in combination with the phrase The developer also requests users to not bug Chainfire with compatibility requests for SuperSU with Magisk from the portal article, raised my left eyebrow by nigh half an inch. The popular systemless xposed mod is apparently now based on it, and apparently it now no longer works with SuperSU, and apparently I'm not supposed to fix that, nor any of the other found issues. I found that a bit weird. So yes, I have told @topjohnwu that I was a bit surprised he was posting about issues with SuperSU without notifying me about them (I can't fix or help fix issues I'm not aware of, after all).

    He's also spreading a modified version of the SuperSU package, which is not all that uncommon, nor necessarily a problem. I have not looked into what he modified, I only ran a few quick tests on one of my devices, and found some commonly used commands run as root to be broken. I have informed him of this as well.

    It appears the tool of choice for Magisk is phh's Superuser, because of some of the mentioned issues with SuperSU. That's fine by itself, but fixing issues in that superuser by incorporating SuperSU's binaries into it is a somewhat questionable practise. After all, SuperSU is a commercial closed-source package that helps pay for my dinner, and superuser is a direct competitor. I have informed him that I was surprised he did this without asking for permission. I have expressed similar surprise on him spreading a modified version of LiveBoot (which helps pay for a snack now and then).
    @topjohnwu has also stated that Magisk's scripts are largely influenced by mine (I have not checked). Scripts based on mine are used all over the place on XDA, some people have crafted amazing things based on them, I have never made an issue of this (otherwise I would have just made them binaries). But yes, I have also stated to him that I don't think it's very nice to base something on one program, and then using that to (almost exclusively) push something directly competing with that program.

    tl;dr Towards @topjohnwu, I have:
    - expressed surprise he has issues getting Magisk to work with SuperSU, and has chosen not to inform me about those
    - expressed surprise he is using SuperSU binaries in a competing superuser without permission
    - expressed surprise he is posting a modified LiveBoot without permission
    - informed him of issues with the modified SuperSU he has posted
    - let him know I thought it wasn't very nice to be applying my scripts to benefit seemingly exclusively that same competing superuser

    To be crystal clear:
    - I have not asked for an apology
    - I have not asked for Magisk to be abandoned, neither the root hiding nor systemless module parts, and certainly not systemless xposed
    - I have not made an issue of any of this anywhere, until this post
    - I have not even specifically asked for anything to be taken down (though obviously in my opinion the other superuser package mixed with SuperSU's binaries, as well as the LiveBoot package, should go)
    - I have not reported this thread to XDA moderators for copyright violations or otherwise

    While my conversation with @topjohnwu may not win any awards for being friendly (though it may win some for brevity), I think all things considered my response has been rather mild. To be perfectly honest, until the apology post, I thought this was over with already. I think the apology post was triggered because I haven't replied to his last PM for a while - I was in the zone, it happens.

    To emphasize again, I have nothing against @topjohnwu, Magisk, or systemless xposed, and it is certainly not my goal to see any of them go. If it can be made to work together with SuperSU, great.

    I get it though: you think of something, you want to see if you can make it work, you finally get it to work, you publish it, it takes off - enthusiasm gets the better of you. Maybe in the rush some mistakes are made. That doesn't mean you have to just drop it and run. None of my stuff would make it past 0.1 if I stopped at the first big mistake :)

    Aside from said being in the zone coding, I usually regret actually responding to these sort of things the day after, which has made me hesitant to reply. Surprise me.
    Thread temporarily closed so everyone sees this.

    The flood of "SafetyNet isn't working for me either!" posts are not helpful, at all. Please refrain from posting further, it will be looked into. Please do not forget that not passing SafetyNet is 100% NORMAL AND INTENDED when you have an unlocked booloader or running custom firmware. These are workarounds and they will be worked around in turn.

    The Flash
    Forum Moderator

    EDIT: Thread is reopened... I will be cleaning any SafetyNet posts for a while to keep the thread clean for real issues.
    Hello everyone!

    I am aware that Google has updated Safety Net that makes Magisk itself a no go for Android Pay. In fact, I witnessed the change live while I am developing the new magiskhide, which should hide all Magisk modules and Magisk installed root.

    Google is serious about Safety Net now, clearly hunting down all possibility to run Xposed with Safety Net passed. I spend quite some time examining the new security measures last midnight, and fortunately it seems that it is possible to run Magisk and root along with Safety Net if no Xposed is running. I'm glad I removed the old root toggle at the right time lol, that is no longer feasible with the latest detection.

    So stay tuned for the next update, it will come with bug fixes, along with the new magiskhide to bypass that Safety Net.

    Google, how will a few systemless mods do any harm :p:p