Magisk General Support / Discussion

Search This thread

73sydney

Senior Member
This was an upgrade to stock A13 from stock A12 with full data wipe after. As soon as bootloader unlocked, netflix said uou need to update and on google play said no version available. then after passing integrity and debloating Netflix+netflix activation I can install again from play store but just hangs at logo. Same thing sideloading from apk mirror

I did delete netflix.partner.activation app.

For now, can someone please tell how to hide root related apps?
not very keen on data wipe again

Youre in the legacy Magisk thread, you need to go here (link below), and click the Watch option (at right, above first post on page) to keep it in your Watched Forums sidebar (top left) <--- this is what everyone in this thread needs to do.....

Watch is a useful way to keep an index of threads where information is changed often, where threads you visit often stay, the average user should have the main section for their devices in here too.....just a tip


Most info on Magisk and current hiding root hiding methods are discussed and linked on that first page - read all the way down that 1st page. New issues using the newer (Zygisk) system are discussed in that thread.
 
Last edited:
  • Like
Reactions: galaxys and ipdev

ipdev

Recognized Contributor
Feb 14, 2016
2,226
1
4,339
Google Nexus 10
Nexus 7 (2013)
@Drahy @pndwal

I do not have Disney but, I did check HBO Max and have a rendering playback issue on my Pixel 6.
Stock Google 12L, Magisk debug, renamed (hidden), and a slug of modules.
Unlocked bootloader, Widevine L1, Pass Play Integrity, SafetyNet, ...​

Looks similar to a buffering issue but, it does not behave the way a buffering issue should. :unsure:
Instead it behaves more as a codec issue. :unsure:

Tried a few things this morning and same thing. 🙃
About 5 to 20 seconds of video and then garbage.
I think the video starts in SD and then shifts to HD.?

When I have some more time, I will setup my Pixel 7 and see if HBO works correctly on a completely stock/locked Pixel.
Then unlock it and see if HBO breaks or not.

Cheers. :cowboy:

PS.
I ended up grabbing a logcat to see what was going on.
If anyone is curious, attached logcat is started from selecting play from the HBO menu screen.
- Hence the switching from portrait to landscape in the log. -
It played for roughly 15 seconds before rendering is garbled.
Logcat was closed shortly after.


PPS.
I thought L1 was broken/disabled by some manufactures when the bootloader is unlocked.
With newer versions/devices maintaining the L1 cert but, disabling the L1 decryption. ¯\_(ツ)_/¯


Edit:
HBO Max used to be HBO Now.
I do not have a sim card in my P6.


Edit 2:
WTF XDA....
LogFile can not be attached no matter how I name it. ¯\_(ツ)_/¯
Uploaded to gDrive
 
Last edited:

m0han

Senior Member
Apr 30, 2012
5,311
2,410

Attachments

  • Screenshot_20221204_233312.jpg
    Screenshot_20221204_233312.jpg
    72.7 KB · Views: 50
  • Like
Reactions: pndwal

Drahy

Senior Member
Apr 27, 2012
509
85
@Drahy @pndwal

I do not have Disney but, I did check HBO Max and have a rendering playback issue on my Pixel 6.
Stock Google 12L, Magisk debug, renamed (hidden), and a slug of modules.​
Unlocked bootloader, Widevine L1, Pass Play Integrity, SafetyNet, ...​

Looks similar to a buffering issue but, it does not behave the way a buffering issue should. :unsure:
Instead it behaves more as a codec issue. :unsure:
This is very similar issue on my Disney+ Yes seems the same issue like I have.
There must be something "wrong" with these apps - they check something we dont know about even though we have:
- Integrity check passed
- Displax USNF working
- Widevine L1 ok
- Magisk hidden as app
- Disney+ in blocked apps in Magisk
- Zygisk + Shamiko
- Device is certified in Google Play
- Play Protect passed
- Original Samsung (rooted) Newest Android 13 + November security


There must be something else these streaming apps (Disney and HBO) are checking ...
 
  • Like
Reactions: ipdev

zgfg

Senior Member
Oct 10, 2016
8,215
5,848
Xiaomi Mi 11
Xiaomi Mi 11 Lite 5G
How switching Mount Namespace Mode under Magisk app/Settings/SuperUser potentially affects modules and root hiding (detection)

As far as I can see, Magisk (incl. Delta) sets the Inherit mode by default

Is there any advantage in switching to Isolated mode?

On the other side (as needed for some other things to work), would chosing the Global Namespace mode mess up something?
 

Attachments

  • -5794129247487507423_121.jpg
    -5794129247487507423_121.jpg
    63.6 KB · Views: 47
Last edited:

Loustsoul

Senior Member
You could review

And use foxmm for module management
Pixel 7pro. Okay, I have downloaded the modules and I need help with the first one. I believe it is supposed to hide the unlocked bootloader so that you can still use Google wallet. I have enabled zygisk and I still am unable to use Google wallet. Any suggestions would be greatly appreciated.
 

asripath

Senior Member
Jul 12, 2020
227
180
Redmi K20 Pro
Pixel 7pro. Okay, I have downloaded the modules and I need help with the first one. I believe it is supposed to hide the unlocked bootloader so that you can still use Google wallet. I have enabled zygisk and I still am unable to use Google wallet. Any suggestions would be greatly appreciated.
Welcome to the
cat&mouse...
Tom&Jerry show...
Aka root hiding shenanigans....

You will find more info in dedicated thread
 

Loustsoul

Senior Member
Welcome to the
cat&mouse...
Tom&Jerry show...
Aka root hiding shenanigans....

You will find more info in dedicated thread
It worked!! Good call!! Thanks for the help!
 

pndwal

Senior Member
Read that; mulling over the idea, while waiting to see if some other method is available 👍.
Well you can use custom XiaomiEU ROM as has been said... Other than this or stock, only option is take-to-service-centre method AFAIK, and you'd need device to be stock for that anyway...

Nb. Custom XiaomiEU (basically debloated stock) also keeps this facility and may actually be required as it actually offers later MIIU than official for for some devices, porting late MIUI from models that did get the updates... Yours may be one that actually requires this custom ROM... PW
 
Last edited:
  • Like
Reactions: m0han and ipdev

pndwal

Senior Member
This is very similar issue on my Disney+ Yes seems the same issue like I have.
There must be something "wrong" with these apps - they check something we dont know about even though we have:
- Integrity check passed
- Displax USNF working
- Widevine L1 ok
- Magisk hidden as app
- Disney+ in blocked apps in Magisk
- Zygisk + Shamiko
- Device is certified in Google Play
- Play Protect passed
- Original Samsung (rooted) Newest Android 13 + November security


There must be something else these streaming apps (Disney and HBO) are checking ...
I wrote this to you earlier:
It seems that affected apps are not allowing liboemcrypto.so use for ANY streaming and root detection (or possibly even detection that existing hardware for TEE decryption exists and should be used... Could be using model / other props with their own model whitelist too...) seems to be the likely reason to me... Ie. it's likely that these apps are simply restricting their use to SD decoding with older libraries (as liboemcrypto.so is primarily designed to decrypt HD content in secure TEE OS) rather than preventing apps from working on devices w/o hardware TEE...

Netflix does this too BTW, but relies wholly on Widevine certification since v5.0, making their approach much simpler...

All best on your quest... Hope something here was helpful... PW
🙂 PW
 
  • Like
Reactions: ipdev

pndwal

Senior Member
Don't blame you...

Seems Xiaomi don't want untold users to do this either or they wouldn't have provided the facility for a user fix for many devices... Still seems a responsible move to me; when something similar happens (ie Widevine keys are revoked) with several other OEMs users report they are told there's no way to restore / they're lost forever! 🙁

Anyway, I wasn't encouraging you to go to a service centre... I posted as 1) I understand that since you evidently need new L1 keys/certificate to fix this, at least w/ Xiaomi devices, I doubt that
mulling over the idea, while waiting to see if some other method is available...
will benefit you, and 2) to clarify that Stock MIUI is not the only solution (and in fact a MIUI port, eg XiaomiEU custom ROM, may be the only option w/ some devices...

It seems you will need to back up / clean install stock (may be able to ascertain if stock supports certificate generation for your device) or XiaomiEU custom (seems this does support) in order to fix yourself; probably need full wipes to restore your ROM of choice too... 🙂 PW
 
Last edited:
  • Like
Reactions: ipdev

zgfg

Senior Member
Oct 10, 2016
8,215
5,848
Xiaomi Mi 11
Xiaomi Mi 11 Lite 5G
Magisk Delta (but probably not specific to)

Xiaomi, MIUI 13/A12

I just set Second Space on my phone - seems I will need to use for business applications and corporate phone

YASNAC, Play Integrity pass (Device Integrity) - Xiaomi.eu ROM forces Basic attestation and 'hides that BL is unlocked' and Device is certified

S-Check and Oprek fully pass

Ruru and TB-Checker pass but detect Second space

Momo still detects Magisk (?) and BL unlocked

Explanation:
Second space works kind of dual boot. You can switch between the First and Second Space (takes me cca 5 seconds)

All apps must be separately installed to Second space, Google acc too, etc

Second space has also its own Internal storage (empty when you set)

Hence eg, I don't have Magisk app in the Second space and I had to install all the above checkers again to the Second space

PS: Mounts applied by Magisk when device booted still apply (as expected) in Second space:
- Ads are blocked (Systemless hosts)
- My Sytemless debloater
- YouTube Re-Vanced (root)

However, modules like LSPosed are not active in Second space

Not so bad thing
 

Attachments

  • Screenshot_2022-12-08-10-58-38-309_io.github.vvb2060.mahoshojo.jpg
    Screenshot_2022-12-08-10-58-38-309_io.github.vvb2060.mahoshojo.jpg
    390.7 KB · Views: 31
  • Screenshot_2022-12-08-10-59-22-243_com.byxiaorun.detector.jpg
    Screenshot_2022-12-08-10-59-22-243_com.byxiaorun.detector.jpg
    377.5 KB · Views: 31
  • Screenshot_2022-12-08-11-34-11-691_krypton.tbsafetychecker.jpg
    Screenshot_2022-12-08-11-34-11-691_krypton.tbsafetychecker.jpg
    355 KB · Views: 30
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 8
    Didge says Bye...

    I was very sorry to see yesterday's MHPC commits:
    1. Update FUNDING.yml
      Didgeridoohan committed yesterday

    2. Bye.
      Didgeridoohan committed yesterday
    and the update of @Didgeridoohan's OP in [MODULE] [DEPRECATED] MagiskHide Props Config - SafetyNet, prop edits, and more - v6.1.2 thread:
    MagiskHide Props Config v6.1.2

    Note: This project is dead, and has been for some time. I have not been involved in the Android modding scene for some time and I no longer have the energy to take it up again.

    If anyone feels like taking over give me a holler.
    This project was a mainstay of Magisk modification, giving John Wu's Magisk applet resetprop, an advanced system property manipulation utility, the terminal based UI that made prop manipulation accessible to Magisk users in general...

    Each option has been elegantly implemented to make what would otherwise be an arduous exercise involving user creation of custom boot scripts the no-brainer that we know so well!

    What a project, what a plethora of uses...

    @Didgeridoohan's Last post in that thread was back in February:
    Just popping in and letting everyone know I'm still alive.

    There are simply too many things going on outside the world of Android tinkering for me to be able to give XDA much attention at all. Once things settle down, and if I'm not entirely burnt out by then, I've got quite a lot of catching up to do. Can't give any kind of ETA, but I'm hoping for things clearing up before the end of February.

    Huge thanks to everyone answering questions and helping out...
    ... well clearly no clearing has occurred in Feb. or later... 🙁

    @Didgeridoohan's last XDA post, only weeks later, was a response regarding his officially endorsed comprehensive Magisk Troubleshooting Wiki:
    Everything about Magisk install and more can be found in this great guide by @Didgeridoohan .
    https://www.didgeridoohan.com/magisk/Magisk
    Thank you... With the slight caveat that it needs a serious update after the v24 release. I've just been too swamped IRL the past few months. Hopefully soon™.
    So no further updates to that either, but whatawiki!!! - Still a principle go-to for any non-lazy Magisk user w/ any issue!...

    ... So as a foreigner living in Didgeridooland, I'd like to wish the Didgeridoo man from Sweden all the very best with real life, and to thank him for such elegant contributions to the Magisk modding community...

    I hope you can visit Didgeridooland soon Sir! ... I have a boomerang with your name on it... 👍👏 PW
    6
    The caveat to this is if OEM Unlocking is enabled in Developer Options. I'm not sure if this is a bug; the Pixel devices can be flashed this way even on a locked bootloader.
    Are you referring to when using Android Flash Tool to flash? If this is the case, Android Flash Tool actually unlocks the bootloader (with the prerequisite that OEM Unlocking is enabled) during the process so it can flash the image. If, however, you flash an image via flash-all, for example, with OEM Unlocking enabled but with the bootloader still locked, you won't be able to flash the image.
    6
    Think you might be quoting the wrong person. The person I was responding to couldn't root their phone because their bootloader was locked.
    Sorry, it was @TheNixck . I am going through chemo therapy and I think I have one of the side effects: chemo brain lol!







    6
    kdragon has released an updated version (v2.4.0) of his USNF mod for his Patreon members. Hopefully will go public in a week or two.

    v2.4.0 (early access)

    Repository: kdrag0n/safetynet-fix · Tag: v2.4.0-ea · Commit: 2f18d85 · Released by: kdrag0n

    Highlights​

    • Play Integrity bypass without breaking device checks or causing other issues
    • Disabled use of hardware attestation on Pixel 7 and newer (@anirudhgupta109)

    Other changes​

    • Updated instructions for newer Android and Magisk versions
    • Better debugging for future development
    It's taken a while to find way to bypass Play Integrity that doesn't require spoofing the build fingerprint permanently, but I wanted to make sure this module doesn't cause any unnecessary breakage. Just like the original goal of Universal SafetyNet Fix, this minimizes adverse effects by spoofing dynamically at runtime only when necessary. Enjoy!
    Public release now available.

    6
    Hello, I need some help with spoofing sys.oem_unlock_allowed to 0.

    My banking app (Estonian Swedbank app "Swedbank Eestis," package name "com.swedbank") detects sys.oem_unlock_allowed if it is set to 1 and disables specific options in the app (like biometric login). I can confirm that it is sys.oem_unlock_allowed because setting it temporarily with resetprop -n sys.oem_unlock_allowed 0 and deleting the app data allowed me to use the blocked features. The app doesn't complain about root; hiding root with Zygisk works without issue.

    However, I am unsure what method I should use to safely spoof this value without bricking my device. Is it safe to use resetprop -n? Does it persist after a reboot? Should I use a different method entirely?

    I'm running:
    LineageOS 20-20230105-NIGHTLY-kebab on a OnePlus 8T KB2003
    Magisk 25.2
    Universal SafetyNet Fix 2.4.0
    Swedbank version 21440
    Passing SafetyNet with YASNAC
    I am also spoofing device fingerprint with MagiskHide Props Config to pass SafetyNet.

    I really appreciate any help you can provide.
    Ok, so as guessed in my yesterday's post/answer #54234, it seems that you could more-or-less achieve your wanted functionality - could you try please:

    1) Install the following module and reboot - all thanks to @huskydg for his interesting and excellent module:

    2) Go to:
    /data/adb/modules/magisk_proc_monitor

    and rename the original (dummy/template) dynmount.sh script to dynmount.bak,
    and replace that dynmount.sh with my customized script:

    My changes (customizations) in the script can be recognized as commented by CAPS LOCK comments

    How it works:

    myAPP=com.swedbank defines the package name for your Estonian Swedbank app

    myPROP=sys.oem_unlock_allowed defines the property you want to 'hide'/'un-hide'(corresponding to your Developer Options, OEM Unlock disable/enable switch)

    hidePROP=0 defines the 'hidden' property value (OEM Unlock disabled)
    unhidePROP=1 defines the 'un-hidden' property value (OEM Unlock enabled)

    You can redefine those variables (lines 24-32) if you need

    Eg, I did my own non-intrusive tests (still commented out in the script if somebody else wants to play) with MiXPlorer instead of your banking app:
    myAPP=com.mixplorer

    and by playing with a dummy prop:
    myPROP=my.test

    a)
    When module recognizes that your banking app $myAPP is pre-initializing,
    it will 'hide' $myPROP 'by setting to $hidePROP (lines 39-46)

    and you will see the notification like:
    "Hide my prop / com.swedbank, sys.oem_unlock_allowed=0"

    For this event to happen, the banking app $myAPP must be started, not brought back from background (kill and restart your app)

    b)
    Whenever the module recognizes that any other user app is pre-initializing AND that $myPROP was still 'hidden',
    it will 'un-hide' the prop by setting it back to $unhidePROP (lines 51-60)

    and you will see the notification like:
    "Un-hide my prop / com.xda.labs.play, sys.oem_unlock_allowed=1"

    All the $myPROP sitches are systemless - when you reboot, the prop will be back to its original/default value

    Issue/question:

    Of course, instead of monitoring while any other user app is initializing (case b),
    it would be better if the module could directly recognize when your banking app $myAPP gets closed (killed) and to 'un-hide' then the $myPROP property back

    However, I did not find how to recognize in the dynmount.sh script when an app is really closing and that's why I put the case b as described above

    Maybe the module's developer @huskydg could better customize the script dynmount.sh to more closely cover the original functionality as you needed:
    - 'hide' the $myPROP property only for the $myAPP application

    ---

    The really good and interesting thing with his module is that user can customize the provided default dynmount.sh script
    to catch-up events when particular app(s) are starting to dynamically apply certain changes (redefine certain properties, do particular mounts)

    Otherwise, one would need to develop his own Zygisk module, but there the Zygisk part must be coded in C (and recompiled),
    it cannot be made simply by scripting as here with his simple dynmount.sh script
  • 1089
    This is the place for general support and discussion regarding "Public Releases", which includes both stable and beta releases.
    All information, including troubleshoot guides and notes, are in the Announcement Thread
    156
    Hello, I haven't given much support on XDA lately. It can be resulted from
    • University started and I have limited free time. In fact, I mostly develop during midnight
    • I live in Taiwan, which has large time zone differences between my European/American contributors/testers, which usually forces me to stay up late at night to discuss/test stuffs.
    • The new version is about to come, I don't want to spend effort on supporting old releases
    The planned update is delayed again and again, to some point I think I'll shed some light about what has been happening lately, also along with some announcements.

    New Forum!
    As you might have already discovered, Magisk got its own subforum on XDA! Many thanks to all the support you gave me, and much more information/features/support is about to come!
    **For developers supporting all the devices that are not using standard Android boot format, feel free to create threads in this section (actually, PLEASE do so) for your favorite devices after v7 is out. As I currently know, Asus devices require signing the boot image before flashing, and is model dependant; Sony devices seems to use ELF kernel that is unpatchable, or some has two ramdisks (inner + outer), both requires different workarounds; LG bootloader locked devices has to manually "BUMP" the boot image after flashing Magisk..... and there may be lots of other crazy boot image formats that haven't come up to my attention yet.
    It is impossible for me to support all these non-standard boot images, and I hope the community can collaborate to make Magisk running across all the devices. Overall, community collaboration is what XDA about :D

    The Pixel Phone
    Some of you might already know this news, that the next Pixel Phone right around the corner seems like it does not have ramdisk in boot image, which pretty much wrecked Magisk in all ways. However, it pretty much doomed root itself too. Kernel modifications is inevitable IMO, so I'll try to migrate my scripts to C programs that could possibly be included into the kernel itself. Note that I'm not familiar with linux kernel, I'm not even sure if my idea and concept is correct or not. But once the device is available, I think developers will find a way to bypass all the difficulties, and I'll do my best to learn things ;)

    Current Progress
    In the past month, I've spent quite some time learning SELinux, so that I can avoid using SuperSU's sepolicy patches. Thanks to the helps and tips from @phhusson and @Chainfire, I finally have a much clearer understanding of how SELinux works. The Magisk core parts (the scripts, boot image patches, new features, more supports) are actually done some time ago. What is causing all the delays is the Magisk Manager.
    To be completely honest, although I can code in Java without much issues, Magisk Manager is actually my first Android application, I had to reach out for assistance, and fortunately awesome developers like @DVDandroid and @digitalhigh contributed a lot, which makes the current Manager awesome.
    After the repo system and module management is mostly done, I was about to do some adjustments and release, but what we really done is decided to add another feature: auto-unroot with per-app settings. I decided to wait for it to be finished, and then do my adjustments. Due to reasons that'll be mentioned later, this feature will likely not be available for the next release (should come in future updates)

    Safety Net Disaster
    Those who are using Magisk for Safety Net bypass purposes must have known that Google recently updated the detection method of my Systemless Xposed. I still have no idea what Safety Net is detecting, so currently I cannot fix it on my side (also because I'm busy working on the next update). However, suhide developed by @Chainfire is able to hide Xposed and worked fine.
    However, only my Systemless Xposed v86.2, which is based on SuperSU's su.d, is supported using that method. v86.2 and v86.5 (latest, Magisk based) have nearly identical binaries, and the only difference is the path where the binaries are stored.
    I'm still not sure what's the real issue for it not being supported, I just hope it is not done intentionally.

    Conclusion
    Due to the fact that my Safety Net bypass is not 100% perfect now, I do not want to spend any more time waiting for auto-unroot to be polished. What I'm doing now is finishing up all the things I'd like to change in Magisk Manager (it has been a while since I last contributed to Manager, my fellow developers are doing all the heavy job), which might take a little more time, after that, packed with tons of information to be announced in Magisk Section, I'll release the long awaited update.

    Hope this lengthy post gives you the idea of the whole situation, and again thanks for all your support!!
    121
    Ah, some Chainfire bashing, I hope it is not too late for me to exercise additional villainy.

    First, let me make clear I have nothing against @topjohnwu, nor against Magisk. Magisk is an interesting project and it certainly displays @topjohnwu ingenuity and persistence. I don't doubt we will see more interesting things from his hands.

    -------------------------

    What has happened here is not all that dark and complicated, from either end. I returned from holidays, and someone pointed me at Magisk. My first thought: interesting!

    Among other things, the thread lists some issues with SuperSU, which in combination with the phrase The developer also requests users to not bug Chainfire with compatibility requests for SuperSU with Magisk from the portal article, raised my left eyebrow by nigh half an inch. The popular systemless xposed mod is apparently now based on it, and apparently it now no longer works with SuperSU, and apparently I'm not supposed to fix that, nor any of the other found issues. I found that a bit weird. So yes, I have told @topjohnwu that I was a bit surprised he was posting about issues with SuperSU without notifying me about them (I can't fix or help fix issues I'm not aware of, after all).

    He's also spreading a modified version of the SuperSU package, which is not all that uncommon, nor necessarily a problem. I have not looked into what he modified, I only ran a few quick tests on one of my devices, and found some commonly used commands run as root to be broken. I have informed him of this as well.

    It appears the tool of choice for Magisk is phh's Superuser, because of some of the mentioned issues with SuperSU. That's fine by itself, but fixing issues in that superuser by incorporating SuperSU's binaries into it is a somewhat questionable practise. After all, SuperSU is a commercial closed-source package that helps pay for my dinner, and superuser is a direct competitor. I have informed him that I was surprised he did this without asking for permission. I have expressed similar surprise on him spreading a modified version of LiveBoot (which helps pay for a snack now and then).
    @topjohnwu has also stated that Magisk's scripts are largely influenced by mine (I have not checked). Scripts based on mine are used all over the place on XDA, some people have crafted amazing things based on them, I have never made an issue of this (otherwise I would have just made them binaries). But yes, I have also stated to him that I don't think it's very nice to base something on one program, and then using that to (almost exclusively) push something directly competing with that program.

    tl;dr Towards @topjohnwu, I have:
    - expressed surprise he has issues getting Magisk to work with SuperSU, and has chosen not to inform me about those
    - expressed surprise he is using SuperSU binaries in a competing superuser without permission
    - expressed surprise he is posting a modified LiveBoot without permission
    - informed him of issues with the modified SuperSU he has posted
    - let him know I thought it wasn't very nice to be applying my scripts to benefit seemingly exclusively that same competing superuser

    To be crystal clear:
    - I have not asked for an apology
    - I have not asked for Magisk to be abandoned, neither the root hiding nor systemless module parts, and certainly not systemless xposed
    - I have not made an issue of any of this anywhere, until this post
    - I have not even specifically asked for anything to be taken down (though obviously in my opinion the other superuser package mixed with SuperSU's binaries, as well as the LiveBoot package, should go)
    - I have not reported this thread to XDA moderators for copyright violations or otherwise

    While my conversation with @topjohnwu may not win any awards for being friendly (though it may win some for brevity), I think all things considered my response has been rather mild. To be perfectly honest, until the apology post, I thought this was over with already. I think the apology post was triggered because I haven't replied to his last PM for a while - I was in the zone, it happens.

    To emphasize again, I have nothing against @topjohnwu, Magisk, or systemless xposed, and it is certainly not my goal to see any of them go. If it can be made to work together with SuperSU, great.

    I get it though: you think of something, you want to see if you can make it work, you finally get it to work, you publish it, it takes off - enthusiasm gets the better of you. Maybe in the rush some mistakes are made. That doesn't mean you have to just drop it and run. None of my stuff would make it past 0.1 if I stopped at the first big mistake :)

    Aside from said being in the zone coding, I usually regret actually responding to these sort of things the day after, which has made me hesitant to reply. Surprise me.
    76
    Thread temporarily closed so everyone sees this.

    The flood of "SafetyNet isn't working for me either!" posts are not helpful, at all. Please refrain from posting further, it will be looked into. Please do not forget that not passing SafetyNet is 100% NORMAL AND INTENDED when you have an unlocked booloader or running custom firmware. These are workarounds and they will be worked around in turn.

    The Flash
    Forum Moderator

    EDIT: Thread is reopened... I will be cleaning any SafetyNet posts for a while to keep the thread clean for real issues.
    75
    Hello everyone!

    I am aware that Google has updated Safety Net that makes Magisk itself a no go for Android Pay. In fact, I witnessed the change live while I am developing the new magiskhide, which should hide all Magisk modules and Magisk installed root.

    Google is serious about Safety Net now, clearly hunting down all possibility to run Xposed with Safety Net passed. I spend quite some time examining the new security measures last midnight, and fortunately it seems that it is possible to run Magisk and root along with Safety Net if no Xposed is running. I'm glad I removed the old root toggle at the right time lol, that is no longer feasible with the latest detection.

    So stay tuned for the next update, it will come with bug fixes, along with the new magiskhide to bypass that Safety Net.

    Google, how will a few systemless mods do any harm :p:p