• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Magisk General Support / Discussion

Search This thread

Flole998

Member
Jan 3, 2015
12
0
I'm also having issues with latest 13.1 and HTC One M8 (Google Play Edition). It always shows "not installed". 12.0 is working perfectly fine.
 

NinjaBoyLao

Member
Oct 24, 2016
17
4
North Carolina
I'd like to report a bug involving the latest 13.1 release. For some reason, version 5.0.4 of the Magisk Manager doesn't ever show that the latest version is installed. Instead, it just hangs forever on the spinning circle of "checking for latest version". Has anyone else encountered this issue? I checked a couple pages back in this thread but didn't see anything
 

tomkho12

Member
Oct 28, 2012
35
7
My device (xperia M4 aqua) got bootlooped after upgrading to 13.1. It worked fine with 13.08 beta tho. I tried to use uninstaller magisk zip first then flash the 13.1 but the problem didn't go away. ?
 

n0th1nk

Member
Jun 19, 2017
5
1
I'd like to report a bug involving the latest 13.1 release. For some reason, version 5.0.4 of the Magisk Manager doesn't ever show that the latest version is installed. Instead, it just hangs forever on the spinning circle of "checking for latest version". Has anyone else encountered this issue? I checked a couple pages back in this thread but didn't see anything
Same here, moto x 2014, beta 13 worked fine
 
  • Like
Reactions: NinjaBoyLao

andMego

Senior Member
Jul 24, 2015
265
55
Miami
When I try installing magisk on my unlocked US Moto E4 in twrp I always get an error, either that it can't mount the magisk image or that my boot image isn't supported, what should I do?
I tried magisk 11.6 12 13 and 13.1
I'm attaching my stock boot image and some logs from twrp
 

Attachments

  • boot.img.zip
    10.1 MB · Views: 12
  • dmesg.log
    104.5 KB · Views: 4
  • recovery.log
    21.6 KB · Views: 8

Ker~Man

Senior Member
Nov 2, 2010
877
468
36
Louisville
After upgrading to v13.1, I keep getting this (see image)... Any advice would be much appreciated!
 

Attachments

  • Screenshot_20170710-233257.png
    Screenshot_20170710-233257.png
    123.1 KB · Views: 498

shiroc

New member
Dec 9, 2008
1
0
My HTC10 (android 6.0, Magisk 12.0 + xposed ) works well. When I upgrade to Magisk 13.1, it is stuck in boot screen and fail to boot.
 

klaustroeger

Senior Member
Jan 28, 2011
388
315
Nuremberg
linuxstar.net
Just quick (and without logs)

v13.1 does not work on S7E with actual RR/openGAPPS nano versions..... neither as complete clean install (all wiped) nor as upgrade.

Symptoms: Tons of FC's (Google play services etc.)

Back on v12 + safetynet patch
===> Works like a charm!!!
 

Xaif

Senior Member
Jan 26, 2014
668
1,095
25
Mumbai
xtremetricks.net
After upgrading to 13.1 I have seen the issue in my banking application.



Sent from my Google Nexus 5 using XDA Labs
 

Attachments

  • Screenshot_20170711-091516.png
    Screenshot_20170711-091516.png
    139.1 KB · Views: 754

danmaman

Senior Member
Jan 15, 2012
1,376
891
On OnePlus 3T
All good here
Thanks a lot
 

Attachments

  • Screenshot_20170711-055716.jpg
    Screenshot_20170711-055716.jpg
    245.5 KB · Views: 470

Rohi09

Senior Member
Sep 12, 2013
322
94
Kolkata
Inbuilt updater didn't work, so I completely uninstalled 12 and installed 13.1 along with the latest magisk manager. phone stays on the logo screen for 5 mins, then it boots and magisk says no root installed. Moto g 2015.
 

HannibalIII

Member
May 25, 2015
9
1
Hi, Thanks for the job you're doing.
When hide is active, apps such as snapchat don't detect the root but the mc Donald's Belgium app does....

I checked the logs and it doesn't show anything...
 

Rohit-WarG

Member
Jun 24, 2017
5
0
In my Custom ROM RR Nougat
this version 13.1 is not support fully
when I open tab of Superuser from Magisk it crashed..
& root is not working...
 
Last edited:

admiralspeedy

Senior Member
Dec 22, 2011
308
132
Google Nexus 4
Nexus 7
No, basically it works. But it breaks systemless host and magisk hide :) Just try - after boot you will not pass SafetyNet until you will go to settings and re-enable hide manually.
https://github.com/topjohnwu/Magisk/blob/master/jni/daemon/bootstages.c - lines 543-544, it ends doing anything if core mode is enables (and skips systemless host and magisk hide phase)
Fix is easy - instead of going to end, make another label on line 702 and change this goto to line 702. Pretty easy, works perfectly in my Pixel build of magisk

Where do you keep your source for the Pixel version of Magisk? Your Magisk repo on Github hasn't been updated for a month now so I assume you are doing your work elsewhere?

I'd like the source so I can try and figure out why 99% of apps cannot mount /system with Magisk (I don't know if it's specifically a Pixel issue). The only two apps that I have found that can mount /system as RW are FX File Explorer and Root Explorer. No other app, including using terminal commands, is able to do it (the terminal says /system is not in /proc/mounts).
 

Top Liked Posts

  • 2
    for sake of clarity: alpha last but three version, namely 0c1f6881 (Dec 2021, 20th) never looses root, all is working as expected in same system (except Zygisk...)

    something has been added that breaks something else
    Good to know. In fact, I still keep that Alpha apk and my corresponding patched boot.img (just in case)

    I have updated through all the later Alpha versions, updated LSPosed, HMA, installed and updated Shamiko

    Sometime among those updates I started to observe instabilities. I never observed loosing the root but occasionally it loop-boots two or three times (soft- rebooting) before booting successfully. One day it rebooted five times to TWRP (I didn't do anything there except wiping Cache and Dalwik trying to 'help') until it finally rebooted successfully to the system

    Since it does not happen on every reboot and since (as mentioned above) I updated various components, I was unable to point to anything specific (Alpha, Shamiko...) but my hunch was that it's maybe related to Magisk (thinking that I saw it first time upon updating Alpha from that version, before all the later updates)

    But without a hard proof I didn't want to charge anything or anybody
    2
    No. You said ...but source is in accompanying zip.
    Maybe I misunderstood you. I thought that meant if I downloaded the latest magisk- alpha.zip file extracted it I could find the source in it.
    On telegram he posts the source.zip: 76ddfeb9-alpha.zip and the standalone.apk: app-release.apk, as the latest example.
    2
    Module Update Notifications

    ...So we're getting getting active module.zipUrl with new updateJson! 😛 🎉
    https://github.com/topjohnwu/Magisk/issues/4908#issuecomment-1015911378

    Thanks vvb2060. 👍 PW
    1
    why is there no allowlist, i want to block all apps from knowing the device is rooted once.
    Traditionally, hiding more than a few apps / processes made the system unstable due to restrictions on the hide daemon's passive reaction speed (to app processes). Also Webview and more are broken by indiscriminate hiding of Chrome etc:
    - www.twitter.com/topjohnwu/status/1039528958289760256
    - https://forum.xda-developers.com/t/magisk-general-support-discussion.3432382/post-84868359

    Nb. The hiding elements retained by denyist may well have changed, ie hijacking app_process (Zygote) rather than simply monitoring these passively may now be used / possible with Zygisk and be faster / not face this restriction any longer. However I haven't checked code for this nor am I aware of comments by John about changes to the mechanism used here. Someone may care to comment further...

    It's worth noting that vvb2060 did produce Magisk Lite builds using whitelist mode for some time. Lite however works entirety differently and sacrifices some functionality; it's experimental MagiskHide functions to hide isolated processes. - Magisk Lite has only SU function and does not provide full/normal support for modules. In Magisk in whitelist mode all applications are hidden by default, and only checked applications can obtain super user permissions.

    Testing this solution seems to have stalled / Lite is deprecated... I think I posted re. latest here:
    https://forum.xda-developers.com/t/magisk-general-support-discussion.3432382/post-85226953
    - https://github.com/vvb2060/magisk_files/commits/master
    - https://t.me/MagiskLite

    🤠 PW
    1
    edit: wonder why 'latest' is 558710bb-alpha-2 (23016) (23).
    Update channel points to JSON file in GitHub repo. Last pushed was 558710bb-alpha-2 (synced with Canary v23016, Stub v23) of 10 days ago, here:
    https://github.com/vvb2060/magisk_files/tree/3d74b529d447dadb99ee18c57cdc602bbc470d4b

    Neither 76ddfeb9-alpha nor 558710bb-alpha-3 have yet been pushed to GitHub yet. They were only released to Telegram group, but source is in accompanying zip. PW
  • 11
    Can you confirm that all apps checked in the deny list are hidden to the system, pleeeaaase ???
    Few things to note: You really need to read release notes before using any Magisk build, official or otherwise. 🙃

    The build @Johnson_Ran posted is his own build of latest unofficial Alpha Magisk + LoveSys fix for OnePlus 7 / 7 Pro (and possibly other devices) w/ ramdisk detection issue; I posted re. a test build based on canary, now he posted his personal Alpha Magisk with fix for OnePlus... Nb. The fix has NOT been merged in Magisk master, Canary or even latest vvb2060 Alpha yet.

    Well this concept of deny list is confusing so I tried to treat it as a MagiskHide list and all apps I checked are not working as they did with v23... ^^
    Do you mean Are root-related execution environment changes hidden from the app? If so, that depends...

    MagiskHide is dead and gone in TJW builds going forward; denylist is quite different - it 'reverts Magisk features in use for selected processes', ie w/ denylist "Magisk denies further modifications and reverts all changes it had done. Magisk will not spoof/alter/manipulate any non-Magisk related signals or traces to circumvent any device state detection." So denylist is actually made more powerful for hiding TEE mods because of Zygisk, but won't perform the spoofing / alterations / manipulations of non-Magisk related signals or traces formerly done by MagiskHide.

    Even more powerful hiding methods are now available however, thanks to John's strengthened Magisk framework; he just won't do it himself:
    www.twitter.com/topjohnwu/status/1445598597521633285

    Universal SafetyNet Fix and Shamiko are examples where Zygisk is used for advanced hiding by 3rd party modules. Nb. Denylist is not even needed if Devs choose to "do everything themselves"!
    www.twitter.com/topjohnwu/status/1445598601372069890

    As I indicated, the biggest favour users can do themselves is read release notes before using any Magisk build, official or otherwise. For TJW Canary start with this one:
    https://github.com/topjohnwu/magisk-files/blob/9537c5d8cedfc09ca723ae0392b1219e75d9b636/notes.md
    ... read the blog John links there (for good reason) also... and scroll down and read the 2020 one also for more understanding of the general Magisk roadmap / direction...

    ONLY after understanding these major changes, if you want to try HIGHLY EXPERIMENTAL bleeding edge vvb2060 Alpha builds, read IT'S Changelog (translate Chinese)... Latest here:
    https://forum.xda-developers.com/t/magisk-general-support-discussion.3432382/post-86215689

    Coming back to your statement
    I tried to treat it as a MagiskHide list and all apps I checked are not working as they did with v23... ^^
    Note a major difference between TJW denylist and Alpha denylist:
    • [General] Use MagiskHide to hide when Zygisk is closed
    So denylist in Alpha works like MagiskHide / hidelist only after Zygisk is closed; Nb. you NEED TO REBOOT to disable Zygisk.

    After this Riru modules will also work (it's a choice; Riru or Zygisk, not both), and if you needed 2.x series Universal SafetyNet Fix for your device, you'll need to swap to a USNF-Riru build if you had USNF-Zygisk. Note: There is no option to do this in TJW Canary as current USNF-Riru builds require MagiskHide to function.*

    Nb.1. In TJW builds denylist WON'T be used as hidelist or with MagiskHide. Alpha restores MagiskHide... This is peculiar to custom Magisk forks...

    Nb. 2. There are differences with MagiskHide in Alpha. Importantly, toggling MagiskHide off then on again does NOT add Google Play Services safetynet process to denylist (whether in denylist or hybrid alpha hidelist mode). You need to do this manually to pass SafetyNet as follows:

    Add Google Play Services process(es) to denylist unless a solution for hiding root associated modifications from GPS SafetyNet process(es) is incorporated in an active module. For devices where Magisk resides in /sbin (many pre. Android 11), only deny SafetyNet process, com.google.android.gms.unstable. For Android 11+ etc (non /sbin), deny Main process, com.google.android.gms also.

    Happy reading / playing, and hope this helps! 😀 PW

    Edit:

    *FWIW, this makes Alpha attractive for anyone wanting to use Riru and pass SafetyNet on late devices (w/ TEE Attestation in hardware affected by September Google server end changes) with post 23001 Magisk builds... This may only be useful in the interim until general Zygisk module conversion / take-up and Riru is dropped...

    However if (and only if) Riru does get continued support / remains popular / doesn't die post Magisk 24000 (ie. Zygisk in Stable Magisk), and @kdrag0n reconsiders this:
    https://github.com/kdrag0n/safetynet-fix/issues/120#issuecomment-971831719
    we may see working USNF-Riru for official TJW post Zygisk Magisk...

    I suspect though that predictions of Riru's imminent demise will be realised, so don't hold your breath.

    Thanks for all the fun RikkaW and team; You did it (allowed modules to run code in apps w/ zygote injection / Xhook) first! 👏 PW
    9
    ...snip...
    Just meant nandroid restore should be usable to roll back since you seemed concerned you'd 'lose ability to use nandroid backup' & would need to restore beloved A10 setup / mods piece by piece!...
    ...snip...
    A LOT of config is stored in the settings. For example:
    PHP:
    settings put global "window_animation_scale" "0.5";
    Because I use to build ROMs from source and therefore clean flash my devices a lot, I built a method to extract and reinstate all my config, to be used selectively and in combination with normal back-up apps, to reinstate my device as close to its previous state without manually hunting and seeking all the settings, after a clean flash.

    I automated this task as a method within the app TeMeFI and can be found under Current State>Settings>Generate Set All
    7
    Victory! What did I Will Merv!😉
    6
    I'm going to update my Samsung S21 from Android 11 One UI 3.1 to Android 12 One UI 4, can someone confirm that the standard firmware update procedure (patched system image + home_csc) will work?

    Thank you!
    Broken in current released builds. Fix merged in Magisk master repo downstream for S21
    https://github.com/topjohnwu/Magisk/issues/5162#issuecomment-1004475802
    + many other Sammy models two weeks ago.

    PR: https://github.com/topjohnwu/Magisk/pull/5139
    Committed:
    https://github.com/topjohnwu/Magisk/commit/19182ffddf6f7c87bacab4b9f91cfaec3ee79537

    John commented on Sammy's 'solution' for broken fstab in device tree (MA content):
    www.twitter.com/topjohnwu/status/1475985579036667904

    You'll need to wait for next TJW build (Canary or Beta), but you can try latest test build from artifacts here:
    https://github.com/topjohnwu/Magisk/actions/runs/1632403163
    Also, fix is merged in latest vvb2060 Alpha builds.
    https://github.com/vvb2060/Magisk/commit/19182ffddf6f7c87bacab4b9f91cfaec3ee79537

    I'm going to update my Samsung S21 from Android 11 One UI 3.1 to Android 12 One UI 4, can someone confirm that the standard firmware update procedure (patched system image + home_csc) will work?
    Nb. Standard procedure is to flash patched firmware file as AP + HOME_CSC + BL + CP as per instruction:
    • Never just flash only AP, or else Odin may shrink your /data filesystem size. Flash AP + BL + CP + HOME_CSC when upgrading.
    👀 PW
  • 1071
    This is the place for general support and discussion regarding "Public Releases", which includes both stable and beta releases.
    All information, including troubleshoot guides and notes, are in the Announcement Thread
    156
    Hello, I haven't given much support on XDA lately. It can be resulted from
    • University started and I have limited free time. In fact, I mostly develop during midnight
    • I live in Taiwan, which has large time zone differences between my European/American contributors/testers, which usually forces me to stay up late at night to discuss/test stuffs.
    • The new version is about to come, I don't want to spend effort on supporting old releases
    The planned update is delayed again and again, to some point I think I'll shed some light about what has been happening lately, also along with some announcements.

    New Forum!
    As you might have already discovered, Magisk got its own subforum on XDA! Many thanks to all the support you gave me, and much more information/features/support is about to come!
    **For developers supporting all the devices that are not using standard Android boot format, feel free to create threads in this section (actually, PLEASE do so) for your favorite devices after v7 is out. As I currently know, Asus devices require signing the boot image before flashing, and is model dependant; Sony devices seems to use ELF kernel that is unpatchable, or some has two ramdisks (inner + outer), both requires different workarounds; LG bootloader locked devices has to manually "BUMP" the boot image after flashing Magisk..... and there may be lots of other crazy boot image formats that haven't come up to my attention yet.
    It is impossible for me to support all these non-standard boot images, and I hope the community can collaborate to make Magisk running across all the devices. Overall, community collaboration is what XDA about :D

    The Pixel Phone
    Some of you might already know this news, that the next Pixel Phone right around the corner seems like it does not have ramdisk in boot image, which pretty much wrecked Magisk in all ways. However, it pretty much doomed root itself too. Kernel modifications is inevitable IMO, so I'll try to migrate my scripts to C programs that could possibly be included into the kernel itself. Note that I'm not familiar with linux kernel, I'm not even sure if my idea and concept is correct or not. But once the device is available, I think developers will find a way to bypass all the difficulties, and I'll do my best to learn things ;)

    Current Progress
    In the past month, I've spent quite some time learning SELinux, so that I can avoid using SuperSU's sepolicy patches. Thanks to the helps and tips from @phhusson and @Chainfire, I finally have a much clearer understanding of how SELinux works. The Magisk core parts (the scripts, boot image patches, new features, more supports) are actually done some time ago. What is causing all the delays is the Magisk Manager.
    To be completely honest, although I can code in Java without much issues, Magisk Manager is actually my first Android application, I had to reach out for assistance, and fortunately awesome developers like @DVDandroid and @digitalhigh contributed a lot, which makes the current Manager awesome.
    After the repo system and module management is mostly done, I was about to do some adjustments and release, but what we really done is decided to add another feature: auto-unroot with per-app settings. I decided to wait for it to be finished, and then do my adjustments. Due to reasons that'll be mentioned later, this feature will likely not be available for the next release (should come in future updates)

    Safety Net Disaster
    Those who are using Magisk for Safety Net bypass purposes must have known that Google recently updated the detection method of my Systemless Xposed. I still have no idea what Safety Net is detecting, so currently I cannot fix it on my side (also because I'm busy working on the next update). However, suhide developed by @Chainfire is able to hide Xposed and worked fine.
    However, only my Systemless Xposed v86.2, which is based on SuperSU's su.d, is supported using that method. v86.2 and v86.5 (latest, Magisk based) have nearly identical binaries, and the only difference is the path where the binaries are stored.
    I'm still not sure what's the real issue for it not being supported, I just hope it is not done intentionally.

    Conclusion
    Due to the fact that my Safety Net bypass is not 100% perfect now, I do not want to spend any more time waiting for auto-unroot to be polished. What I'm doing now is finishing up all the things I'd like to change in Magisk Manager (it has been a while since I last contributed to Manager, my fellow developers are doing all the heavy job), which might take a little more time, after that, packed with tons of information to be announced in Magisk Section, I'll release the long awaited update.

    Hope this lengthy post gives you the idea of the whole situation, and again thanks for all your support!!
    121
    Ah, some Chainfire bashing, I hope it is not too late for me to exercise additional villainy.

    First, let me make clear I have nothing against @topjohnwu, nor against Magisk. Magisk is an interesting project and it certainly displays @topjohnwu ingenuity and persistence. I don't doubt we will see more interesting things from his hands.

    -------------------------

    What has happened here is not all that dark and complicated, from either end. I returned from holidays, and someone pointed me at Magisk. My first thought: interesting!

    Among other things, the thread lists some issues with SuperSU, which in combination with the phrase The developer also requests users to not bug Chainfire with compatibility requests for SuperSU with Magisk from the portal article, raised my left eyebrow by nigh half an inch. The popular systemless xposed mod is apparently now based on it, and apparently it now no longer works with SuperSU, and apparently I'm not supposed to fix that, nor any of the other found issues. I found that a bit weird. So yes, I have told @topjohnwu that I was a bit surprised he was posting about issues with SuperSU without notifying me about them (I can't fix or help fix issues I'm not aware of, after all).

    He's also spreading a modified version of the SuperSU package, which is not all that uncommon, nor necessarily a problem. I have not looked into what he modified, I only ran a few quick tests on one of my devices, and found some commonly used commands run as root to be broken. I have informed him of this as well.

    It appears the tool of choice for Magisk is phh's Superuser, because of some of the mentioned issues with SuperSU. That's fine by itself, but fixing issues in that superuser by incorporating SuperSU's binaries into it is a somewhat questionable practise. After all, SuperSU is a commercial closed-source package that helps pay for my dinner, and superuser is a direct competitor. I have informed him that I was surprised he did this without asking for permission. I have expressed similar surprise on him spreading a modified version of LiveBoot (which helps pay for a snack now and then).
    @topjohnwu has also stated that Magisk's scripts are largely influenced by mine (I have not checked). Scripts based on mine are used all over the place on XDA, some people have crafted amazing things based on them, I have never made an issue of this (otherwise I would have just made them binaries). But yes, I have also stated to him that I don't think it's very nice to base something on one program, and then using that to (almost exclusively) push something directly competing with that program.

    tl;dr Towards @topjohnwu, I have:
    - expressed surprise he has issues getting Magisk to work with SuperSU, and has chosen not to inform me about those
    - expressed surprise he is using SuperSU binaries in a competing superuser without permission
    - expressed surprise he is posting a modified LiveBoot without permission
    - informed him of issues with the modified SuperSU he has posted
    - let him know I thought it wasn't very nice to be applying my scripts to benefit seemingly exclusively that same competing superuser

    To be crystal clear:
    - I have not asked for an apology
    - I have not asked for Magisk to be abandoned, neither the root hiding nor systemless module parts, and certainly not systemless xposed
    - I have not made an issue of any of this anywhere, until this post
    - I have not even specifically asked for anything to be taken down (though obviously in my opinion the other superuser package mixed with SuperSU's binaries, as well as the LiveBoot package, should go)
    - I have not reported this thread to XDA moderators for copyright violations or otherwise

    While my conversation with @topjohnwu may not win any awards for being friendly (though it may win some for brevity), I think all things considered my response has been rather mild. To be perfectly honest, until the apology post, I thought this was over with already. I think the apology post was triggered because I haven't replied to his last PM for a while - I was in the zone, it happens.

    To emphasize again, I have nothing against @topjohnwu, Magisk, or systemless xposed, and it is certainly not my goal to see any of them go. If it can be made to work together with SuperSU, great.

    I get it though: you think of something, you want to see if you can make it work, you finally get it to work, you publish it, it takes off - enthusiasm gets the better of you. Maybe in the rush some mistakes are made. That doesn't mean you have to just drop it and run. None of my stuff would make it past 0.1 if I stopped at the first big mistake :)

    Aside from said being in the zone coding, I usually regret actually responding to these sort of things the day after, which has made me hesitant to reply. Surprise me.
    76
    Thread temporarily closed so everyone sees this.

    The flood of "SafetyNet isn't working for me either!" posts are not helpful, at all. Please refrain from posting further, it will be looked into. Please do not forget that not passing SafetyNet is 100% NORMAL AND INTENDED when you have an unlocked booloader or running custom firmware. These are workarounds and they will be worked around in turn.

    The Flash
    Forum Moderator

    EDIT: Thread is reopened... I will be cleaning any SafetyNet posts for a while to keep the thread clean for real issues.
    75
    Hello everyone!

    I am aware that Google has updated Safety Net that makes Magisk itself a no go for Android Pay. In fact, I witnessed the change live while I am developing the new magiskhide, which should hide all Magisk modules and Magisk installed root.

    Google is serious about Safety Net now, clearly hunting down all possibility to run Xposed with Safety Net passed. I spend quite some time examining the new security measures last midnight, and fortunately it seems that it is possible to run Magisk and root along with Safety Net if no Xposed is running. I'm glad I removed the old root toggle at the right time lol, that is no longer feasible with the latest detection.

    So stay tuned for the next update, it will come with bug fixes, along with the new magiskhide to bypass that Safety Net.

    Google, how will a few systemless mods do any harm :p:p