[Magisk][Module] OnePlus 3(T) Wifi Channel Bonding Enabler

Search This thread

cornroll

Member
Apr 22, 2010
39
7
Dear all,

I'm using a xiaomi Mi5 64gb running on JDCs AOSP 7.1.2 ROM.

Is this module applicable for my phone? I have downloaded and installed the zip file via magisk manager but I'm still getting 72mbps on my 2.4ghz network.

Router has been set to 20mhz/40mhz.

Thank you all..
 

onliner

Senior Member
Oct 29, 2016
2,422
1,031
Dear all,

I'm using a xiaomi Mi5 64gb running on JDCs AOSP 7.1.2 ROM.

Is this module applicable for my phone? I have downloaded and installed the zip file via magisk manager but I'm still getting 72mbps on my 2.4ghz network.

Router has been set to 20mhz/40mhz.

Thank you all..
So... The answer is: no
 

nicknacknuke

Senior Member
Jan 14, 2011
106
18
is this the official module ?
i tried to install this, but failed at merging the .ini file...
if it's not the correct module, can someone upload the zip file here ?
btw, i'm in oreo stock, magisk 14.5

edit : nvm, edited the file manually. works now
 

Attachments

  • Screenshot_20171202-174718_01.jpg
    Screenshot_20171202-174718_01.jpg
    182.6 KB · Views: 544
Last edited:
On my Asus Zenfone 3 running Oreo, the .ini file is in /system/vendor/firmware/wlan/prima/. I edited the module's install script to look in that path and it installed successfully. Like others, my 2.4GHz WiFi connection rate increased from 72Mbps to 150Mbps. Thanks a lot for this find and creating this module!
 

nicknacknuke

Senior Member
Jan 14, 2011
106
18
Just a note, if you enable this module, then tethering will no longer work.

I have to disable this module first to do tether, then enable it back after.
So it seems like tethering is using the "extra" channel.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 52
    Hi,

    I have an OnePlus 3T and apparently OpePlus simply took the default WiFi config file provided by Qualcomm. This means that while for 5GHz channel bonding is enabled, 2.4GHz connections only use 20MHz wide channels, whereas channel bonding would allow to use 40MHz (where supported by the router).

    This problem can be remedied by editing the config file WCNSS_qcom_cfg.ini located in system/etc/wifi. However, I found it unpleasant to modify my system partition as Magisk would give me systemless root and Xposed. So I did a very simply Magisk Module to overcome this.

    To my understanding, this configuration is the same for OP3 and OP3T - but can't say for sure.

    EDIT: Download removed. Now in official Repo.


    Thanks!

    BTW: It's free. If you like it, hit the THANKS button. If you want to donate, please donate to @topjohnwu for making Magisk!
    3
    I did some further testing and it works. The link speed doubled. See the Screenshots.
    2

    System/vendor/etc/wifi

    ---------- Post added at 08:24 AM ---------- Previous post was at 08:23 AM ----------

    Have the same question.

    ....

    ---------- Post added at 08:24 AM ---------- Previous post was at 08:24 AM ----------

    This not working anymore in oreo? where is the file located?

    See above
    1
    It does work even on the Nougat version of OOS. @dreinulldrei, you really should apply for the repo because this is a solid mod.

    I applied for a repository, but so far no response from topjohnwu. Guess he's working on next release of Magisk.
    1
    It's on the official repo now.