[Magisk][Module] OnePlus 5GHz mod

Thomasvt

Member
Dec 10, 2014
41
17
0
Hi,

I just got my Google WiFi 3-kit and it seems that the channel they work on (149) wasn't supported in my country (NL) so I made a simple Magisk module to change the region to [EU]

This 'fix' is simpy a change to "wifi-service.jar" which can be located in /system/framework/

Source: https://github.com/thomasvt1/extendwifi

DOWNLOAD

Updates v7
  • Update OOS to 4.5.10
  • Add support for Magisk v14.0



Special thanks to:
- https://forum.xda-developers.com/pixel/themes/mod-wifi-country-code-fix-root-required-t3558044
 

Attachments

Last edited:

ToucanSam

Member
Feb 24, 2010
47
69
0
The wifi region is selected based on the SIM in your phone. Most people won't need this, care, or notice.
Second, this is probably illegal since it changes your phone to use frequencies that are not allowed in the users home country. Is anyone going to get caught or in trouble for this? Unlikely. But it also won't be useful unless you've purchased hardware that broadcasts on frequencies not allowed in your country. IE, Google WiFi hasn't been released in Europe yet and doesn't officially follow EU frequency range. Which is why it's useful for @Thomasvt but not for anyone else. :)


@PokemonTotalWar: Long answer? No.
 

Thomasvt

Member
Dec 10, 2014
41
17
0

ToucanSam

Member
Feb 24, 2010
47
69
0
@Raharazod Actually Google WiFi is released in the EU. (France, Germany and the UK) http://www.androidpolice.com/2017/06/26/google-wifi-may-coming-france-monday/ as for my country. All Apple products, and my laptop happily use the 5GHz network without any modification except my OnePlus 5.
OH! I thought it was still pending release over here. Wasn't really keeping a close eye.

Well it shouldn't. :D
There ARE 5Ghz bands that are allowed in the EU, just not all of them. I was assuming that your module enabled ones that weren't otherwise allowed.
 

Kinger1970

New member
Jan 24, 2017
4
1
0
I've got my phone bootloop

Hi,

I just got my Google WiFi 3-kit and it seems that the channel they work on (149) wasn't supported in my country (NL) so I made a simple Magisk module to change the region to [EU]

This 'fix' is simpy a change to "wifi-service.jar" which can be located in /system/framework/

Source: https://github.com/thomasvt1/extendwifi

DOWNLOAD

Updates v7
  • Update OOS to 4.5.10
  • Add support for Magisk v14.0



Special thanks to:
- https://forum.xda-developers.com/pixel/themes/mod-wifi-country-code-fix-root-required-t3558044
After installing module I've got my phone bootloop. May you define place for the original wifi-service.jar file during module installation.

Thanks, Kinger
 

Dimontiman

Senior Member
Apr 6, 2017
293
111
43
I got another Problem on oreo closed beta 2.

After update from 4.5.14 my 5ghz wont connect with settings in router auto channel..

This means channels 36 above until 52 wont work.
If i sett a special channel like 52 above my 5ghz wifi connects to my op5..

Did OnePlus messed something up?

Located in Germany op5 A5000
 

keepasa

Senior Member
Sep 4, 2013
59
9
0
Hi Dimontiman,

Have you tried with the official OxygenOS Open Beta 1? Since leaked closed beta 1 and 2 were not made for public and lots of bugs.

Did it give any errors when adding the module in Magisk?

If still doesn't work on official open beta 1, then perhaps an update to this module would be required perhaps.
 
Last edited:

Thomasvt

Member
Dec 10, 2014
41
17
0
Last edited:

Dimontiman

Senior Member
Apr 6, 2017
293
111
43
I do have a Oxygen (leaked build 1) version on my github: https://github.com/thomasvt1/extendwifi/tree/4.5.2 (just download as zip).

I haven't been able to get smali working yet with the open beta 1. I'm not sure if the closed beta one works on the open beta.

Edit: My version from git still does work with the open beta 1. Just tested.

Edit2: New updated version for Open Beta 1: https://github.com/thomasvt1/extendwifi/tree/O2_Open1 [just downoad zip and use in magisk]

Hey

Appreciate your work, what does your module change exactly?

Additional to OP
 

Thomasvt

Member
Dec 10, 2014
41
17
0
Hey can you update this version to magisk repo as i cant use the zip on magisk
Sorry the magisk repo version will only be the stable version of OxygenOS.

Maybe try a file explorer to select the zip, I know ES File Explorer works when using the 'file way' and not the 'normal android way'.

I hope this helps!
 
  • Like
Reactions: Dimontiman

Dimontiman

Senior Member
Apr 6, 2017
293
111
43
Sorry the magisk repo version will only be the stable version of OxygenOS.

Maybe try a file explorer to select the zip, I know ES File Explorer works when using the 'file way' and not the 'normal android way'.

I hope this helps!
If i flash the zip from twrp, can stock be afterwards restored? I mean to uninstall
 
Last edited: