[MAGISK] [MODULE] Webview Manager

Search This thread

androidacy

Senior Member
Apr 1, 2019
216
186
www.androidacy.com
New updates are out:


Also please note magisk manager will no longer show updates even to stable users. The only office place to download zips is our website:

 
  • Like
Reactions: TiTiB

nacos

Senior Member
Sep 27, 2007
537
246
Here & Now
Please remember config.txt is deprecated and no longer read from. Instead, the installer will allow you to make selections using your volume keys.
Unfortunately, Webview Manager no longer works on S20 (possibly on all newer Samsung devices). It ends up with an error (see attached screenshot).
 

Attachments

  • IMG_30122021_094002_(1080_x_2178_pixel).png
    IMG_30122021_094002_(1080_x_2178_pixel).png
    441 KB · Views: 86
Last edited:

nacos

Senior Member
Sep 27, 2007
537
246
Here & Now
Please remember config.txt is deprecated and no longer read from. Instead, the installer will allow you to make selections using your volume keys.
I just tried and it failed with the same message. The current version (even after db refresh) shown in Magisk Manager is 10.2.5 (5019) and it seemed to have been released on Nov.20.2021. Maybe it takes some time for it to get updated. I'll keep looking for the new version and I'll report back.
 

androidacy

Senior Member
Apr 1, 2019
216
186
www.androidacy.com
I just tried and it failed with the same message. The current version (even after db refresh) shown in Magisk Manager is 10.2.5 (5019) and it seemed to have been released on Nov.20.2021. Maybe it takes some time for it to get updated. I'll keep looking for the new version and I'll report back.
Magisk repository no longer receives updates, the submissions repo was archived preventing the bot from pushing updates.

Keep an eye on our repository instead: https://www.androidacy.com/modules-repo/
 

temporarium

Senior Member

whatsisnametake2

Senior Member
hi,

your new version managed to install ok on my pixel 6 pro. I installed bromite browser and webview. my main goal is to get webview pages (specifically the ones flipboard opens) to open in dark read mode. I have the setting activated in bromite browser and it works there, but still getting non dark pages via flipboard. any clues?

w.
 

androidacy

Senior Member
Apr 1, 2019
216
186
www.androidacy.com
Yes, you do. However, you're "hosting" others' open source projects, and monetizing on that. Something's not right there...
The only code we add to those modules is an entirely opt-out function to launch the correct download page so the use may, at their leisure, download updates for their modules. We don't inject ads or anything else for that matter.

And those module, the API behind it, and the website are not free for us to host. Between bandwidth, server, and security costs we barely break even most months. We see 2-3TB of transfer a month, and upwards of 21M users a month during peak season. None of that is cheap for us.

Unless, of course, you're suggesting we remove ads from the website entirely. But then again, that's what you want, isn't it? Something for nothing.

You are, of course, free to use your own alternatives. But do not come here and crap on our work because you don't like the way we do it.

That is all we have to say on the subject. Thanks for reading.
 

nacos

Senior Member
Sep 27, 2007
537
246
Here & Now
Magisk repository no longer receives updates, the submissions repo was archived preventing the bot from pushing updates.

Keep an eye on our repository instead: https://www.androidacy.com/modules-repo/
The Webview Manager version downloaded from the suggested repository above installed without errors however, surprisingly, it installed an older version of Bromite System webview . I needed to download the latest version from F-Droid.

Thanks for your prompt assistance!
 

Top Liked Posts

  • There are no posts matching your filters.
  • 49
    Welcome to the XDA home of Webview Manager by Androidacy

    Read about it on our blog:​

    What is this?

    This magisk module allows to install several webviews and browsers, replacing the stock one with more privacy friendly/better performing browser and/or webview. By default this module will install Bromite.

    Can I use older versions?​

    No.

    Why use different webview or default browser?

    These webviews are de-googled or more privacy friendly, or just more updated, or better optimized. Because it's better than Google or AOSP webview.

    Why not other methods?

    These usually involve directly modifying system and are less versatile and more incompatible. In addition, thanks to auto updates and dynamic system detection, you know you get the right files without extra bloat.

    Systemful install

    Systemful install is not supported and we currenly have no plans to change that.

    Configuration

    Configuration is done during install, thanks to @Zackptg5 magnificent Volume-Keys selector with a touch of our own spice.

    Getting support

    Zip /sdcard/WebviewManager/logs, and send along with detailed description of the issue including device name, ROM, and Android version.

    Links

    Website and blog is at https://www.androidacy.com
    Donations are here
    Beta/alphas: no longer available, due to an improved QA process.
    ZIPs: click me
    Telegram: Androidacy Discussions
    Discord: Available to Patrons. See our donation link above.
    6
    It's back in the repository, now with official support from the Bromite team!!
    6
    Ok guys sorry I haven't logged in for awhile, been kinda busy
    The short of it is that as far as I know currently, no other webview besides Google supports Q. In addition, the way webview is handled changed on Q

    So although there have been updates, none have made it to stable because I'd like to tackle Q compatibility in the next release. However, if no upstream support is added by end of year I'll push current fixes anyway

    In addition to the poster who is complaining about "all devices" -if you read the README (which actually I need to update with the status of Q)* it specify only 7.0-9.0 ROMs are supported

    However if you really want to see support for your device enhanced, you really need to join my telegram group, https://t.me/inlmagisk so I can get feedback and provide betas

    So yeah. Been a little busy lately with life, and waiting on upstream support. Not dead yet ;)

    Sent from my Pixel 2 XL using Tapatalk
    6
    We're excited to be releasing version 3.1

    Sorry for the massive bug introduced in v3.0 but 3.1 is confirmed working on AOSP, RR, LOS, and OOS (needs testing). For some reason, appropriate directory was not getting copied over

    Changelog:
    • Fixed installer and boot scripts (finally!)
    • Reduced file size by downloading external resources separate
    • Attempt to support more webview installation scenarios
    5
    Good news everyone!

    V4 is live in the Magisk repo, with all stock compatibility fixes

    A clean flash is highly recommended for proper functionality of the module