[MAGISK] [MODULE] Webview Manager

Search This thread

TiTiB

Senior Member
Jun 19, 2015
919
719
Earth, for now
Does the 'Compatibility' portion from Magisk Manager still hold true? Particularly the statement, "OneUl users: make sure Secure Folder Is disabled before installing."

Is there new info concerning OneUI users?
 
  • Like
Reactions: Swordfishx86

nacos

Senior Member
Sep 27, 2007
537
246
Here & Now
Been resolved for awhile now, can you recheck if you haven't already?
Both, good AND bad news: I've just reinstalled Bromite WebView using the latest WebView Manager and although the app intalled without problems (which wasn't really a version update but rather just a confirmation that the manager is now installing the latest version correctly), I believe this version somehow interferes with Magisk's internal hiding mechanism (still on Magisk v.23). I'm saying this because with this new version four (4) banking apps I have installed just stopped working (all of them). As soon as I've restored the previous app + data using Titanium Backup all four banking apps started working again. Please look into this.
 
Last edited:

androidacy

Senior Member
Apr 1, 2019
216
186
www.androidacy.com
Both, good AND bad news: I've just reinstalled Bromite WebView using the latest WebView Manager and although the app intalled without problems (which wasn't really a version update but rather just a confirmation that the manager is now installing the latest version correctly), I believe this version somehow interferes with Magisk's internal hiding mechanism (still on Magisk v.23). I'm saying this because with this new version four (4) banking apps I have installed just stopped working (all of them). As soon as I've restored the previous app + data using Titanium Backup all four banking apps started working again. Please look into this.
Install the WebView APK in /sdcard/WebViewManager/apks, this just means the boot script that installs it as an user app on top of the system app failed to run and as a result the WebView is no longer accessible to apps on the DenyList/Hide list
 

nacos

Senior Member
Sep 27, 2007
537
246
Here & Now
Install the WebView APK in /sdcard/WebViewManager/apks, this just means the boot script that installs it as an user app on top of the system app failed to run and as a result the WebView is no longer accessible to apps on the DenyList/Hide list
In other words I should install the webview apk version just as a regular apk (on top of the existing system app)?

Another thing, I'm trying to download the zip version of webview manager from your website and I just can't. The downloads either end up with a weird string of characters or it just simply doesn't download.
 

androidacy

Senior Member
Apr 1, 2019
216
186
www.androidacy.com
In other words I should install the webview apk version just as a regular apk (on top of the existing system app)?

Another thing, I'm trying to download the zip version of webview manager from your website and I just can't. The downloads either end up with a weird string of characters or it just simply doesn't download.
Works fine here. Make sure you're not using an ad blocker or something.

Also I recommend this instead:


It will always download the latest
 

nacos

Senior Member
Sep 27, 2007
537
246
Here & Now
Install the WebView APK in /sdcard/WebViewManager/apks, this just means the boot script that installs it as an user app on top of the system app failed to run and as a result the WebView is no longer accessible to apps on the DenyList/Hide list
Installing the apk version on top of the existing system app works temporarily - until after next reboot. In other words, for the banking apps to work, I would have to reinstall the WebView apk after each and every reboot - not the expected behaviour. I'm now on Magisk v.24.1

Edit (Jan.29.2022): The apk needs to be reinstalled, on top of the (same) system app, a couple of times, but eventually it sticks.
 
Last edited:

nacos

Senior Member
Sep 27, 2007
537
246
Here & Now
Gotnit
Works fine here. Make sure you're not using an ad blocker or something.

Also I recommend this instead:


It will always download the latest

Works fine here. Make sure you're not using an ad blocker or something.

Also I recommend this instead:


It will always download the latest
Got it! Thanks!
 

Aushilfsarnie

Member
Jul 7, 2014
9
1
Hi all, I'm trying to change webview under development options but bromite is not showing there. When the manager is enabled, only bromite is shown there and I can't switch to android webview anymore. How do I make it so that I can switch between Android, Bromite (and Chromium) under the development options? Thanks in advance!
 

AlreadyFree

Member
Feb 1, 2017
44
10
I'm on Android 10 & Magisk 20.4. Trying to install Bromite using the latest version of Webview Manager recognizes my internet connection but fails to download the Bromite files. Downloading them manually and putting them in the "root/webview manager" folder seems to cure that but then the install fails with a Verification Error. I don't know what it's trying to verify or why the module won't even run at all without am internet connection. But then doesn't even work with an internet connection.

Luckily for me I still have a backup copy of Webview Switcher 7.2.6. It still installs smoothly and without hassle. I don't understand why all traces of this version were scoured from the internet despite it obviously still being useful to some people. I also don't know why 2 previous versions of Webview Manager are archived (and nothing prior) yet upon attempted installation it checks to determine the current version and refused to even try to work at all unless you download the most recent version (why bother archiving previous versions at all if it's impossible to roll back to a previously working version?).

I'm just happy I had a backup copy of Webview Switcher so I'm not scrambling for an alternative way to install Bromite Webview. I just hope it still works in the future when I finally have to update Android (and maybe Magisk too, jeez!).
 
Last edited:

androidacy

Senior Member
Apr 1, 2019
216
186
www.androidacy.com
I'm on Android 10 & Magisk 20.4. Trying to install Bromite using the latest version of Webview Manager recognizes my internet connection but fails to download the Bromite files. Downloading them manually and putting them in the "root/webview manager" folder seems to cure that but then the install fails with a Verification Error. I don't know what it's trying to verify or why the module won't even run at all without am internet connection. But then doesn't even work with an internet connection.

Luckily for me I still have a backup copy of Webview Switcher 7.2.6. It still installs smoothly and without hassle. I don't understand why all traces of this version were scoured from the internet despite it obviously still being useful to some people. I also don't know why 2 previous versions of Webview Manager are archived (and nothing prior) yet upon attempted installation it checks to determine the current version and refused to even try to work at all unless you download the most recent version (why bother archiving previous versions at all if it's impossible to roll back to a previously working version?).

I'm just happy I had a backup copy of Webview Switcher so I'm not scrambling for an alternative way to install Bromite Webview. I just hope it still works in the future when I finally have to update Android (and maybe Magisk too, jeez!).
Previous versions are not supported as we simply don't have the resources to continue supporting them.

That being said, effective today, all previous versions are no longer available for download. If the current version fails to install for you still, head on over to our telegram group and provide logs so we can assist you further (link is in the OP).
 

AlreadyFree

Member
Feb 1, 2017
44
10
Previous versions are not supported as we simply don't have the resources to continue supporting them.

That being said, effective today, all previous versions are no longer available for download. If the current version fails to install for you still, head on over to our telegram group and provide logs so we can assist you further (link is in the OP).
You don't have to support old versions but why make it impossible to use them (or make them completely unavailable altogether)? Meanwhile you're maintaining a Magisk module repo for people who don't want to update to the latest (& inferior) version of that. Strange.
I'll just stick with the old version of Webview Switcher I have that already works. It's easier than trying to help you reinvent the wheel in the shape of a square for no good reason. Thanks.
 
  • Like
Reactions: ledd988 and gh0st85

ledd988

Senior Member
Apr 4, 2012
151
45
33
Download of Bromite browser and Bromite webview keeps failing. I tried at least ten times. I can download both browser and webview from https://github.com/bromite/bromite/releases in regular browser without any issues... How can I use files I downloaded with module. Where to put them on the phone so module use them instead of continuously trying to download them and failing.
 
  • Like
Reactions: gh0st85

androidacy

Senior Member
Apr 1, 2019
216
186
www.androidacy.com
You don't have to support old versions but why make it impossible to use them (or make them completely unavailable altogether)? Meanwhile you're maintaining a Magisk module repo for people who don't want to update to the latest (& inferior) version of that. Strange.
I'll just stick with the old version of Webview Switcher I have that already works. It's easier than trying to help you reinvent the wheel in the shape of a square for no good reason. Thanks.
Simple. If we provide them, people expect us to support them.

Nonetheless, you are free to do you, but if you want to help us troubleshoot in the future, we'll be happy to assist.
 

androidacy

Senior Member
Apr 1, 2019
216
186
www.androidacy.com
Download of Bromite browser and Bromite webview keeps failing. I tried at least ten times. I can download both browser and webview from https://github.com/bromite/bromite/releases in regular browser without any issues... How can I use files I downloaded with module. Where to put them on the phone so module use them instead of continuously trying to download them and failing.
Can you please join https://t.me/androidacy_discussions? I'd like to troubleshoot this and there's some steps we can take that would be faster on Telegram.
 
  • Like
Reactions: ledd988

ledd988

Senior Member
Apr 4, 2012
151
45
33
Can you please join https://t.me/androidacy_discussions? I'd like to troubleshoot this and there's some steps we can take that would be faster on Telegram.
I am in telegram group. I figured it out myself thank you. I put the files in /storage/emulated/0/WebviewManager/apks/ and renamed them to BromiteBrowser.apk and BromiteWebview.apk and module used those instend of downloading them.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 49
    Welcome to the XDA home of Webview Manager by Androidacy

    Read about it on our blog:​

    What is this?

    This magisk module allows to install several webviews and browsers, replacing the stock one with more privacy friendly/better performing browser and/or webview. By default this module will install Bromite.

    Can I use older versions?​

    No.

    Why use different webview or default browser?

    These webviews are de-googled or more privacy friendly, or just more updated, or better optimized. Because it's better than Google or AOSP webview.

    Why not other methods?

    These usually involve directly modifying system and are less versatile and more incompatible. In addition, thanks to auto updates and dynamic system detection, you know you get the right files without extra bloat.

    Systemful install

    Systemful install is not supported and we currenly have no plans to change that.

    Configuration

    Configuration is done during install, thanks to @Zackptg5 magnificent Volume-Keys selector with a touch of our own spice.

    Getting support

    Zip /sdcard/WebviewManager/logs, and send along with detailed description of the issue including device name, ROM, and Android version.

    Links

    Website and blog is at https://www.androidacy.com
    Donations are here
    Beta/alphas: no longer available, due to an improved QA process.
    ZIPs: click me
    Telegram: Androidacy Discussions
    Discord: Available to Patrons. See our donation link above.
    6
    It's back in the repository, now with official support from the Bromite team!!
    6
    Ok guys sorry I haven't logged in for awhile, been kinda busy
    The short of it is that as far as I know currently, no other webview besides Google supports Q. In addition, the way webview is handled changed on Q

    So although there have been updates, none have made it to stable because I'd like to tackle Q compatibility in the next release. However, if no upstream support is added by end of year I'll push current fixes anyway

    In addition to the poster who is complaining about "all devices" -if you read the README (which actually I need to update with the status of Q)* it specify only 7.0-9.0 ROMs are supported

    However if you really want to see support for your device enhanced, you really need to join my telegram group, https://t.me/inlmagisk so I can get feedback and provide betas

    So yeah. Been a little busy lately with life, and waiting on upstream support. Not dead yet ;)

    Sent from my Pixel 2 XL using Tapatalk
    6
    We're excited to be releasing version 3.1

    Sorry for the massive bug introduced in v3.0 but 3.1 is confirmed working on AOSP, RR, LOS, and OOS (needs testing). For some reason, appropriate directory was not getting copied over

    Changelog:
    • Fixed installer and boot scripts (finally!)
    • Reduced file size by downloading external resources separate
    • Attempt to support more webview installation scenarios
    5
    Good news everyone!

    V4 is live in the Magisk repo, with all stock compatibility fixes

    A clean flash is highly recommended for proper functionality of the module