Magisk Root without TWRP for OnePlus 6 Oxygen OS Android 10 Open Beta 5 | OOS 10.3.1

Search This thread

~yal~

New member
Mar 24, 2011
3
0
Hello,

I also have a problem with the patch 9.0.9.

I can reboot but many apps can't open and Magisk crashes
 

marcash

Senior Member
Jul 11, 2007
177
9
so i flashed full 909.zip ... all works fine
root with magisk also work.

bootloop happens after i remove google apps like maps. music game ect.

this is new in 909 and was not a problem in previous versions
 
Last edited:
Oct 11, 2015
14
2
Friends, now I am on oos 909. How can I root it? Just flash latest twrp using fastboot and flash the latest magisk version 20? If not anyone please help with step by step procedure?
 

xpakage

Senior Member
Oct 23, 2010
2,094
685
Oklahoma
so i flashed full 909.zip ... all works fine
root with magisk also work.

bootloop happens after i remove google apps like maps. music game ect.

this is new in 909 and was not a problem in previous versions

Can you remove one app at a time, then reboot until you find out which one is causing the bootloop, reinstall 9.0.9, and remove all Google apps but that one?
 

rwhryz

Senior Member
Oct 16, 2012
114
12
Even easier way to root without TWRP:
1. Install OTA update (Don't reboot).
2. Open Magisk Manager, install Magisk and choose "Install to Inactive Slot (After OTA)" (Now reboot).
3. Now you are rooted without TWRP and without any boot img hassles as well. :D

Coming from Pie, BETA25, this won't work on OP6 O2 OBT1 right?
 
  • Like
Reactions: djrocks

oTeMpLo

Senior Member
Mar 30, 2012
568
179
Maribor
OOS 10 Open Beta 1 Patched Boot wont boot from fastboot.. you get same error as with twrp

downloading 'boot.img'...
OKAY [ 0.569s]
booting...
FAILED (remote: unknown command)
finished. total time: 0.598s
 

lucaam

Senior Member
Nov 17, 2014
106
44
25
Dugenta
Do you guys have mobile signal when using Magisk on OB1? When I try both options to very Magisk I loose SIM cards.
 

vkass

Senior Member
Jan 8, 2011
566
175
Be careful when installing or updating modules, I updated the busybox module and the phone wouldn't boot anymore, just went straight to fastboot with no boot animation.
I had to flash stock boot img to boot again, but then it's not possible to remove the bad module.
Backed up my sdcard and apps and rolled back to pie until there's working twrp.
 
Last edited:

rwhryz

Senior Member
Oct 16, 2012
114
12
I tried but system didn't boot and kept getting back into recovery

Maybe you have modules installed that are not supported?
Thank you for the heads up man.

Updated with Oxygen OS Android 10 Open Beta 1 Patched and Stock boot imgs:

OOS 10 Open Beta 1 Patched Boot
OOS 10 Open Beta 1 Stock Boot

Anyone tried to install OTA > install magisk(after OTA) > restart?
I literally have no modules installed.
 
  • Like
Reactions: ddaharu

Top Liked Posts