Magisk Root without TWRP for OnePlus 6 Oxygen OS Android 10 Open Beta 5 | OOS 10.3.1

Search This thread

Dimitrimem

Senior Member
Jan 19, 2018
77
8
Honolulu
Last edited:

spyderon

Senior Member
Jul 31, 2008
99
13
Setif
Are OB31 and OB2 the same ?
I've tried the to flash the images in the post above but didn't work
Edit : It worked, the files are in the link in the post above
 
Last edited:

DivineJimmi

New member
Jun 10, 2019
2
0
My problem is: after flashing the patched boot.img, i got no Sim card connection. It says for both sim card slots, that theres no sim card found. I cant root my phone, until this bug is fixed..
 

mascian

Senior Member
Nov 9, 2004
733
74
56
Italy
Sorry, I need help.
I made a clean flash; installed the official version (Android Q), then updated to the Beta 3 version (local upgrade).
I then flashed the recovery but the system does not boot anymore (I'm using Mauronofrio's recovery, 3.3.1-14 version).
So I flashed the patched boot image available here: https://forum.xda-developers.com/oneplus-6/how-to/guide-how-to-update-op6-to-ob3-q-magisk-t4021303
and the system has started.
Now, if I try to flash the recovery again, the system does not boot anymore... can anyone tell me how to solve?
Thanks so much.
 
Last edited:

Dimitrimem

Senior Member
Jan 19, 2018
77
8
Honolulu
Thank you for posting the link for BETA 3 .. i am upgrading as we speak .. if the "imagisk trick" works will update my comment .. also if i am using the beta 3 link :)

i cant download the patched img as they exceeded their transfer quota .. any other link for it please


Sorry, I need help.
I made a clean flash; installed the official version (Android Q), then updated to the Beta 3 version (local upgrade).
I then flashed the recovery but the system does not boot anymore (I'm using Mauronofrio's recovery, 3.3.1-14 version).
So I flashed the patched boot image available here: https://forum.xda-developers.com/oneplus-6/how-to/guide-how-to-update-op6-to-ob3-q-magisk-t4021303
and the system has started.
Now, if I try to flash the recovery again, the system does not boot anymore... can anyone tell me how to solve?
Thanks so much.
 
Last edited:

S4rr4cino

Senior Member
Mar 15, 2008
81
23
Updated with Oxygen OS 10.3.0 and Oxygen OS 10 Open Beta 3 Patched and Stock Boot Imgs:

OOS 10 Open Beta 3 Patched Boot
OOS 10 Open Beta 3 Stock Boot

OOS 10.3.0 Patched Boot
OOS 10.3.0 Stock Boot

Thanks friend, I flashed your "OOS 10.3.0 Patched Boot" on my OOS 10.3 and at first the root seemed absent, then I downloaded the Magisk Manager, I installed it and the root was already installed, it has me automatically asked to download something, I confirmed, automatically it restarted and as if by magic the root is perfectly functional, I restarted it and turned it off a couple of times to be sure not to lose it but it doesn't seem to disappear. Thanks for the Boot Patched friend.
-----------------------------
Grazie amico, ho flashato il tuo "OOS 10.3.0 Patched Boot" sulla mia OOS 10.3 e in un primo momento il root sembrava assente, poi ho scaricato il Manager di Magisk, l'ho installato e il root risultava già installato, mi ha chiesto in automatico di scaricare qualcosa, io ho confermato, in automatico si è riavviato e come per magia il root è perfettamente funzionante, l'ho riavviato e spento un paio di volte per essere sicuro di non perderlo ma sembra non scomparire. Grazie per il Boot Patched amico.
 

amihir

Senior Member
Dec 7, 2014
93
15
Nagpur
bit.ly
Right now I have OOS 9.0.9
And i have got notification about the OTA of OOS 10.3.0

I have Magisk 20.1 installed..

Will "Install to Inactive Slot (after OTA)" work ?

Or should I unroot and then install and again root?
 

Top Liked Posts