Magisk Root without TWRP for OnePlus 6 Oxygen OS Android 10 Open Beta 5 | OOS 10.3.1

Search This thread

rwhryz

Senior Member
Oct 16, 2012
108
11
Hello.
For some reason, I messed up my completely working Magisk.
Im on OP6_O2_BETA_25.
What I did to recover, flash the ob25_stock_boot.img then ob25_patched_boot.img.
When I open Magisk manager, MAgisk is not installed.
When I try to click Install, the only option I have is to "Download Zip Only" and "Select and Patch a File"
I tried "Download Zip Only" > Magisk-v20.3(20300).zip
It just downloaded the zip.
When I click "Select and Patch a File", it tells me to "Select a raw image(*.img) or an ODIN tarfile(*.tar)
Obviously, Magisk-v20.3(20300).zip is not the correct file but I tried it anyway, desperate to get titanium backup to work.
Unsupported/Unknown image format
Installation failed

Should I copy ob25_patched_boot.img to my phone and Install Magisk > Select and Patch a File > ob25_patched_boot.img?
 
Last edited:

agnostu

Member
Mar 6, 2014
15
22
Venice
Hello.
For some reason, I messed up my completely working Magisk.
Im on OP6_O2_BETA_25.
What I did to recover, flash the ob25_stock_boot.img then ob25_patched_boot.img.
When I open Magisk manager, MAgisk is not installed.
When I try to click Install, the only option I have is to "Download Zip Only" and "Select and Patch a File"
I tried "Download Zip Only" > Magisk-v20.3(20300).zip
It just downloaded the zip.
When I click "Select and Patch a File", it tells me to "Select a raw image(*.img) or an ODIN tarfile(*.tar)
Obviously, Magisk-v20.3(20300).zip is not the correct file but I tried it anyway, desperate to get titanium backup to work.


Should I copy ob25_patched_boot.img to my phone and Install Magisk > Select and Patch a File > ob25_patched_boot.img?

if you are on OB 25 just flash the patched boot.img you find in the thread and shuld work. No other things.
 

rwhryz

Senior Member
Oct 16, 2012
108
11
Fixed my issue by using twrp temporarily > Flash magisk uninstaller > Boot phone.
Boot twrp temporarily again > Flash Magisk.
 

MrDivinus

New member
Nov 19, 2017
2
0
Hey all!
After installing latest magisk manager+magisk on 10.3.2, everything worked fine, even after rebooting.
But when I move an app as system app, after rebooting, the system goes into bootloop.
Tried many ways, but it's always doing the bootloop, after sticking an app as system app.
Installed Oos 8.1.0, MM v7.1.2 and M v19.1 and everything worked fine after making the same procedure I've tried on 10.3.2.
Anyone tried and had bootloop?
Should we wait until a new version?

Thanks,
MrDivinus
 

Sharlimar

Senior Member
Apr 14, 2016
82
11
Successfully installed beta 6 and keep root!

Method:
1. Uninstall ALL your Magisk modules and Reboot!
2. Install OTA update (DO NOT REBOOT).
3. Open Magisk Manager, install Magisk and choose "Install to Inactive Slot (After OTA)" and reboot
4. Reinstall your Magisk modules from scratch
 

ffdp

New member
Dec 27, 2015
4
0
Successfully installed beta 6 and keep root!

Method:
1. Uninstall ALL your Magisk modules and Reboot!
2. Install OTA update (DO NOT REBOOT).
3. Open Magisk Manager, install Magisk and choose "Install to Inactive Slot (After OTA)" and reboot
4. Reinstall your Magisk modules from scratch


But I have bootloop. Now I'm waiting for patched boot.
 

ffdp

New member
Dec 27, 2015
4
0
One time I had a bootloop from beta 4 to 5
What I did was booting to twrp just one time, and disable all the modules in magisk and restart
Try yourself

Thanks for advise But I have already tried everything. I have made patched boot by myself with help of instruction in old theme and it works fine.
 

5xonlineage

Member
Jul 6, 2017
34
6
Denver, CO

Top Liked Posts

Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone