• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Magisk update and Android 11?

Search This thread

TY53

Member
May 27, 2019
7
0
Hello everyone,
I just received a new Magisk update. Does it mean that I don't need Canary for android 11 anymore? Since there's a new version?
I am just afraid to root with Canary, heard stories and don't want to take the even bigger risk.
Thanks:)
 

v12xke

Senior Member
Dec 5, 2010
2,056
664
The Woodlands, TX
Hello everyone,
I just received a new Magisk update. Does it mean that I don't need Canary for android 11 anymore? Since there's a new version?
I am just afraid to root with Canary, heard stories and don't want to take the even bigger risk.
Thanks:)
You are still on 10, waiting?? Pretty sure you will still need canary to root 11. What does the changelog say on your stable version? Until it says "supports Android 11" you'll still need to use the canary version which by the way is quite safe if you are using pretty much any mainstream phone. There is no risk at all. Use canary to patch the stock boot image. Put both in the same folder. Flash the patched image. If you don't have immediate success, you simply flash the stock boot.img and you are back to stock. Any stories you heard are just that... stories.
 

Lughnasadh

Senior Member
Mar 23, 2015
2,083
1,380
Google Nexus 5
Huawei Nexus 6P
Hello everyone,
I just received a new Magisk update. Does it mean that I don't need Canary for android 11 anymore? Since there's a new version?
I am just afraid to root with Canary, heard stories and don't want to take the even bigger risk.
Thanks:)
The new Stable Magisk Manager (8.0.0) is fine to use on Android 11. The latest Beta Magisk (21.0) is also fine to use on Android 11. Both were just updated to be Android 11 compatible. Soon the Beta Magisk will be moved to the Stable channel once any bugs (if any) are worked out.

By the way, the latest Canary also works fine on Android 11.

Installation instructions and documentation have been updated. https://github.com/topjohnwu/Magisk
 

TY53

Member
May 27, 2019
7
0
Thanks for answering ?. I'll see if it says supports android 11. Yes I was on 10 waiting, root is a small risk, but Canary is a bigger one that I didn't want to take. Hopefully it supports it and I can root to Android 11.

By the way, do you know if the Soli motion sense module works with Android 11?
Thanks in advance:)
 

Lughnasadh

Senior Member
Mar 23, 2015
2,083
1,380
Google Nexus 5
Huawei Nexus 6P
Thanks for answering ?. I'll see if it says supports android 11. Yes I was on 10 waiting, root is a small risk, but Canary is a bigger one that I didn't want to take. Hopefully it supports it and I can root to Android 11.

By the way, do you know if the Soli motion sense module works with Android 11?
Thanks in advance:)
The latest Beta does support Android 11. https://twitter.com/topjohnwu/status/1312342107139440640

Make sure you set the channel in the Manager to Beta.

I don't know anything about the Soli motion sense module..
 

v12xke

Senior Member
Dec 5, 2010
2,056
664
The Woodlands, TX
Thanks for answering ?. I'll see if it says supports android 11. Yes I was on 10 waiting, root is a small risk, but Canary is a bigger one that I didn't want to take. Hopefully it supports it and I can root to Android 11.

By the way, do you know if the Soli motion sense module works with Android 11?
Thanks in advance:)
It's ready to go now. Latest version 21 (MM v8.0.0) stable supports 11. I don't use the Soli module so can't comment on that.
 
Last edited:

elrarour

New member
Mar 24, 2011
2
0
Thanks for answering ?. I'll see if it says supports android 11. Yes I was on 10 waiting, root is a small risk, but Canary is a bigger one that I didn't want to take. Hopefully it supports it and I can root to Android 11.

By the way, do you know if the Soli motion sense module works with Android 11?
Thanks in advance:)

I'm on 11 with canary rooted. Patched EnableSoli.Magisk20.2.V1.2 via magisk is working