[Main Thread] Ulefone Armor 6 (Stock, Root, TWRP, Flash, & GSI-A)

Extosis

Senior Member
Dec 22, 2014
74
72
0
[Note:] XDA doesn't have a forum for this device as of yet, however they do have tags, with other posts on here. I am going to try to keep this the main thread up-to-date with all the latest tools, mods, roms, etc..
If anyone has anything to add, let me know in the comments or private messages. We will make this the main thread to get current info on this device (Armor 6, and possibly Armor 6E)


Root (Click on image)


PitchBlack Recovery
(TWRP Mod Alt) (credits to chankruze)


TWRP (Team Win Recovery Project) 3.3.X (credits to chankruze for the port only)


Stock OS & Drivers (Google Drive & Mega) (credits to agramgoodghost for showing me the mega URL)


Flashing 2 Stock


Treble Checker (checks if your device is compatible)


Installing GSI-A roms


ps: the mega link has all the roms that Ulefone has updated for all of their devices, Including the Armor 6.

Keepin' it simple.
 
Last edited:

Extosis

Senior Member
Dec 22, 2014
74
72
0
Hi, before almost month, Ulefone had put new stock rom release 05.06.2019. on other site ,but I can send a link...contact me and I will sent you a link..(because i have no right to do that yet)
Best regards,
[email protected]
The Stock OS link, takes you directly to Ulefones Google drive's folder. They upload the files there. I got that link directly from their website.
Unless they use some other file share that I don't know of.
 

bandario

Senior Member
Feb 1, 2011
435
143
63
Victoria

SMAAALLL BR

Member
Aug 13, 2018
25
3
0
21
Cruz das Almas
www.instagram.com
The 6 and 6E are very similar devices. The TWRP listed here works on the 6E. Magisk also works as described.

I cannot confirm for the 6 (but is likely), but the 6E works with all phh-based GSI ROMs.
These phones use A/B images.
did anyone install a GSI ROM by Treble?
I tried Resurrection Remix and ViperOS, but it gives infinite loop.
Also unable to install TWRP with Stock Rom, when I installed the stock system did not start.

ulefone armor 6 uses image A only.
 

godzilla.79

New member
Aug 28, 2019
1
0
0
Аrmor 6

всем привет! у меня проблема с тачскрином.самопроизвольные нажатия ,и не управляемость телефоном - сам нажимает чего попадётся. выяснилось,что вся беда в неправильных драйверах.они находятся в ядре.чтобы драйвера исправить,нужен исходный код ядра. поддержка только отсылает на страницу мега,где они выложили прошивку исправляющую проблемы с таскрином.я прошил армор 6 этой прошивкой - исправлений нет.отсюда просьба о помощи - как,где достать исходный код ядра? есть человек который сможет переписать,исправить драйвера.помогите

Auto Translate -

Hello! I have a problem with the touchscreen. random clicks. it turned out that the trouble is in the wrong drivers. they are in the kernel. in order to fix the drivers, you need the kernel source code. Support only sends to the mega page, where they posted the firmware correcting problems with taskrin. I requested Armor 6 with this firmware - there are no corrections. Hence the request for help - how, where to get the kernel source code? there is a person who can rewrite, fix drivers. help
 
Last edited by a moderator:

SacredDeviL666

Retired Senior Moderator - May You Rest in Peace -
Sep 11, 2008
7,409
8,297
0
¤No Man's Land¤
Non-English Post.

Just a reminder to users who wants to post in Native language kindly follow below


4. Use the English language.

We understand that with all the different nationalities, not everyone speaks English well, but please try. If you're really unable to post in English, use an online translator. You're free to include your original message in your own language, below the English translation. (This rule covers your posts, profile entries and signature). You could try :- https://translate.google.com/ or https://www.babelfish.com/ or use one of your choice.
Thanks
SacredDeviL666.
 
  • Like
Reactions: Extosis

Extosis

Senior Member
Dec 22, 2014
74
72
0
did anyone install a GSI ROM by Treble?
I tried Resurrection Remix and ViperOS, but it gives infinite loop.
Also unable to install TWRP with Stock Rom, when I installed the stock system did not start.

ulefone armor 6 uses image A only.
I did.
I have tried both A & A/B images. Haven't had any luck with the A/B images. So I am safe to assume this is only a, A bootable device.
I've tried Ressurection Remix GSI & Lineage Rom GSI.
I've only had luck with Lineage, I got it to boot and once I unlocked to use the home screen it froze. It keeps freezing for me.
I've tried almost everything.
Fastboot wiping the partitions.
Fastboot flashing modded boot image.
Flashing GSI images using TWRP.
No luck.
However A images seem to work best.

Update: A images WORK! :D
I tried a different image by a different developer and it fu**ing worked! :D
 
Last edited:

SMAAALLL BR

Member
Aug 13, 2018
25
3
0
21
Cruz das Almas
www.instagram.com
I did.
I have tried both A & A/B images. Haven't had any luck with the A/B images. So I am safe to assume this is only a, A bootable device.
I've tried Ressurection Remix GSI & Lineage Rom GSI.
I've only had luck with Lineage, I got it to boot and once I unlocked to use the home screen it froze. It keeps freezing for me.
I've tried almost everything.
Fastboot wiping the partitions.
Fastboot flashing modded boot image.
Flashing GSI images using TWRP.
No luck.
However A images seem to work best.

Update: A images WORK! :D
I tried a different image by a different developer and it fu**ing worked! :D
which?? Tell me did, please.
is everything working? twrp, root, notch, BT, gps ...

Enviado de meu Armor_6 usando o Tapatalk
 

Extosis

Senior Member
Dec 22, 2014
74
72
0
which?? Tell me did, please.
is everything working? twrp, root, notch, BT, gps ...

Enviado de meu Armor_6 usando o Tapatalk
This is the one that worked for me so far.
https://forum.xda-developers.com/pr...vice-development/aosp-9-0-phh-treble-t3831915
Everything seemed to be working as it should have.
However, I didn't use TWRP to flash the image, I keep using fastboot.
I also didn't test everything to see if it worked correctly.
The downside to this was, that it takes forever for the OS to boot up.
One day, ill make a guide on how to flash etc..
 

SMAAALLL BR

Member
Aug 13, 2018
25
3
0
21
Cruz das Almas
www.instagram.com
This is the one that worked for me so far.

https://forum.xda-developers.com/pr...vice-development/aosp-9-0-phh-treble-t3831915

Everything seemed to be working as it should have.

However, I didn't use TWRP to flash the image, I keep using fastboot.

I also didn't test everything to see if it worked correctly.

The downside to this was, that it takes forever for the OS to boot up.

One day, ill make a guide on how to flash etc..
okay, thanks, I'll be waiting for news, send us feedback, maybe I'll try over the weekend.

Enviado de meu Armor_6 usando o Tapatalk