Managed to brick my wife's Moto G Power twice trying to put a new image on it. Help Please.

Search This thread


May 25, 2021
*hangs head in shame*

Ok, I'm stumped and I need help.

Last time I rooted a phone, it was our old HTC Thunderbolts... Things have changed significantly since then, or so it would appear.

Trying to fix my wife's phone after a Verizon OTA update seems to have jumped her phone from Android 10 to 11, and in the process nerfed the hotspot (which we need, as we're rural with no landline broadband available)

I'm working on a Moto G Power (sofia XT2041-4), bought late last year off the shelf from Best Buy.

Home PC is a Windows 10 box. I do not have a linux environment available to me.

I am \ was trying to put LinageOS on it, but honestly don't care what OS it is as long as we can turn the hotspot on ourselves, regardless of what Verizon wants. Over a decade ago, I rooted our phones with ICS image, so I have some outdated experience here. CalyxOS looks nice but I don't think it'll work on Moto G Power.

So, here's where I'm at in the last 48 hours.
  • I have gone in and gotten the unlock key from motorola, and successfully undone the OEM Lock. (I know this is the case because it tells me I'm an idiot and I should lock it, every time it boots up now). This also managed to wipe the phone, which, oops, read to the end of the paragraph BEFORE unlocking and deleting pictures of the grandkids which came in since the last backup.
  • Somehow last night, I managed to get it to be a brick, but used LMSA to unbrick it, but that version is still the OTA updated Android 11, so same problem with the hotspot.
  • I have installed the Android SDK, newest motorola drivers, and also the standalone 'Minimal ADB and Fastboot' on my PC
  • I've managed to get TWRP installed in the recovery portion of the phone. (note: may have been wiped now, but I can get it back on I believe)
  • Following this video, I managed to bring TWRP up, wiped the device, then copied the Lineage OS image to the microSD card, as well as Open GApps. The only thing I couldn't get to work, other than, you know, the new OS, is I didn't see a place to enable advanced boot options, so I have to get back to the bootloader via Volume Down and Power from a full shutdown state.
  • When I try to install the LinageOS (17.1), it looks like it's installing, goes through steps 1 and 2, then a slew of error messages in the log.
  • I've got the 4 image files I pulled out of one of the LineageOS zip files (Boot, Product, System, VBMeta) in the 'Minimal ADB and Fastboot' directory.
  • I can run 'fastboot flash boot boot.img' from the 'Minimal ADB and Fastboot' directory and it succeeds.
  • When I try to run Product, System or VBMeta in the same way (cmdline = fastboot flash product product.img), all of them fail the Preflash Validation and it comes back with 'FAILED (remote failure)'
  • During this process, somehow I bricked my wife's phone AGAIN, but just got it reset with LMSA for the second time. So, I may have wiped out everything I've done previously on the phone, which may or may not be a good thing. But, I believe everything I've done up to this point is repeatable (which is somewhat why I wrote all of the above details out)
  • Edit: Progress is Made! - Ok, now that I've got FASTBOOTD figured out, I was able to flash the Boot, Product, System and VBMeta into active partition A. But when I use the command 'flashboot reboot' it just keeps coming back to the fastboot flashload screen with the green android with it's access panel open. I tried to get back into TWRP via entering 'Recovery Mode' at the loader, but apparently it got wiped. I'm guessing I should flash it back into the recovery slot ("fastboot flash recovery twrp-3.4.0-0-sofia-test9") and then maybe try to recover from Partition A via TWRP?
Things I'm not sure about
  • First, I'm pretty sure I'm not in FastbootD. I don't see a big red FASTBOOTD at the top, and according to this thread, means I'm not in it.
    • Update: Ok, I realized I didn't have the 'platform tools', which I have now downloaded, and once I was back in fastboot, I was able to run 'Flashboot reboot flashboot' and now I know I'm in FlashbootD. Not sure what I'm supposed to do in here at this point, but hey, I've now got the correct interface.
  • I think FASTBOOTD should be something I'm interacting with on the Moto G Power, but for the life of me, I can't figure out how to get to it.
    • Update on this, see above.
I feel like I've got to be CLOSE to getting this thing working, but damned if I can seem to cross the finish line.


Further Edit: So, I tried another OS, ResurrectionOS, just to see if it was an issue with the image.
  • Started with another reset with LMSA (I love that tool... It zeroes out all the stupid things I'm doing on the Moto G Power during this process)
  • Rebooted into FastBootD mode (with the nice red at the top)
  • Flashed all four of the images. No errors noted during the process
  • Wiped the Data
  • Rebooted... And right back to the bootloader. Cannot seem to get out of the boot loader to get the new OS to initialize.
  • Again, Help?
Last edited: