Maskrom Rk3399 (px6)

Search This thread

s.danyliak

Member
Jul 6, 2022
8
0
Hi all, a need help. After an unsuccessful update, I received a bootloop. There are no physical buttons on the device. Found instructions for recovery through ANDROID TOOL. I connected it to the computer in maskrom mode, but I can’t find the firmware that needs to be uploaded in order for the device to work. Share a dump that suits me or give instructions on how I can restore the device.
 

Attachments

  • 13022022_123133.Mi9T-R4.jpg
    13022022_123133.Mi9T-R4.jpg
    7.1 MB · Views: 45
Last edited:

s.danyliak

Member
Jul 6, 2022
8
0
Thanks for the answer, but all I found is different ota update.zip. And my device is loaded only in maskrom mode.
That's why I'm looking for a full recovery version.
 

Pavel-71

Senior Member
Jul 9, 2020
256
138
Hi, you have to use the IMG file that contains the recovery and then update normally via OTA. For example, the IMG is:
CHS2_RK3399_10.0_IMG(20200424)
HCT7_rk3399_10.0_IMG(20200415)
OLS_rk3399_10.0_IMG(20201012)
I recommend reading this thread, you will find answers to your questions here:
 
  • Like
Reactions: marchnz

s.danyliak

Member
Jul 6, 2022
8
0
I downloaded the firmware, I start to flash it and every time it breaks off by 50-60%. I used different firmware from the attached ones and different versions of AndroidTool. And different driver versions. Log attached.
 

Attachments

  • Log2022-07-07.txt
    6.2 KB · Views: 9

s.danyliak

Member
Jul 6, 2022
8
0
I did, first cleared, reboot and firmware. The result is the same :( I read a lot of documentation, they wrote that there may not be enough power, but the power supply is 5A.
 

s.danyliak

Member
Jul 6, 2022
8
0
I noticed that the device turns itself off after a couple of minutes of operation. Possible overheating! I will check it.
 

EdinM30

Senior Member
Feb 22, 2010
811
211
Louisville
I noticed that the device turns itself off after a couple of minutes of operation. Possible overheating! I will check it.
I had the same problem I bricked my headunit (rk3399 PX6 Android 10) trying to recover root after updating magisk to 25.1 went into maskrom mode but device lost connection to my PC and flash fails at different percentage.

Cause ended up being the adapter i was using to power the device I used 12v 2A adapter
After switching to 12v 10A adapter it finished flashing. BUT make sure the chip has cooling like a heatsink or it will overheat during flash.
 

s.danyliak

Member
Jul 6, 2022
8
0
I changed the power supply to 10A. Installed cooling. The result is the same. The device reboots even if nothing is done.
 

Attachments

  • Безымянный.png
    Безымянный.png
    13.2 KB · Views: 12
  • Безымянный1.png
    Безымянный1.png
    16 KB · Views: 12

s.danyliak

Member
Jul 6, 2022
8
0
I have tried two different cables. But I connect via usb which is from the device kit and also the usb a - usb a cable is possible in this problem. There are also only 4 contacts, and for otg you need 5. I did not find information on the board :( I attached the photo.
 

Attachments

  • photo_2022-07-09_07-08-54.jpg
    photo_2022-07-09_07-08-54.jpg
    218.1 KB · Views: 26
  • photo_2022-07-09_07-08-50.jpg
    photo_2022-07-09_07-08-50.jpg
    230.3 KB · Views: 28
  • photo_2022-07-09_07-08-48.jpg
    photo_2022-07-09_07-08-48.jpg
    229.2 KB · Views: 28

Top Liked Posts