• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Mate 20 Pro crashing randomly after update 9.1

Search This thread

Alextm24

Member
Mar 11, 2019
19
0
same problem here, after update to 9.1 random freeze and password request.

9.1.0.300
LYA-L29

I know it's so annoying because it can happen in the middle of a phone call, youtube video, watching movies or video phone calls. There's a user mentioning that the update 306 fixes everything, I will try to see and find what method exactly I have to do to get rid of this ****ty situation
 

Ironjer

Senior Member
May 29, 2009
134
3
I know it's so annoying because it can happen in the middle of a phone call, youtube video, watching movies or video phone calls. There's a user mentioning that the update 306 fixes everything, I will try to see and find what method exactly I have to do to get rid of this ****ty situation

i will wait for Huawei, i don't wanna upload the Firmware Unofficially
 

Alextm24

Member
Mar 11, 2019
19
0
i will wait for Huawei, i don't wanna upload the Firmware Unofficially

Me too because last time I did it manually on another mate 20 pro I couldn't get any ota updates

Then I got this phone and after 3 months I got the last update 2 weeks ago. And then this is happening.

So I don't wanna wait for too long and have a faulty phone but if I do it manually I don't know if will screw it up.

So the question is how long should we have to wait until huawei give us a solution???? I hate this situation
.
 

Ironjer

Senior Member
May 29, 2009
134
3
Me too because last time I did it manually on another mate 20 pro I couldn't get any ota updates

Then I got this phone and after 3 months I got the last update 2 weeks ago. And then this is happening.

So I don't wanna wait for too long and have a faulty phone but if I do it manually I don't know if will screw it up.

So the question is how long should we have to wait until huawei give us a solution???? I hate this situation
.

Nobody knows but, we need stick reporting this issues, the problem is real.
 

cygnus56

Senior Member
Apr 11, 2010
464
25
Oaxaca
I did this method but it installed the same version 300 not the 306 version. No messages of error



This is weird
We do not know exactly why only this happens to some devices, and it is not due to bad format, I did 12 full wipes and it was never solved until version 306, we do not know exactly the reason, but it is a fact that it is a problem, and the solution is this.

Enviado desde mi LYA-L09 mediante Tapatalk
 

Alextm24

Member
Mar 11, 2019
19
0
We do not know exactly why only this happens to some devices, and it is not due to bad format, I did 12 full wipes and it was never solved until version 306, we do not know exactly the reason, but it is a fact that it is a problem, and the solution is this.

Enviado desde mi LYA-L09 mediante Tapatalk

It really bothers not being able to use the phone

I'll keep trying to install the version 306 I followed every single step and it ended up installing the same version
 

ChongoDroid

Senior Member
Jul 29, 2010
6,228
2,916
Vancouver
Google Pixel 4
Google Pixel 4 XL
Then the only solution is to install the 9.1.0.306 or 9.1.0.310 by hstool

Enviado desde mi LYA-L09 mediante Tapatalk
Yeah I might try my hand at that, I could never get hstool to work for me. One thing to note that it hasn't locked up since it did it that one time last night.

300 would lock up every 20 minutes or so for me so this is a huge upgrade already. It seems to have smoother animations as well.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 3
    Bro can you tell me where you got that firmware version? And if that method formats the phone?
    This is the firmware https://drive.google.com/file/d/1-9JvnbdhF2-_yWCV5yPMCpamRADkK31U/view?usp=sharing

    Search the hstool metod in this forum

    Enviado desde mi LYA-L09 mediante Tapatalk
    1
    what apps have you specifically removed?

    almost all of these ( including the home launcher app ) :

    pm uninstall -k --user 0 com.google.android.videos

    pm uninstall -k --user 0 com.google.android.apps.photos

    pm uninstall -k --user 0 com.google.android.music

    pm uninstall -k --user 0 com.touchtype.swiftkey

    pm uninstall -k --user 0 com.swiftkey.swiftkeyconfigurator

    pm uninstall -k --user 0 com.huawei.search

    pm uninstall -k --user 0 com.huawei.hwid

    pm uninstall -k --user 0 com.huawei.omacp

    pm uninstall -k --user 0 com.huawei.KoBackup

    pm uninstall -k --user 0 com.huawei.health

    pm uninstall -k --user 0 com.hicloud.android.clone

    pm uninstall -k --user 0 com.android.hwmirror

    pm uninstall -k --user 0 com.microsoft.translator

    pm uninstall -k --user 0 com.huawei.android.tips

    pm uninstall -k --user 0 com.android.calculator2

    pm uninstall -k --user 0 com.android.email

    pm uninstall -k --user 0 com.example.android.notepad

    pm uninstall -k --user 0 com.huawei.livewallpaper.matetwenty

    pm uninstall -k --user 0 com.huawei.gameassistant

    pm uninstall -k --user 0 com.huawei.parentcontrol

    pm uninstall -k --user 0 com.facebook.services

    pm uninstall -k --user 0 com.facebook.system

    pm uninstall -k --user 0 com.google.android.apps.tachyon
    1
    is there a 9.1 download for the L09 that fixes rebooting? thanks
    Have you cleared cache in boot loader menu? It's help sometimes after ota to fix reboot problems
    1
    I have the normal Mate 20, upgraded via dload to 9.1.0.300 and since the upgrade I'm having this problem. Very boring business.
    My version is HMA-L29C605, can anyone help me?
    @cygnus56

    @ChongoDroid


    Apparently there's a few new methods for flashing files. For me 301 made it happen less often, and 316 has completely gotten rid of the issue.
    1
    How do I get these files and how do flashing to the device?

    Remembering I have Mate 20 (non-pro).

    I used Huawei firmware finder and hstool. I'm not sure since I don't have that device.