Mate 9 Pro - Android Oreo - EMUI 8 - notification issues

Search This thread

numzie

Member
May 8, 2017
11
0
After upgrading (non-root), I have several apps (Snapchat, Tidio, Shopify just to name some) where notifications don't work anymore.
I've been in contact with both Huawei and the app providers - but noone can solve the problem - accusing each other for causing the problem.

I've tried a bunch of thing including letting these apps override battery saver mode, launch them in background, never go hibernate etc - but nothing worked.

Does anyone have a solution to this?
 

CadillacMike

Senior Member
Apr 13, 2016
1,055
158
Louisville, KY
i was having problems with my regular Mate 9 and notifications.

i tried a bunch of stuff, probably messed some settings up. But I went to

Settings > Battery > Launch

and changed it to "Manage all automatically"

then clicked on "Manage batch manually"
and checked all 3 boxes for All

and I think that fixed it. However it might be overkill, and I'm not sure what impact it has had on my battery yet
 

numzie

Member
May 8, 2017
11
0
i was having problems with my regular Mate 9 and notifications.

i tried a bunch of stuff, probably messed some settings up. But I went to

Settings > Battery > Launch

and changed it to "Manage all automatically"

then clicked on "Manage batch manually"
and checked all 3 boxes for All

and I think that fixed it. However it might be overkill, and I'm not sure what impact it has had on my battery yet
Thanks for writing. I did try that together with the other tweaks in the first place, but it didn't have any impact.
 

numzie

Member
May 8, 2017
11
0
Well I am probably getting 90% of my notifications now, where as before I was getting like 10%.

So i am still trying to figure out what settings I need to adjust

Agree. I'm also down to around 10% now, I guess - mainly Shopify an Snapchat problems - but I hope they'll be sorted out with future updates.