McDonalds App

Search This thread

jkaart

Member
May 11, 2011
30
11
Install Island app from Google Play store!?
It uses built-in Android work profile.
Pokemon Go and McDonald's work with Island perfect.
 

GabWas

Member
Nov 10, 2018
5
2
it worked for me after i did that

1.erase phone data and back to original recovery.

2.Re flash TWRP recovery & magisk manager (don't install TWRP app)
don't install lucky patcher.

3.flash universal safetynet fix.zip using magisk or TWRP then reboot your device (i did using TWRP).

Optional.install EdXposed manager (you have to install Riru & EdXposed modules in magisk first).

4.open magisk manager and activate hide magisk from settings.

5.rename package name of magisk from settings in magisk manager to random name.

6.turn off developer options from phone settings (important)

7.install MacDonald's app (dont open it)

8.back to magisk manager then go to magisk hide and check for MacDonald's app to hide root from it.

open EdXposed manager and go for Xposed hide(black) and check for MacDonald's app.

that's it and it worked no root check failed
note: if the app shows an error in the future you have to uninstall any apps that Detects the presence of the root for other applications like lucky patcher ..etc & (some modded apps) also and turn off developer options then reboot your phone done.
Oh. My. God. For me it was as simple as turning the developer options off. It sounded so stupid, that I never really thought of doing that. Thank you so much!
 

maretodoric

Member
Mar 7, 2012
46
1
Following steps worked for me for McDonlad's version 2.20.1
- Remove the app
- Remove Lucky Patcher
- Hide he Magisk app (mask it as Settings)
- Enable MagiskHide
- Install the App (don't open it)
- Hide McDonalds from Magisk (There are 2 versions to hide when you check McDonalds, check them both)
- Run McDonalds app

Honestly, what i think it helped is removing Lucky Patcher, as I've tried all the above steps without removing lucky patcher, but when i did so in the above order, McDonalds started working.

I had the error "It appears like the application has been installed from unknown source, please install the application from Google play". Weird.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    yes.... just tried also magisk hide... but is always error

    I have just flashed fresh stock firmware on my XZ1 Compact and Magisk nothing else. Then in Magisk Manager app i clicked magisk hide so that it reinstalls with different name. Lastly i opened Magisk app again, tapped on the menu icon in the upper left corner, tapped settings and in the Magisk tab(orange text) i turned on "Magisk Hide". The McDonalds app works perfectly fine, Snapchat as well. Both of them are on their latest versions. Make sure you did all that otherwise try to reinstall stock firmware and install only Magisk apart from the apps that did not work.
    1
    How rename ? I use PixelExperience 10,

    Go in Magisk Manager's settings, you will see "Hide Magisk Manager" option. ;)
    And you should rename "TWRP" folder in root of your phone memory too ; It can be detected by some apps.
    :)
    1
    Go in Magisk Manager's settings, you will see "Hide Magisk Manager" option. ;)
    And you should rename "TWRP" folder in root of your phone memory too ; It can be detected by some apps.
    :)
    I delete the TWRP folder but is always seen rooted.
    1
    The magiskhide stuff works for my samsung s8 but not for my samsung s10 both running android 9 and passing safetynet which is really weird
    Can someone help me get it working on my samsung s10?
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone