General Medeke/Navifly 7862

Search This thread

dsa8310

Senior Member
Sep 21, 2014
2,013
1,015
For those who want to root their device is quick and easy. 1. Place the contents of this file on a FAT32-formatted flash drive
2. Insert the flash drive into the powered-on main unit and wait until it automatically restarts
3. After the green inscription with the timer appears, the flash drive can be pulled out
4. Wait for the main drive to load, manually install the Magisk apk file. apk
5. Completed
6. As a precaution, your original boot was copied to a flash drive named stock_boot.img. It is taking advantage of I am also sending the most current system file 08/20/22.


Root

Kernel
Has anyone checked out this method of installing Magisk, with success?
And, is the included firmware also good for M600 Mekede units?
(like this one, Color: TY70M600S)
Thanks.
 

Pino1966

Member
Aug 8, 2022
12
0
Look here (and translate to english). The second image is a series of three images. https://vk.com/@teyes_by_maga-vneshnii-mikrofon This is from @gordgelin

Below image comes from 4pda, but I can't find it back. It is not mine. I am sorry that I can't give the correct cred

Look here (and translate to english). The second image is a series of three images. https://vk.com/@teyes_by_maga-vneshnii-mikrofon This is from @gordgelin

Below image comes from 4pda, but I can't find it back. It is not mine. I am sorry that I can't give the correct credits here.



Screenshot_20220925_215616.jpg

Hello everyone, I have a question about the problem with the microphone in our HU if you installed it as an alternative
https://a.aliexpress.com/_mMhmJBK, would that be good or is it too complicated, what is your opinion, thanks in advance for your answer
 

surfer63

Senior Member
May 4, 2010
4,506
2,061
Zwolle
github.com
Hello everyone, I have a question about the problem with the microphone in our HU if you installed it as an alternative
https://a.aliexpress.com/_mMhmJBK, would that be good or is it too complicated, what is your opinion, thanks in advance for your answer

And additionally.
The builtin and external microphone are not very good, but that is not the issue.
These units are not using noise cancellation.
As soon as you drive faster, or simply have a noisy car, the signal to noise ratio becomes worse and worse. Even a very good microphone will not help in that case and might even be more susceptible as it is more sensitive.
In a parked car with contact on and motor off, quality is fine (or at least: good enough).
 
  • Like
Reactions: DexterMorganNL

Neogx

Senior Member
Jan 25, 2014
99
14
san
So i have a teyes head unit and don't really like the lockdown they have with their firmware. I was thinking of trying these since I saw they are like teyes without the locked firmware on my sister's 2012 Toyota Tacoma. Are these pretty good?
 

marchnz

Senior Member
Nov 26, 2012
5,134
1,095
NZ
So i have a teyes head unit and don't really like the lockdown they have with their firmware. I was thinking of trying these since I saw they are like teyes without the locked firmware on my sister's 2012 Toyota Tacoma. Are these pretty good?
Try installing non crap teyes firmware such as fyt = 1 you might need to first update fyt value per surfer63
 

rafaloqc

New member
May 2, 2013
1
0
Hi, I have the Mekede M700s model and I have doubts about the deep sleep function. How long should this option run? In the settings, there is only ON / OFF Sleep mode without the possibility of setting the time.
In my case, the function works about 1 minute after removing the key from the ignition. A longer time results in a cold start.
The Isudar and Sinosmart units can be set to deep sleep for 1, 3 or 7 days.
The CAN decoder is connected and works properly.

The second problem is that the loading of the camera application takes too long. From the moment of shifting into reverse it takes 3-4 seconds, and in my opinion it should take 1 second
 

Attachments

  • VID_20220917_095445.mp4
    47.5 MB · Views: 0

DexterMorganNL

Senior Member
Dec 1, 2010
952
152
Hi, I have the Mekede M700s model and I have doubts about the deep sleep function. How long should this option run? In the settings, there is only ON / OFF Sleep mode without the possibility of setting the time.
In my case, the function works about 1 minute after removing the key from the ignition. A longer time results in a cold start.
The Isudar and Sinosmart units can be set to deep sleep for 1, 3 or 7 days.
The CAN decoder is connected and works properly.

The second problem is that the loading of the camera application takes too long. From the moment of shifting into reverse it takes 3-4 seconds, and in my opinion it should take 1 second
Deep sleep should just work? If it doesn't, than perhaps it's an issue with your wiring. I have found out, that the unit will shut down after 3 or 4 days. Or at least it doesn't stay for a week in deep sleep.

There isn't any setting, where you can specify how long the unit should stay in deep sleep.

I think the delay in the reverse camera switching on is normal: because once you switch into reverse, your reverse light goes on and that triggers the reverse camera to go on as well.

It's unavoidable that there is a delay: it's even worse when your engine isn't running yet, and you start it and directly start driving backwards. If deep sleep is working, than it shouldn't take long for the reverse camera to show the image. But if you get a cold boot, than it will take more than 20 seconds for your reverse camera to show it image.

Somehow the reverse camera only works, when the unit is fully booted. I though before it was also suppose to work, while the unit is still booting. But in my case it doesn't work like that....

Personally I don't care to much for these delays, before I had the reverse camera I was also capable of reversing. Just in some situations it's annoying.
 

Gscipione

Member
Jun 30, 2022
47
14
44
Serbia
Hi, I have the Mekede M700s model and I have doubts about the deep sleep function. How long should this option run? In the settings, there is only ON / OFF Sleep mode without the possibility of setting the time.
In my case, the function works about 1 minute after removing the key from the ignition. A longer time results in a cold start.
The Isudar and Sinosmart units can be set to deep sleep for 1, 3 or 7 days.
The CAN decoder is connected and works properly.

The second problem is that the loading of the camera application takes too long. From the moment of shifting into reverse it takes 3-4 seconds, and in my opinion it should take 1 second
I have the same hu and my camera works immediately when i put the reverse. Maybe there are same settings that you must do on the hu. For the deep sleep it is an option that Mekede took off from there hu same month ago but if your wire are correctly installed you will have no problem with the car battery. Why Mekede took away this option I don't now.
 

dsa8310

Senior Member
Sep 21, 2014
2,013
1,015
You can do the procedure without fear friend.
I have done the procedure as soon as I got the M600 unit, but it failed. Fortunately, the stock boot image was copied to the USB drive (as described in the readme file), so I used the latest Magisk app (25200) to patch it. Then, since the procedure is shell scripted, I modified it to skip entirely the patching process (which was failing) and made it use the Magisk patched file for flashing instead. The file should be named magisk_patched.img and put in the root of the USB disk, too, while the new patched procedure is this one:

Universal_ROOT_7862_9863_8141_9853_new++.zip

If file magisk_patched.img is not present on the USB drive then the procedure remains unchanged.
 

dsa8310

Senior Member
Sep 21, 2014
2,013
1,015
Just a few comments about the new Mekede M600 unit I have bought recently.
Hardware wise, I had to defeat a few issues so far: the fan was not working (even with AMP on), so I replaced it with a Noctua 40x40x20mm fan, much nicer (btw, the built in fan is 40x40x10); then the SIM slot attached to the RCA connector, actually the second slot, was not working either (the error was - slot empty, although I had a proper card inserted and secured), so I had to use the first SIM slot on the unit's board - that one worked very well; finally, rather funny, but my Blu-ray Qled display (purchased together with the unit, in place of the regular one) becomes invisible as soon as I use my polarized driving glasses... I think the display is polarized along its length, but was mounted horizontally (its natural position should be vertical, as text is displayed, for instance, during firmware upgrades). I might be out of luck here; furthermore, it's a real fingerprints magnet, terrible.

Software wise, I have only one issue left, I need a service (or, with Magisk, an xposed module) capable of converting intents, generated (probably by a native MCU app) when the next/prev buttons are pressed on the steering wheel controls, to the required next/previous intents for my Poweramp app (or any other music playing app). I don't use a CAN bus adapter (except for my JBL external amplifier), so Petrows' old mtcservice app might come in handy - for adjustment on these new units, especially since it's available in source. But If anyone knows of an existing solution, please let me know! Thanks.
 

surfer63

Senior Member
May 4, 2010
4,506
2,061
Zwolle
github.com
Software wise, I have only one issue left, I need a service (or, with Magisk, an xposed module) capable of converting intents, generated (probably by a native MCU app) when the next/prev buttons are pressed on the steering wheel controls, to the required next/previous intents for my Poweramp app (or any other music playing app). I don't use a CAN bus adapter (except for my JBL external amplifier), so Petrows' old mtcservice app might come in handy - for adjustment on these new units, especially since it's available in source. But If anyone knows of an existing solution, please let me know! Thanks.
Did you check the settings?
The Settings have the option to reverse prev/next and/or vol+/vol-.
No need at all for xposed or Magisk.
 
  • Like
Reactions: Specy01

dsa8310

Senior Member
Sep 21, 2014
2,013
1,015
Did you check the settings?
The Settings have the option to reverse prev/next and/or vol+/vol-.
No need at all for xposed or Magisk.
I don't understand what they mean. Right now, vol+ and vol- work well, as well as the mode button. When I press prev/next, I get a beep (set by me somewhere in the settings, for all keys), but Poweramp does not do anything. However, the Radio app, which should be native, can read next/prev - it steps through the available frequencies.
But I will give it a try, thanks.
 

dsa8310

Senior Member
Sep 21, 2014
2,013
1,015
Did you check the settings?
The Settings have the option to reverse prev/next and/or vol+/vol-.
No need at all for xposed or Magisk.
My mistake, I have associated the next and previous buttons to the wrong operations, just small forward/backward steps instead of track changing (and Poweramp seems to ignore them).
Yes, indeed, everything works out of the box nowadays...
 

dsa8310

Senior Member
Sep 21, 2014
2,013
1,015
By the way, the external SIM slot could easily be fixed, I had a disconnected wire, now it's soldered, and the slot, made out of two plastic covers, snaps safely into place, no destruction involved.
 

Nicoss30

New member
Oct 15, 2022
3
0
Hi all,

I'm here because I want to totally update my Navifly M700S I've installed in my car. I would like to update the Android and the core firmware.
i don't really know how to do it, I have download the 7862-A11-wbt-9-10.zip on Mekede website, put it on an USB drive, but the unit doesn't launch any update :(

Thank you
 

daviddosa

Senior Member
Sep 21, 2015
302
181
Livingston
OnePlus 3
OnePlus 5
Hi all,

I'm here because I want to totally update my Navifly M700S I've installed in my car. I would like to update the Android and the core firmware.
i don't really know how to do it, I have download the 7862-A11-wbt-9-10.zip on Mekede website, put it on an USB drive, but the unit doesn't launch any update :(

Thank you
First, you need to unzip the package. It shouldn't be a .zip file and it shouldn't be in any folder. The contents of that zip should be directly on the USB drive. In my case with an M300S it's the following:
  • lsec_updatesh
  • 6315_1.zip
  • AllAppUpdate.bin
  • config.txt
  • lsec6315update
  • lsec6316update
  • updatecfg.txt
The USB drive also have to be formatted to FAT32. You can do this easily. Open "My Computer", right click on the drive, select Format and make sure to choose FAT32 as the filesystem. You can leave Quick Formatting on, and the name doesn't matter. After it's done (few seconds), copy all your files you just extracted and you're good to go. The headunit should detect the update file on the drive and start counting back from 5 seconds before it reboots. Some of your data on the headunit might get reset or deleted when updating.
 

Nicoss30

New member
Oct 15, 2022
3
0
First, you need to unzip the package. It shouldn't be a .zip file and it shouldn't be in any folder. The contents of that zip should be directly on the USB drive. In my case with an M300S it's the following:
  • lsec_updatesh
  • 6315_1.zip
  • AllAppUpdate.bin
  • config.txt
  • lsec6315update
  • lsec6316update
  • updatecfg.txt
The USB drive also have to be formatted to FAT32. You can do this easily. Open "My Computer", right click on the drive, select Format and make sure to choose FAT32 as the filesystem. You can leave Quick Formatting on, and the name doesn't matter. After it's done (few seconds), copy all your files you just extracted and you're good to go. The headunit should detect the update file on the drive and start counting back from 5 seconds before it reboots. Some of your data on the headunit might get reset or deleted when updating.

Thank you for your answer. Here is what I got on my USB
1665834680296.png
 

Nicoss30

New member
Oct 15, 2022
3
0
Thank you ! It works ! Is this update MCU and CAN ? What is the difference ? Looks like by reading every forum, there is Android 11, then MCU and CAN, or Android is part of MCU ?
 

Top Liked Posts

  • There are no posts matching your filters.
  • 3
    Thank you for your very helpful info. You could have send me the link via pm as you have done it before. I wish you a lucky and peaceful life. bye
    Woohoo. You want special service? :) Short toes I assume.
    check your PM ;)
    2
    So i checked, with my previous radio it was really needed to change the pin to 1234 in the settings.. Because there was no popup asking for the pin..

    Now i tried to connect with this radio and i get a popup for the pin. So i tried 0000 and error.. Tried 1234 and again error. Disabled bluetooth on my phone so there is no active bluetooth connection. Tried to pair again and worked with code 1234. Installed torque and all works fine. See the screenshots.

    So maybe before buying a new one you can try to change the pin in the settings to the correct one that is needed for the dongle you have. (mine is really 1234 i checked with my phone) make sure there is no active connection to other device (your phone) and try to pair after a new scan.

    Edit: Also check on your phone what the mac is when you are connected to the OBD dongle. If the mac is the same, then you know it should just work fine. If you see a different mac there then order a new dongle.
    More info: https://incardoc.com/en-us/thread/Attention-Bad-Bluetooth-adapters-/
    2
    I know Surfers post was from a long time ago but I look to have the same issues.

    Currently my M700s is not in the car but powered from a battery and being used inside. The wifi on 2.4Ghz lists all of the house Wifi 2.4Ghtz transmitters but none of the 5ghz. For it to use the phone Hotspot the phone has to be within 2 or 4 ft of the unit and even though the phone is dual 2.4/5Ghz it only connects on 2.4Ghz.

    I turned on the M700S's own Hotspot set to 5Ghz and it shows up and the phone connects so it can transmit 5Ghz but does not seem to be able to receive 5Ghz or maybe it could if I set it right next to a router.

    I thought it might help by fitting the 4G antenna but once fitted the results are the same. As I plan on using Bluetooth for Torque Pro it would be best if I could force 5Ghz Wifi but if it does not work that is scuppered and I will have to go for USB.

    The black rubber coated 5Ghx antenna looks to be directly soldered to the board, maybe it could be replaced with an SMA type socket for a full 5G antenna to be screwed onto it like the 4G and the GPS.

    See at 7.20 on this


    That's not showing, search for '

    EKIY T7 Tech Deep Dive & Tech Teardown / Overview for 200 Series Toyota Land Cruiser' on You Tube and go to 7.20.


    Is there any hidden settings, I fixed my 5G on my Draytek router by changing the channels it transmits on and no more drops of service.

    Update: I took a phone that can create hotspots on only 2.4Ghz or 5Ghz and set it to 5Ghz and put it under the unit next to the antenna and then did a wifi search on the Unit and the phone never appeared in the list. Odd when you can set the unit to create its own 5Ghz hotspot that works.
    Well finally got some 5Ghz routers to show but still not the phone, I am now thinking the 7862 units Wifi has a restricted sets of bands especially on 5Ghtz.

    I installed the Android Shortcuts Settings app from


    and went into engineering menu and played around.

    If this page is correct then 5Ghz is restricted to 6 channels 42, 58, 106, 122, 138 and 155. I went in and changed each band's bandwidth from 20mhz to 80mhz and then the routers appeared. I think expanding the bandwidth increases the channels as each 20mhz is one channel.

    Channels.jpg
    1
    I will try to update firmware of my Navifly 7862 unit (ro.build.fytmanufacturer=1) , I looked on Mekede repository but found two options:

    7862/9" 10"

    7862-9"-10"-360

    Wich is the right to download? Thanks to all.
    If you don't have a 360 camera setup, choose the first.
    Of you do havehav e a 360 camera setup, choose the second.
    1
    Update:

    Thank you @leo06 @kommando @Tweak-NL for your suggestions, but I couldn't get the M700S to recognize my OBD2 dongle despite their suggestions.

    I bought on Amazon the OBD2 dongle suggested by @Gscipione, it's arrived yesterday afternoon. As soon as it was inserted into the appropriate space, the M700S immediately recognized it, so also obviously the Torque app.
    I was a bit disappointed, because I was hoping that the "car info" app, that is the app that appears when you install and set the right canbus, would show me additional/complementary info but it is not so. But it does nothing, so much it cost little (10.75 €), although nowadays even that sum is relevant 🙄. Anyway thanks @Gscipione.

    @mastrv Your advice not to buy a new OBD2 was not heard because I was hoping to have more info from the "car info" app, thanks anyway
    The car info has nothing to do with obd, it’s only CanBus related
  • 6
    The link is in Russian!?
    welcome to the internet
    5
    Looks like the fan power.
    To tell the truth, that is what i supposed and connected it to the only fitting connector on when of the wire harnesses coming out of the device, BUT my fan never turns on, sooooo maybe im wrong.
    As well as connecting the fan to the harness you also have to switch it on in the UI. In Settings go to Device/Sound/Amp OnOff set to On to have the fan on. Looks like there isn't proper integration for the fan so they just use the switchable amp power output to drive the fan.
    5
    Very clear, many thanks.
    Only one more question, navifly models seems doen't have cooling fan in the back. Is it suggested to have it or not?
    It is definitely suggested especially if you live in (sub-)tropical areas. The fan is really quite and keeps the temperature about 20 degrees lower (in my case).

    And with regard to "UI looks different": I just created a modded firmware based on the latest Mekede in combination with the latest core/kernel I could find, that contains all 11 launchers that are available for the several FYTs around. I currently use Nova Launcher. My current Mekede firmware (build date 18 September 2021) contains 3 launchers: 2 of them look very nice, but that is only eye candy. Real functionality is not so great. I will simply test all 11 and might get back to Nova again. I will also test if my modded firmware is "sharable". I know simply how to overcome issues, so I want to test first.

    I also use something else than the "twipe_all" or "twipe_data", that removes everything (all) or all data including your 3rd party installed apps including their settings. And only because FYT still doesn't have a good update protocol for their own apps after 6+ years.
    My "post upgrade" action is only removing all FYT related data/cache/profiles.
    But first test if that really works ;)
    4
    Excuse me for the little OT. By connecting a smartphone to the Navifly/Mekede with Bluetooth and sharing the address book with it, does it remain in memory with the device? That is, let me explain better, if another smartphone is connected will it have access to the address book of the first smartphone?
    Hello there. I've already test it. Me and my girlfriend usually travel together so I have to choose between her phone and mine (FYT unit only connects to 1 phone at a time). So she's connected and all her contacts appear (and I store it) and as soon as I connect my phone the list is swapped and I cannot see her list anymore.
    It's a good thing. And other fact is that the unit first pairing is always to the last paired phone during switch off (assuming that that phone bluetooth is enabled).
    3
    I finally received my Mekede uis7862 unit for my Octavia 2015, but it doesn't fit correctly. It needs to be pushed in and "click" tight. That is the system VW/Skoda/Seat/Audi use after 2013. That doesn't work and therefore it can easily fall out of the dashboard.
    I did a test drive this afternoon and as such the unit functions fine, but the fact that it is completely loose and can fall out of the dash is an extreme annoyance after having waited so long.

    EDIT: And the 5GHz WiFi reception is a big deception. I have to park my car almost inside my nearest WiFi Mesh AP, while I have a perfect MESH WiFi network.