• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Mediatek fastboot

Search This thread

certomaz

Senior Member
May 23, 2007
69
10
Sofia
Hi, i have a problem connecting 2 phones with MTK Helio P95 and Dimensity 800 in fastboot.

One phone is F150 R2022 (oukitel i guess) and the other is Ulefone Armor 11T.

I am connecting them in adb, debloating, no problem.

But if i put them in fastboot with adb reboot bootloader command or from the phone itself with the key, they go in fastboot, but then they don't show with "fastboot devices" command.

For example my other phones, oneplus, samsung, etc have no problems and they show up in fastboot.

But those 2 phones with MTK chipsets does not.

I tried maybe everything:
Different cables
Different usb ports
Different computers (only windows 10)
Installed and uninstalled drivers - google fastboot drivers, mtk drivers a lot of different versions and places a downloaded them.
Tried to install drivers in windows no signed drivers mode.
Tried to manually add hardware and choose mtk drivers. What not... Maybe i miss something....

Even when the phones show up in device manager and does not have yellow triangle, they don't show up in fastboot devices.

WTF is going on, other people here and in other forums have no problems with mtk phones, but i tried everything i can think of and no luck.

Can someone help, please?
 

SubwayChamp

Senior Member
Aug 6, 2016
3,410
3
1,445
Hi, i have a problem connecting 2 phones with MTK Helio P95 and Dimensity 800 in fastboot.

One phone is F150 R2022 (oukitel i guess) and the other is Ulefone Armor 11T.

I am connecting them in adb, debloating, no problem.

But if i put them in fastboot with adb reboot bootloader command or from the phone itself with the key, they go in fastboot, but then they don't show with "fastboot devices" command.

For example my other phones, oneplus, samsung, etc have no problems and they show up in fastboot.

But those 2 phones with MTK chipsets does not.

I tried maybe everything:
Different cables
Different usb ports
Different computers (only windows 10)
Installed and uninstalled drivers - google fastboot drivers, mtk drivers a lot of different versions and places a downloaded them.
Tried to install drivers in windows no signed drivers mode.
Tried to manually add hardware and choose mtk drivers. What not... Maybe i miss something....

Even when the phones show up in device manager and does not have yellow triangle, they don't show up in fastboot devices.

WTF is going on, other people here and in other forums have no problems with mtk phones, but i tried everything i can think of and no luck.

Can someone help, please?
You said that you installed a lot of drivers, this is exactly how it shouldn´t work. Uninstalled all the drivers, at least those that are for MediaTek and reinstall only what you need. Probably you only need this https://www.thecustomdroid.com/google-android-usb-drivers/ and this https://www.droidwin.com/download-install-mediatek-bootloader-drivers-for-fastboot-connection/
 

certomaz

Senior Member
May 23, 2007
69
10
Sofia
Thanks, tried the MTK driver. No luck. Tried the google driver, no luck.

God knows what is happening..
 

certomaz

Senior Member
May 23, 2007
69
10
Sofia
Weird, did you try enabling USB debugging and then waiting for the connection to the device from being allowed? Try this https://adb.clockworkmod.com/

Hi, i have no problem to connect it to adb, debugging is on and i debloated the phones successfully, the only problem is that when i put them in fastboot (either from adb or from the phone with the power + vol. up) they does not show when i type "fastboot devices".
 

SubwayChamp

Senior Member
Aug 6, 2016
3,410
3
1,445
Hi, i have no problem to connect it to adb, debugging is on and i debloated the phones successfully, the only problem is that when i put them in fastboot (either from adb or from the phone with the power + vol. up) they does not show when i type "fastboot devices".
Ok, and try firstly sending device from ADB (device on) adb reboot bootloader
 

SubwayChamp

Senior Member
Aug 6, 2016
3,410
3
1,445
Yes, i am doing that, no problem. The problem is in fastboot. In adb no problems.
I know, you said that, but starting from this process it could bypass some restriction that could come from your device. One thing I have clear, you have to start from scratch, the unnecessary drivers one over other overwriting it is not a good thing.