• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

"Message not sent" error :(

Search This thread

arathur

Senior Member
Hey everyone. I'm having a big problem w/ my 16GB GSM Galaxy Nexus running bigxie's rooted, deodexed 4.1 rom, and I'm hoping you guys can help me.

Whenever I send a message, I get a "Message not sent" error in the notifications bar, and a red triangle w/ an exclamation point appears under the text of the text message. I have T-Mobile and I have FULL signal bars. I can make calls and this texting issue is the only problem I'm having. I installed this rom a few days ago and this problem just suddenly started today. When I send a text with the "Messaging" app, the area code (I live in the US) of the phone number disappears. So if the number in my phonebook is stored as:

"1 (areacode) sevendigit-phonenumber"

It instead shows up like this after I select the contact:

"1 sevendigit-phonenumber"

If I try and send a text by selecting the contact from the "People" app, it works just fine.

Last night I flashed the Popcorn kernel, but I then I also sent a text and it worked. I thought maybe somehow this might have something to do w/ the kernel or a rom (both unlikely), so just in case I re-flashed the STOCK 4.1 this time (the first rom, the one that appeared on ROM Manager the day of the Google I/O). Now I'm back to stock Jelly Bean everything (including kernel, and also the Jelly Bean baseband) but I'm still getting the problem. I tried clearing the "Messaging" app's data and cache, but nothing fixes the problem. I have a strong feeling that the cause of the error is because the "Messaging" app removes the area code from in front of the phone number, but now I can't remember if that's normal (did that happen in ICS?, did it happen before in JB?, I don't remember).

Has anyone else encountered such an error? Please help me.
 

arathur

Senior Member
I think I may have fixed the problem for myself. It seems like in both the stock JB and also bigxie's rom, the "Messaging" app is doing some sort of mishandling of the phone numbers. Try changing one or some of your phone numbers in your contact list to this format: "(307) 456-7895" <-- parenthesis around the area code, then a space after the parenthesis, then the seven digit number with a dash (-) after the third. Try changing this format on Google Contacts, not on your phone. Then sync the contacts on your phone.

Try this with just one contact that wasn't previously working and please let me know what happens.
 

NineONine

Member
Apr 29, 2010
25
1
I'm having the same problems with the same rom and tried the same steps to fix it but it didn't work for me. Also tried going back to cm9, no luck.
 

[email protected]

Senior Member
Apr 25, 2011
76
5
Search for the setting for something like ##info#* or whatever. I blew mine out when I flashed a new rom (not the roms fault i did it not knowing better). Don't have time now to look but there are important settings for sending sms.

Jeff
 

NineONine

Member
Apr 29, 2010
25
1
Search for the setting for something like ##info#* or whatever. I blew mine out when I flashed a new rom (not the roms fault i did it not knowing better). Don't have time now to look but there are important settings for sending sms.

Jeff

Thanks I figured it out. I had a hard time finding this info so ill re post it here for any one who needs it. It solved all my problems.

http://rootzwiki.com/topic/14916-howto-sms-centre-numbers-if-your-gnex-wont-send-messages/

Hi

This damned *#*#4636#*#* menu!!!

I know, I shouldn't be messing with what I don't know but I moved from an iphone so that I could 'fiddle' with a phone hence the GNex.

Anyhow. I have been having serious issues in sorting this out until I pieced the information together in this post. None of this I can take credit for - as it is built on others work - I just put it together in one easily accessible place.

The problem is that this menu somehow wipes the SIM card's record of the SMSC number.

You can't just enter the SMS Centre number as it is, you have to convert it into something called PDU format (no idea what this is)

I have converted a number of UK SMS Centre numbers into the correct format below.

Method:
1. Go to phone dialpad.
2. Enter *#*#4636#*#*
3. Scroll down to the bit that says SMSC
4. Type your sixteen digit number in from the table below.
5. Press Update
6. Press Refresh
7. Press Back button to exit the app.
8. Test by sending an SMS

Hope that helps. The GNex doesn't give an option which is easily accessible from anywhere to change the SMSC number, downright silly as my 10 year old Nokia would let me do that.

PDU Decoder
http://www.twit88.com/home/utility/sms-pdu-encode-decode
 

hp13

Senior Member
Feb 17, 2011
1,141
222
Toronto
i tried these steps but no luck.. its simply the format of phone numbers.
this format is no good: +1 (123)-456-7891
this format is good: +1 123-456-7891

another solution is just to manually update each contacts.. i wish there was an app that does it automatically :D
 

tarekh020

Senior Member
Oct 1, 2009
838
183
Alexandria
I had the same problem , Can't send but can recieve sms ,
the problem presents since updating to jb 4.2.2 ,but it was working in 4.1.2
I tried the smsc solution but no luck at all ,
I think it's not a carrier problem cause i can send from Moto Defy "CM7.2 " ,but no luck with JB

Plz help
 

hellandj

New member
Jun 18, 2013
1
2
Another Fix

Tried all the fixes I could find with no luck. Then found out that I had enabled Google Voice+ to send SMS messages through Google Voice. After I disabled this everything went back to normal.

Just another thing to try that worked for me.
 
Jan 11, 2012
23
1
I know this is somewhat old but wanted to say for me, that the messages were being sent but there was one stuck in the queue. I followed the directions of installing handcent and found the empty text sitting in the queue... like a draft message. Once removed the message went away. I uninstalled handcent and all is good. It sucks that the stock JB 4.2 messaging app doesn't have a outbox and draft box to find stuff like this. Thanks for the help!
 

chellexor

New member
Feb 21, 2013
3
0
Tried all the fixes I could find with no luck. Then found out that I had enabled Google Voice+ to send SMS messages through Google Voice. After I disabled this everything went back to normal.

Just another thing to try that worked for me.

THIS all the way!! I was trying everything to get my sms to work but it ended up being google voice+
Thanks for the reminder :)
 

Top Liked Posts

  • There are no posts matching your filters.
  • 3
    install handcent sms app...go to undelivered SMS in menu...delete in any undelivered sms is there...it worked for me...


    u can uninstall Handcent post that
    2
    Another Fix

    Tried all the fixes I could find with no luck. Then found out that I had enabled Google Voice+ to send SMS messages through Google Voice. After I disabled this everything went back to normal.

    Just another thing to try that worked for me.