• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Mi A2 - Problems with storage / downloads / Apps

Search This thread

hackwerk

Senior Member
Jan 7, 2010
426
106
Amsterdam
I have a brand new Mi A2, which I updated to Android 9, I unlocked the bootloader, and installed Magisk.
I let Google take all my Apps and settings from backup (from an old phone; RedMi 3).

All looks fine but loads of problems with (I guess) storage!?
I cannot download anything, I cannot make a new folder, I cannot use the camera (!) because it says it needs an SD (which A2 doesnt support!), I cannot install a lot of Apps (some do, some dont, with error 190), I cannot open/download pics in WhatsApp, WhatsApp cannot recover the chat backups etc. etc. etc.

Seems almost nothing can write to my device!?

Tried all the Play Store stuff (clear data of Play Store, Play Services, Framework etc., and removed my account and re-added).
Also tried putting all security settings on allow to use storage etc.

I did all settings etc so please dont tell me to do a factory reset :(
Is it because of settings it copied from my old device!? So I cant?!

UPDATE 1: Tried everything I guess, and I went crazy. Now did a factory reset and did NOT restore all apps from cloud (backup from old phone) but only the settings. Fixed. Strange and annoying (to manually install all apps now etc)!
 
Last edited: