Mi unlock tool getting the "Please rebind and try again error.". Did somebody encounter this error?

Search This thread

5aruman

Member
Apr 10, 2019
7
2
Xiaomi Mi Mix 3 5g
I want to unlock the bootloader on my Mi Mix 3 5G, but I'm not able to... getting really frustrated with this.

I've done all the steps required prior to unlocking the Bootloader:

  1. Enabled OEM Unlocking
  2. Enabled USB Debugging
  3. Added my Mi Account successfully in the Mi Unlock status setting
  4. Downloaded the Mi Unlock tool and updated to the latest version + updated USB drivers
  5. I logged in with the same Mi account on my PC
  6. Plugged my phone into an USB 2.0 port
  7. Entered Fastboot on my phone
Here's a screenshot with the error:
Here's the log for the error:

Code:
DEBUG  <12:43:16.016,T:20112> : User click unlock button!

    DEBUG  <12:43:27.040,T:19924> : -s *** oem device-info

    DEBUG  <12:43:27.097,T:19924> : (bootloader) Verity mode: true

    (bootloader) Device unlocked: false

    (bootloader) Device critical unlocked: false

    (bootloader) Charger screen enabled: false

    OKAY [  0.006s]

    Finished. Total time: 0.006s

    DEBUG  <12:43:32.045,T:19924> : VerifyDeviceInfo

    INFO   <12:43:32.045,T:19924> : product:andromeda

    DEBUG  <12:43:32.045,T:19924> :  getvar tokenversion -s ***

    DEBUG  <12:43:32.097,T:19924> : getvar:tokenversion                                FAILED (remote: 'GetVar Variable Not found')

    Finished. Total time: 0.004s

    INFO   <12:43:32.097,T:19924> : getvar:tokenversion                                FAILED (remote: 'GetVar Variable Not found')

    Finished. Total time: 0.004s

    INFO   <12:43:32.097,T:19924> : tokenversion=0

    DEBUG  <12:43:32.141,T:19924> : FAILED (remote: 'unknown command')

    fastboot: error: Command failed

    INFO   <12:43:32.141,T:19924> : FAILED (remote: 'unknown command')

    fastboot: error: Command failed

    Finished. Total time: 0.003s

    DEBUG  <12:43:32.186,T:19924> : to sign token with key for device:andromeda

    DEBUG  <12:43:34.791,T:19924> : sign result:{

       "code" : 20056,

       "descCN" : "请重新绑定后再次尝试解锁",

       "descEN" : "Please rebind and try again.",

       "description" : "请重新绑定后再次尝试解锁"

    }

  

    DEBUG  <12:43:34.791,T:19924> : unlock return:11111 msg:please rebind and try again.

I want to flash a new ROM on my device, but I'm getting pretty annoyed right now.

Thanks for the help in advance!
 
Last edited:

iamstillhuman

New member
May 13, 2022
2
0
I would like to confirm the problem. In addition to the steps described above I also enabled the "find lost device" functionality and updated the device location via Xiaomi cloud before trying to unlock.

I am trying to unlock a POCO X3 Pro using Mi unlock tool version 6.5.406.31.

Unlock procedure stage one worked. I was told to wait for another 16 hours. After that time period I only get the aforementioned error message.
 

DeadRabbit62

Member
May 25, 2017
28
2
Xiaomi Mi 8
Having the exact same problem. I think the problem is, that mi binds the device wrongly to your account. When I check my Mi Account online and look under "Manage devices", it shows the phone, but without the real model
and name.
Screenshot 2022-05-13 142630.png
 

N_E_A_L

New member
May 13, 2022
1
2
Having the same problem tried rebinding the account didn't work I think it's a new problem on xiaomi's end tried new versions of unlock tool and old versions. All didn't work and I've unlocked xiaomi phones without a problem in the past.
 
Same here on my Poco X3 Pro 8/256, tried both the official Xiaomi Unlock Tool and the XiaoMiTool V2, installed drivers again, rebooted and my device doesnt get recognized at first but after the doing the MiAssistent step in XMT2 it does get the device data
It does show my device name and model correctly tho
 

Attachments

  • 20220513_154808.jpg
    20220513_154808.jpg
    1.2 MB · Views: 210
  • 20220513_155040.jpg
    20220513_155040.jpg
    6 MB · Views: 189
  • 20220513_155425.jpg
    20220513_155425.jpg
    78.8 KB · Views: 195
  • 20220513_155609.jpg
    20220513_155609.jpg
    1.4 MB · Views: 184

damjan778899

Member
May 13, 2022
11
7
Same problem with Mi 10T.

Waited patiently 168 hours to unlock it, just to get this error. Frustrated. Anyone solved it?
 

the developer

Member
Oct 26, 2014
10
5
same happening to me my model and product no is correct but having same problem.
xiaomi 11i 5g PISSARRO 12.5.6.0 RKTINFK
 

MoonBoomLT

New member
May 13, 2022
4
3
Same problem with Mi 10T.

Waited patiently 168 hours to unlock it, just to get this error. Frustrated. Anyone solved it?
As mentioned above it's probably a server issue, best way to solve it now is just to wait it out.

EDIT: If I'm incorrect and someone actually found a solution feel free to add it to the forum.
 

damjan778899

Member
May 13, 2022
11
7
I googled this error. This thread shows up as the first result. Without OP posting about this today I wouldn't post here. I created my account just to confirm this problem.

I'm saying we might be the outliers that have this specific problem. Perhaps many people can unlock and will not post here about their success.
 
  • Like
Reactions: MoonBoomLT

Top Liked Posts

  • There are no posts matching your filters.
  • 5
    After many tries with modified unlockers, VPN and so on I was finally able to unlock my mi 9t pro with a german number&sim. I created a new US Mi-Account and added my phone there. Then I was able to unlock it with the current unlock tool. No VPN, no modifications, no waiting for days.
    5
    means they're working on it
    i hope so. they emailed me this

    'Thank you so much for notifying us about the issue. Regarding to your issue, we already sent this to our relevant team to get a resolution. Once we have an update we will contact you immediately.'
    5
    Given the number of various bugs on mi.com and Xiaomi ecosystem, espacially on auth system, I would advise to wait for a reaction on Xiaomi behalf before convincing ourselves of a voluntary change in policy, preventing EU users of unlocking bootloader.

    It's been a week, it's frustrating, but as of now, it's pure speculation (and fear) to suspect a deliberate move.

    Let's keep checking, trying, and most important, reporting+++ on mi.com.

    An article from @xda would help, as we - as simple users - have no way of questioning Xiaomi directly.
    5
    redmi note 9 pro global unlocked successfully after 168h with US account
    Capture.PNG
    about:blank
    5
    Can we spam Xiaomi through its rrss or some support chat? If we use a similar speech we may attract attention. It would be helpful if the media talked about this problem.

    Thanks to those who tried some solutions. Do we confirm that it happens from Europe only? I am from Spain. Yesterday I got tired of trying.