Mini M8S TV Box Review - Amlogic S905, 2GB Ram, Android 5.1

Search This thread

multiturk

Member
Jul 7, 2005
38
13
Izmir
Hi, I m looking for the firmware in Android 6…
I cannot find it….
It is offered the article : Superview (R) Mini M8S Pro T95N Google Android 6.0 TV Box 2GB 8GB 4K Amlogic S905 Quad Core with WiFi HDMI DLNA…

This has got Android 6. May be someone find the firmware of this article and give me the link….

Thanks in advance and best wishes from my side....
 

Mrkijo

Senior Member
Apr 15, 2011
96
12
Bijeljina
My Mini M8s II just stooped working this morning after two moths of use. I have not done any change on softer side was using is as it was. I found out this morning just a black screen with blue led at front, restarted it and the box was suck at goole TV logo even after second reboot. I have tied to rested device by holding pin at the bottom while inserting power plug. That resulted in black screen again and no more blue led in front. Therefore i decided to attempt flashing factory firmware with USB Burning tool. Got device to connect with PC but had two failed attempt flashing device at 7%.

Any suggestion?
 

Attachments

  • 2017.04.25-13.txt
    7.6 KB · Views: 56
Last edited:

guardian_uk

Senior Member
Apr 16, 2007
106
6
Hi. I am planning to purchase this box (2 GB/16 GB version) very soon, just wanted a few doubts cleared. WiFi strength is not an issue, I will be using it with a LAN cable.


1. Anyone using Amazon Prime on this? If yes, through the browser or official app? Any issues in streaming?

2. Do streaming video sites opened using a web browser work? I had read a post somewhere saying it doesn't. Don't remember whether it was this box in particular or some other one.

3. I'm not too keen on putting a custom ROM, just want to use the one it comes with after updating fully. The latest OS updates come pre-rooted right?

4. Can I flash TWRP on this box?
 

andrewilley

Senior Member
Mar 17, 2006
961
180
Birmingham
3. I'm not too keen on putting a custom ROM, just want to use the one it comes with after updating fully. The latest OS updates come pre-rooted right?

I simply installed a new OS on the SD Card and boot from that, the original Android setup is still there in the firmware but I never use it, it just boots directly using LibreELEC into Kodi. But then I never want to use it for anything other than Kodi, so that wouldn't work for everyone.

Andre
 
Last edited:
  • Like
Reactions: flipmode_11

raftom57

Member
May 19, 2010
8
1
Hello
Sorry for my english I'm french.
I have a mini m8s.
So I was trying to make an update of my box. I put my prepared SD car on the box an tried to make a reset by cliking with à toothpick on the reset and put out and on the power câble. But since then my box is bricked. Led blue on and no blinking. Nothing on screen. I tried to make an sd card with files like explained on post 361 but nothing happened. Try to flash trough USB burning tool with a mâle mâle USB but the first Time the program was recognized the box. Blocked at 2% when I try to flash. And since then my computer dont recognize the box anymore. Always saying unknow devices in windows. Tried 2 computer it's the same.

i dont know what I Can do anymore ? if someone have an Idea ? i think m'y box is blocked in some state but I don't know wich.

Thank you verry much
 

raftom57

Member
May 19, 2010
8
1
Thanks for the answer this is what I tried but the first Time i plugged the box it was recognized as winlib worldcup USB but since then it's unknown devices.
Maybe try on an other Windows ? (2 computer tried Windows 7 )
 

bijurajnr

New member
Jul 15, 2013
1
0
How to increase RAM of Mini M8S II tv box ( mine is 1 GB RAM)

Dear Friends,
Is it possible to increase RAM of Mini M8S II tv box as its current RAM is only 1 GB.
Pls help me.
 

ustach

Member
Sep 18, 2008
16
0
He Topper, because I rooted all my androids. And some of this devices I have killed by this prozedure, but I don´t know why, like a cocking-man "He don´t know what he have done wrong. but this cost to much every month."
You live in EastEU, I live in Hungary and Germany so perhaps you see, this cheap TV-Box is a easy learnig field.
-> My [FULL] backup was not successfull in restore, I was sure "Data with 27GB" is not true... Get error code "255"
So perhaps I bring easy understandig knowledge to all!#
so if there is a question I used:
update_minim8s_rv106L03.img
from: https://mega.nz/#!DtxX1J5a!SXFNzs6gl...FUb4g_x0bgcxbg

and

USB_Burning_Tool_v2.0.5.15-build8.rar

from: https://mega.nz/#!np5nkQxQ!uKiezTwnO...DgGjhyiKBp_O9s

this worked!

But now I have to go a new way...

Do typy have these firmware and program from links?
These doesant work.
I have rv104 i my mini m8s and wifi is super slow.
I would like to repair it.
Can you help me?

I never upgrade a tv box.
 

chooch901

New member
Dec 15, 2017
3
0
i have already downloaded ROM from different site, i try different version, the result is the same.
with the same file, check-sum generated is different
' failed:Verify Failed with sha1sum, origin sum "f21bc4365828f0e25ac10d69d591b3a4781712d8" != gen sum "932ef1a30c1ab3f827aa45b078b3cbf137540fc2" '
' failed:Verify Failed with sha1sum, origin sum "f21bc4365828f0e25ac10d69d591b3a4781712d8" != gen sum "fb4936761db5390ab1e3214ad1159e3476d6939e" '
' failed:Verify Failed with sha1sum, origin sum "f21bc4365828f0e25ac10d69d591b3a4781712d8" != gen sum "50d2ec20c5d45bf1ad44cd7a0965f60804d55847" '
' failed:Verify Failed with sha1sum, origin sum "f21bc4365828f0e25ac10d69d591b3a4781712d8" != gen sum "b27ebee079bb71b724d2a75c1fee46deb544e780" '


This is happening to me, did anyone ever figure it out???
 

tgabby

New member
Jan 11, 2018
2
0
remote.conf/Vendor_0001_Product_0001.kl

SOS
someone would ask you to download the mini m8s remote.conf file
and Vendor_0001_Product_0001.kl filet

android is here
- /system/etc/remote.conf
- /system/usr/keylayout/Vendor_0001_Product_0001.kl

thx tgabby
 

Top Liked Posts

  • There are no posts matching your filters.
  • 7
    I unbricked my box again, finally. The nand was all messed up and I used a bootable microsd with aml_autoscript file to scrub it. Then I flashed the full image with Vadiator fix using a bootable microsd prepared with u-boot.bin.sd.bin (868.864 bytes). OTA update then worked and updated the system to 105L03. WiFi flies now like an aeroplane! 46 Mbps download and 46 Mbps upload speed on the Internet and some 10 m away from the router. Thank you again Vadiator! This box is now a real value with your fix!

    For those who want to boost the WiFi speed, without the USB cable method with driver problems and transfer errors, here's a faster way to flash the .img files to your box.

    NOTE: Although this is an usual Amlogic method for so many boxes, it is not ment for the normal user. If you don't know exactly what a boot, rom, flash, brick, unbrick means, please don't try it or you may render your box unusable. Also there may be different revisions and clones of Mini M8S out in the market using different flash, wifi or other chips so it may not work for all. Also it may void your warranty.

    1. Get the attached View attachment 3754515 containing all the needed tools (Amlogic bootcard maker, u-boot.bin.sd.bin 868.864 bytes and aml_sdc_burn.ini file).
    2. Get a clean microsd card and insert it into the reader on your pc. Open Amlogic bootcardmaker.exe, select your card, check yes to partition and format, chose u-boot.bin.sd.bin and click Make. Format your card when prompted. In must end with a Success box.
    Note that you must use u-boot.bin.sd.bin with the size of 868.864 bytes (provided in attached the tools package). Bootloader.img from the Mini M8S OTA archive renamed to u-boot.bin does not boot.
    3. On the prepared microsd card, copy aml_sdc_burn.ini. Rename miniM8S_104L3_Fix_WiFi_SDwrite_by_vadiator.img (https://yadi.sk/d/3JKuyWGoreotx) to aml_upgrade_package.img and copy it on the microsd, too. You must end with 2 files on the card:
    - aml_sdc_burn.ini
    - aml_upgrade_package.img
    4. Insert the microsd in the Mini M8S and power on while holding the reset button pressed with a paperclip or toothpick. When the upgrade will start by showing the green robot and progress bar, release the reset button and don't touch anything until it finishes and restarts.
    5. Now you have a 104L03 system with full wifi speed. Launch OTA and update to 105L03 to have the latest system.
    6. Enjoy!

    Note 2:
    If the update finishes successfully, after reboot wait some minutes for the box to finish reinstalling apps (black screen) and start up. Do not unplug or restart immediately, first start takes longer.
    If the box still won't start to Android, try to reflash something else on it like OpenElec to refresh the NAND (delete all files on the bootable microsd and copy OpenELEC-Amlogic.MiniMX.arm64-7.0-devel-20160120113810-r21920-gff430a0-update.zip recovery. img and the proper factory_update_param.aml). Boot from the card, let it finish flashing and after OpenElec starts up, try again to flash the wifi fixed image as described first. The OpenElec image is not fully usable on Mini M8S, I just used it to refresh the NAND.

    Note 3: The aml_sdc_burn.ini contains values for the type of flash format, like in the USB Burning Tool:
    0 – Do not erase flash
    1 – Normal erase
    3 – Erase all
    4 – Force erase all
    If you want to change values use Notepad++ or DOS Edit to preserve format, don't edit in Windows Notepad.
    4
    This box is very nice, here are some details:

    There is a small hole underneath for the reset button; you can use a toothpick to hold the button while you insert the power. This will give you access to recovery.

    Looking at traffic flow I can see it connects to fota4.adups.cn to determine if there is a new update and downloads the updates from: hwfotadown.mayitek.com
    Here is the latest patch as of this writing:
    http://hwfotadown.mayitek.com/ota/r...04011829-LMY47V-2016041117331460428050687.zip

    At this time I am unable to find a full firmware IMG file that I could use with the "USB Burning Tool" (The ultimate recovery, if things go bad)
    3
    Just to confirm so that people don't flash the wrong firmware to the wrong box.
    This thread is for the Mini M8S
    MAbUhO4.jpg


    Not any of these boxes
    U4GkLIj.jpg

    qLoCYly.jpg

    V7M4k5W.jpg
    3
    FIX issue with WIFI

    Hi from Russia)) :)
    Today build a rom, based on 104L03.
    Fix a trubl with low speed 8273BS wifi chip....
    Modul 8723bs.ko from box MK06 and edit DTB tables in kernel with needly req.
    Now speed wifi >>>>> and work idealy)
    also edit permission for write application on SDcard.

    posted in 4pda
    4pda.ru_forum_index.php?showtopic=741134&st=280
    firmware
    h t t p s:__yadi.sk_d_3JKuyWGoreotx

    i'nt placed links
    2
    yes, my 1tb drive works fine, don't know what the limit is.

    ____________________________________________________________________________________________

    Here is the rom image download and instructions: http://4pda.ru/forum/index.php?showtopic=741134&st=120#entry49295536

    Hi,

    Does it connect to an external portable hdd?

    It works on my USB 2TB NTFS drive too. I think it should be good up to 4TB.

    I am pleasantly surprised to discover that it plays a 32GB blue-ray rip mkv file with MX player very well and in full 7.1 Dolby TrueHD audio thru my Onkyo receiver!

    Another link to get the factory image file is: http://chinagadgetsreviews.com/down...lipop-5-1-stock-firmware-mini-m8s-tv-box.html