MK809 II

Search This thread


New member
Nov 25, 2015
MK809II Linux Distribuition


I'm trying to install a ubuntu distribuition in my MK809II E809 with RK3066 chip. So, I tried all available tutorials for RK3066 chipset and nothing worked. I can't insert the tutorial links. :(

I tried to install Finless ROM 1.5, 1.7, 1.8 and 2.0. As a result: bricked all times. I don't know if it's possible to run Ubuntu or another linux distribuition in the NAND of this chipset. Anyone can help me?


- Sorry if my english isn't good :) -


New member
Aug 10, 2016
Hi guys,

I need some help,

I purchased a zoweetek Bluetooth keyboard to work with my mk809ii, but it doesn't work, any advice?

Top Liked Posts

  • There are no posts matching your filters.
  • 9
    Root MK809 (II)

    everything related 2 the MK809 II

    Be gentle people it's my first post

    all the credits go to:

    bothlynn from vondroid com

    I don't accept any responsibility for loss of warranty, brain cells, hair or your TV stick as a result of following this guide. All I can say is it worked for me on my Jelly Bean version of the MK809 (II)

    So here it is for the community, a step-by-step to root this device.

    1/ If not already done install Android SDK and make sure it runs. Put the platform-tools directory in your system PATH variable.

    download the attachments for the drivers and TS Sparky root hack

    3 / Add lines to <Your Android SDK>\extras\google\usb_driver\android_winusb.inf

    Under the [Google.NTx86] and [Google.NTamd64] section:


    %SingleAdbInterface% = USB_Install, USB\VID_2207&PID_0010
    %CompositeAdbInterface% = USB_Install, USB\VID_2207&PID_0010&MI_01

    4/ Connect your MK809 DC port to a high power USB port on your PC or Laptop

    on the mk809II its the small microusb port on the left side of the stick
    do not connect any other power-source or device to the stick ( with exception of a mouse to control the device).

    I found that the supplied micro USB cable caused a bootloop and I changed
    to the decent HTC data cable that came with my phone

    5/ Once the MK809 is powered up turn on USB Debugging under Developer Settings and allow installations from unknown locations.

    In my case. I needed to reset my stick to factory default settings before it enabled USB debugging.

    6 / Start the Installation of the drivers. When prompted to plug and un-plug your device use the "Connect to PC" option under Settings->USB on your MK809.

    After the driver installation is complete you can do a quick test that all is OK so far
    by opening a command prompt on your PC and typing "adb shell" and hitting enter.

    If all is well you should get a remote adb shell to your MK809II.

    If it's not working at this point could be that step 4 above is wrong.

    The original TPSparkyRoot.bat file had a bug. I already corrected this by adding a line: in the bat file:

    under line "echo --- Installing SuperSU"
    adb push SuperSU.apk /system/app/SuperSU.apk

    If you did the test at Step 6 make sure that adb shell is exited before proceeding
    Also you might want to disconnect and reconnect your MK809 either physically or via Settings->USB
    on your MK809 just to make sure of a clean connection before the point of no return

    9/ Run the batch file TPSparkyRoot.bat from the shell you opened at Step 8. Note that after each reboot and before you hit space to continue you will need to reconnect your MK809 to the host PC via Settings->USB.
    Before entering the spacebar to proceed with the hack

    You should now be rooted. It's worth running superSU on your MK809 to update the su binary and superSU itself. Then you're done.
    Video Guide on Flashing ROM to MK809II

    Hey all,

    I followed a couple of guides/gathered resources and managed to flash my MK809II with the iMito firmware. I made a video tutorial on how to flash your device as I thought it could help new users such as myself. I hope it's useful:

    everything related 2 the MK809 II
    [FOR ALL HAVING 'adb device' ISSUES] - need older adb

    An important note to all those who, like me, have the Android SDK installed and adb in their path (or decide to use that adb and not the one in the TPSparky package attached by the OP).

    In short, it won't work. Use the one in the package. =)

    The OP states:

    After the driver installation is complete you can do a quick test that all is OK so far
    by opening a command prompt on your PC and typing "adb shell" and hitting enter.

    If all is well you should get a remote adb shell to your MK809II.

    ...and you will, providing that you're using that adb...which is version 1.0.26.

    I tried using 1.0.31 (which is in the SDK from Dec.2012/Jan 2013) and it doesn't see anything.
    Interestingly enough, 1.0.26 reports the device id as:

    ...which I'm pretty sure is not valid (i'm not an expert on Google's device UIDs but a safe guess is that they are supposed to be *unique* hehe.)

    Anyways, i don't have the time resources to investigate why this is (and since there are a few clones of MK809II devices out there, YMMV). I am guessing it's probably related to the non-unique "UID", and that the mk809 vendor of these particular devices is playing loose with the ADB protocol standard; something that google likely patched somewhere from 1.0.26->1.0.31.

    The short of it is that root DOES work as described by the OP as long as you use ADB version 1.0.26 on your host computer.
    Very likely it'll work for SDK work too (debugging, deploying apps, etc)


    p.s. My device also had a very finnicky power appetite. I needed to use an external ACDC power brick->USB (use a 2.1Amp "ipad approved" one to be sure). *One thing to note though*: whenever you do this AND your computer is NOT a laptop AND/OR is NOT running on batteries, be careful that the ACDC charger and the computer are plugged into the **same** wall outlet! (or, if you're using a UPS, plug either both the computer and ACDC chrg. to the wall, or to the UPS, but not 1 to the wall and the other to the UPS). A ground differential can make weird things happen, and in very rare but severe cases where the diff is high, can destroy the mk stick, the computer's USB port, or both.
    just FYI + word of friendly caution
    MK809 results with finless 1.5 (not MK809II)

    Works flawless!

    Now i do have finless rom and cwmrecovery.

    Bye stockrom ;)

    Tried the Finless 1.5 Imito ROM on my MK809 (not MK809II). Booted fine but no wifi even after several reboots. Must be a different wifi module? Back to stock without issue.

    Definitely benefits to having gone through this though:

    Reformatted system partition to 1GB (MK809 only has 4GB in total, not 8 like MK809II). Selected this in the finless utility. Be careful, changing the parameter file during flash formats your internal SD too.
    Seem to have the benefits of the finless 1080p kernel surviving revert to stock: changing output mode actually does something now, as does display scaling. Still getting 1080p resolution, definitely not before.
    Wondering if the xbox controller elements have survived, yet to test this.

    Hope this helps anyone thinking of flashing finless on an MK809.