Question MMS not working after January 2022 Security Update

Search This thread

johninsf

Senior Member
I just updated the P6P with the January update (OTA manually requested in System Update).
  • After the update, MMS is not working in the Google messages app.
  • I am on T-Mobile in US and phone purchased unlocked from Google Store
  • MMS settings haven't changed in the app.
  • SMS works
Unsure if this matters, but a couple MMS came in right at the time the phone was starting up after the update / when the notification of "finishing update" or something to that effect was showing.

Has anyone else experienced issues with Google Messages MMS with January or December update?

Thoughts on how to resolve this?

If a solution is posted elsewhere, let me know and I will ask the Mod to remove this post.
 
Last edited:
  • Wow
Reactions: roirraW "edor" ehT

Morgrain

Senior Member
Aug 4, 2015
893
965
I just updated the P6P with the January update (OTA manually requested in System Update).
  • After the update, MMS is not working in the Google messages app.
  • I am on T-Mobile in US and phone purchased unlocked from Google Store
  • MMS settings haven't changed in the app.
  • SMS works
Unsure if this matters, but a couple MMS came in right at the time the phone was starting up after the update / when the notification of "finishing update" or something to that effect was showing.

Has anyone else experienced issues with Google Messages MMS with January or December update?

Thoughts on how to resolve this?

If a solution is posted elsewhere, let me know and I will ask the Mod to remove this post.
New bugs? Again?

so-it-begins-raining.gif


Jokes aside, best try to reset your network/messaging/phone services/apps. That might help you.
 

johninsf

Senior Member
MMS is working again but it required factory resetting the phone. Resetting WIFI / mobile only didn't help. Nor did clearing storage in carrier services (if that matters).

On a positive note, signal seems a bit better with this update. I cleanly move from LTE to 5G to 5G UC walking down the hall in my flat. (e.g. my Bermuda Triangle of signals). I love the Net Monster app. I never knew where the cell points are located near me. I am between 2 LTE points which explains the bouncing back and forth. Interesting to see the 5G UC point which is much farther away than I thought.

I am glad that UC is in large letters now vs. the microscopic letters before the update.
 
  • Wow
Reactions: roirraW "edor" ehT

RetroTech07

Senior Member
Apr 24, 2021
342
260
Google Pixel 2 XL
Google Pixel 6 Pro
I noticed android messages somehow had notification sounds set to nothing, which was odd as I never touched it, but wondered why my phone was vibrating and only playing a sent message tone. I cleared app data and it's back to default.

Try setting up your phones carrier settings manually and see if it helps, or try resetting the value to default.

Go to settings > network > SIMs > APNs (at the bottom) > three dots in the top right > reset to default.

What carrier do you have?
 

pedro6669

Senior Member
Jul 25, 2012
232
78
Fairfield
Try this....1. turn wifi off. 2. Force stop messages. 3. Clear cache. 4. Open messages. 5. Check the status of "chat features", if it takes longer than a couple minutes to be "connected"...repeat steps 2 &3.
 
  • Like
Reactions: johninsf

RetroTech07

Senior Member
Apr 24, 2021
342
260
Google Pixel 2 XL
Google Pixel 6 Pro
Try this....1. turn wifi off. 2. Force stop messages. 3. Clear cache. 4. Open messages. 5. Check the status of "chat features", if it takes longer than a couple minutes to be "connected"...repeat steps 2 &3.
That doesn't really impact MMS though, it's just setting up to use advanced features like wifi and chatting through your PC if you wanted.
 
  • Like
Reactions: roirraW "edor" ehT

pedro6669

Senior Member
Jul 25, 2012
232
78
Fairfield
No not really. If you're setup to use RCS and it's not connected you will not get any MMS's. Hope you get it figured out.
 

NYCHitman1

Recognized Developer
Apr 9, 2010
5,579
6,740
New York
Google Pixel 2 XL
Google Pixel 3
MMS is working again but it required factory resetting the phone. Resetting WIFI / mobile only didn't help. Nor did clearing storage in carrier services (if that matters).

On a positive note, signal seems a bit better with this update. I cleanly move from LTE to 5G to 5G UC walking down the hall in my flat. (e.g. my Bermuda Triangle of signals). I love the Net Monster app. I never knew where the cell points are located near me. I am between 2 LTE points which explains the bouncing back and forth. Interesting to see the 5G UC point which is much farther away than I thought.

I am glad that UC is in large letters now vs. the microscopic letters before the update.
I hate the large letters. Looks so stupid.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 4
    I just updated the P6P with the January update (OTA manually requested in System Update).
    • After the update, MMS is not working in the Google messages app.
    • I am on T-Mobile in US and phone purchased unlocked from Google Store
    • MMS settings haven't changed in the app.
    • SMS works
    Unsure if this matters, but a couple MMS came in right at the time the phone was starting up after the update / when the notification of "finishing update" or something to that effect was showing.

    Has anyone else experienced issues with Google Messages MMS with January or December update?

    Thoughts on how to resolve this?

    If a solution is posted elsewhere, let me know and I will ask the Mod to remove this post.
    New bugs? Again?

    so-it-begins-raining.gif


    Jokes aside, best try to reset your network/messaging/phone services/apps. That might help you.
    3
    I'm on a stock P6P US Tmo with Jan. update. MMS is working fine for me, including airplane mode using wifi.
    1
    @RetroTech07 thank you! I will keep this in mind in the future.

    I have had disappearing notification sounds for years with Android. Not this time though because I completely reset the phone.
    1
    Try this....1. turn wifi off. 2. Force stop messages. 3. Clear cache. 4. Open messages. 5. Check the status of "chat features", if it takes longer than a couple minutes to be "connected"...repeat steps 2 &3.
    1
    Try this....1. turn wifi off. 2. Force stop messages. 3. Clear cache. 4. Open messages. 5. Check the status of "chat features", if it takes longer than a couple minutes to be "connected"...repeat steps 2 &3.
    That doesn't really impact MMS though, it's just setting up to use advanced features like wifi and chatting through your PC if you wanted.