[MOD][29 October] MultiROM v32b - the ultimate multiboot method! [EOL]

Are you interested more to boot ROMs from MicroSD Card or USB-OTG drive?


  • Total voters
    109
  • Poll closed .
Search This thread

AntaresOne

Recognized Developer
Sep 30, 2013
2,205
17,619
0
27
Chieti, Italy
www.antaresone.eu
Great work, Antares. Do you have any update on your solution for Verizon and AT&T variants?

Seems yes :) stay tuned on the following days

my secondare rom can't connect to the network. i can't even put in my sim code. i'm using CM12 android 5.0
pleas help
sorry for bad english

What ROM build? Install the latest available


A new MultiROM (big) update is coming tomorrow, bump to the v30 :)
 

rebel1699

Senior Member
Feb 13, 2008
2,066
1,468
193
Oklahoma
Google Pixel 4 XL
Just installing the newest recovery and mr through multirom manager. Problem is, the newest recovery wont boot, so I cant install mr v30. Just vibrates and goes to mr v29 boot screen. Cant access recovery at all. Anyone else get this, or maybe fixex it by flashing via odin? Not near my pc atm.
 

MohamedN

Senior Member
Mar 16, 2012
494
321
63
Cairo
Good news bad news..
Good news: v30 is out and also recovery is updated.
Bad news: New recovery won't open
Fortunately for me I have flashify and I kept a backup of the old recovery, flashed it and it works like a charm. Then flashed v30
So now I have v30 with the old recovery until it's fixed
 

soulstorm

Senior Member
May 9, 2006
126
8
0
Good news bad news..
Good news: v30 is out and also recovery is updated.
Bad news: New recovery won't open
Fortunately for me I have flashify and I kept a backup of the old recovery, flashed it and it works like a charm. Then flashed v30
So now I have v30 with the old recovery until it's fixed

Can you upload the old recovery please. Thanks
 

`SBR`

Senior Member
Apr 5, 2010
1,035
358
103
NJ
I installed multirom app but didn't find an option to install the v30 update....

Initially installed v29 from recovery..
 

Attachments

  • uploadfromtaptalk1416974341694.png
    uploadfromtaptalk1416974341694.png
    96.1 KB · Views: 430

troullis2004

Senior Member
Mar 1, 2012
759
129
73
Use flashify from play store. It has all available recoveries and versions and it flashes them automatically without reboot.

Sent from my GT-I9505 using XDA Free mobile app
 
  • Like
Reactions: Technical

XxmentxX

Senior Member
Jun 14, 2013
112
7
0
I tried to update to v30 but it always fails! you know why?
 

Attachments

  • uploadfromtaptalk1417030406156.png
    uploadfromtaptalk1417030406156.png
    185.8 KB · Views: 380
  • uploadfromtaptalk1417030417749.png
    uploadfromtaptalk1417030417749.png
    64.4 KB · Views: 380

Top Liked Posts

  • There are no posts matching your filters.
  • 84
    aop0rp.png


    MultiROM for the Samsung Galaxy S4 (Qualcomm variants)
    Brought to you by AntaresOne


    2vacmip.png

    Code:
    #include <std_disclaimer.h>
    
    /*
     * Your warranty is now void.
     *
     * I'm not responsible for bricked devices, dead SD cards,
     * thermonuclear war, or you getting fired because the alarm app failed. Please
     * do some research if you have any concerns about features included in this ROM
     * before flashing it! YOU are choosing to make these modifications, and if
     * you point the finger at me for messing up your device, I will laugh at you.
     *
     */

    Introduction
    MultiROM is one-of-a-kind multi-boot mod for Galaxy S4. It can boot any Android ROM as well as other systems like Ubuntu Touch, once they are ported to that device. Besides booting from device's internal memory, MultiROM can boot from external SD card. The main part of MultiROM is a boot manager, which appears every time your device starts and lets you choose ROM to boot. You can see how it looks on the image above. ROMs are installed and managed via modified TWRP recovery. You can use standard ZIP files to install secondary Android ROMs and MultiROM even has its own installer system, which can be used to ship other Linux-based systems.

    Features:
    * Multiboot any number of Android ROMs
    * Restore nandroid backup as secondary ROM
    * Boot from Internal memory and MicroSD Card



    Warning!
    This whole thing is basically one giant hack - none of these systems are made with multibooting in mind. It is no longer messing with data partition or boot sector, but it is possible that something goes wrong (even if never happened until now) and you will have to flash stock firmware with Odin. Make backups. Always.


    Installation
    1. Via MultiROM Manager app
    This is the easiest way to install everything MultiROM needs. Install the app and select MultiROM and recovery on the Install/Update card. If the Status card says Kernel: doesn't have kexec-hardboot patch! in red letters, you have to install also patched kernel - either select one on the Install/Update card or get some 3rd-party kernel here on XDA. You are choosing kernel for your primary ROM, not any of your (future) secondary ROMs, so select the version accordingly.
    Press "Install" on the Install/Update card to start the installation.

    2. Manual installation
    Firstly, there are videos on youtube. If you want, just search for "MultiROM installation" on youtube and watch those, big thanks to all who made them. There is also an awesome article on Linux Journal.

    Note 1: Your device must not be encrypted (hint: if you don't know what it is, then it is not encrypted).

    MultiROM has 3 parts you need to install:
    • MultiROM - download the ZIP file and flash it in recovery.
    • Modified recovery - download the ZIP file and flash it in recovery or Mobile Odin app to flash the recovery.img contained inside ZIP.
    • Patched kernel - Download the ZIP file and flash it in recovery or keep stock kernel (only for CM11-based ROMs after 6 August 2014 & CM12-based ROMs)

    You current rom will not be erased by the installation.
    Download links are in the third post.



    Adding ROMs
    1. Android
    Go to recovery, select Advanced -> MultiROM -> Add ROM. Select the ROM's zip file and confirm.

    3. Other systems (once ported to device)
    Firefox OS and Sailfish OS are just another Android ROM under MultiROM's point of view, so add them as if it were Android.


    Using MicroSD Card

    During installation, recovery lets you select install location. You just select the location (extX, NTFS and FAT32 partitions are supported) and proceed with the installation.
    If you wanna use other than default FAT32 partition, just format it in PC. If you don't know how/don't know where to find out how, you probably should not try installing MultiROM.
    If you are installing to NTFS or FAT32 partition, recovery asks you to set image size for all the partitions - this cannot be easilly changed afterward, so choose carefully. FAT32 is limited to maximum of 4095MB per image - it is limitation of the filesystem, I can do nothing about that.
    Installation to MicroSD Card takes a bit more, because the external memory is (usually) slower and it needs to create the images. Also boot process is longer, highly depends on card's class. You can find ROMs installed on SD card in the "External" tab in boot menu.


    Updating/changing ROMs
    1. Primary ROM (Internal)
    • Flash ROM's ZIP file as usual, do factory reset if needed (it won't erase secondary ROMs)
    • Go to Advanced -> MultiROM in recovery and do Inject curr. boot sector.

    2. Secondary Android ROMs
    If you want to change the ROM, delete it and add new one. To update ROM, follow these steps:

    • Go to Advanced -> MultiROM -> List ROMs and select the ROM you want to update.
    • Select "Flash ZIP" and flash ROM's ZIP file.


    Explanation of recovery menus
    Main menu
    - Add ROM - Add ROM to boot manager
    - List ROMs - List installed ROMs and manage them
    - Inject curr. boot sector - Use this option if MultiROM does not show up on boot, for example after kernel installation.
    - Settings - Well, settings

    Manage ROM
    - Rename, delete - I believe these are obvious
    - Flash ZIP (only Android ROMs) - Flash ZIP to the ROM, for example GApps
    - Add/replace boot.img - Replaces boot.img used by the ROM, this is more like developer option.


    Source Code
    MultiROM - https://github.com/Tasssadar/multirom/tree/master (branch master)
    Modified TWRP - https://github.com/Tasssadar/Team-Win-Recovery-Project (branch master)
    Alucard Kernel w/ kexec-hardboot patch - https://github.com/Alucard24/Alucard-Kernel-jfltexx
    Googy-Max3 kernel w/ kexec-hardboot patch - https://github.com/googyanas/Googy-Max3-Kernel
    Hulk kernel w/ kexec-hardboot patch - https://github.com/Tkkg1994/Hulk-Kernel
    Imperium kernel w/ kexec-hardboot patch - https://github.com/Slim80/Imperium_Kernel_TW_4.4.2
    KT kernel w/ kexec-hardboot patch - https://github.com/ktoonsez/KT-SGS4
    CM11 stock kernel w/ kexec-hardboot patch - https://github.com/CyanogenMod/android_kernel_samsung_jf/tree/cm-11.0
    CM12 stock kernel w/ kexec-hardboot patch - https://github.com/CyanogenMod/android_kernel_samsung_jf/tree/cm-12.0
    CM12.1 stock kernel w/ kexec-hardboot patch - https://github.com/CyanogenMod/android_kernel_samsung_jf/tree/cm-12.1
    MultiROM device tree - https://github.com/AntaresOne/multirom_device_samsung_jflte


    Big thanks to Tasssadar for this awesome utility.

    Thanks a lot to @daveyannihilation for the S4 template.


    XDA:DevDB Information
    MultiROM, multiboot for Galaxy S4 (Qualcomm variants) (GRUB-like), Tool/Utility for the Samsung Galaxy S4

    Contributors
    AntaresOne

    Version Information
    Status: No Longer Updated
    Current Stable Version: 20151029-v32b
    Stable Release Date: 2014-09-01

    Created 2014-09-01
    Last Updated 2017-05-19
    24
    Updates!

    Hi guys

    I have a news for you...

    Samsung made our recovery partition only 10.5MB big, while the new recovery is much bigger. Finally I succeeded into building the new recovery for our device, and to achieve this I had to sacrifice some things: crypto compatibility (the encrypted /data partitions can't be managed anymore, not that bad since MultiROM wasn't compatible with this. If you don't know what's Android encryption then your partition is not encrypted) and SuperSU installer (you can't root a ROM with integrated TWRP feature anymore, but you can still flash SuperSU zip)

    Now, let the game begin :cool:

    MultiROM v32 and MultiROM TWRP 2.8.6.0 are perfectly running on my device!!!!!!!

    Booted a Lollipop 5.1 ROM as secondary, everything fine

    Expect a public release very soon... :)
    23
    Changelog

    15/6/2015 - v32a
    • Update after 6 months!! :) read post #669
    • Modified TWRP:
      • Base updated to 2.8.6.0
      • Sacrificed crypto and embedded SuperSU installer to get an image that fits 10.5MB recovery partition size
      • Detailed changes here
    • MultiROM:
      • Base update to v32
      • Added support for 5.1.x Lollipop ROMs
      • Better support for 5.0.x Lollipop ROMs
      • Detailed changes here

    16/12/2014 - v30c
    • Modified TWRP:
      • Base updated to 2.8.2.0
      • Better support for primary/secondary Lollipop ROMs install/update
    • MultiROM:
      • Better support for Lollipop-based ROMs
      • Fixed the ghost update found in previous build

    26/11/2014 - v30

    12/11/2014
    • Modified TWRP:
      • Build an updated image without event logging

    4/11/2014
    • Modified TWRP:
      • Add back "Share kernel" option (same behavior can be obtained by pressing "Remove boot.img" under MultiROM>List ROMs>*rom name*)

    30/10/2014

    25/10/2014 - v29
    • MultiROM:
    • Modified TWRP:
    • Uninstaller ZIP:
      • Add support for other jf variants

    2/10/2014

    1/10/2014 - v28c

    30/9/2014 - v28b
    • MultiROM:
      • ROM boot from external SD (MicroSD card) is now supported
    • TWRP Recovery:
      • General update (branch master)
      • Removed "Share kernel" option
      • ROM Installation to external SD (MicroSD card) is now supported
    • Uninstaller ZIP added back and now working

    16/9/2014

    12/9/2014
    • TWRP Recovery:

    6/9/2014

    3/9/2014
    • Fixed installation on other jflte devices

    1/9/2014 - v28
    • Device source:
      • add power button init (needed to reboot device when "an error occurred" and to exit from pong game, available by clicking on Miri)
    23
    Downloads

    1. Main downloads

    MultiROM EXT4 (20151029-v32b): https://www.androidfilehost.com/?fid=24052804347849558

    MultiROM F2FS (20151029-v32b): https://www.androidfilehost.com/?fid=24052804347849563

    Modified TWRP (20151029-v2.8.7.0): https://www.androidfilehost.com/?fid=24052804347849556

    MultiROM Manager App: Google Play Store (by default it will install the EXT4 version!)

    2. Kernels for primary ROM (Internal) based on Android 5.1.x Lollipop

    Kernel with kexec-hardboot patch for AOSP/CM 5.1 ROMs:
    • AOSP 5.1 & Optimized CyanogenMod 12.1 from JDCTeam: Alucard is embedded and always up to date
    • Alucard AOSPv2 5.1 v1.3ba
    • Stock CM12.1 kernel (included in ROM's zip)

    3. Kernels for primary ROM (Internal) based on Android 5.0.x Lollipop

    Kernel with kexec-hardboot patch for AOSP/CM 5.0 ROMs:

    Kernel with kexec-hardboot patch for Google Edition 5.0 ROMs:

    Kernel with kexec-hardboot patch for TouchWiz 5.0.1 ROMs:

    4. Kernels for primary ROM (Internal) based on Android 4.4.x KitKat

    Kernel with kexec-hardboot patch for AOSP/CM 4.4 ROMs:
    (builds up to 6 August, including CM11 M9)

    (builds after 6 August, including CM11 M10)

    Kernel with kexec-hardboot patch for Google Edition 4.4.x ROMs:

    Kernel with kexec-hardboot patch for TouchWiz 4.4.4 ROMs:

    Kernel with kexec-hardboot patch for TouchWiz 4.4.2 ROMs:

    5. Uninstaller

    MultiROM uninstaller ZIP: https://www.androidfilehost.com/?fid=95747613655050515

    Just flash this to disable MultiROM and delete all secondary ROMs.


    Alucard-PWR-CORE dev thread by @alucard_24: http://forum.xda-developers.com/showthread.php?t=2590246

    Googy-Max3 dev thread by @googy_anas: http://forum.xda-developers.com/showthread.php?t=2741181

    Hulk Kernel dev thread by @Tkkg1994: http://forum.xda-developers.com/galaxy-s4/i9505-develop/kernel-hulk-kernel-v1-stweaks-based-t3050469

    Imperium dev thread by @slim80: http://forum.xda-developers.com/galaxy-s4/i9505-orig-develop/kernel-imperium-kernel-v1-0-t2910801

    KT-SGS4 dev thread by @ktoonsez: http://forum.xda-developers.com/showthread.php?t=2297379
    19
    Primary ROM is Touchwiz 5.0.1 by Imperium
    Secondary should be Dirty Unicorn but it's bootlooping. I can't find a kernel for fixing that? Which one should I use?

    //Update: I tried with Alucard AOSP v1.0e and it worked. But after "setting up android" he reboots that rom again and again..

    I think there isn't aokp kernel what supports kexec hardboot even though it's based on aosp, is there?
    Kernel page is ancient, I must update it...

    By the way I have a great news!!!!

    I found a way for the new TWRP, expect a full update (MultiROM v32+MultiROM TWRP+MultiROM Manager kernel download+this thread) soon!

    Inviato dal mio GT-I9505
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone