[MOD] 3 CDMA mods updated 7/11/12

Search This thread

motcher41

Senior Member
Jul 29, 2011
3,666
1,337
Perham, Minnesota
Disclaimer: I am not responsible with what you do with your phone or anything that results from my edit/mods.

Nandroid Backup! Its your friend!

READ ENTIRE POST

Mention what rom and mods u used with results in a post please! :)

**If you flashed mashup and miss your data speed you need to redo mod 1**

One user that was plauged with switch to 1x being reported it being eliminated by the mods

Confirmed working on MIUI, eclipse 1.2 & 2.0.3, stock 2.3.4 and CM7

Mod 1 "may" work on any other 3G phones, mod 2 when posted "may" work on other 3G MOTO phones.

-----------------------------------------------------------------------------------------------------------------------
Mod 1

The Problem:
Since I do not have internet at home and I live in a poor service area any increase in 3G data speeds I can get is beneficial. So, I started looking into a way to increase my 3G data speeds.
Please let me know what rom you are using when you post something

Note: The first boot I did on some of these took a few minutes for 3G to first come up. Any reboots later it showed up immediately. I had no service issue and triangle once or twice while I was checking all of these. Reboot always fixed it.

The Solution:

First, nandroid backup prior to changing anything on your phone is a good policy to follow.

Most of the build.prop edits I’ve found are for GSM phones. I did find one thing that might help. I have confirmation from another source this hack works for them as well.

The line to be edited in build.prop which is in your /system/ folder by root explorer, root browser or any other editor/method of choice (make sure you backup your build.prop first):

Code:
persist.ril.uart.flowctrl=1

Change the “1” to “10”, save your build.prop, and reboot.

You can change the 1 to 1-10 and null or blank.


These are my results below in kb/s.

1=baseline 75-100 kb/s

0= no service – Don’t do this!
2-5 = 100 kb/s with some temp increases
6-9 = 150-200 kb/s
10 = 250-350 kb/s

A null value gives me 150-300 kb/s with large fluctuations.

I found that “10” gave me the best speed with most consistent results.

These speeds were clocked in actual large file downloads not a speed testing app.
I found that speed testing apps do not give accurate results. The real downloading gives real results.

Note: With this a tester was getting 500kb/s downloading a rom over 3G.

Please reply back with any results you find as I am looking for conformation of my findings.

If you try this in a different ROM please let me know your findings as well. This SHOULD work in any rooted X2.

Doesn't work on liberty for the moment. Gonna attempt it on fully stock liberty soon

Thanks to MoonShadow-NM for his assistance with the write up
----------------------------------------------------------------------------------------------------------------
Mod 2 - Can be used along with Mod1
Atrix lib replacement mod

This mod I found helped with increasing data speeds in my poor service location as well as an increase in speed in a good service location

Signal at a horrible -102 dBm I was getting a consistant 200kb/s download where I only had 100kb/s before using this in conjunction with mod 1 at a value of 10

Signal at a nice -62 dBm I got a nice 400-500kbs consistant download speed where I only had 250-300kb/s before using this in conjunction with mod 1 at a value of 10
Note: You may see a better increase as I am a huge data user and subject to network optimization by evil red.

This mod at my house also stopped my phone from jumping between two towers. One with a -130 signal and the better with a -102.

The attached file is an Atrix lib_motoril.so file. It is a different file from our stock blur file. It is about 50kb smaller in size then any X2 blurbased non-port rom file I found. It was given to me to try by a Alien port user after talking with him about his nice data speeds and connections prior to any modifications.

This is a fairly easy file swapping mod.

Download the attached atrix lib and extract wherever you want.

Navigate to the /system/lib/ folder in a file manager of choice and either backup by placing a .bak after the .so of the original libmoto_ril.so file.

Go to where you extracted the Atrix lib file. Copy and paste that file to your /system/lib folder and then set permissions to the rw-r--r-- for it..

Reboot and let me know if you had the same good results as me.

Thanks to kinevil for the atrix lib and idea to try this file!


I make sure BSR is installed before I try anything so I can do a battery pull and get into BSR. Wipe cache and dalvik if any issues come up first then you can always nandroid after that if needed.
-----------------------------------------------------------------------------------------------------------------

Mod 3 - May help with connection stability. Not speed.

Easy build.prop addtion

In a fike manager such as root browser and root manager got to /system/ and open your build.prop to edit.
Add the following line.

Code:
ro.mot.eri.losalert.delay=

The standard mod for this us 1000. Feel free to play around with it. Please post your results.

Happy modding!
 
Last edited:

lbroksle

Senior Member
Apr 15, 2011
121
24
Worked for me, doubled the speed. Thanks for the tip!

Sent from my MB870 using xda premium
 

viskey

Senior Member
Oct 19, 2011
279
15
Below are my results using speedtest:

Before mod/reboot: .50 down. .55 up
1 min after mod/reboot: .70 down. .14 up
6 min after mod/reboot: 1.13 down. .52 up

So it seems better. Not sure on the fluctuations after mod though. I'm sitting at my desk at work and haven't moved and all this was completed in a 10 min window. Thoughts?

Stock ROM, 2.3.4, rooted, build.prop mashup v5b

Sent from my DROID X2 using Tapatalk
 
Last edited:

motcher41

Senior Member
Jul 29, 2011
3,666
1,337
Perham, Minnesota
Below are my results using speedtest:

Before mod/reboot: .50 down. .55 up
1 min after mod/reboot: .70 down. .14 up
6 min after mod/reboot: 1.13 down. .52 up

So it seems better. Not sure on the fluctuations after mod though. I'm sitting at my desk at work and haven't moved and all this was completed in a 10 min window. Thoughts?

Sent from my DROID X2 using Tapatalk

Use a real download from the web and watch it. This app works well to watch download rate https://market.android.com/details?id=info.kfsoft.android.TrafficIndicator

Looks to me like it doubled what's your app says on a before and after

Sent from my Cyanocrack using Xparent Blue Tapatalk
 
Last edited:

maggard5

Senior Member
Dec 24, 2011
240
71
This mod crashed my service. After rebooting, I received the triangle and dialed *228 and *22899 with no luck. It failed to activate and update my phone and gave me a "no network" message.

Reset value and phone works again.

Update: Went back and reread OP just to make sure. Noticed 0 was no service and thought I'd better try again just to make sure. Set value to 10 and had the same result. Set value to 9 and it worked. So tried 10 again and it worked. Not sure why but...
 
Last edited:
  • Like
Reactions: i7vSa7vi7y

Elite49

Senior Member
Jul 5, 2011
776
60
Changed it on Eclipse 1.2 with everything listed in my sig. No clue if its actually helping since I'm downloading a 9 MB update from the App Store and its going at 20 - 25 Kbps.

Edit: Testing with the Speed Test app getting just 400 Kbps instead of what you stated the usual 1200 - 2000. Websites seem the same but downloads are worse. Will keep using it for a day or so but every other 3G boost mod had never worked or made it worse on my phone. Especially 3G Turbo Booster.
 
Last edited:

pacman377

Senior Member
Oct 3, 2011
138
13
Tried this on CM7 lost data connectin and had the roaming triangle. After several reboots and *228 2 it Finally came up. Im not noticing a huge difference yet, but I believe Im be throttled like crazy now. I'll know for sure if it make a difference when I get home.

Edit

Im seeing the difference now, and yep it is faster.
 
Last edited:
  • Like
Reactions: DWake014

motcher41

Senior Member
Jul 29, 2011
3,666
1,337
Perham, Minnesota
Changed it on Eclipse 1.2 with everything listed in my sig. No clue if its actually helping since I'm downloading a 9 MB update from the App Store and its going at 20 - 25 Kbps.

Edit: Testing with the Speed Test app getting just 400 Kbps instead of what you stated the usual 1200 - 2000. Websites seem the same but downloads are worse. Will keep using it for a day or so but every other 3G boost mod had never worked or made it worse on my phone. Especially 3G Turbo Booster.
3 g turbo is made for gsm. They're all gsm settings as best I can tell


Sent from my Cyanocrack using Xparent Blue Tapatalk
 

motcher41

Senior Member
Jul 29, 2011
3,666
1,337
Perham, Minnesota
Tried this on CM7 lost data connectin and had the roaming triangle. After several reboots and *228 2 it Finally came up. Im not noticing a huge difference yet, but I believe Im be throttled like crazy now. I'll know for sure if it make a difference when I get home.

Edit

Im seeing the difference now, and yep it is faster.

You could be a victim of network optimization where you're located now.

Sent from my Cyanocrack using Xparent Blue Tapatalk
 

Elite49

Senior Member
Jul 5, 2011
776
60
Tried downloading a file I have uploaded on a server, only 25 MB but had to cancel it after 5 Min XD . Was only at 17% at that time.
 

motcher41

Senior Member
Jul 29, 2011
3,666
1,337
Perham, Minnesota
Tried downloading a file I have uploaded on a server, only 25 MB but had to cancel it after 5 Min XD . Was only at 17% at that time.

Thanks...hmm maybe not blur compatible ...should be though. Try the cm7zip I downloaded that 90 MB file in 9 min earlier
If u want I can see what I get with your file. if its ok pm me the link
Sent from my Cyanocrack using Xparent Blue Tapatalk
 

booked

Senior Member
Nov 20, 2010
533
111
LA
I tried this on Liberty and after a reboot I the Motorola systen was fc'ing as was the some android media something. When I first tried to change the number to 10 it root explorer wouldnt let me add another digit, I could change the digit and did so to 9 but thats when I started having system fc's. Im now installing cm7, again, and then going to try this mod, again. I'll report back if it works for me or not.
 
  • Like
Reactions: motcher41

beavy

Member
Oct 3, 2007
5
1
Thanks for the work motcher just an fyi my 3g at work is real spotty and the alien port data was blazing even there maybe something to look into
 

booked

Senior Member
Nov 20, 2010
533
111
LA
I installed CM7 then edited the build.prop using root explorer. I dont see any change in 3g speed.
 

litetaker

Senior Member
Dec 2, 2011
1,746
626
London
Google Pixel 2
I don't see much of a difference. I got a high of about 140 KBps and an average of ~100 KBps without the modification. I am getting a high of about 160-180 KBps and an average of about 100 KBps with the mod. If I leave it to statistical error, there probably is no difference to me.

Meh!
 

Top Liked Posts

  • There are no posts matching your filters.
  • 43
    Disclaimer: I am not responsible with what you do with your phone or anything that results from my edit/mods.

    Nandroid Backup! Its your friend!

    READ ENTIRE POST

    Mention what rom and mods u used with results in a post please! :)

    **If you flashed mashup and miss your data speed you need to redo mod 1**

    One user that was plauged with switch to 1x being reported it being eliminated by the mods

    Confirmed working on MIUI, eclipse 1.2 & 2.0.3, stock 2.3.4 and CM7

    Mod 1 "may" work on any other 3G phones, mod 2 when posted "may" work on other 3G MOTO phones.

    -----------------------------------------------------------------------------------------------------------------------
    Mod 1

    The Problem:
    Since I do not have internet at home and I live in a poor service area any increase in 3G data speeds I can get is beneficial. So, I started looking into a way to increase my 3G data speeds.
    Please let me know what rom you are using when you post something

    Note: The first boot I did on some of these took a few minutes for 3G to first come up. Any reboots later it showed up immediately. I had no service issue and triangle once or twice while I was checking all of these. Reboot always fixed it.

    The Solution:

    First, nandroid backup prior to changing anything on your phone is a good policy to follow.

    Most of the build.prop edits I’ve found are for GSM phones. I did find one thing that might help. I have confirmation from another source this hack works for them as well.

    The line to be edited in build.prop which is in your /system/ folder by root explorer, root browser or any other editor/method of choice (make sure you backup your build.prop first):

    Code:
    persist.ril.uart.flowctrl=1

    Change the “1” to “10”, save your build.prop, and reboot.

    You can change the 1 to 1-10 and null or blank.


    These are my results below in kb/s.

    1=baseline 75-100 kb/s

    0= no service – Don’t do this!
    2-5 = 100 kb/s with some temp increases
    6-9 = 150-200 kb/s
    10 = 250-350 kb/s

    A null value gives me 150-300 kb/s with large fluctuations.

    I found that “10” gave me the best speed with most consistent results.

    These speeds were clocked in actual large file downloads not a speed testing app.
    I found that speed testing apps do not give accurate results. The real downloading gives real results.

    Note: With this a tester was getting 500kb/s downloading a rom over 3G.

    Please reply back with any results you find as I am looking for conformation of my findings.

    If you try this in a different ROM please let me know your findings as well. This SHOULD work in any rooted X2.

    Doesn't work on liberty for the moment. Gonna attempt it on fully stock liberty soon

    Thanks to MoonShadow-NM for his assistance with the write up
    ----------------------------------------------------------------------------------------------------------------
    Mod 2 - Can be used along with Mod1
    Atrix lib replacement mod

    This mod I found helped with increasing data speeds in my poor service location as well as an increase in speed in a good service location

    Signal at a horrible -102 dBm I was getting a consistant 200kb/s download where I only had 100kb/s before using this in conjunction with mod 1 at a value of 10

    Signal at a nice -62 dBm I got a nice 400-500kbs consistant download speed where I only had 250-300kb/s before using this in conjunction with mod 1 at a value of 10
    Note: You may see a better increase as I am a huge data user and subject to network optimization by evil red.

    This mod at my house also stopped my phone from jumping between two towers. One with a -130 signal and the better with a -102.

    The attached file is an Atrix lib_motoril.so file. It is a different file from our stock blur file. It is about 50kb smaller in size then any X2 blurbased non-port rom file I found. It was given to me to try by a Alien port user after talking with him about his nice data speeds and connections prior to any modifications.

    This is a fairly easy file swapping mod.

    Download the attached atrix lib and extract wherever you want.

    Navigate to the /system/lib/ folder in a file manager of choice and either backup by placing a .bak after the .so of the original libmoto_ril.so file.

    Go to where you extracted the Atrix lib file. Copy and paste that file to your /system/lib folder and then set permissions to the rw-r--r-- for it..

    Reboot and let me know if you had the same good results as me.

    Thanks to kinevil for the atrix lib and idea to try this file!


    I make sure BSR is installed before I try anything so I can do a battery pull and get into BSR. Wipe cache and dalvik if any issues come up first then you can always nandroid after that if needed.
    -----------------------------------------------------------------------------------------------------------------

    Mod 3 - May help with connection stability. Not speed.

    Easy build.prop addtion

    In a fike manager such as root browser and root manager got to /system/ and open your build.prop to edit.
    Add the following line.

    Code:
    ro.mot.eri.losalert.delay=

    The standard mod for this us 1000. Feel free to play around with it. Please post your results.

    Happy modding!
    3
    Below are my results using speedtest:

    Before mod/reboot: .50 down. .55 up
    1 min after mod/reboot: .70 down. .14 up
    6 min after mod/reboot: 1.13 down. .52 up

    So it seems better. Not sure on the fluctuations after mod though. I'm sitting at my desk at work and haven't moved and all this was completed in a 10 min window. Thoughts?

    Sent from my DROID X2 using Tapatalk

    Use a real download from the web and watch it. This app works well to watch download rate https://market.android.com/details?id=info.kfsoft.android.TrafficIndicator

    Looks to me like it doubled what's your app says on a before and after

    Sent from my Cyanocrack using Xparent Blue Tapatalk
    2
    I've done 1 & 2 with marginal results. Where should I add the line in build.prop? Just anywhere or below mod 1?

    Sent from my MB855 using xda app-developers app

    Anywhere is fine the bottom is usually easiest. I don't know that it would work on the droid especiallymod 2. 1 and 3 would probably

    Sent from my EVO using Tapatalk 2
    2
    Thanks for your response, and yes its cdma.
    Which mods should I use? All of them, or just only one, or two?

    just 1 and 3
    2
    where the hell is the build.prop located? I cannot for the life of me remember where it is!!!

    I found the build.prop but what the hell am I editing? I am sorry but i dont understand. I see a long list of things and am unsure what exactly needs to be edited
    In /system.