• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[MOD] Always On Display Enabler - Magisk Module

Search This thread


Forum Moderator
Staff member


  • Screenshot_20200412-120208.jpg
    66.9 KB · Views: 591


Senior Member
Sep 21, 2012
I flash this on my OnePlus 7T and restart, however I don't even see the module in magisk afterwards? There's no indication of any errors when I install it.


Senior Member
Apr 27, 2017
I get invalid zip error when trying to flash this both in magisk and orangefox.
Any way to fix this?

I tried to understand how this zip works and found that it sets the boolean value of
config_dozeAlwaysOnDisplayAvailable to true. What about config_dozeAlwaysOnEnabled, doesn't that also need to be touched? (see Here)
I'm running los18.1 by zeelog on mido.

Top Liked Posts

  • There are no posts matching your filters.
  • 3
    Dear all,
    I have removed some off topic posts from this thread. Please show respects to developers and users who are doing work at their free time. Thanks.

    Rule refresher:

    2.3 Flaming / Lack of respect: XDA is about sharing and this does not involve virtual yelling (flaming) or rudeness. Flaming or posting with a lack of respect is unacceptable. Treat new members in the manner in which you would like to have been treated when you were a new member. When dealing with any member, provide them with guidance, advice and instructions when you can, showing them respect and courtesy. Never post in a demanding, argumentative, disrespectful or self-righteous manner.

    Forum Moderator
    I tried this module on my klte Galaxy S5 running LOS 16, and the option shows up and enables, but when AOD is active, it blinks on and off. Besides that, it seems to operate just fine. When I cover the top of my phone where the ambient light sensor is, it stays off.

    Now, I know I'm running an older device without much hope for real AOD support, so I'm not asking you to fix my problem. But if you had an idea of what might be causing the blinking behavior, what would it be? My guess is something to do with the light sensor?
    Please try this modified AODEnablerv3 I created. All I did was let it install to system/product/overlay again but this fixed the flickering Issue I had on my Note 4 running Resurrection Remix 7.0.0
    I noticed that this was changed between AODEnabler.zip and AODEnablerv3.zip so maybe the "newer" Method just won't work with our older devices
    deep sleep working but it doesnt move around. i put a dollar bill to measure, it doesnt move. burn in incomingggg

    I use this module since its existence and i hate burn in as much as everyone else, i check it now and then with burn in fixer and i got zero nada nothing burned in my screen, stop fear mongering please.

    Great module, I have one issue, when my pixel XL is sleep for a while and I double tap to wake it up it doesn't seem to work, if I'm using it and I have it off for a couple minutes it will work, the last version before i updated didn't have that issue

    Dev already knows about the issue mate, fix will come don´t worry. Also if you get a new notification or move the device a little after it´s sleeping for a while it works, it´s weird i know.
    You can prevent battery drain by putting phone upside down as the screen turns off in 5 seconds when phone is in pocket
    Hi. I'm the dev of Lawnstep/QuickSwitch, and a bunch of my users have been reporting breakages when this module is installed.

    I just had a read of this thread and saw you fixed it but looking for the module directly only linked me here which only has the original module. I'm not sure if that's where my users are getting it but I had to search for your username to find this thread. (Also a little tip, id recommend not setting the priority to 1. We only set it to 99 as we didn't think others would so we wouldn't get conflicts lol. Perhaps a more random number between 1 and 99 would be better.)

    Also just one other thing, but /product/overlay doesn't work on every device as far as I know and when this module is installed QuickSwitch detects /product/overlay as a possible overlay dir and as it has top priority it will always use it.

    Have you tried putting your overlay in /vendor/overlay? That should work fine for basically every device except for huawei devices which use /product/overlay.

    Sent from my LGE Nexus 5X using XDA Labs