[MOD] Data Latency (Slow Data) Fix

mysterioustko

Senior Member
Sep 15, 2007
613
316
0
Atlanta, Ga
thesmartphonechamp.com
I've noticed that the data on the Sensation seems to have a bit of latency. I decided to poke around in the phone as much as I can and I found a setting called "toggle ciphering". When I turned "toggle cyphering" off, my data seemed to greatly improve. I am not getting the same data lag that I was previously getting. Hopefully this isn't just some coincidence. Well without further delay, here's what I did:
-Go into the dialer and dial *#*#4636#*#*
-Select Phone Info
-Go to the "toggle cyphering" button and disable it
-For good measure turn off radio and then turn it back on
-Then reenable the "toggle cyphering" button

This seems to have made a difference for me, hopefully this helps everyone. Please post your results after doing this. :)


P.S. Mods I meant to put this thread in the General section. Sorry about that :)
 
Last edited:

catohagen

Senior Member
May 27, 2010
99
9
0
might be unsafe settings to play with, but i did try 'toggle cyphering' off and damn
the speed is really noticable faster...

thx for the tip :)
 

mysterioustko

Senior Member
Sep 15, 2007
613
316
0
Atlanta, Ga
thesmartphonechamp.com
might be unsafe settings to play with, but i did try 'toggle cyphering' off and damn
the speed is really noticable faster...

thx for the tip :)
ok good to see it isn't just me. Also I found that you can turn the cyphering back on and still maintain the speed increase. Browsing on my Sensation is now faster than on my G2X when I compared them side by side. Before my G2X was winning hands down, now the Sensation is coming out faster.
 

ChrisAC84

Senior Member
Nov 11, 2009
703
58
0
36
Clinton, TN
It seems to have helped. I used to get Network error on the Market a few times, even though I had 4 bars on a 4G connection. Now it connected right away after a few seconds, and only one network error. Thanks for the tip. What would happen if we just left the data ciphering off?
 

dr9722

Senior Member
Oct 8, 2008
667
99
0
Newhaven
Thanks for the tip.

Excuse the noob question but is the UK version of the Sensation 4G capable? I know the UK doesnt have 4G infrastructure in place yet but if I was to take the phone to the States for example would I get a 4G connection?
 

madindehead

Senior Member
Apr 14, 2009
2,292
81
0
Thanks for the tip.

Excuse the noob question but is the UK version of the Sensation 4G capable? I know the UK doesnt have 4G infrastructure in place yet but if I was to take the phone to the States for example would I get a 4G connection?
As far as I know it wouldn't, as it doesn't have the correct hardware inside it to connect to 4G data bands. Our devices are GSM here, in the States, it's CDMA.
 

eadred

Senior Member
Jan 21, 2010
332
59
0
I've noticed that the data on the Sensation seems to have a bit of latency. I decided to poke around in the phone as much as I can and I found a setting called "toggle ciphering". When I turned "toggle cyphering" off, my data seemed to greatly improve. I am not getting the same data lag that I was previously getting. Hopefully this isn't just some coincidence. Well without further delay, here's what I did:
-Go into the dialer and dial *#*#4636#*#*
-Select Phone Info
-Go to the "toggle cyphering" button and disable it
-For good measure turn off radio and then turn it back on
-Then reenable the "toggle cyphering" button

This seems to have made a difference for me, hopefully this helps everyone. Please post your results after doing this. :)


P.S. Mods I meant to put this thread in the General section. Sorry about that :)
I just don't understand what it means 'turn off radio'? You mean mobile data, or what? Thanks
 

dr9722

Senior Member
Oct 8, 2008
667
99
0
Newhaven
I just don't understand what it means 'turn off radio'? You mean mobile data, or what? Thanks
Just under the Toggle Cyphering button there is a button to Turn off Radio. Push this, wait a few moments and then turn it back on again. Failing that just put the phone in Airplane mode.
 

rahan95

Senior Member
Aug 30, 2006
339
185
0
Works very well for me too.

I had noticed Speedtest would fail the upload test on my device all the time, just freezing

Now, I'm getting an excellent 1.6 Mbps upload speed !

Thanks !