[MOD] Disable On Screen when receiving a Text

Search This thread

PuffJr2

Senior Member
May 4, 2013
92
63
To disable this feature, you need root.

start off by opening up a file explorer, I used Root Browser.
head off to /data/data/com.android.mms/shared_prefs/
once in that folder, open up com.android.mms_preferences.xml
scroll down and find <boolean name="pref_key_backlight" value="true" />
change true to false.
save, and reboot.

have someone send you a message with the screen off. it should work. :)
 

seanatsb

Senior Member
Sep 16, 2010
78
11
Philly
FINALLY!!!!!!! I've been trying to find a solution for this for weeks without having to use a different messaging app or an app to control notifications!

Thank you very much for sharing!!!!!!


To disable this feature, you need root.

start off by opening up a file explorer, I used Root Browser.
head off to /data/data/com.android.mms/shared_prefs/
once in that folder, open up com.android.mms_preferences.xml
scroll down and find <boolean name="pref_key_backlight" value="true" />
change true to false.
save, and reboot.

have someone send you a message with the screen off. it should work. :)
 

PuffJr2

Senior Member
May 4, 2013
92
63
no problem man, Im not a fan of the screen turning on when you receive anything so I find a way to shut it off.

Sent from my SCH-I925
 

kkl1993

Senior Member
Jun 1, 2010
91
22
Florida
To disable this feature, you need root.

start off by opening up a file explorer, I used Root Browser.
head off to /data/data/com.android.mms/shared_prefs/
once in that folder, open up com.android.mms_preferences.xml
scroll down and find <boolean name="pref_key_backlight" value="true" />
change true to false.
save, and reboot.

have someone send you a message with the screen off. it should work. :)

Every time I change the file to false and reboot, it reverts back to its old settings. How do I fix this?
 

sgtcasey

Senior Member
Mar 2, 2007
75
5
To disable this feature, you need root.

start off by opening up a file explorer, I used Root Browser.
head off to /data/data/com.android.mms/shared_prefs/
once in that folder, open up com.android.mms_preferences.xml
scroll down and find <boolean name="pref_key_backlight" value="true" />
change true to false.
save, and reboot.

have someone send you a message with the screen off. it should work. :)

On my Verizon SGS5, rooted, it already says true and the phone screen never comes on when I receive any message. I would like it to. Any ideas?
 

sgtcasey

Senior Member
Mar 2, 2007
75
5
are you using a different MMS program or Stock Samsung one?

I'm using Textra but even when I used the default one after first getting the phone I never noticed it lighting up when I'd receive a message. It was one of the things I was a little disappointed at when compared to the iPhone 5 I switched over from but certainly wasn't something to get all upset over.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 31
    To disable this feature, you need root.

    start off by opening up a file explorer, I used Root Browser.
    head off to /data/data/com.android.mms/shared_prefs/
    once in that folder, open up com.android.mms_preferences.xml
    scroll down and find <boolean name="pref_key_backlight" value="true" />
    change true to false.
    save, and reboot.

    have someone send you a message with the screen off. it should work. :)
    3
    I am using Root Explorer

    try using Root Browser. it'll have a popup when you click the xml file, use RB text editor.
    1
    So when the screen is off and I get a text the screen will my light up?

    Sent from my SM-G900V using XDA Free mobile app

    it should not light up. I did this to mine because I hate when its in my pocket and starts to unlock. ha.

    Sent from my SCH-I925
    1
    I'm using Textra but even when I used the default one after first getting the phone I never noticed it lighting up when I'd receive a message. It was one of the things I was a little disappointed at when compared to the iPhone 5 I switched over from but certainly wasn't something to get all upset over.

    That's pretty strange.
    You could try changing it to false, rebooting and back to true to see if it works.
    But, if that doesn't, you may have to take apart SecMms_Blue.apk/odex to edit the preference for it.
    I've been working on trying to get the option to work, but no luck yet.
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone