[MOD] Faster WIFI for X8 - N standard enabling

Search This thread

Graveir

Senior Member
Jan 5, 2011
703
238
Łódź
Hi folks!

The modification I present here comes from this thread.

So far tested on: miniCM RC1, CM7 RC4

To work!

1. We go to /system/etc/firmaware directory and find files named:
Code:
/etc/firmware/fm_rx_init_1273.2.bts
/etc/firmware/fm_tx_init_1273.2.bts
/etc/firmware/fmc_init_1273.2.bts
2. Are they there? Good, don't touch them. Are they not there? Well, it's a pity, you won't get 5GHz band :p
3. Go back to /system/etc and find a file named tiwlan.ini
NOTE: In CM7 based ROMs the path may be /system/etc/wifi
4. Look for the following lines:
Code:
HT_Enable=0                                           #0=diable 802.11n support / 1=Enable
BurstModeEnable = 0                                   # 0 - Disabled  1 - Enabled
WiFiAdhoc = 0
and change them into:
Code:
HT_Enable=1                                           #0=diable 802.11n support / 1=Enable
BurstModeEnable = 1                                   # 0 - Disabled  1 - Enabled
WiFiAdhoc = 1
5. This stage is for people who have files from step 1!
Look for the line:
Code:
Single_Dual_Band_Solution = 0
and change it into
Code:
Single_Dual_Band_Solution = 1
6. Save, reboot.

Troubleshooting: If after enabling your wifi keeps disconnecting, or you get the "connecting" bug, go to settings->networks->wifi, erase all remembered networks and reboot.

Disclamer: if you crush your wifi or brick your phone, I'm not responsible for it.

5GHz band and AdHoc features need testing to prove they work, N standard 100% working.
Also, I've been told that each ROM has different tiwlan file - if it's so, then we need custom zip for each ROM available. I'm not familiar with how it's done, so if someone could prepare them I'll attach them to the first post :)

Enjoy, X8 users!
 
Last edited:

owain94

Inactive Recognized Developer
Sep 21, 2010
3,538
6,041
27
The Hague
Thanx for this when i got home i will test on my mini pro with 5gHz if it works i will include it as standart in my rom (mini and mini pro roms)

Sent from my U20i using XDA Premium App
 

Graveir

Senior Member
Jan 5, 2011
703
238
Łódź
Well, I've installed it something like half an hour ago, so I can't say for sure. There are two possibilities:
1. Since we already had more aerials in our phones, only they were unused, the battery drain with enabled wifi will stay as it was.
2. The additional aerials for n standard were inactive (I don't know if it's possible if they're on one chip, though) and after enabling them the battery drain will increase.

What can I say - check it yourself :p
 

Graveir

Senior Member
Jan 5, 2011
703
238
Łódź
i noticed no defference !!!!!!!

Check stuff like connection speed or distance that you can now have from you router. Mayhaps you simply have a good router hardware and the difference is hard to spot - I feel an improvement personally ;)

But if you feel you don't need it - switch it off, why risk a higher battery drain if nothing really changes ;)
 

ponanovn

Senior Member
Dec 31, 2010
573
667
Can anyone confirm by checking connected devices in your routers status?
192.168.0.1
192.168.1.1
and username and password is often:
Code:
admin
admin
or
Code:
admin
1234

EDIT: If anyone can confirm this I will add this to the next MiniCM.
 
Last edited:

Graveir

Senior Member
Jan 5, 2011
703
238
Łódź
TESTS:
http://forum.android.com.pl/f257/mo...i-802-11n-dla-x8-60185/index4.html#post541352

What I'm posting is a translation of the linked post:

I'm currently using Sense CM7RC3 ROM. In my tiwlan.ini file (which in my case was in /system/etc/wifi) I changed only the lines:
HT_Enable=1
BurstModeEnable = 1

After a restart the phone established connection with Dlink Dir-615 router with firmware dd-wrt without any problem. In order to make sure if the phone is working in n standard I switched the router into N-only mode and it works, while my other phone without this improvement lost connection.
As I use FTP server in my phone on daily basis I made some speed tests.
In G mode I get average of 700kBps.
In N mode I get slightly more - 800kBps.
This means that the phone cannot even fully use the functionality of B standard. Let's add that during saving files on 4 class SD card via USB I get about 1500 kBps.

During tests I was using channel 1, however, there is another network in my range working on the same channel, so I switched my router in channel 13 and the connection speed dropped below 100 kBps.

The Single_Dual_Band_Solution = 1 issue:
I need more tests, but it seems that it does not unlock 5GHz band, but rather extends 2,4Ghz one. In the 2.4 there are 14 channels defined, but you cannot use any above the 9th, this setting allows to use 10-14 channels.

I also tasted range, and there is a considerable improvement here. In the room where G standard was working unstably and slower, N works flawlessly.

Hope it's enough :)
 
  • Like
Reactions: ponanovn

Graveir

Senior Member
Jan 5, 2011
703
238
Łódź
What'd you know, you're right... I'll post it on polish board then and ask for more tests :) However, this still means that n standard works, and that 5GHz band might be operational! :)
 

-ReaL-

Senior Member
Nov 6, 2009
367
117
32
Yoshkar-Ola
Find variable:
Code:
WiFiAdhoc = 0
Change it to:
Code:
WiFiAdhoc = 1
Now you can connect to Ad|hoc (computer<>computer networks)
 
  • Like
Reactions: Graveir

smoczoos

Member
Dec 14, 2010
31
0
Tested on racht's v0.15 Floyo. Wifi connected to my TP-Link WR740N. Was set as 11n only. But after 10-15 secs phone couldn't find any network. Restart of wifi doesn't work.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 36
    Hi folks!

    The modification I present here comes from this thread.

    So far tested on: miniCM RC1, CM7 RC4

    To work!

    1. We go to /system/etc/firmaware directory and find files named:
    Code:
    /etc/firmware/fm_rx_init_1273.2.bts
    /etc/firmware/fm_tx_init_1273.2.bts
    /etc/firmware/fmc_init_1273.2.bts
    2. Are they there? Good, don't touch them. Are they not there? Well, it's a pity, you won't get 5GHz band :p
    3. Go back to /system/etc and find a file named tiwlan.ini
    NOTE: In CM7 based ROMs the path may be /system/etc/wifi
    4. Look for the following lines:
    Code:
    HT_Enable=0                                           #0=diable 802.11n support / 1=Enable
    BurstModeEnable = 0                                   # 0 - Disabled  1 - Enabled
    WiFiAdhoc = 0
    and change them into:
    Code:
    HT_Enable=1                                           #0=diable 802.11n support / 1=Enable
    BurstModeEnable = 1                                   # 0 - Disabled  1 - Enabled
    WiFiAdhoc = 1
    5. This stage is for people who have files from step 1!
    Look for the line:
    Code:
    Single_Dual_Band_Solution = 0
    and change it into
    Code:
    Single_Dual_Band_Solution = 1
    6. Save, reboot.

    Troubleshooting: If after enabling your wifi keeps disconnecting, or you get the "connecting" bug, go to settings->networks->wifi, erase all remembered networks and reboot.

    Disclamer: if you crush your wifi or brick your phone, I'm not responsible for it.

    5GHz band and AdHoc features need testing to prove they work, N standard 100% working.
    Also, I've been told that each ROM has different tiwlan file - if it's so, then we need custom zip for each ROM available. I'm not familiar with how it's done, so if someone could prepare them I'll attach them to the first post :)

    Enjoy, X8 users!
    2
    FYI I'm putting this in the next 3G TurboCharger update... ;)
    1
    TESTS:
    http://forum.android.com.pl/f257/mo...i-802-11n-dla-x8-60185/index4.html#post541352

    What I'm posting is a translation of the linked post:

    I'm currently using Sense CM7RC3 ROM. In my tiwlan.ini file (which in my case was in /system/etc/wifi) I changed only the lines:
    HT_Enable=1
    BurstModeEnable = 1

    After a restart the phone established connection with Dlink Dir-615 router with firmware dd-wrt without any problem. In order to make sure if the phone is working in n standard I switched the router into N-only mode and it works, while my other phone without this improvement lost connection.
    As I use FTP server in my phone on daily basis I made some speed tests.
    In G mode I get average of 700kBps.
    In N mode I get slightly more - 800kBps.
    This means that the phone cannot even fully use the functionality of B standard. Let's add that during saving files on 4 class SD card via USB I get about 1500 kBps.

    During tests I was using channel 1, however, there is another network in my range working on the same channel, so I switched my router in channel 13 and the connection speed dropped below 100 kBps.

    The Single_Dual_Band_Solution = 1 issue:
    I need more tests, but it seems that it does not unlock 5GHz band, but rather extends 2,4Ghz one. In the 2.4 there are 14 channels defined, but you cannot use any above the 9th, this setting allows to use 10-14 channels.

    I also tasted range, and there is a considerable improvement here. In the room where G standard was working unstably and slower, N works flawlessly.

    Hope it's enough :)
    1
    Find variable:
    Code:
    WiFiAdhoc = 0
    Change it to:
    Code:
    WiFiAdhoc = 1
    Now you can connect to Ad|hoc (computer<>computer networks)
    1
    The router must be set on which.
    11b only
    11g only
    11bg mixed. Or
    11bgn mixed.


    PLEASE HELP

    Sent from my U20i using xda premium


    11bgn mixed. Router will choose best possible connection.