• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[MOD]i9195 Disable HOME button on lockscreen(rooted stock rom)[MOD]

Search This thread

jodge

Senior Member
Nov 7, 2006
63
32
Hi

The main goal: disabling the home button wake on the lockscreen and every other home fuction remain the same

this solution based on this tutorial:
http://forum.xda-developers.com/showthread.php?t=2224688

you need root acces:
http://forum.xda-developers.com/showthread.php?t=2364980

Download Total Commander from Play (it's better bcose there is automatic moun/remount function )
https://play.google.com/store/apps/details?id=com.ghisler.android.TotalCommander

- allow root acces to TC
- navigate to /system/usr/keylayout
- locate and copy to safe place gpio-keys.kl and sec_keys.kl
- open the original files with TC editor (press once on the filename and choose "Edit")
- Search the following lines in gpio-keys.kl:
Code:
key 102 HOME        WAKE
key 172 HOME        WAKE
and delete the WAKE world and all spaces after HOME!
it should be looking:
Code:
key 102 HOME
key 172 HOME

- save gpio-keys.kl (TC do all mount-remount thing)

- Search the following line in sec_keys.kl:
Code:
key 172 HOME        WAKE
and delete the WAKE world and all spaces after HOME!
it should be looking:
Code:
key 172 HOME

- save sec_keys.kl (TC do all mount-remount thing)

restart the phone and enjoy :)
 
Last edited:

Whosat

Senior Member
May 9, 2013
789
266
If you're using CM, go to Settings - Display and Uncheck the second last option to achieve the same effect in a much simpler way :)
 

Attachments

  • 1381496295881.jpg
    1381496295881.jpg
    58.8 KB · Views: 3,129

miso00

Senior Member
Jun 5, 2012
54
11
Very useful tutorial. Thank you a lot. My phone used to unlock itself in my pocket and then make a call or mess up settings... S4 mini reacts to touches trough thin cloth. This wasn't problem on HTC.
 

tobbbie

Senior Member
Jan 5, 2007
1,452
252
Stuttgart
Wanam xposed module can do it ss well. Obviously you need to have xposed framework installed.

Sent from my GT-P3110 using XDA Free mobile app
 

timothybaran

New member
Jul 15, 2014
3
0
Not working with my AT&T S3 with stock 4.4.2 android. This is driving my nuts. There has to be a way to disable this. HELP!!!
 

zxcvbe

New member
Jun 25, 2014
4
0
Hi,

I've rooted my Galaxy S4 mini because the home button is turning on the screen continiously draining my battery. The root was succesfull, but i cant edit the files with Total commander. I get a 're-mount error'. Anyone know how to solve this? I'm running stock android 4.2.2.

I also tried installing Wanam Xposed and found the option, but it didn't work.

Thanks
 
Last edited:

no-idea

Member
Mar 22, 2008
23
9
Removing WAKE didn't help my either. I had to comment out (#) the whole line in gpio-keys.kl.

Now HOME is completely disabled and I installed Auto Hide Soft Keys to create a virtual nav bar.

On the other hand, who needs HOME ;)
 
  • Like
Reactions: zxcvbe

zxcvbe

New member
Jun 25, 2014
4
0
Removing WAKE didn't help my either. I had to comment out (#) the whole line in gpio-keys.kl.

Now HOME is completely disabled and I installed Auto Hide Soft Keys to create a virtual nav bar.

On the other hand, who needs HOME ;)

Thanks for your reaction! My problem is that i cant change the gpio-keys.kl file. I get a 're-mount error'. But maybe i will need your suggestion further on.
 

no-idea

Member
Mar 22, 2008
23
9
Hmmm, phone is rooted?

I used ES File Explorer in Root Mode, changed gpio-keys.kl file permissions to rx-rx-rx, edited the file and restored permissions to rx-r-r. After a reboot, HOME was disabled.
 

zxcvbe

New member
Jun 25, 2014
4
0
Hmmm, phone is rooted?

I used ES File Explorer in Root Mode, changed gpio-keys.kl file permissions to rx-rx-rx, edited the file and restored permissions to rx-r-r. After a reboot, HOME was disabled.

Yes the phone is rooted. I checked it with root checker. Maybe i need to change the the file permissions. How can i do this? With ES file explorer?
Do you use stock android ?
 

no-idea

Member
Mar 22, 2008
23
9
Yes I'm on stock rom.

Open ES Explorer and go to Tools. Switch on Root Explorer. Mark the file and change the permissions via More > Properties. Just add the middle and lower check on the right side.

Now edit the file and change the permissions back.
 
  • Like
Reactions: zxcvbe

zxcvbe

New member
Jun 25, 2014
4
0
I am able to save the file now, but the home button is still functioning. I commented out the lines with HOME in gpio-keys.kl and rebooted. But still the screen keeps turning on because of the home button.:crying:
 

iamsorandom

New member
Jul 20, 2013
2
0
In reverse?

Anyone know if the opposite variation on this is possible?
I.e., I'd like to be able to use the home button to wake my phone up, but not to take me to the home screen, simply to turn the screen on so I can continue with whatever app I'm currently using, such as gps... (if it can carry on working as home button when the screen is already on, that would be fine).

Using the side power button can sometimes be a hassle and I'd like a way to simply turn the screen on quickly. I'm also on CM not stock though...

Thanks!
 

Top Liked Posts

  • There are no posts matching your filters.
  • 4
    Hi

    The main goal: disabling the home button wake on the lockscreen and every other home fuction remain the same

    this solution based on this tutorial:
    http://forum.xda-developers.com/showthread.php?t=2224688

    you need root acces:
    http://forum.xda-developers.com/showthread.php?t=2364980

    Download Total Commander from Play (it's better bcose there is automatic moun/remount function )
    https://play.google.com/store/apps/details?id=com.ghisler.android.TotalCommander

    - allow root acces to TC
    - navigate to /system/usr/keylayout
    - locate and copy to safe place gpio-keys.kl and sec_keys.kl
    - open the original files with TC editor (press once on the filename and choose "Edit")
    - Search the following lines in gpio-keys.kl:
    Code:
    key 102 HOME        WAKE
    key 172 HOME        WAKE
    and delete the WAKE world and all spaces after HOME!
    it should be looking:
    Code:
    key 102 HOME
    key 172 HOME

    - save gpio-keys.kl (TC do all mount-remount thing)

    - Search the following line in sec_keys.kl:
    Code:
    key 172 HOME        WAKE
    and delete the WAKE world and all spaces after HOME!
    it should be looking:
    Code:
    key 172 HOME

    - save sec_keys.kl (TC do all mount-remount thing)

    restart the phone and enjoy :)
    1
    Removing WAKE didn't help my either. I had to comment out (#) the whole line in gpio-keys.kl.

    Now HOME is completely disabled and I installed Auto Hide Soft Keys to create a virtual nav bar.

    On the other hand, who needs HOME ;)
    1
    Yes I'm on stock rom.

    Open ES Explorer and go to Tools. Switch on Root Explorer. Mark the file and change the permissions via More > Properties. Just add the middle and lower check on the right side.

    Now edit the file and change the permissions back.