[MOD][JB][Camera] Cyber-shot™ For Xperia Z & ZL "Updated 13-04-2013"

Search This thread

Rizal Lovins

Recognized Developer / Themer / Inactive RC
May 30, 2012
1,617
15,948
Bandung
LG V30
NOTE: If you want to use Cyber-shot™ in your own ROMs, I really don't have anything, but please, before you do that, speak to me first. this is my projects hours of hard work, so please respect my decision

ONE OF THE MOST EVER CAMERA MOD DOWNLOADED​

My Camera Mod Started From Xperia 2011 Xperia 2012



About Cyber-shot™

Camera Mod Cyber-shot™ is made to improve the quality of images, video and audio recordings as you want, you will find the best camera experience from SONY

Requirements For Install Cyber-shot™ :

You should use Official JB ROM or Custom ROM Based Stock JB
Rooted Phone


Hello Friends ......

This is my first Thread on Xperia Z / ZL Forum :cowboy: :fingers-crossed: :p

I know that Xperia Z / ZL is a nice Camera, but I try to improve image quality in certain light conditions :p


Version 1


What's New ? :


- Initial release
- Implementing Burst Mode Quality to Camera (Normal Mode) (WIP)
- Small Improved Image Quality
- 100% JPEG Quality
- Modded media_profile.xml
- New app label/name changed to Cyber-shot™
- Some New Driver Camera
- All the bitmaps changed to ARGB_8888 from RGB_565 for better image quality.
- Tried to enable inPreferQualityOverSpeed and inDither to the bitmap
- Audio bitrate changed to 256kbps Video Recording
- Bitrate Video Recording Full HD 17,5mbps-25mbps


Version 2


What's New ? :


- Bitrate Video Recording Full HD locked in 20mbps
- Bitrate Video Recording HD changed to 15mbps
- Fix not Installed
- ReModded media_profile.xml
- Fix 100% JPEG Quality
- Signed apk
- Zipaligned


Version 3


What's New ? :


- Fix Video Recording (Stock Bitrate)
- Fix not installed
- Signed
- Zipaligned

Download :


Download Cyber-shot™ JB v.3.1.1 Xperia Z/ZL (Stable Version)


***************************************************************************************************************************************************​
INSTALLATIONS​
***************************************************************************************************************************************************​

JUST APPLY VIA CWM/TWRP, DON'T FORGET BEFORE INSTALLING, PLEASE WIPE CACHE PARTISION, WIPE DALVIK CACHE, REBOOT & ENJOY...!!!​

After installing please clear data Cyber-shot™ in setting>applications>all


Note : Please Backup Before Installing



Credit :
Xperia-Ray
krabappel2548 for support me
 
Last edited:

Rizal Lovins

Recognized Developer / Themer / Inactive RC
May 30, 2012
1,617
15,948
Bandung
LG V30
This is value media_profile.xml i change and this is what I'm adjusting to change in SemcCameraUI.apk

You can't change media_profile.xml without Editing Parameter in SemcCameraUI.apk


Code:
<!ATTLIST ImageEncoding quality [COLOR="Red"](100|100|100|100|100|100)[/COLOR] #REQUIRED>

        <EncoderProfile quality="1080p" fileFormat="mp4" duration="60">
            <Video codec="h264"
                   bitRate="20000000"
                   width="1920"
                   height="1080"
                   frameRate="30" />

            <Audio codec="aac"
                   bitRate="[COLOR="Red"]256000[/COLOR]"
                   sampleRate="48000"
                   channels="2" />
        </EncoderProfile>

        <ImageEncoding quality="[COLOR="Red"]100[/COLOR]" />
        <ImageEncoding quality="[COLOR="Red"]100[/COLOR]" />
        <ImageEncoding quality="[COLOR="Red"]100[/COLOR]" />
        <ImageDecoding memCap="[COLOR="Red"]30000000[/COLOR]" />

    </CamcorderProfiles>

[COLOR="Red"]
    <!--
         If a codec is not enabled, it is invisible to the applications
         In other words, the applications won't be able to use the codec
         or query the capabilities of the codec at all if it is disabled[/COLOR]

    <VideoEncoderCap name="h264" enabled="true"
        minBitRate="96000" maxBitRate="[COLOR="Red"]20000000[/COLOR]"
        minFrameWidth="176" maxFrameWidth="1920"
        minFrameHeight="144" maxFrameHeight="1088"
        minFrameRate="1" maxFrameRate="30" />

    <VideoEncoderCap name="m4v" enabled="true"
        minBitRate="64000" maxBitRate="[COLOR="Red"]20000000[/COLOR]"
        minFrameWidth="176" maxFrameWidth="1920"
        minFrameHeight="144" maxFrameHeight="1088"
        minFrameRate="1" maxFrameRate="30" />


    <AudioEncoderCap name="aac" enabled="true"
        minBitRate="8000" maxBitRate="[COLOR="Red"]256000[/COLOR]"
        minSampleRate="8000" maxSampleRate="48000"
        minChannels="1" maxChannels="2" />



Activating 100% JPEG Quality in build.prop

add this line

Code:
ro.media.enc.jpeg.quality=100
 
Last edited:

sacredsoul

Senior Member
Feb 17, 2007
1,894
565
Singapore
Please let me be the first to say thank you. You might just have saved the entire camera problem of the Z. Installed fine on KA04. :)

One request, if possible, could you fix the screen when the camera is in Normal mode and ISO is set to 100? The screen is extremely dark indoors with the ISO set to 100 but the picture turns out fine.
 
Last edited:

FiDra

Senior Member
Jul 30, 2010
297
87
Sony Xperia 1
Sony Xperia 5 II
Thanks.
But after flashing the package, I lost my camera. There is no camera in app drawer.
I tried to use Root explorer to move camera to system but the phone is getting reboot each time I mount rw. :(

Please help!
thanks.
 

Rizal Lovins

Recognized Developer / Themer / Inactive RC
May 30, 2012
1,617
15,948
Bandung
LG V30
Please let me be the first to say thank you. You might just have saved the entire camera problem of the Z. Installed fine on KA04. :)

One request, if possible, could you fix the screen when the camera is in Normal mode and ISO is set to 100? The screen is extremely dark indoors with the ISO set to 100 but the picture turns out fine.

yeah coz you set to 100 ... ISO 100 for out door, ISO 100 for reduce noise but quality color of image will reduce

Thanks.
But after flashing the package, I lost my camera. There is no camera in app drawer.
I tried to use Root explorer to move camera to system but the phone is getting reboot each time I mount rw. :(

Please help!
thanks.

Try back to stock camera, reboot ... open camera take some photo, reboot to recovery install again don't forget before installing please mount system

Enjoy!! ;)
 
  • Like
Reactions: FiDra

zaynal

Senior Member
Apr 16, 2011
202
74
Thanks.
But after flashing the package, I lost my camera. There is no camera in app drawer.
I tried to use Root explorer to move camera to system but the phone is getting reboot each time I mount rw. :(

Please help!
thanks.

Same here. Lost my camera app as well.

EDIT: Tried to move it manually to system/app, still not appeared in app drawer.
 
Last edited:

GSeeker

Senior Member
Aug 12, 2008
366
103
Guangzhou
format cache, mount system, flash zip, and now Camera is gone, and no Cyber-Shot shows up.:(

Sent from my C6603 using xda premium
 

SaGaR_

Senior Member
Apr 5, 2013
231
34
i must say, apart from the problems now reported like the camera app is lost and stuff, it looks as a promising project!
one day i will definitely try this!
keep up the good work :D
 

anirudhks

Senior Member
May 7, 2009
1,205
1,079
Thanks.
But after flashing the package, I lost my camera. There is no camera in app drawer.
I tried to use Root explorer to move camera to system but the phone is getting reboot each time I mount rw. :(

Please help!
thanks.

buddy this is a problem if your root is broken , reroot the device and you should be fine ... I had the same problem tooo :good::good:
 

BeDesireS

Senior Member
Aug 30, 2011
1,421
531
Trier
For all with the reboot problem after system mount,
I used the new V26 from bin4ry to root and this worked fine for me.

Script went till the end without probs and root is working fine without reeboots!
 

anirudhks

Senior Member
May 7, 2009
1,205
1,079
no, the root is fine on my Z. and still no camera.

Sent from my C6603 using xda premium

your root may work when yu open titanium or any file explorer , try just remounting ur file system on root explorer it may reboot that means there is a problem , in this case rerooting defnitely helps
 

Top Liked Posts

  • There are no posts matching your filters.
  • 109
    NOTE: If you want to use Cyber-shot™ in your own ROMs, I really don't have anything, but please, before you do that, speak to me first. this is my projects hours of hard work, so please respect my decision

    ONE OF THE MOST EVER CAMERA MOD DOWNLOADED​

    My Camera Mod Started From Xperia 2011 Xperia 2012



    About Cyber-shot™

    Camera Mod Cyber-shot™ is made to improve the quality of images, video and audio recordings as you want, you will find the best camera experience from SONY

    Requirements For Install Cyber-shot™ :

    You should use Official JB ROM or Custom ROM Based Stock JB
    Rooted Phone


    Hello Friends ......

    This is my first Thread on Xperia Z / ZL Forum :cowboy: :fingers-crossed: :p

    I know that Xperia Z / ZL is a nice Camera, but I try to improve image quality in certain light conditions :p


    Version 1


    What's New ? :


    - Initial release
    - Implementing Burst Mode Quality to Camera (Normal Mode) (WIP)
    - Small Improved Image Quality
    - 100% JPEG Quality
    - Modded media_profile.xml
    - New app label/name changed to Cyber-shot™
    - Some New Driver Camera
    - All the bitmaps changed to ARGB_8888 from RGB_565 for better image quality.
    - Tried to enable inPreferQualityOverSpeed and inDither to the bitmap
    - Audio bitrate changed to 256kbps Video Recording
    - Bitrate Video Recording Full HD 17,5mbps-25mbps


    Version 2


    What's New ? :


    - Bitrate Video Recording Full HD locked in 20mbps
    - Bitrate Video Recording HD changed to 15mbps
    - Fix not Installed
    - ReModded media_profile.xml
    - Fix 100% JPEG Quality
    - Signed apk
    - Zipaligned


    Version 3


    What's New ? :


    - Fix Video Recording (Stock Bitrate)
    - Fix not installed
    - Signed
    - Zipaligned

    Download :


    Download Cyber-shot™ JB v.3.1.1 Xperia Z/ZL (Stable Version)


    ***************************************************************************************************************************************************​
    INSTALLATIONS​
    ***************************************************************************************************************************************************​

    JUST APPLY VIA CWM/TWRP, DON'T FORGET BEFORE INSTALLING, PLEASE WIPE CACHE PARTISION, WIPE DALVIK CACHE, REBOOT & ENJOY...!!!​

    After installing please clear data Cyber-shot™ in setting>applications>all


    Note : Please Backup Before Installing



    Credit :
    Xperia-Ray
    krabappel2548 for support me
    11
    Hello friends ....

    i'm sorry ... i'm late for update this mod, i'm still sick right now :crying:

    but I was forced to take the time for this

    here is stable version

    fix Video Recording & fix not installed

    http://d-h.st/4aN



    Enjoy!!!
    10
    Undo Cyber-shot™ camera mod

    Undo Cyber-shot™ mod
    What & How:

    Hey guys, I've made a recovery flashable zip to undo all modifications made by this mod, since many of you seem to be having problems with it.
    The original files for this were pulled from .434, but should work with .350 also.
    I've tested this on my Xperia Z & it works fine; I'm pretty sure it should work fine on ZL also.

    How to apply:
    • Download the zip
    • Push the zip to your SD Card
    • Reboot into recovery
    • Choose zip & apply
    Downloads:

    Undo_Cyber-shot™_mod_by_kgs1992.zip Mirrors:

    My server - kgs1992.com (Fast)
    Dev-Host (Fast)
    XDA Attachment (Possibly slow)
    Mediafire (Slow)

    MD5: 64b18b8baa5252ab1d33bf6995afce84
    Lastly:

    Please do hit thanks if this helped! :D
    You may need to wipe Dalvik cache & clear data for the camera app.
    If you still have any trouble/problems with this, please let me know.
    Rizal, please link to this in the OP if you think it's useful.​
    9
    This is value media_profile.xml i change and this is what I'm adjusting to change in SemcCameraUI.apk

    You can't change media_profile.xml without Editing Parameter in SemcCameraUI.apk


    Code:
    <!ATTLIST ImageEncoding quality [COLOR="Red"](100|100|100|100|100|100)[/COLOR] #REQUIRED>
    
            <EncoderProfile quality="1080p" fileFormat="mp4" duration="60">
                <Video codec="h264"
                       bitRate="20000000"
                       width="1920"
                       height="1080"
                       frameRate="30" />
    
                <Audio codec="aac"
                       bitRate="[COLOR="Red"]256000[/COLOR]"
                       sampleRate="48000"
                       channels="2" />
            </EncoderProfile>
    
            <ImageEncoding quality="[COLOR="Red"]100[/COLOR]" />
            <ImageEncoding quality="[COLOR="Red"]100[/COLOR]" />
            <ImageEncoding quality="[COLOR="Red"]100[/COLOR]" />
            <ImageDecoding memCap="[COLOR="Red"]30000000[/COLOR]" />
    
        </CamcorderProfiles>
    
    [COLOR="Red"]
        <!--
             If a codec is not enabled, it is invisible to the applications
             In other words, the applications won't be able to use the codec
             or query the capabilities of the codec at all if it is disabled[/COLOR]
    
        <VideoEncoderCap name="h264" enabled="true"
            minBitRate="96000" maxBitRate="[COLOR="Red"]20000000[/COLOR]"
            minFrameWidth="176" maxFrameWidth="1920"
            minFrameHeight="144" maxFrameHeight="1088"
            minFrameRate="1" maxFrameRate="30" />
    
        <VideoEncoderCap name="m4v" enabled="true"
            minBitRate="64000" maxBitRate="[COLOR="Red"]20000000[/COLOR]"
            minFrameWidth="176" maxFrameWidth="1920"
            minFrameHeight="144" maxFrameHeight="1088"
            minFrameRate="1" maxFrameRate="30" />
    
    
        <AudioEncoderCap name="aac" enabled="true"
            minBitRate="8000" maxBitRate="[COLOR="Red"]256000[/COLOR]"
            minSampleRate="8000" maxSampleRate="48000"
            minChannels="1" maxChannels="2" />



    Activating 100% JPEG Quality in build.prop

    add this line

    Code:
    ro.media.enc.jpeg.quality=100
    5
    Forgot to backup the original apk. :eek:

    Can anyone share the file here?

    Here you go