[MOD][MAGISK] GPE Dialer and Contacts Magisk Mod for HTC 10.

Search This thread

jsaxon2

Senior Member
Mar 3, 2010
973
701
Lock Haven, PA
OnePlus 6
OnePlus 6T
Pixel GPE Dialer and Contacts

This mod now works with Android N.

Updated to Google Pixel version of the Dialer and Contacts

I have taken the GPE Dialer and Contacts found here [url]http://forum.xda-developers.com/showpost.php?p=68096911&postcount=95[/URL] and made it a Magisk Module. This allows the Dialer to act as though it is installed directly with in the system without actually modifying the system

For information on what Majisk is and how to install it, please read here: [url]http://forum.xda-developers.com/android/software/mod-magisk-v1-universal-systemless-t3432382[/URL]

This mod was tested on the HTC 10 using Magisk v7.
Only thing you can't do is change your Wi-Fi calling preference. If you are on WiFi preferred, you can't change it unless you disable the MOD and reboot. Make your change then re-rnable the MOD and reboot again. That is the only problem I have. It is the same if you flash the original zip that writes directly to system.

This zip file requires Magisk to be installed. It will not work without Magisk.

Changes sync'd and now available to download in Magisk Manager. Thanks for those testing...

v3.0.0

Update to new Magisk template to work with Magisk v12+
Update Dialer to v8.0.148481159
Update Contacts to v1.7.6

Or download from here: Magisk-GPEDialer_HTC10.v3.0.0

Download Here:
Magisk v7 version
This can be installed through the Magisk Manager 2.0 or flashed in recovery.

Note: All updates will only be available through the Magisk Manager going forward.

10/16/16 - New update with Google Contacts 1.5.16 downloadable through the Magisk Manager...

GPEDialer Pixel Version 2.0.0
GPEDialer_v5.1.13(Magisk v7)

GPEDialer Marshmallow Version 1.0.0
GPEDialer_v4.0.12(Magisk v7)

Magisk v6 version
Flash the zip file in recovery.
GPEDialer_v4.0.12(Magisk v6)
 
Last edited:

threetwentyfizzle

Senior Member
Oct 31, 2012
1,019
410
Albuquerque
OnePlus 10 Pro
Thanks for posting, I personally prefer the Google Dialer UI over the Stock HTC. Is there any functionality issues? such as wifi calling compatibility, or speakerphone, receiving calls etc?

Sent from my HTC 10 using Tapatalk
 

jsaxon2

Senior Member
Mar 3, 2010
973
701
Lock Haven, PA
OnePlus 6
OnePlus 6T
Thanks for posting, I personally prefer the Google Dialer UI over the Stock HTC. Is there any functionality issues? such as wifi calling compatibility, or speakerphone, receiving calls etc?
Everything is working for me. I am on US Unlocked firmware on T-Mobile. Only thing you can't do is change your Wi-Fi calling preference. If you are on WiFi preferred, you can't change it unless you disable the MOD and reboot. Make your change then re-rnable the MOD and reboot again. That is the only problem I have. It is the same if you flash the original zip that writes directly to system.
 

jascolli

Senior Member
Aug 7, 2013
636
190
Wow, this is working great. I love this dialer. Thanks for sharing your work!
 

jsaxon2

Senior Member
Mar 3, 2010
973
701
Lock Haven, PA
OnePlus 6
OnePlus 6T
How can you disable this and revert to HTC?
Use a root file explorer to go to /magisk/GPEDialer folder. Create a new empty file and name it disable then reboot

To re-enable, just delete the file and reboot. :)
 

Attachments

  • Screenshot_20160924-082853.jpg
    Screenshot_20160924-082853.jpg
    221 KB · Views: 3,018
Last edited:

jsaxon2

Senior Member
Mar 3, 2010
973
701
Lock Haven, PA
OnePlus 6
OnePlus 6T

Damn, My bad and good find. I copied the wrong zip file to my google drive. The one you have installs to /magisk/PixelLauncher. If you did not install the PixelLauncher, just delete that folder and reinstall the updated zip. I have updated the Original Post. Sorry bout that.
Link to updated zip.
GPEDialer_v4.0.12(Magisk)
 
  • Like
Reactions: yojoe600

yojoe600

Senior Member
Jan 10, 2009
2,199
494
33
Greensboro, NC
Damn, My bad and good find. I copied the wrong zip file to my google drive. The one you have installs to /magisk/PixelLauncher. If you did not install the PixelLauncher, just delete that folder and reinstall the updated zip. I have updated the Original Post. Sorry bout that.
Link to updated zip.
GPEDialer_v4.0.12(Magisk)

That one now gives the right folder. But the update-binary file still says its the pixel launcher under mod name while flashing just an FYI.
 
Last edited:

threetwentyfizzle

Senior Member
Oct 31, 2012
1,019
410
Albuquerque
OnePlus 10 Pro
Just a quick observation I noticed after using this mod for the past few days,

The ice view case works on receiving/rejecting calls with the GPE Dialer, but the caller always shows as "unknown". I'm assuming it's due to the HTC Contacts app integration into Ice View, but just figured I'd mention it. The fact that everything else works flawlessly, is totally awesome.

Sent from my HTC 10 using Tapatalk
 

CrazyCypher

Senior Member
Oct 19, 2010
2,059
450
Samsung Galaxy Watch 4
After flashing this everything is working perfectly except I dont have heads up when I receive a call..I remember having it when I flashed GPE dialer on my M8.. is there any way to enable it?

Thanks
 

jsaxon2

Senior Member
Mar 3, 2010
973
701
Lock Haven, PA
OnePlus 6
OnePlus 6T
I have stock HTC Rom with root and xposed... Any way you could help me to get them working? I think the stock rom supports the heads up...
I'm sorry, there is really nothing I can do. All I did was package the dialer to work as a Magisk Module. I don't use xposed but maybe there is an xposed module to do what you want. I just have no idea. Maybe someone else can suggest something.
 

CrazyCypher

Senior Member
Oct 19, 2010
2,059
450
Samsung Galaxy Watch 4
I'm sorry, there is really nothing I can do. All I did was package the dialer to work as a Magisk Module. I don't use xposed but maybe there is an xposed module to do what you want. I just have no idea. Maybe someone else can suggest something.
Yes I know it is not your fault :) It is working perfectly and I really prefer gpe over htc, its beautiful and smooth :)
 

Top Liked Posts

  • There are no posts matching your filters.
  • 20
    Pixel GPE Dialer and Contacts

    This mod now works with Android N.

    Updated to Google Pixel version of the Dialer and Contacts

    I have taken the GPE Dialer and Contacts found here [url]http://forum.xda-developers.com/showpost.php?p=68096911&postcount=95[/URL] and made it a Magisk Module. This allows the Dialer to act as though it is installed directly with in the system without actually modifying the system

    For information on what Majisk is and how to install it, please read here: [url]http://forum.xda-developers.com/android/software/mod-magisk-v1-universal-systemless-t3432382[/URL]

    This mod was tested on the HTC 10 using Magisk v7.
    Only thing you can't do is change your Wi-Fi calling preference. If you are on WiFi preferred, you can't change it unless you disable the MOD and reboot. Make your change then re-rnable the MOD and reboot again. That is the only problem I have. It is the same if you flash the original zip that writes directly to system.

    This zip file requires Magisk to be installed. It will not work without Magisk.

    Changes sync'd and now available to download in Magisk Manager. Thanks for those testing...

    v3.0.0

    Update to new Magisk template to work with Magisk v12+
    Update Dialer to v8.0.148481159
    Update Contacts to v1.7.6

    Or download from here: Magisk-GPEDialer_HTC10.v3.0.0

    Download Here:
    Magisk v7 version
    This can be installed through the Magisk Manager 2.0 or flashed in recovery.

    Note: All updates will only be available through the Magisk Manager going forward.

    10/16/16 - New update with Google Contacts 1.5.16 downloadable through the Magisk Manager...

    GPEDialer Pixel Version 2.0.0
    GPEDialer_v5.1.13(Magisk v7)

    GPEDialer Marshmallow Version 1.0.0
    GPEDialer_v4.0.12(Magisk v7)

    Magisk v6 version
    Flash the zip file in recovery.
    GPEDialer_v4.0.12(Magisk v6)
    7
    I've updated the module. If you are going to update to v2.2.4, please delete the old version first. The only reasons to update to this version is if you are running Viper Magisk Rom and/or if anyone else releases a Magisk Rom and are on Magisk v10. This fixes 2 issues.

    Issue 1. Phone won't boot with Magisk v10 and Viper Magisk Rom. - Fixed by removing the added framework file. This file seams to have no effect wither way so I have removed it for now. I will open an issue in github if it still does not work with the Official update that @topjohnwu should be releasing soon. The problem seems to be that Viper has /system/framework files that are updated and this mod added one. Magisk seems to get confused for lack of a better term and cause the phone to hang on boot animation and then reboot.

    Issue 2. HTC Phone still available when running Viper Magisk Rom. - I have changed the magisk directory that the mod is stored in to zGPEDialer_HTC10. This allows the GPE Dialer mod to take precedence over the Viper mod and allows the appropriate replacement to take place.

    I have not updated the github to show an update in Magisk since you need to delete the current version, reboot and then nstall the new version. If your current version is working for you, there is no need to update except to prepare for the future.

    Please let me know if you find any issues.

    Here is a link to download for those having issues installing from MagiskManager download section.

    https://drive.google.com/open?id=0B1iRsZPFZo3EbENESGpoWEVzU0k
    5
    Anyone that installed version 2.2.2, please update to 2.2.3 through Magisk Manager. It should solve some issues people were having.

    v2.2.3
    - Fix version detection - Thanks to @dastinger for testing MM version
    5
    Changes sync'd and now available to download in Magisk Manager. Thanks for those testing...

    v3.0.0

    Update to new Magisk template to work with Magisk v12+
    Update Dialer to v8.0.148481159
    Update Contacts to v1.7.6
    5
    Feel free. I've been too busy with work to look at anything and I have not been running sense rooms for a couple months so can't really test anything. If it's working, please share...

    sweet OK. I run viper with sprint and even though I have asop roms working I run viper all the time and I run apkupdater almost every other day so I can keep at least the apks updated in the module. But as for the actual module itself I have no idea lol as I've never written a module before. But here what I'm calling version 3.0.3 for anyone that wants it with the latest 10.0 dialer and 2.0.7 contacts. Enjoy and please let me know if it's working or not for anyone. It works for me perfectly. But I've never had any problems with any of the other dialer or contacts updates as other people have.