[MOD][PERFORMANCE]Watson - Your device's personal, automated butler!

sonickles9

Senior Member
Sep 4, 2014
337
153
0
São Paulo
You did not mention the way to remove the 'mod', if someone desires to do so. Would you please explain?
Whoops sorry... I only added an uninstaller in the beta, just recently, but for now, removing the symlinks in /etc/init.d, moving the build.prop.bak file back to system and the Watson folder are enough. The next release adds an uninstaller that also removes symlinks in /system/bin.
(that reminds me I need to update the op)

Enviado do meu GT-S5312
 

veez21

Senior Member
Feb 22, 2016
2,172
2,706
183
Guess Where
At last, 1.2.1 is out! We finally get an uninstaller, and a few fixes! Enjoy!

Enviado do meu GT-I9505
Yeah...[emoji106]

Sent by a Cool Guy using XDA-Developers mobile app

---------- Post added at 06:52 AM ---------- Previous post was at 06:21 AM ----------

'=' shouldn't be there, i think.


Sent by a Cool Guy using XDA-Developers mobile app

---------- Post added at 06:54 AM ---------- Previous post was at 06:52 AM ----------

On pm.sleep.mode and others

Sent by a Cool Guy using XDA-Developers mobile app
 
  • Like
Reactions: truefriendcz

veez21

Senior Member
Feb 22, 2016
2,172
2,706
183
Guess Where
@sonickles9, your setprop script works like rad dude... Your works are awesome...
Can i share Watson in my device's thread because it works great....[emoji1]

Sent by a Cool Guy using XDA-Developers mobile app
 

acestars

Senior Member
Mar 31, 2011
294
37
0
In my build.prop use
# ro.product.cpu.abi and ro.product.cpu.abi2 are obsolete,
# use ro.product.cpu.abilist instead.
ro.product.cpu.abi=arm64-v8a
ro.product.cpu.abilist=arm64-v8a,armeabi-v7a,armeabi
ro.product.cpu.abilist32=armeabi-v7a,armeabi
ro.product.cpu.abilist64=arm64-v8a

so the installer script wont copy busybox and sqlite binary. so when i type watson in terminal error not found occurred.

Sent from my Redmi Note 2 using Tapatalk
 

sonickles9

Senior Member
Sep 4, 2014
337
153
0
São Paulo
In my build.prop use
# ro.product.cpu.abi and ro.product.cpu.abi2 are obsolete,
# use ro.product.cpu.abilist instead.
ro.product.cpu.abi=arm64-v8a
ro.product.cpu.abilist=arm64-v8a,armeabi-v7a,armeabi
ro.product.cpu.abilist32=armeabi-v7a,armeabi
ro.product.cpu.abilist64=arm64-v8a

so the installer script wont copy busybox and sqlite binary. so when i type watson in terminal error not found occurred.

Sent from my Redmi Note 2 using Tapatalk
Okay, I will push a minor update today.
 

Ronnie_180808

Senior Member
Dec 8, 2015
194
47
0
Hmm... is there a "00onetime" on your init.d folder?
If it is, please check permissions and run it manually via the terminal, then it's up
Enviado do meu GT-S5312
Hmm... I too am facing the same problem...
After writing "su" followed by "watson" terminal emulator shows "nothing found"....
I tried to search for "00onetime" in my init.d folder but there's no such thing.
I do have a file by the name
"9900initWatson".
Shall I try to run it manually through terminal emulator?
Or if not plz help and guide me.
I'm using
Nokia XL with root latest SuperSU
Custom recovery:- twrp 2.7.0.2
Custom rom:- Semi-Aosp v.2.0
Init.d supported and running.