[MOD][Xposed] Vine Downloader

MohammadAG

Inactive Recognized Developer
Sep 7, 2009
1,080
5,504
0
27
Jerusalem
mohammadag.xceleo.org
Requires Xposed Framework!

This Xposed module adds a Download option to Vine. Clicking that will download the video to a Vine/ directory under your usual downloads directory.

Screenshots:


Compatibility:
This requires the official Vine application, the Xposed framework only runs on ICS+ so this will only work on ICS or above.

Source:
The mod is open source, and licensed under GPLv3: https://github.com/MohammadAG/Xposed-VineDownloader
You may not distribute this on the Play Store.

Download:
http://repo.xposed.info/module/com.mohammadag.xposedvinedownloader

Support development:
If you found this mod useful, consider donating with PayPal.

Thanks to:
@rovo89 for his awesome framework, and helping me out with an issue in this module.
 
Last edited:

cewong2

Senior Member
Apr 18, 2011
52
4
0
failed download

I keep getting failed download! I'm on stock firmware, on the i9505, latest xposed framework, and vine 1.3.3

There are no settings so I can't tell if it's because it can't save to location or something
 

MohammadAG

Inactive Recognized Developer
Sep 7, 2009
1,080
5,504
0
27
Jerusalem
mohammadag.xceleo.org
I keep getting failed download! I'm on stock firmware, on the i9505, latest xposed framework, and vine 1.3.3

There are no settings so I can't tell if it's because it can't save to location or something
Sorry, apparently DownloadManager doesn't auto-create needed directories.
Either redownload the fixed apk (same link), or just create a Vine (case sensitive) directory in /sdcard/Download (or Downloads, depending on your device).
 

cewong2

Senior Member
Apr 18, 2011
52
4
0
Sorry, apparently DownloadManager doesn't auto-create needed directories.
Either redownload the fixed apk (same link), or just create a Vine (case sensitive) directory in /sdcard/Download (or Downloads, depending on your device).
Works great now, thanks maybe future feature would be to be able to specify where it downloads to, like SD card vs internal memory
 

MohammadAG

Inactive Recognized Developer
Sep 7, 2009
1,080
5,504
0
27
Jerusalem
mohammadag.xceleo.org
Fails to download most of the time. Every once in a while it is successful, but most of the time fails.
I found a bug yesterday that would prevent downloading videos with a "/" in their description. Most Vine videos are doing it now and that's why it fails. (Some long description W/ Username)





Could you please make something like this for YouTube?

Sent from my GT-N7100 using Tapatalk 4 Beta
Not sure if I want to touch YouTube, the package is obfuscafed with ProGaurd so each update would break the module for users, and I'd have to go through the source again.

Sent from my GT-I9500 using xda app-developers app
 
  • Like
Reactions: Simba501

cewong2

Senior Member
Apr 18, 2011
52
4
0
Thanks again for the mod, just wondering since the new version of vine I haven't been able to use the mod hitting download does nothing. Did something change?
 

madprofessorus

Senior Member
Jan 23, 2012
309
32
48
Achaia
I tried it on my tipo with custom 4.1.2 Rom,it works fine, only problem is the videos with the / character

Update : all videos with special characters won't download

Sent from my Xperia Tipo using xda app-developers app
 
Last edited:

laserbiz

Senior Member
Mar 23, 2011
200
25
0
I am not even showing the download option.
I also downloaded and installed the apk, which curently resides in my sdcard\download directory on my Samsung Galaxy Note 8 (GT-N5110) running Android 4.1.2 KernEl version 3.0.31, Build number JZ054K.N5110EEMF2. There is no download option for me either. What Am I doing wrong? Help! Thanks
 

MohammadAG

Inactive Recognized Developer
Sep 7, 2009
1,080
5,504
0
27
Jerusalem
mohammadag.xceleo.org
I also downloaded and installed the apk, which curently resides in my sdcard\download directory on my Samsung Galaxy Note 8 (GT-N5110) running Android 4.1.2 KernEl version 3.0.31, Build number JZ054K.N5110EEMF2. There is no download option for me either. What Am I doing wrong? Help! Thanks
You need to install Xposed and enable the module.

Sent from my Sony Xperia Z1 (C6903) using Taptalk 4
 
  • Like
Reactions: laserbiz

laserbiz

Senior Member
Mar 23, 2011
200
25
0
You need to install Xposed and enable the module.

Sent from my Sony Xperia Z1 (C6903) using Taptalk 4
I have installed Xposed, but nothing shows up in the menu, othere than share on twitter, facebook, report etc. How do I enable the Module? That is the million dollar question!
Thanks again!