[MODULE] App Systemizer for Magisk v9-v14 -- DEPRECATED

Search This thread

Top Liked Posts

  • There are no posts matching your filters.
  • 73
    Instead of including the third party APK files in the magisk modules/repo, this module, developed by @loserskater and me, systemizes user-installed apps systemlessly thru magisk. Another benefit of systemizing the user-installed apps is that if you uninstall magisk, your settings for the apps will be retained. If you originally install any of the apps above thru an app-specific magisk module (like Pixel Launcher magisk module for example), then when magisk is uninstalled or disabled, app settings will be gone.

    If you're on Oreo ROM, you will need this add-on developed by @yochananmarqos: https://forum.xda-developers.com/apps/magisk/module-privileged-permission-whitelist-t3670646

    This module requires installation from Magisk Manager, not recovery.

    This module might lead to your device stuck on logo or booting to recovery, I gather it might be a kernel issue -- the closer you're to stock firmware/kernel the more likely it is to work. If it fails, try the "Terminal App Systemizer" instead.

    Important links:

    NOW IN OFFICIAL MAGISK REPO!

    11.0.6: This is the last "classic/simple" version I could get from github, (11.0.6) which might fail on the larger APKs but doesn't include magisk partition resizing code which might cause problems. It also does NOT include a companion app.

    12.0.5: This is the latest "stable" version with the companion app. Based on pre-"magisk 13" template (version 3), but seems to work with magisk 13.

    14.0.0: This is the 12.0.5 version migrated to 1400 template (released with magisk 14). Not tested by me, so use at your own risk (but please post back wherever it does/does not work).

    The source code (with history) is available here if anyone wants to continue development: https://github.com/stangri/AppSystemizer
    13
    @stangri
    It took rebooting three times (see attached logs) after updating for it to work properly. Why was the app removed in favor of the appslist.conf?

    I can't comment on why it took 3 times, possibly result of me not using the template 4.

    The reasons I've tried to do without the app were two-fold:
    1. To allow easy app updates without updating the module.
    2. (Mostly) to limit the use scenarios, as some of them were resulting in unexpected behavior which were very difficult to replicate.

    Sadly, the move away from the app resulted in an even more complicated code of the module (because now it had to support its own config list + app's config list if the app was installed separately from the module).

    As version 12.0.5 seem to have worked the best for a lot of people, I've rewinded to the commit for 12.0.5 (so it includes @loserskater's app again), updated the template to v4 + PR #27 (fix for /cache installed magisk) and tried my best to update the module code to the changes in magisk/magisk template. Result of it is an attached module version 12.0.8.

    I've tested an upgrade from 12.0.7 to 12.0.8 with a single systemized app (Pixel Launcher) and it worked. However, upgrade from versions 12.0.6/12.0.7 with a lot of apps systemized might not go smoothly. I appreciate you using 12.0.6 and 12.0.7, but if you have apps other than Pixel/Action Launchers systemized with those versions, please delete the old module and reboot first.

    I would *hugely* appreciate if people test 12.0.8 (especially those for whom 12.0.7 didn't work) and post back.

    I'd like to push a stable version to the repo before I cease further development.
    12
    Alright time for another test!
    The main thing is that we can now systemize ANY app regardless of size. Although didn't test games or anything ridiculously large but it should still work!
    A few fixes in the companion app as well including reboot actually writing the config file.
    You can check out the sources for a complete rundown:
    AppSystemizer commits
    Companion app commits

    Only install through Magisk Manager! Flashing in recovery doesn't work at the moment but we're looking into it.
    10
    I did notice a bug with apps not showing selected when closing and opening the app. Sometimes if there is already a magisk-merge.img the script won't copy over the files correctly. I believe this is due to the magisk-merge img already being created with not enough space. A reboot should fix that problem.

    Attached is the 12.0.3 version with the latest app. I've also tried to fix the bug mentioned above.

    PS. Unrelated to the message above, but prompted by a few recent posts: I'll keep repeating it in every post I guess: any report of things not working as intended is useless without magisk log. If it takes more than one reboot to systemize apps -- save magisk log before and after reboot.
    9
    12.0.4

    I've looked into the installation from recovery issue and while it might (to an extent) work on some phones/recoveries, the default shell in recovery is very limited comparing to the shell when the phone is booting/booted up. So I gave up on trying to figure out how to have the module install from recovery.

    However, now there's a big fat warning and the proper error on attempt to install the module from recovery. Just to make sure I do not misdetect installation from recovery (or an otherwise incompatible shell) I'd appreciate feedback from a wide number of users on 12.0.4. All my devices are LOS14.1, so if you're running any other flavour of Android (stock, AOSP, older versions) please post wherever an upgrade to/install of 12.0.4 worked or not.

    Just this one time, no magisk log on error is needed, if you get an error from Magisk Manager on installation, please post as much information as possible about your ROM.

    There's no fix on missing companion app on the Marshmallow ROMs yet.