• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[MODULE] Blobs Forever - Get the blob emoji back in Android 8.0!

Search This thread

bdr9

Senior Member
Mar 3, 2013
86
46
tHGnJMt.png
Blobs Forever
tHGnJMt.png


If you have upgraded your Nexus or Pixel device to Android 8.0 and you are missing Google's blob emoji, then this module is for you. I was very disappointed when I found out that Google was getting rid of the blob emoji. At first, I thought I could get used to the new emoji, but I always miss the blobs. This simple module will replace your emoji with the blob emoji from Android 7.1.

I have tested it on my Google Pixel running Android 8.0, with Magisk 14.2 beta. It is not guaranteed to work on other devices, but please feel free to try it out. It does require at least Magisk 14.0. For Pixel devices, 14.2 is required.

To install this module, use Magisk Manager to install the attached zip file. I am planning to submit this module to the Magisk Manager module repo soon. I did find another module that is supposed to provide the Android 7.1 emoji, but it appears to be unmaintained, and one user has reported that it is not working on their Pixel running 8.0.

Let me know how it works for you!

Screenshot:

 

Attachments

  • BlobsForever.zip
    5 MB · Views: 6,727
Last edited:

mrgooglegeek

New member
Feb 6, 2016
4
1
New emoji + blob emoji

I made a similar module a while back but never released it because I was unable to include the new emoji missing from the old notocoloremoji file. I had every set up but I was unable to compile a working tff file. If anyone is interested I can give it another try on a different computer.
 
  • Like
Reactions: kawaii.beans

kawaii.beans

Senior Member
Jan 30, 2017
114
107
Kolkata
I made a similar module a while back but never released it because I was unable to include the new emoji missing from the old notocoloremoji file. I had every set up but I was unable to compile a working tff file. If anyone is interested I can give it another try on a different computer.

Great , umm can you help me please , I am trying to compile a .ttf emoji font and i have all the .svg files which i guess are required to compile a emoji ttf font. I want to make a .ttf file for tweemojis
 

bdr9

Senior Member
Mar 3, 2013
86
46
I made a similar module a while back but never released it because I was unable to include the new emoji missing from the old notocoloremoji file. I had every set up but I was unable to compile a working tff file. If anyone is interested I can give it another try on a different computer.

Interesting. I didn't actually realize that there are new emoji that aren't in the font from Android 7.1. What tools were you using to extract/compile the ttf files?
 

bdr9

Senior Member
Mar 3, 2013
86
46
Whoops, it looks like someone else had the same idea before me. I didn't see that one.

My module provides only the blobs, while the NotoColorEmoji Replacer module mixes the blobs with the new emoji from Oreo. Use whichever one fits your needs.
 
  • Like
Reactions: joeyhuab

iluvmynxd

New member
Nov 19, 2017
2
0
Please help me get the blob emoji back!

Hi, so glad I stumbled on your post! I have a Google pixel XL. Can you please direct me step by step how to get the blob back? I would appreciate it soooo much! I'm not a developed by any means so I'm not as savvy as others on this forum, but I'm smart enough to go step by step if you'd be so kind to help me! I miss the blob emoji so bad and HATE these new emoji.

I googled magisk 14.2, downloaded it, phone said it couldn't open file. Came back to your post, downloaded zip, phone said couldn't open file. No app for magisk in Google play store.

What am I doing wrong? Please help me!!!!
 

Didgeridoohan

Senior Moderator / Dev Committee / Dev Relations
Staff member
May 31, 2012
12,264
1
14,530
Gothenburg
Google Nexus 4
Nexus 6
Hi, so glad I stumbled on your post! I have a Google pixel XL. Can you please direct me step by step how to get the blob back? I would appreciate it soooo much! I'm not a developed by any means so I'm not as savvy as others on this forum, but I'm smart enough to go step by step if you'd be so kind to help me! I miss the blob emoji so bad and HATE these new emoji.

I googled magisk 14.2, downloaded it, phone said it couldn't open file. Came back to your post, downloaded zip, phone said couldn't open file. No app for magisk in Google play store.

What am I doing wrong? Please help me!!!!

To install Magisk you have a couple of options. But first of all I'd like to point out that the best way to get the proper installation files is from the release or beta threads here on xda. Googling, you'll never be sure what you find... :)

Easiest way to install Magisk is to simply flash the zip (stable or beta) in TWRP. Done.

If you don't have TWRP, you can install the Manager (you won't find it in the Play store, Google doesn't like it) and let it patch the stock boot image (extract it from a factory image) and then flash that to your device with fastboot.

There are installation instructions in the release thread and you might also find some info in the installation and troubleshooting guide.

If you've got questions about any of the above, first try searching through your device's forum, the Magisk forum and the rest of xda. Most beginner questions have been asked and answered many, many times.

Once you have Magisk up and running on your device, you just need to flash the zip from the OP in the Manager (Modules section, "+" button at the bottom) or in TWRP to get the blobs you want.
 

iluvmynxd

New member
Nov 19, 2017
2
0
I'm still stuck!

Hello and thank you for the response! I've downloaded magisk and I've downloaded TWRP from the Google play store, yet it still won't open the zip file. So frustrating! Would it be crazy of we talked on the phone and u helped me lol... I'm serious! What am I doing wrong :( I can't figure out that image thing either.... The image I need to have beforehand? Ughh please help!
 

Didgeridoohan

Senior Moderator / Dev Committee / Dev Relations
Staff member
May 31, 2012
12,264
1
14,530
Gothenburg
Google Nexus 4
Nexus 6
Hello and thank you for the response! I've downloaded magisk and I've downloaded TWRP from the Google play store, yet it still won't open the zip file. So frustrating! Would it be crazy of we talked on the phone and u helped me lol... I'm serious! What am I doing wrong :( I can't figure out that image thing either.... The image I need to have beforehand? Ughh please help!

You need to start by doing a lot of reading. A lot... Before you start doing this stuff you need to know a little bit more about what you're doing.

First: You don't download TWRP from the Play store. It's a custom recovery that you install on your device to do a lot of fun stuff (flashing ROMs, custom kernels, root, mods, making backups, etc). More on TWRP here: https://twrp.me/

I'd start looking through the Pixel XL forums. There you're probably gonna be able to find some guides and beginners threads to start you on your way. The users there are gonna be able to provide a lot more help as well, since they often know the device pretty good.

And before you do anything, make sure you have a backup of any important data before you do anything. When learning, you will end up wiping your device a few times. Just make sure to read, read and then read some more before continuing...
 

Cleath

New member
Jan 22, 2018
2
1
- Copying zip to temp directory
- Installing BlobsForever.zip
- Mounting /system, /vendor, /data, /cache
***********************************
! /data/magisk isn't setup properly!
! Please install Magisk v14.0+!
***********************************
Failed!
! Installation failed

Is this module compatible with Magisk v15.3?
 
  • Like
Reactions: Kayniedude

David B.

Senior Member
Mar 25, 2016
327
67
Thanks for making this! I would be sad if an upgrade to LineageOS 15.1 meant losing my beloved blobs.

Quick question though. Does this module support new emojis like ? that are present in the new Android emoji set but not present in the Nougat blob set? I am asking because someone sent me ? in a Hangouts message and it didn't display right on my phone with this module installed.
 
  • Like
Reactions: Poebat

XperiaFZ

Member
May 8, 2014
13
0
Is there a way to use the android 6.0 blob emojis on oreo, while the new ones can be used where blob 6.0 dont exist?
 

Top Liked Posts

  • There are no posts matching your filters.
  • 17
    tHGnJMt.png
    Blobs Forever
    tHGnJMt.png


    If you have upgraded your Nexus or Pixel device to Android 8.0 and you are missing Google's blob emoji, then this module is for you. I was very disappointed when I found out that Google was getting rid of the blob emoji. At first, I thought I could get used to the new emoji, but I always miss the blobs. This simple module will replace your emoji with the blob emoji from Android 7.1.

    I have tested it on my Google Pixel running Android 8.0, with Magisk 14.2 beta. It is not guaranteed to work on other devices, but please feel free to try it out. It does require at least Magisk 14.0. For Pixel devices, 14.2 is required.

    To install this module, use Magisk Manager to install the attached zip file. I am planning to submit this module to the Magisk Manager module repo soon. I did find another module that is supposed to provide the Android 7.1 emoji, but it appears to be unmaintained, and one user has reported that it is not working on their Pixel running 8.0.

    Let me know how it works for you!

    Screenshot:

    1
    New emoji + blob emoji

    I made a similar module a while back but never released it because I was unable to include the new emoji missing from the old notocoloremoji file. I had every set up but I was unable to compile a working tff file. If anyone is interested I can give it another try on a different computer.
    1
    Whoops, it looks like someone else had the same idea before me. I didn't see that one.

    My module provides only the blobs, while the NotoColorEmoji Replacer module mixes the blobs with the new emoji from Oreo. Use whichever one fits your needs.
    1
    - Copying zip to temp directory
    - Installing BlobsForever.zip
    - Mounting /system, /vendor, /data, /cache
    ***********************************
    ! /data/magisk isn't setup properly!
    ! Please install Magisk v14.0+!
    ***********************************
    Failed!
    ! Installation failed

    Is this module compatible with Magisk v15.3?
    1
    I cannot seem to get this module to work properly on my OnePlus 2, running Cosmic OS 3.1 Oreo, any advice?