[Module] Easy font installer.

xdddd23

Senior Member
Mar 31, 2015
229
180
73
21
Alcalá la Real
-What do this module?
This zip change the default font in system/font/ roboto-regular to the default in the zip or your font (see down).

-How to use?
•(You need magisk installed obviously )
•Flash the zip in magisk manager or in twrp.
•Reboot and enjoy new font.

-How to change default font in zip?
1.Change the name of your font xxxx.xxx.ttf to Roboto-Regular.ttf
2.Decompress the zip go to system/fonts and replace with your favorite font renamed.
3.Compress the zip and flash in twrp/magisk manager.

-Thanks
To @topjohnwu for all the effort of their mods and the magisk template really easy for make modules.

Magisk : http://forum.xda-developers.com/apps/magisk/official-magisk-v7-universal-systemless-t3473445

Donate: https://www.paypal.me/MartinJesus23
 

xdddd23

Senior Member
Mar 31, 2015
229
180
73
21
Alcalá la Real
Can you please rephrase the instructions? I can't understand what files I have to compress and what should I replace
Lol Just rename the name of font with the same In the zip and replace it and compress all folders and archives in one zip .If you don't know how to do it better don't try .
 

Attachments

Shpitzick

Member
Aug 6, 2012
5
0
0
Lol Just rename the name of font with the same In the zip and replace it and compress all folders and archives in one zip .If you don't know how to do it better don't try .
Oh, that's it? I feel pretty stupid now haha

It caused a little problem in WhatsApp though. The weird symbols are letters in Hebrew and it only happens in the name field. Also, it doesn't happen in any other application. I'll try finding a solution and will update if I manage to :)
 

Attachments

xdddd23

Senior Member
Mar 31, 2015
229
180
73
21
Alcalá la Real
Oh, that's it? I feel pretty stupid now haha

It caused a little problem in WhatsApp though. The weird symbols are letters in Hebrew and it only happens in the name field. Also, it doesn't happen in any other application. I'll try finding a solution and will update if I manage to :)
The problem there is the font used some fonts don't have some simbols like this . So try other font .
 

pirasalbe

Senior Member
Jan 9, 2013
215
40
28
Hi,
Is it possible to change also roboto bold and light placing them in system/font before compressing and flashing??

Sent from my Nexus 6 using Tapatalk
 

pirasalbe

Senior Member
Jan 9, 2013
215
40
28
Sure if you replace the font with the system stock name correctly.

Sent from my ZUK Z1 using XDA Labs
I've tried placing the font I wanted (bellota) in the folder, but it seems not to be working (at least the regular one). I'm not sure if it's because I've an OMS Rom
If you have time can you test it or at least tell me if I did something wrong??
BellotaMagisk

Edit: OMS was messing up with this module
 
Last edited:

xdddd23

Senior Member
Mar 31, 2015
229
180
73
21
Alcalá la Real
I've tried placing the font I wanted (bellota) in the folder, but it seems not to be working (at least the regular one). I'm not sure if it's because I've an OMS Rom
If you have time can you test it or at least tell me if I did something wrong??
BellotaMagisk

Edit: OMS was messing up with this module
Sure than not​, I use susbtratum with this module without​ problems check If you have properly installed magisk and the module and don't have any font applied In substratum. Take a look .

Sent from my ZUK Z1 using XDA Labs
 

Attachments

  • Like
Reactions: pirasalbe

pirasalbe

Senior Member
Jan 9, 2013
215
40
28
Sure than not​, I use susbtratum with this module without​ problems check If you have properly installed magisk and the module and don't have any font applied In substratum. Take a look .

Sent from my ZUK Z1 using XDA Labs
Can you tell me why I see something like this??
In substratum there is a theme with the same font works without this problem
 

pirasalbe

Senior Member
Jan 9, 2013
215
40
28
Because surely you have any font installled with substratum or don't installed correctly.

Sent from my ZUK Z1 using XDA Labs
No, the font is copied from that theme and then the module installed into a Nexus 4 with stock rom and without any substratum theme/font
 

xdddd23

Senior Member
Mar 31, 2015
229
180
73
21
Alcalá la Real
If one needs to replace fonts well, then all the variations needs to be replaced - about 18 fonts.. does this module support adding all 18?
Of course yes, magisk can replace all fonts that you want setting it with the correct name to be replaced also can replace the Emojis system I like to have the one emojis in my system:)
 

jabbarh123

Senior Member
Jun 16, 2014
427
52
0
Bradford
-What do this module?
This zip change the default font in system/font/ roboto-regular to the default in the zip or your font (see down).

-How to use?
•(You need magisk installed obviously )
•Flash the zip in magisk manager or in twrp.
•Reboot and enjoy new font.

-How to change default font in zip?
1.Change the name of your font xxxx.xxx.ttf to Roboto-Regular.ttf
2.Decompress the zip go to system/fonts and replace with your favorite font renamed.
3.Compress the zip and flash in twrp/magisk manager.

-Thanks
To @topjohnwu for all the effort of their mods and the magisk template really easy for make modules.

Magisk : http://forum.xda-developers.com/apps/magisk/official-magisk-v7-universal-systemless-t3473445

Donate: https://www.paypal.me/MartinJesus23
Hi, i flashed this via magisk on my g955f stock rom and it changed the font to roboto regular, then i decompressed the file, changed the name to roboto condensed and flashed again and rebooted but it did not work. I also downloaded the font package and replaced the .ttf file and reflashed but it only changed the font back to stock. Help please? Thanks
 

xdddd23

Senior Member
Mar 31, 2015
229
180
73
21
Alcalá la Real
Hi, i flashed this via magisk on my g955f stock rom and it changed the font to roboto regular, then i decompressed the file, changed the name to roboto condensed and flashed again and rebooted but it did not work. I also downloaded the font package and replaced the .ttf file and reflashed but it only changed the font back to stock. Help please? Thanks
Make sure that you replace the file name with the exact name that it is in system, and after a first installation flash the zip via magisk and not TWRP
Hope can help you
 
  • Like
Reactions: jabbarh123

jabbarh123

Senior Member
Jun 16, 2014
427
52
0
Bradford
Make sure that you replace the file name with the exact name that it is in system, and after a first installation flash the zip via magisk and not TWRP
Hope can help you
Okay so the file name is exactly the same as it is in system/fonts. Shall i first flash via magisk or twrp? If i flash via magisk after the first flash the app crashes. Thanks

EDIT: I've got it working now, thanks!
 
Last edited:
  • Like
Reactions: xdddd23