• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[Module] F-Droid Privileged Extension

Search This thread

a1291762

Senior Member
Nov 20, 2012
698
301
yasmar.net
There's been an update to the fdroid privileged extension. But it's fine to install it normally, since it works like an update to a system app (with this module making it a system app).
 
  • Like
Reactions: Quaicheist

Mr. Fitzie

Member
Jan 27, 2017
7
3
Brooklyn
The extension hasn't been working for me lately. I have to install apks manually via the package installer. Is that because the module hasn't been updated for the latest magisk version? I'm on the Canary channel.

the current version corresponding to the current version (0.2.11) of the F-Droid Privileged Extension is inside the masgisk module repository that magisk manager app can retrieve (updated Nov 23, 2019). The last version posted in this thread (in the OP) seems to be not current, and should be avoided. This is mentioned in post #2.
 
Last edited:

zedoc

Senior Member
Dec 5, 2014
140
20
Hi,
Tried to update from magisk 21.4 repo but not working, privilege section is gone from F-Droid (v1.11) expert mode after reboot...
i've manually reinstall the 2019-11-23(18) version from storage and it's working.
i'm on LOS 17.1 official with MicroG nanodroid.
 

KRafi

Member
WA4LBkF.png
I decided to continue @PunchyStick's Magisk module and keep it updated as F-Droid releases updates. You can generally expect updates the day after if not the day of F-Droid updating the extension.

What to know:
-Please make sure you're running at least F-Droid 0.103
-Disable auto app updates from within F-Droid. F-Droid Privileged Extension will automatically update and succeed, and I don't know how this will affect SafetyNet and/or the Magisk Module. (This is because the extension doesn't update like a normal app by placing updates in the data partition, it overwrites the apk in system directly).

Changelog:
v1
- Private release
- Privileged Extension 0.1
- Based directly on PunchyStick's extension


v2
- Private release
- Privileged Extension 0.2

v3
- Private release
- Privileged Extension 0.2.2

v4
- First public release
- Privileged Extension 0.2.3

v5
-If you installed the zip on the XDA thread, please remove that module before installing this version.
-Privileged Extension 0.2.4

v6
-Privileged Extension 0.2.5
-Please update F-Droid to version 0.103 if you have not already.

v7
-Updated to template 4

v8
-Update to template 1400
-Please update to Magisk 14.0 if you have not already

v9
-Privileged Extension 0.2.6

v10
-Privileged Extension 0.2.7
-Template 1410
-Only install this if you are on Magisk 14.1, a zip for Magisk 14.0 can be found attached.
It's not working. I'm getting this error in my Android 10 device with F-Droid 1.11 whenever I try to install a package:

Code:
Error -110: The system failed to install the package because of system issues.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 37
    WA4LBkF.png
    I decided to continue @PunchyStick's Magisk module and keep it updated as F-Droid releases updates. You can generally expect updates the day after if not the day of F-Droid updating the extension.

    What to know:
    -Please make sure you're running at least F-Droid 0.103
    -Disable auto app updates from within F-Droid. F-Droid Privileged Extension will automatically update and succeed, and I don't know how this will affect SafetyNet and/or the Magisk Module. (This is because the extension doesn't update like a normal app by placing updates in the data partition, it overwrites the apk in system directly).

    Changelog:
    v1
    - Private release
    - Privileged Extension 0.1
    - Based directly on PunchyStick's extension


    v2
    - Private release
    - Privileged Extension 0.2

    v3
    - Private release
    - Privileged Extension 0.2.2

    v4
    - First public release
    - Privileged Extension 0.2.3

    v5
    -If you installed the zip on the XDA thread, please remove that module before installing this version.
    -Privileged Extension 0.2.4

    v6
    -Privileged Extension 0.2.5
    -Please update F-Droid to version 0.103 if you have not already.

    v7
    -Updated to template 4

    v8
    -Update to template 1400
    -Please update to Magisk 14.0 if you have not already

    v9
    -Privileged Extension 0.2.6

    v10
    -Privileged Extension 0.2.7
    -Template 1410
    -Only install this if you are on Magisk 14.1, a zip for Magisk 14.0 can be found attached.
    5
    I removed the module zip from this thread as it is obsolete and my module is in the Magisk Module Repo now (and thus can be installed via Magisk). Also, as per the changelog, if you installed the zip on this thread please uninstall that module before upgrading to v5.
    1
    I thought so, becuase otherwise it would not make any sense :)

    The reason I asked you to use that module to place an app in /system/priv-app is that some devices [when running stock] do not like things being placed in that directory, and with Magisk it is just as if that app is actually in that directory even though it really isn't so the device will react just how it would if you actually placed it on the system partition for real. Some devices can just have really odd glitches too, for example I have an LG-K330 from a friend, and some Magisk modules that work just fine on my other devices cause it to lose its IMEI (it is not actually gone, but the OS does not see that there is one and it will refuse to connect to a mobile network), and it causes really odd battery issues too.