• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[MODULE][Magisk 17+] Volume Steps Extender

Search This thread

LoaderFabi

Senior Member
Yeah, the Module has been removed from repo because:

"
What Will NOT be Approved
If you cannot properly submit a module, it means you cannot even read basic instructions.
Your module will never get approved even if you get it right after multiple "tries".
A repo without master branch.
A module that only contains some simple boot scripts.
A module that only uses system.prop to modify system props.
A module that is simply a duplicate of an existing module, or only little modifications are done.
In other words: no plagiarism.
"

I don't see the Point in this but well - It's not my Decision.
 
  • Like
Reactions: Carnage_mafia

gengki

Member
Nov 15, 2018
7
1
Hi newbie here. Do I have to input the prop entries? Or just flash the zip tru magisk module. Sorry for the trouble. Why this module does not appear in my magisk module? I just found this module in youtube.
 
P

PixelChris95

Guest
Hi newbie here. Do I have to input the prop entries? Or just flash the zip tru magisk module. Sorry for the trouble. Why this module does not appear in my magisk module? I just found this module in youtube.
Just flash it with the magisk manager. The module got removed because of new policies for uploading modules to the repo.
 

sas.mar

Senior Member
May 6, 2015
82
36
Works fine on my OPO with TugaPower Pie and V4A installed. Huge thanks to the OP, now I can precisely control volume with my high gain setup as I use 50 Ohm earphones.
 

shmp30

Senior Member
Jun 8, 2012
122
29
Prop Entries:
ro.config.vc_call_vol_steps=14
ro.config.media_vol_steps=30
audio.safemedia.bypass=true
Hi!
I added these values manually in build.prop and the worked perfectly on android Pi (Mi A1), can some body provide me value to change steps for "Ring Volume" In android Pie? need more steps for ring and notification volume in Pie.
 

Attachments

  • Screenshot_20181231-111418.png
    Screenshot_20181231-111418.png
    92.4 KB · Views: 651
Last edited:

dbreed53

Senior Member
Jun 13, 2013
77
11
68
Fordland, MO
Samsung Galaxy A21s
I've got Magisk 18.1 & Magisk Mgr. 7.0.0 on my Samsung Galaxy SM-J727P Perx (Boost) with Android 8.1.0, ROOTED. I used TWRP to get root, then installed No_verity & Magisk.

It seems that some tweak or other that I have used in Magisk is the reason I cannot find to alter the settings you indicated.
If you don't mind pointing me in the right direction, I like to see if I can make yours work.
I installed Volume Steps+ 1.3.9 for Magisk, but it has ALSO not changed my settings.
 

LoaderFabi

Senior Member
I've got Magisk 18.1 & Magisk Mgr. 7.0.0 on my Samsung Galaxy SM-J727P Perx (Boost) with Android 8.1.0, ROOTED. I used TWRP to get root, then installed No_verity & Magisk.

It seems that some tweak or other that I have used in Magisk is the reason I cannot find to alter the settings you indicated.
If you don't mind pointing me in the right direction, I like to see if I can make yours work.
I installed Volume Steps+ 1.3.9 for Magisk, but it has ALSO not changed my settings.

Afaik did Samsung remove or renamed those Values.
Can't really look that up since there is no Source Code from Samsung of the audioservice.jar
Idk if that Changed but last Contact with a Samsung was an S8+ I rooted for a Friend. Didn't worked on it either.

That's why its a Module for AOSP - Not OEM altered ROMs.
And TouchWiz couldn't be further away from aosp.
 

Micha_Btz

Senior Member
Prop Entries:
ro.config.vc_call_vol_steps=14
ro.config.media_vol_steps=30
audio.safemedia.bypass=true

Hey, I try to use this settings in a LOS build. I set all options in https://github.com/LineageOS/android_device_bq_sdm660-common/blob/lineage-15.1/vendor_prop.mk
and these options lands in the build.prop after build. THe option for media vol step are used, but the option for call step is always ignored and the steps are set to the default 7.

I try to set it on the device, but the option can't be set.
Code:
zangyapro:/ # getprop |grep call                                                                                                                                         
[persist.audio.fluence.voicecall]: [false]
[persist.radio.calls.on.ims]: [true]
[persist.vendor.audio.fluence.voicecall]: [true]
[ro.config.vc_call_vol_steps]: [14]
[ro.telephony.call_ring.multiple]: [false]
zangyapro:/ # setprop ro.config.vc_call_vol_steps 35                                                                                                                     
setprop: failed to set property 'ro.config.vc_call_vol_steps' to '35'
1|zangyapro:/ # setprop ro.config.vc_call_vol_steps=35                                                                                                                   
See setprop --help
setprop: Need 2 arguments
1|zangyapro:/ # setprop ro.config.vc_call_vol_steps 15                                                                                                                   
setprop: failed to set property 'ro.config.vc_call_vol_steps' to '15'
1|zangyapro:/ # setprop ro.config.vc_call_vol_steps 7                                                                                                                    
setprop: failed to set property 'ro.config.vc_call_vol_steps' to '7'
1|zangyapro:/ # setprop ro.config.vc_call_vol_steps 5                                                                                                                    
setprop: failed to set property 'ro.config.vc_call_vol_steps' to '5'
1|zangyapro:/ # setprop ro.config.vc_call_vol_steps 1                                                                                                                    
setprop: failed to set property 'ro.config.vc_call_vol_steps' to '1'
https://github.com/LineageOS/androi...va/com/android/server/audio/AudioService.java
Maybe you have an idea why it's not working.

TIA Micha
 

LoaderFabi

Senior Member
Hey, I try to use this settings in a LOS build. I set all options in https://github.com/LineageOS/android_device_bq_sdm660-common/blob/lineage-15.1/vendor_prop.mk
and these options lands in the build.prop after build. THe option for media vol step are used, but the option for call step is always ignored and the steps are set to the default 7.

I try to set it on the device, but the option can't be set.

https://github.com/LineageOS/androi...va/com/android/server/audio/AudioService.java
Maybe you have an idea why it's not working.

TIA Micha

I can't really tell you...
Maybe manually editing build.prop from TWRP works.
But that is more of a dirty workaround than a solution tho.

Keep in mind - I'm not a dev after all.
 

ximmox

Senior Member
Mar 14, 2010
589
312
Hi Fabi,

Could you have a look at the new Magisk Module requirements being enforced in the new version 19?
Old modules won't work with it as I understand the changelog, so I won't upgrade right away.

The new Module Installer is documented here: https://topjohnwu.github.io/Magisk/guides.html#magisk-modules

Thanks!

Edit: Seems as if I was too quick, it still works after updating to v19.
 
Last edited:

LoaderFabi

Senior Member
Hi Fabi,

Could you have a look at the new Magisk Module requirements being enforced in the new version 19?
Old modules won't work with it as I understand the changelog, so I won't upgrade right away.

The new Module Installer is documented here: https://topjohnwu.github.io/Magisk/guides.html#magisk-modules

Thanks!

Edit: Seems as if I was too quick, it still works after updating to v19.

I still maintain a Module in the Repo, so I know about the new Template, but thanks for the notice.
I upload a version with the new Teplate if I get my ass up tomorrow. done.

But the T19's abort installation on Magisk 18.1 with Manager 7.1.1, maybe I made a mistake or T19 requires Magisk 19 or Canary Builds, can't tell yet. - I forgot the Update-Binary is now for whatever reason a dummy file in the template, I just had to fill in a Script mentioned by Magisk dev... Works now.
 
Last edited:

steveglowplunk

Senior Member
Sep 15, 2015
273
100
This doesn't work on LOS 15.1 on my Xperia XA2.
I've even tried manually adding the lines to /system/build.prop but the media volume steps didn't change at all.
I have magisk v18 installed and used the T17 zip as instructed. Can somebody help me with this please? I've been trying to find a method for changing the media volume steps for a long time :(
 

LoaderFabi

Senior Member
This doesn't work on LOS 15.1 on my Xperia XA2.
I've even tried manually adding the lines to /system/build.prop but the media volume steps didn't change at all.
I have magisk v18 installed and used the T17 zip as instructed. Can somebody help me with this please? I've been trying to find a method for changing the media volume steps for a long time :(

You are the next with LaOS having this issue.
Perhaps they override the value within late-boot or changes the Var name within the Audio Service...

I might take a look at their Audio Service files since its Open Source anyway.

Btw you can use the T19 in Magisk 18 too. Works fine.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 49
    Updated the Module.
    Moved the new one to GitHub. https://github.com/Fabl0s/VolumeStepsExtender

    Moved from the old Magisk-Template to the newer MMT-Ex Template and now contains 4 values for build.prop:

    Code:
    ro.config.vc_call_vol_steps=30
    ro.config.media_vol_steps=30
    ro.config.alarm_vol_steps=30
    ro.config.system_vol_steps=30

    Notification-Steps are still not changed by any build.prop value I can find, maybe you can find something helpful.
    I won't create multiple Modules with own Setp-numbers again.
    Just change those numbers mentioned above, 30, 60 and 100 were tested with the old Modules and should work with the new module too.

    Tested on my Nokia 8 with Android 9 and my ASUS Zenfone 6 with Andoird 10 (Both Stock ROM, Magisk 20.3 Stable)
    No support for OEM-Roms.
    Lineage should work, can't test it yet tho.

    Old Post:

    Hi there,

    A Simple Magisk Module to Increase the Volume Steps of any ROM with stock AudioService.jar by adding 3 entries to the build.prop!

    Prop Entries:
    ro.config.vc_call_vol_steps=XX
    ro.config.media_vol_steps=XX
    audio.safemedia.bypass=true

    Depending on Zip, you get either 30, 60 or 100 Steps for MediaVol. InCallVol is set to 14 in all Zips, change it youself if you want another value. (common/system.prop in the Zip)
    Bypass Safemedia should disable the Loud Volume Warning on European Devices (Don't Quote me on that tho)

    IT WON'T WORK WITH ANY STOCK SAMSUNG DEVICE AND I CAN'T CHANGE THAT!
    SAME GOES FOR ANY OEM WHO CHANGES ANDROIDS AudioFramework.jar!!!


    Until now, it seems like Lineage 15.1 doesn't work either.
    Maybe other versions too.

    T17 is for Magisk 17 and 18
    T19 is for Magisk 18 and 19+

    If you need this for Magisk 16 or earlier, take a look at this: [url]https://forum.xda-developers.com/apps/magisk/module-volume-steps-increase-magisk-v10-t3554996[/URL]

    I tested T17 on my Devices (Xperia Z4 with Android 7, Xperia XZ with Android 8 and Nokia 8 with Android 9)

    ## Changelog ##
    T17: Release for Magisk 17+
    T19: Release for Magisk 19+

    This is not much work, but if you appreciate it anyway, hit Thanks or consider to gift me a drink.
    Cheers
    2
    Please help to increase steps to 100, I tried to edit and zip, but not flashable, ty

    See OP Attachments
    1
    Possible to increase music to 60? Ty

    Uploaded 60 Steps Module to first Post! (Left the In-Call Steps at 14)
    1
    Works perfect on pocophone f1 with miui 10 beta
    Thanks :D
    1
    It still did not work :( Can you edit the file changing the 4 values to 60 and upload the file here for me please? I will really appreciate that.

    not tested but idk - there is no reason for it to not work