• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[MODULE] Volume Steps Increase (for Magisk v10+)

Search This thread

ahrion

Retired Forum Moderator / Recognized Developer
Jul 19, 2013
3,102
5,122
I get it that you're trying to promote use of your own audmodlib template over the standard magisk template. Have you personally tried using *this* module *without* any other borked/broken modules? If so, please list the HW/SW (ROM, kernel, magisk and magisk manager versions, list of installed modules) combination which results in a bootloop.

PS. This is not a support thread for other broken modules.
I'm not promoting my modules in this thread. Neither am I using this thread for modules that may or may not be broken. Simply put I'm saying that I had this issue with my modules and now yours as well as other modules after the 11.5/11.6 update, which I was able to fix and I wanted to see how we could collectively fix it or pinpoint the issue.

I was told that I am assuming things, which is not true, and in response to that I have to explain the reasoning behind what I am saying, not by using the thread to advertise which clearly means you folks didn't read my responses.

I'm simply trying to help and figure out why resetprop is doing this because it has happened to me on my mod and is happening to me on your mods, when the system.prop is deleted it fixes the issue. This happens both on your mod and my mods that had system.prop only in 11.5/11.6 and not the versions prior.

Not once in this thread have I attempted to advertise the use of my installers nor my modules Only in defense from individuals who have said that this SystemUI FC problem lies within my modules code, is where I've mentioned that it's not just happening with my modules. The advertising comment is simply not the case. If you were to look at the code itself you'd understand (given that system.prop is the only thing that causes the issue).

I'm on LineageOS 7.1.1 with blu spark kernel custom which was designed with Magisk compatibility. I tested just now with no mods installed besides yours. Same thing I've been mentioning, SystemUI FC on every boot with a black screen which forces me to clean install or restore my backup (dirty flash and magisk uninstall and reinstall don't work). I can provide a log to the issue if you would like.

Rather than y'all attacking me and getting defensive about this or by just saying "well it's clearly your broken modules" without clearly seeing that I want to fix the issue that has occured with multiple modules (not just mine), just know that I just want to fix the issue whether it be with my modules, yours, or anyone else's so we can help each other as should be done on a forum like this.

I expect petty stuff like this from a forum newbie, not not from a senior member like yourself. If I find what's up I'll let you know.
 
Last edited:
I'm on LineageOS 7.1.1 with blu spark kernel custom which was designed with Magisk compatibility. I tested just now with no mods installed besides yours. Same thing I've been mentioning, SystemUI FC on every boot with a black screen which forces me to clean install or restore my backup (dirty flash and magisk uninstall and reinstall don't work). I can provide a log to the issue if you would like.

Attached are the screenshots from LineageOS 7.1.1 on which this module is working perfectly.

If you're asking for help/cooperation trying to identify your problem, you're not doing it right by making generalized statement claiming this module cases System UI FCs (which, as I provided evidence to, it does not) and calling me petty. I would suggest you open an issue on magisk github posting as much detail as possible (as a fellow developer you should understand the importance of all details like *all* version numbers and adb logs) and try to test on a variety of systems.
 

Attachments

  • Screenshot_20170329-183753.png
    Screenshot_20170329-183753.png
    65.9 KB · Views: 554
  • Screenshot_20170329-183802.png
    Screenshot_20170329-183802.png
    123.5 KB · Views: 554
  • Like
Reactions: Didgeridoohan

ahrion

Retired Forum Moderator / Recognized Developer
Jul 19, 2013
3,102
5,122
Attached are the screenshots from LineageOS 7.1.1 on which this module is working perfectly.

If you're asking for help/cooperation trying to identify your problem, you're not doing it right by making generalized statement claiming this module cases System UI FCs (which, as I provided evidence to, it does not) and calling me petty. I would suggest you open an issue on magisk github posting as much detail as possible (as a fellow developer you should understand the importance of all details like *all* version numbers and adb logs) and try to test on a variety of systems.
I forgot to mention my device, but It's a OnePlus3. I wasn't able to post logs at work. I will post logs when I'm near my PC.

With that said, what was petty is suggesting I'm advertising my mods in your thread.
 
Last edited:

ahrion

Retired Forum Moderator / Recognized Developer
Jul 19, 2013
3,102
5,122
Quite a bit of detail to omit given the warning in the first post of this thread:
Not at all. This mod worked prior on LineageOS 100%, and it did not face the issue mentioned there. The guy clearly states OxygenOS.

That is OxygenOS that the mods doesn't work, and like I said earlier, I didn't get bootloops before 11.5/11.6 update.

No worries man.
 

Kéno40

Senior Member
Nov 1, 2010
2,288
572
Hi, just try it on my OP X with Candy 7 on it.
It seems to increase the nimber of steps for multimedia, but not for ring & alarm.
Anyway, that's perfect for me :)
Thanks!
 
  • Like
Reactions: stangri

senny22

Senior Member
Mar 31, 2017
238
36
Uppsala
total noob here.. like a previous post I would like to modify the steps for volume as well.. what would I use to modify the steps? do I modify in the zip file?

Download powergrasp

Open the zip file in powergrasp

Copy the file you want to edit out of the zip

Edit the zip

Paste the edited file back into the original location inside the zip file
 

belrik

Senior Member
Nov 25, 2010
467
108
Working on LG G4 (H815) on Lineage 14.1. Great fix for overly loud in-ear Bluetooth headset where the normal usable range is 3 steps. I upped the media steps to 60, I tried 100 also. Both values work fine.
Very helpful, thanks. I was having to edit build.prop manually before and this is a nice example of how to make a magisk module so I might try myself now.
 

Top Liked Posts