Moto camera with slowmo

Search This thread

kraatus90

Senior Member
Sep 2, 2012
407
479
Sup guys , after searching and messing with media_profiles.xml alot, finally i found a fix for slowmotion recording with stock moto camera on cm12.1.
just replace media_profiles.xml i have provided and volla :laugh:.

these are the changes i have done apart from slowmo -
increased 4k bitrate to 65 from 30 mbps
increased 1080p bitrate to 20 from 17mbps
increased 4k audio bitrate to 320kbps
increased 1080p audio bitrate to 256kbps
image quality to 100%

how to - extract the file and copy it to the /system/etc/ , overwrite and give permission 644. you need moto camera already installed, just install it from playstore.

p.s.- it seems like slowmo isn't working exactly same as stock firmware but it's better than not working :D , it may work on other roms too i haven't tested yet. Doesn't work on cm13 according to some users and i can't fix it since im still on cm12.1 for obvious reasons
 

Attachments

  • media_profiles.7z
    2.7 KB · Views: 793
Last edited:

fgl27

Recognized Developer
Feb 27, 2014
3,639
9,454
Brazil...South of the south
Nice find :D

It work for other then X Moto devices too, I test on MAXX, on CM base RR it use the same media profile from X.

Hope you or some one fix the slomo audio. But like you say better working slow then not working... :good:

Will use yours changes on my ROM...
 

kraatus90

Senior Member
Sep 2, 2012
407
479
Nice find :D

It work for other then X Moto devices too, I test on MAXX, on CM base RR it use the same media profile from X.

Hope you or some one fix the slomo audio. But like you say better working slow then not working... :good:

Will use yours changes on my ROM...

i think audio can't be fixed in slowmo. think of it like this - when you fast forward/ rewind a video in any dvd player or digital player (pc), either audio gets messdup or it gets mute. that's how slowmo works. it records video @120fps and then plays it back at 30 fps. so it will be pretty slow speed audio . also if you open media_profiles.xml you can see it ignores audio settings for timelapse videos. so it can't be fixed without framework changes i guess. no idea honestly :D.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 12
    Sup guys , after searching and messing with media_profiles.xml alot, finally i found a fix for slowmotion recording with stock moto camera on cm12.1.
    just replace media_profiles.xml i have provided and volla :laugh:.

    these are the changes i have done apart from slowmo -
    increased 4k bitrate to 65 from 30 mbps
    increased 1080p bitrate to 20 from 17mbps
    increased 4k audio bitrate to 320kbps
    increased 1080p audio bitrate to 256kbps
    image quality to 100%

    how to - extract the file and copy it to the /system/etc/ , overwrite and give permission 644. you need moto camera already installed, just install it from playstore.

    p.s.- it seems like slowmo isn't working exactly same as stock firmware but it's better than not working :D , it may work on other roms too i haven't tested yet. Doesn't work on cm13 according to some users and i can't fix it since im still on cm12.1 for obvious reasons
    1
    Doesn't work on cm13.
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone