Moto E4 Plus XT1771 recovery from bootloop

Search This thread

palinko91

Member
Jul 8, 2012
9
0
Hello!
I decided to play with my old phone and turn into something new but I'm start to afraid I turned into a brick :(
First of all I've installed TWRP and Magisk successfully, the bootloader being unlocked, the phone fully rooted, I was on the right path. But then for some reason, I had to recover the factory rest. And then when my problems started. After that I just ended up in TWRP boot, loop, and my system never came back. I tried many different things to recover, but nothing worked, as far I studied these forums many people recommended to flash the factory ROM back. I've downloaded this, and copied the boot, system, and recovery img to the phone and flashed via TWRP. That was a very big mistake, because since that my phone in constant boot loop but now I don't even have access to it.

The boot loop look this way. turning on Moto logo, at bottom of the page writing me its unlocked, okay trying to load, after 20 sec or so turning of for 4-5 sec and trying again. If I'm connecting the device to my PC I can see MediTek Preloader USB Vcom for few seconds on my pc then dissapearing. I've installed new drivers because I thought these VCOM drivers will help for SP flash tool to work, but I was wrong.

Actually the flash tool not worked before too, cause not started the program bar, the phone not really reacting if I'm pressing 3 button down. Interestingly enough if I'm removing the VCOM drivers, and keep the Motorola driver on my pc, then I think the 3 button turning off working and even SP tools started to progress but timed out and not finished the procedure. But this 3 button method not working consistently, in the TWRP boot loop before it not worked at all, now since I ruined the TWRP by installed the factory recovery.img (which seems like was bad also, cause I can't boot into recovery mode anymore) seems like I can do something with the SP flash tool. It's just timing out.

Maybe other tools which can communicate with the phone in this preboot state? Adb and fastboot only can be accessed later, and there is no way for me to reach that state now.
What can I do to unbrick and go back to factory state so I can setup TWRP, root etc once more again, and I'll be more catious not to factory reset anymore.